Referenz für die JScript-Laufzeitbibliothek

Microsoft® JScript®
JScript-Sprachverzeichnis 		JScript-Tutorium
Versionsinformationen

Informationen über Leistungsmerkmale

Alphabetische Liste der Schlüsselwörter

Funktionen

Methoden

Objekte

Operatoren

Eigenschaften

Anweisungen

Willkommen beim JScript-Sprachverzeichnis

Diese kompakten Informationsblöcke unterstützen Sie beim Arbeiten in den zahlreichen unterschiedlichen Bereichen von JScript.

Sie finden eine alphabetische Auflistung sämtlicher Bereiche der JScript-Sprache unter der alphabetischen Liste der Schlüsselwörter. Wenn Sie jedoch lediglich zu einer Kategorie, wie z. B. Objekte, etwas nachschlagen möchten, sehen Sie, dass die einzelnen Sprachkategorien jeweils eigene, kompaktere Bereiche enthalten.

Die Funktionsweise ist denkbar einfach. Klicken Sie auf eine der links angezeigten Überschriften, um eine Auflistung der in dieser Kategorie enthaltenen Elemente einzublenden. Wählen Sie aus dieser Auflistung anschließend das gewünschte Thema aus. Nachdem Sie das gewünschte Thema eingeblendet haben, können Sie problemlos zu anderen thematisch verknüpften Bereichen wechseln.

Tauchen Sie also ein! Lesen Sie Wissenswertes über Anweisungen, sinnieren Sie über die Methoden, oder probieren Sie einige Funktionen aus. Sie werden feststellen, dass die JScript-Sprache ausgesprochen vielseitig ist!

Funktionen | Beschreibung
JScript-Funktionen (ECMA) | Auflistung der ECMA-Funktionen, die derzeit in JScript integriert sind.
JScript-Funktionen (Nicht-ECMA) | Auflistung der Nicht-ECMA-Funktionen, die derzeit in JScript integriert sind.
Laufzeitmerkmale von Microsoft Scripting | Auflistung der Laufzeitmerkmale, die derzeit in JScript integriert sind.
Sprachelement | Beschreibung
$1...$9-Eigenschaften | Gibt die neun zuletzt gespeicherten Teile zurück, die während des Mustervergleichs gefunden wurden.
/*..*/ (Mehrzeilige Kommentaranweisung) | Veranlasst den JScript-Parser, mehrzeilige Kommentare zu ignorieren.
// (Einzeilige Kommentaranweisung ) | Veranlasst den JScript-Parser, einzeilige Kommentare zu ignorieren.
abs-Methode | Gibt den absoluten Wert einer Zahl zurück.
acos-Methode | Gibt den Arkuskosinus einer Zahl zurück.
ActiveXObject-Objekt | Aktiviert und gibt eine Referenz auf ein Automatisierungsobjekt zurück.
Additionsoperator (+) | Addiert zwei Zahlen oder verkettet zwei Zeichenfolgen.
anchor-Methode | Setzt ein HTML-Anchor-Tag mit einem NAME-Attribut um einen angegebenen Text im Objekt.
arguments-Eigenschaft | Gibt ein Datenfeld zurück, das alle Argumente enthält, die an die derzeit ausgeführte Funktion übergeben werden.
Array-Objekt | Ermöglicht das Erstellen von Datenfeldern beliebigen Datentyps.
asin-Methode | Gibt den Arkussinus einer Zahl zurück.
atan-Methode | Gibt den Arkustangens einer Zahl zurück.
atan2-Methode | Gibt den Winkel (im Bogenmaß) von der x-Achse zu einem Punkt (y, x) zurück.
atEnd-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob sich der Enumerator am Ende der Auflistung befindet.
Bedingte Kompilierung | Ermöglicht die Verwendung neuer JScript-Sprachfunktionen ohne Verzicht auf die Kompatibilität mit Browsern, die diese Funktionen nicht unterstützen.
big-Methode | Setzt HTML-<BIG>-Tags um einen Text in einem String-Objekt.
Bitweiser AND-Operator (&) | Führt eine bitweise AND-Verknüpfung auf zwei Ausdrücken durch.
Bitweiser Left Shift-Operator (<<) | Verschiebt die Bits eines Ausdrucks nach links.
Bitweiser NOT-Operator (~) | Führt eine bitweise Negation an einem Ausdruck durch.
Bitweiser OR-Operator (|) | Führt eine bitweise OR- Verknüpfung auf zwei Ausdrücken durch.
Bitweiser Right Shift-Operator (>>) | Verschiebt die Bits eines Ausdrucks nach rechts.
Bitweiser XOR-Operator (^) | Führt eine bitweise exklusive OR- Verknüpfung auf zwei Ausdrücken durch.
blink-Methode | Setzt HTML-<BLINK>-Tags um einen Text in einem String-Objekt.
bold-Methode | Setzt HTML-<B>-Tags um einen Text in einem String-Objekt.
Boolean-Objekt | Erstellt einen neuen Booleschen Wert.
break-Anweisung | Beendet die aktuelle Schleife oder in Verbindung mit einem Label die zugehörige Anweisung.
caller-Eigenschaft | Gibt eine Referenz auf die Funktion zurück, die die aktuelle Funktion aufgerufen hat.
catch-Anweisung | Enthält Anweisungen, die beim Auftreten von Fehlern im Code innerhalb eines try-Blocks ausgeführt werden.
@cc_on-Anweisung | Aktiviert die Unterstützung der bedingten Kompilierung.
ceil-Methode | Gibt die kleinste Ganzzahl zurück, die größer oder gleich dem numerischen Argument ist.
charAt-Methode | Gibt das durch den Index angegebene Zeichen zurück.
charCodeAt-Methode | Gibt die Unicode-Codierung eines angegebenen Zeichens zurück.
compile-Methode | Kompiliert einen regulären Ausdruck in ein internes Format.
concat-Methode (Array) | Gibt ein neues Datenfeld zurück, das aus einer Kombination zweier anderer Datenfelder besteht.
concat-Methode (String) | Gibt ein String-Objekt zurück, das die Verkettung zweier angegebener Zeichenfolgen enthält.
constructor-Eigenschaft | Gibt die Funktion an, die ein Objekt erstellt.
continue-Anweisung | Beendet die aktuelle Iteration einer Schleife und beginnt eine neue Iteration.
cos-Methode | Gibt den Kosinus einer Zahl zurück.
Datentypkonvertierung | Erläutert die automatischen Datentypkonvertierung unter JScript.
Date-Objekt | Ermöglicht grundlegende Speicherungs- und Erfassungsmöglichkeiten von Datums- und Zeitvariablen.
Dekrementoperator (--) | Dekrementiert eine Variable um eins.
delete-Operator | Löscht eine Eigenschaft aus einem Objekt, oder entfernt ein Element aus einem Datenfeld.
description-Eigenschaft | Setzt die mit einem bestimmten Fehler zugewiesene beschreibende Zeichenfolge oder gibt diese zurück.
Dictionary-Objekt | Objekt zum Speichern von Schlüssel/Element-Paaren.
dimensions-Methode | Gibt die Zahl der Dimensionen in einem VBArray zurück.
Divisionsoperator (/) | Dividiert zwei Zahlen und gibt ein numerisches Ergebnis zurück.
do...while-Anweisung | Führt einen Anweisungsblock einmal aus und wiederholt dann die Ausführung der Schleife, bis ein bedingter Ausdruck mit false ausgewertet wird.
E-Eigenschaft | Gibt die Eulersche Konstante, die Basis des natürlichen Logarithmus, zurück.
Enumerator-Objekt | Bietet die Möglichkeit, die Elemente einer Auflistung aufzuzählen.
Error-Objekt | Ein Objekt, das Informationen zu Fehlern enthält, die beim Ausführen von JScript-Code auftreten.
escape-Methode | Kodiert String-Objekte, sodass sie auf allen Computern gelesen werden können.
eval-Methode | Wertet und führt JScript-Code aus.
exec-Methode | Führt die Suche nach einer Übereinstimmung in einer angegebenen Zeichenfolge aus.
exp-Methode | Gibt e (die Basis des natürlichen Logarithmus) potenziert zurück.
FileSystemObject-Objekte | Bieten den Zugang zum Dateisystem eines Computers.
fixed-Methode | Setzt HTML-<TT>-Tags um einen Text in einem String-Objekt.
floor-Methode | Berechnet die größte Ganzzahl kleiner oder gleich seinem numerischen Argument.
fontcolor-Methode | Setzt ein HTML-<FONT>-Tag und das COLOR-Attribut um den Text in einem String-Objekt.
fontsize-Methode | Setzt ein HTML-<FONT>-Tag und das SIZE-Attribut um den Text in einem String-Objekt.
for...in-Anweisung | Führt eine oder mehrere Anweisungen für die einzelnen Elemente eines Objekts oder Datenfeldes aus.
for-Anweisung | Führt einen Anweisungsblock aus, solange eine Bedingung true ist.
fromCharCode-Methode | Gibt eine Zeichenfolge aus mehreren Unicode-Zeichenwerten zurück.
Function-Objekt | Erstellt eine neue Funktion.
function-Anweisung | Deklariert eine neue Funktion.
getDate-Methode | Gibt den Tag eines Monats aus einem Date-Objekt unter Verwendung der Ortszeit zurück.
getDay-Methode | Gibt den Wochentag aus einem Date-Objekt unter Verwendung der Ortszeit zurück.
getFullYear-Methode | Gibt den Wert des Jahres im Date-Objekt unter Verwendung der Ortszeit zurück.
getHours-Methode | Gibt den Stundenwert im Date-Objekt unter Verwendung der Ortszeit zurück.
getItem-Methode | Gibt das Element aus dem angegebenen Speicherort zurück.
getMilliseconds-Methode | Gibt den Wert in Millisekunden im Date-Objekt unter Verwendung der Ortszeit zurück.
getMinutes-Methode | Gibt den Wert in Minuten im Date-Objekt unter Verwendung der Ortszeit zurück.
getMonth-Methode | Gibt den Wert des Monats im Date-Objekt unter Verwendung der Ortszeit zurück.
GetObject-Funktion | Gibt eine Referenz auf ein Automatisierungsobjekt von einer Datei zurück.
getSeconds-Methode | Gibt den Wert in Sekunden im Date-Objekt unter Verwendung der Ortszeit zurück.
getTime-Methode | Gibt die Zeit zurück, die in einem Date-Objekt gespeichert ist.
getTimezoneOffset-Methode | Gibt den Zeitunterschied in Minuten zwischen dem Hostcomputer und der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCDate-Methode | Gibt das Datum im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCDay-Methode | Gibt den Wochentag aus einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCFullYear-Methode | Gibt das Jahr im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCHours-Methode | Gibt die Stunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMilliseconds-Methode | Gibt die Millisekunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMinutes-Methode | Gibt die Minuten im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMonth-Methode | Gibt den Monat im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCSeconds-Methode | Gibt die Sekunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getVarDate-Methode | Gibt den Wert VT_DATE in einem Date-Objekt zurück.
getYear-Methode | Gibt den Wert des Jahres in einem Date-Objekt zurück.
Gleichheitsoperator (==) | Vergleicht zwei Ausdrücke miteinander auf Gleichheit.
Global-Objekt | Ein integriertes Objekt, dessen Zweck das Zusammenfassen globaler Methoden in einem Objekt ist.
Größer als-Operator (>) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert größer ist.
Größer gleich-Operator | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert größer ist oder beide gleich sind.
Identitätsoperator (===) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob sie den gleichen Wert und Datentyp aufweisen.
if...else-Anweisung | Bedingte Ausführung einer Gruppe von Anweisungen, abhängig vom Wert eines Ausdruckes.
@if-Anweisung | Bedingte Ausführung einer Gruppe von Anweisungen, abhängig vom Wert eines Ausdruckes.
index-Eigenschaft | Gibt die Zeichenposition zurück, wo die erste erfolgreiche Entsprechung einer gesuchten Zeichenfolge beginnt.
indexOf-Methode | Gibt die Zeichenposition zurück, wo das erste Auftreten einer Teilzeichenfolge in einem String-Objekt gefunden wurde.
Infinity-Eigenschaft | Gibt den Anfangswert von Number.POSITIVE_INFINITY zurück
Inkrementoperator (++) | Inkrementiert eine Variable um eins.
input-Eigenschaft | Gibt die Zeichenfolge zurück, nach der gesucht wurde.
instanceof-Operator | Gibt einen Booleschen Wert zurück, der angibt, ob ein Objekt eine Instanz einer bestimmten Klasse ist.
isFinite-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob die angegebene Zahl endlich ist.
isNaN-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob ein Wert der reservierte Wert NaN (not a number) ist.
italics-Methode | Setzt HTML-<I>-Tags um einen Text in einem String-Objekt.
item-Methode | Gibt das aktuelle Element der Auflistung zurück.
join-Methode | Gibt ein String-Objekt zurück, das aus allen verketteten Elementen eines Datenfelds besteht.
Kleiner als-Operator (<) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert kleiner ist.
Kleiner gleich-Operator (<=) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert kleiner ist oder beide gleich sind.
Komma-Operator (,) | Bewirkt das sequenzielle Ausführen zweier Ausdrücke.
Labeled-Anweisung | Stellt einen Bezeichner für eine Anweisung bereit.
lastIndex-Eigenschaft (RegExp) | Gibt die Zeichenposition zurück, wo die letzte erfolgreiche Entsprechung in einer gesuchten Zeichenfolge beginnt.
lastIndexOf-Methode | Gibt das letzte Auftreten einer Teilzeichenfolge in einem String-Objekt zurück.
lbound-Methode | Gibt den niedrigsten Indexwert zurück, der in der angegebenen Dimension eines VBArrays verwendet wird.
length-Eigenschaft (Array) | Bestimmt einen ganzzahligen Wert, der um eins höher ist als das höchste in einem Datenfeld definierte Element.
length-Eigenschaft (Function) | Enthält die Zahl der Argumente, mit denen eine Funktion definiert wird.
length-Eigenschaft (String) | Gibt die Länge eines String-Objekts zurück.
link-Methode | Setzt ein HTML-Anchor-Tag und ein HREF-Attribut um den Text in einem String-Objekt.
LN2-Eigenschaft | Gibt den natürlichen Logarithmus von 2 zurück.
LN10-Eigenschaft | Gibt den natürlichen Logarithmus von 10 zurück.
log-Methode | Gibt den natürlichen Logarithmus einer Zahl zurück.
LOG2E-Eigenschaft | Gibt den Logarithmus der Eulerschen Konstante e zur Basis 2 zurück.
LOG10E-Eigenschaft | Gibt den Logarithmus der Eulerschen Konstante e zur Basis 10 zurück.
Logischer AND-Operator (&&) | Führt eine logische Konjunktion zweier Ausdrücke durch.
Logischer NOT-Operator (!) | Führt eine logische Negation auf einem Ausdruck durch.
Logischer OR-Operator (||) | Führt eine logische Disjunktion auf zwei Ausdrücken durch.
match-Methode | Gibt die Ergebnisse einer Suche nach Zeichenfolgen unter Verwendung eines angegebenen Regular Expression-Objekts als Datenfeld zurück.
Math-Objekt | Ein integriertes Objekt mit mathematischen Grundfunktionen und Konstanten.
MAX_VALUE-Eigenschaft | Gibt die größte in JScript darstellbare Zahl zurück.
max-Methode | Gibt den größeren Wert von zwei angegebenen numerischen Ausdrücken zurück.
MIN_VALUE-Eigenschaft | Gibt die der Null am nächsten kommenden Zahl zurück, die in JScript dargestellt werden kann.
min-Methode | Gibt die kleinere von zwei angegebenen Zahlen zurück.
Modulo-Operator (%) | Dividiert zwei Zahlen und gibt den Restwert zurück.
moveFirst-Methode | Setzt das aktuelle Element in der Auflistung auf das erste Element zurück.
moveNext-Methode | Verschiebt das aktuelle Element zum nächsten Element der Auflistung.
Multiplikationsoperator (*) | Multipliziert zwei Zahlen miteinander.
NaN-Eigenschaft (Global) | Gibt den Sonderwert NaN zurück, der angibt, dass ein Ausdruck keine Zahl ist.
NaN-Eigenschaft (Number) | Gibt den Sonderwert NaN zurück, der angibt, dass ein Ausdruck keine Zahl ist.
NEGATIVE_INFINITY-Eigenschaft | Gibt einen negativeren Wert als die größte negative Zahl (-Number.MAX_VALUE) zurück, die in JScript darstellbar ist.
new-Operator | Erstellt ein neues Objekt.
Nicht-Identitätsoperator (!==) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob sie einen unterschiedlichen Wert und Datentyp aufweisen.
number-Eigenschaft | Setzt den mit einem bestimmten Fehler zugewiesenen numerischen Wert oder gibt diesen zurück.
Number-Objekt | Eine Objektdarstellung des numerischen Datentyps und Platzhalter für numerische Konstanten.
Object-Objekt | Bietet allen JScript-Objekten eine gemeinsame Funktionalität.
Operatorvorrang | Eine Auflistung mit Informationen zum Ausführungsvorrang von JScript-Operatoren.
parseFloat-Methode | Gibt eine aus einer Zeichenfolge konvertierte Fließkommazahl zurück.
parseInt-Methode | Gibt eine aus einer Ganzzahl konvertierte Fließkommazahl zurück.
parse-Methode | Durchsucht eine Zeichenfolge mit einem Datum und liefert die Anzahl der Millisekunden, die seit diesem Datum und Mitternacht des 1. Januars 1970 vergangen sind.
PI-Eigenschaft | Gibt das Verhältnis eines Kreisumfangs zum Kreisdurchmesser zurück, was ungefähr der Zahl 3,141592653589793 entspricht.
POSITIVE_INFINITY-Eigenschaft | Gibt einen größeren Wert als die größte Zahl (Number.MAX_VALUE) zurück, die in JScript darstellbar ist.
pow-Methode | Gibt den um einen angegebenen Exponenten potenzierten Wert eines Ausdrucks zurück.
prototype-Eigenschaft | Gibt eine Referenz auf den Prototyp einer Objektklasse zurück.
random-Methode | Gibt eine Pseudo-Zufallszahl zwischen 0 und 1 zurück.
RegExp-Objekt | Speichert Informationen zu Mustersuchen regulärer Ausdrücke.
Regular Expression-Objekt | Enthält das Muster eines regulären Ausdrucks.
replace-Methode | Gibt unter Verwendung regulärer Ausdrücke eine Kopie der Zeichenfolge mit ersetztem Text zurück.
return-Anweisung | Verlässt die aktuelle Funktion und gibt einen Wert dieser Funktion zurück.
reverse-Methode | Gibt ein Array-Objekt mit den Elementen in umgekehrter Reihenfolge zurück.
round-Methode | Gibt einen angegebenen numerischen Ausdruck auf die nächste Ganzzahl gerundet zurück.
ScriptEngineBuildVersion-Funktion | Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngine-Funktion | Gibt eine Zeichenfolge zurück, die die verwendete Skriptsprache angibt.
ScriptEngineMajorVersion-Funktion | Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMinorVersion-Funktion | Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
search-Methode | Gibt die Position der ersten Entsprechung einer Teilzeichenfolge in einer Suche nach regulären Ausdrücken zurück.
@set-Anweisung | Erstellt Variablen, die in bedingten Kompilierungsanweisungen verwendet werden.
setDate-Methode | Setzt das numerische Datum des Date-Objekts unter Verwendung der Ortszeit.
setFullYear-Methode | Setzt den Wert des Jahres im Date-Objekt unter Verwendung der Ortszeit.
setHours-Methode | Setzt den Stundenwert im Date-Objekt unter Verwendung der Ortszeit.
setMilliseconds-Methode | Setzt den Millisekundenwert im Date-Objekt unter Verwendung der Ortszeit.
setMinutes-Methode | Setzt den Minutenwert im Date-Objekt unter Verwendung der Ortszeit.
setMonth-Methode | Setzt den Wert des Monats im Date-Objekt unter Verwendung der Ortszeit.
setSeconds-Methode | Setzt den Sekundenwert im Date-Objekt unter Verwendung der Ortszeit.
setTime-Methode | Setzt die Werte für das Datum und die Zeit im Date-Objekt.
setUTCDate-Methode | Setzt das numerische Datum im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCFullYear-Methode | Setzt den Wert des Jahres im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCHours-Methode | Setzt den Stundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMilliseconds-Methode | Setzt den Millisekundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMinutes-Methode | Setzt den Minutenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMonth-Methode | Setzt den Wert des Monats im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCSeconds-Methode | Setzt den Sekundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setYear-Methode | Setzt den Wert des Jahres im Date-Objekt.
sin-Methode | Gibt den Sinus einer Zahl zurück.
slice-Methode (Array) | Gibt einen Abschnitt eines Datenfeldes zurück.
slice-Methode (String) | Gibt einen Abschnitt einer Zeichenfolge zurück.
small-Methode | Setzt HTML-<SMALL>-Tags um einen Text in einem String-Objekt.
sort-Methode | Gibt ein Array-Objekt mit den Elementen in sortierter Reihenfolge zurück.
source-Eigenschaft | Gibt eine Kopie des Textes eines regulären Ausdrucksmusters zurück.
split-Methode | Gibt das Datenfeld der Zeichenfolgen zurück, wenn eine Zeichenfolge in Teilzeichenfolgen separiert wird.
sqrt-Methode | Gibt die Quadratwurzel einer Zahl zurück.
SQRT1_2-Eigenschaft | Gibt die Quadratwurzel von 0,5 (oder 1 geteilt durch die Quadratwurzel von 2) zurück.
SQRT2-Eigenschaft | Gibt die Quadratwurzel von 2 zurück.
strike-Methode | Setzt HTML-<STRIKE>-Tags um einen Text in einem String-Objekt.
String-Objekt | Ermöglicht das Verändern und Formatieren von Zeichenfolgen sowie das Festlegen und Suchen von Teilzeichenfolgen innerhalb von Zeichenfolgen.
sub-Methode | Setzt HTML-<SUB>-Tags um einen Text in einem String-Objekt.
substring-Methode | Gibt die Teilzeichenfolge an der angegeben Position in einem String-Objekt zurück.
substr-Methode | Gibt eine Teilzeichenfolge zurück, die an angegebener Stelle beginnt und die angegebene Länge hat.
Subtraktionsoperator (-) | Führt eine Subtraktion von zwei Ausdrücken durch.
sup-Methode | Setzt HTML-<SUP>-Tags um einen Text in einem String-Objekt.
switch-Anweisung | Aktiviert die Ausführung einer oder mehrerer Anweisungen, wenn der Wert eines angegebenen Ausdrucks einem Label entspricht.
Syntax regulärer Ausdrücke | Eine Liste der Sonderzeichen bzw. Sonderzeichenfolgen, die beim Schreiben von Mustern regulärer Ausdrücke verwendet werden.
tan-Methode | Gibt den Tangens einer Zahl zurück.
test-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob ein Muster in der gesuchten Zeichenfolge vorhanden ist.
this-Anweisung | Verweist auf das aktuelle Objekt.
throw-Anweisung | Löst eine Fehlerbedingung aus, die von einer try...catch-Anweisung behandelt werden kann.
toArray-Methode | Gibt das aus einem VBArray konvertierte Standard-JScript-Datenfeld zurück.
toGMTString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung der GMT (Greenwich Mean Time) an.
toLocaleString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung des aktuellen Gebietsschemas zurück.
toLowerCase-Methode | Gibt eine Zeichenfolge zurück, bei der alle alphabetischen Zeichen zu Kleinbuchstaben konvertiert wurden.
toString-Methode | Gibt eine Zeichenfolgendarstellung eines Objekts zurück.
toUpperCase-Methode | Gibt eine Zeichenfolge zurück, bei der alle alphabetischen Zeichen zu Großbuchstaben konvertiert wurden.
toUTCString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Trinärer Bedingungsoperator (?:) | Führt in Abhängigkeit einer Bedingung eine von zwei Anweisungen aus.
try-Anweisung | Implementiert die Fehlerbehandlung für JScript.
typeof-Operator | Gibt eine Zeichenfolge zurück, die den Datentyp eines Ausdrucks angibt.
Unärer Negationsoperator (-) | Zeigt den negativen Wert eines numerischen Ausdrucks an.
unbound-Methode | Gibt den höchsten Indexwert zurück, der in der angegebenen Dimension eines VBArrays verwendet wird.
unescape-Methode | Dekodiert String-Objekte, die mit der escape-Methode kodiert wurden.
Ungleichheitsoperator (!=) | Vergleicht zwei Ausdrücke miteinander auf Ungleichheit.
UTC-Methode | Gibt die Anzahl Millisekunden zwischen Mitternacht, 1. Januar 1970 gemäß koordinierter Weltzeit (Universal Coordinated Time=UTC) (oder GMT) und dem angegebenen Datum zurück.
valueOf-Methode | Gibt den einfachen Wert des angegebenen Objekts zurück.
var-Anweisung | Deklariert eine Variable.
Variablen für die bedingte Kompilierung | Führt vordefinierte Variablen für die Verwendung mit bedingten Kompilierungen auf.
VBArray-Objekt | Bietet Zugriff auf sichere Visual Basic-Datenfelder.
Verbundzuweisungsoperatoren | Führt sämtliche Verbundzuweisungsoperatoren auf.
Vergleichsoperator | Gibt einen Booleschen Wert zurück, der das Ergebnis des Vergleichs angibt.
void-Operator | Verhindert bei einem Ausdruck die Rückgabe eines Wertes.
Vorzeichenloser Right Shift-Operator (>>>) | Verschiebt die Bits eines Ausdrucks ohne Vorzeichen nach rechts.
while-Anweisung | Führt eine Anweisung aus, bis eine angegebene Bedingung false ist.
with-Anweisung | Legt das standardmäßig zu verwendende Objekt für eine Anweisung fest.
Zuweisungsoperator (=) | Weist einer Variablen einen Wert zu.
Sprachelement | Beschreibung
GetObject-Funktion | Gibt eine Referenz auf ein Automatisierungsobjekt von einer Datei zurück.
ScriptEngineBuildVersion-Funktion | Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngine-Funktion | Gibt eine Zeichenfolge zurück, die die verwendete Skriptsprache angibt.
ScriptEngineMajorVersion-Funktion | Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMinorVersion-Funktion | Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
Sprachelement | Beschreibung
abs-Methode | Gibt den absoluten Wert einer Zahl zurück.
acos-Methode | Gibt den Arkuskosinus einer Zahl zurück.
anchor-Methode | Setzt ein HTML-Anchor-Tag mit einem NAME-Attribut um einen angegebenen Text im Objekt.
asin-Methode | Gibt den Arkussinus einer Zahl zurück.
atan-Methode | Gibt den Arkustangens einer Zahl zurück.
atan2-Methode | Gibt den Winkel (im Bogenmaß) von der x-Achse zu einem Punkt (y, x) zurück.
atEnd-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob sich der Enumerator am Ende der Auflistung befindet.
big-Methode | Setzt HTML-<BIG>-Tags um einen Text in einem String-Objekt.
blink-Methode | Setzt HTML-<BLINK>-Tags um einen Text in einem String-Objekt.
bold-Methode | Setzt HTML-<B>-Tags um einen Text in einem String-Objekt.
ceil-Methode | Gibt die kleinste Ganzzahl zurück, die größer oder gleich dem numerischen Argument ist.
charAt-Methode | Gibt das durch den Index angegebene Zeichen zurück.
charCodeAt-Methode | Gibt die Unicode-Codierung eines angegebenen Zeichens zurück.
compile-Methode | Kompiliert einen regulären Ausdruck in ein internes Format.
concat-Methode (Array) | Gibt ein neues Datenfeld zurück, das aus einer Kombination zweier anderer Datenfelder besteht.
concat-Methode (String) | Gibt ein String-Objekt zurück, das die Verkettung zweier angegebener Zeichenfolgen enthält.
cos-Methode | Gibt den Kosinus einer Zahl zurück.
dimensions-Methode | Gibt die Zahl der Dimensionen in einem VBArray zurück.
escape-Methode | Kodiert String-Objekte, sodass sie auf allen Computern gelesen werden können.
eval-Methode | Wertet und führt JScript-Code aus.
exec-Methode | Führt die Suche nach einer Übereinstimmung in einer angegebenen Zeichenfolge aus.
exp-Methode | Gibt e (die Basis des natürlichen Logarithmus) potenziert zurück.
fixed-Methode | Setzt HTML-<TT>-Tags um einen Text in einem String-Objekt.
floor-Methode | Berechnet die größte Ganzzahl kleiner oder gleich seinem numerischen Argument.
fontcolor-Methode | Setzt ein HTML-<FONT>-Tag und das COLOR-Attribut um den Text in einem String-Objekt.
fontsize-Methode | Setzt ein HTML-<FONT>-Tag und das SIZE-Attribut um den Text in einem String-Objekt.
fromCharCode-Methode | Gibt eine Zeichenfolge aus mehreren Unicode-Zeichenwerten zurück.
getDate-Methode | Gibt den Tag eines Monats aus einem Date-Objekt unter Verwendung der Ortszeit zurück.
getDay-Methode | Gibt den Wochentag aus einem Date-Objekt unter Verwendung der Ortszeit zurück.
getFullYear-Methode | Gibt den Wert des Jahres im Date-Objekt unter Verwendung der Ortszeit zurück.
getHours-Methode | Gibt den Stundenwert im Date-Objekt unter Verwendung der Ortszeit zurück.
getItem-Methode | Gibt das Element aus dem angegebenen Speicherort zurück.
getMilliseconds-Methode | Gibt den Wert in Millisekunden im Date-Objekt unter Verwendung der Ortszeit zurück.
getMinutes-Methode | Gibt den Wert in Minuten im Date-Objekt unter Verwendung der Ortszeit zurück.
getMonth-Methode | Gibt den Wert des Monats im Date-Objekt unter Verwendung der Ortszeit zurück.
getSeconds-Methode | Gibt den Wert in Sekunden im Date-Objekt unter Verwendung der Ortszeit zurück.
getTime-Methode | Gibt die Zeit zurück, die in einem Date-Objekt gespeichert ist.
getTimezoneOffset-Methode | Gibt den Zeitunterschied in Minuten zwischen dem Hostcomputer und der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCDate-Methode | Gibt das Datum im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCDay-Methode | Gibt den Wochentag aus einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCFullYear-Methode | Gibt das Jahr im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCHours-Methode | Gibt die Stunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMilliseconds-Methode | Gibt die Millisekunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMinutes-Methode | Gibt die Minuten im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCMonth-Methode | Gibt den Monat im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getUTCSeconds-Methode | Gibt die Sekunden im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
getVarDate-Methode | Gibt den Wert VT_DATE in einem Date-Objekt zurück.
getYear-Methode | Gibt den Wert des Jahres in einem Date-Objekt zurück.
indexOf-Methode | Gibt die Zeichenposition zurück, wo das erste Auftreten einer Teilzeichenfolge in einem String-Objekt gefunden wurde.
isFinite-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob die angegebene Zahl endlich ist.
isNaN-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob ein Wert der reservierte Wert NaN (not a number) ist.
italics-Methode | Setzt HTML-<I>-Tags um einen Text in einem String-Objekt.
item-Methode | Gibt das aktuelle Element der Auflistung zurück.
join-Methode | Gibt ein String-Objekt zurück, das aus alle verketteten Elementen eines Datenfelds besteht.
lastIndexOf-Methode | Gibt das letzte Auftreten einer Teilzeichenfolge in einem String-Objekt zurück.
lbound-Methode | Gibt den niedrigsten Indexwert zurück, der in der angegebenen Dimension eines VBArrays verwendet wird.
link-Methode | Setzt ein HTML-Anchor-Tags und ein HREF-Attribut um den Text in einem String-Objekt.
log-Methode | Gibt den natürlichen Logarithmus einer Zahl zurück.
match-Methode | Gibt die Ergebnisse einer Suche nach Zeichenfolgen unter Verwendung eines angegebenen Regular Expression-Objekts als Datenfeld zurück.
max-Methode | Gibt den größeren Wert von zwei angegebenen numerischen Ausdrücken zurück.
min-Methode | Gibt die kleinere von zwei angegebenen Zahlen zurück.
moveFirst-Methode | Setzt das aktuelle Element in der Auflistung auf das erste Element zurück.
moveNext-Methode | Verschiebt das aktuelle Element zum nächsten Element der Auflistung.
parseFloat-Methode | Gibt eine aus einer Zeichenfolge konvertierte Fließkommazahl zurück.
parseInt-Methode | Gibt eine aus einer Ganzzahl konvertierte Fließkommazahl zurück.
parse-Methode | Durchsucht eine Zeichenfolge mit einem Datum und liefert die Anzahl der Millisekunden, die seit diesem Datum und Mitternacht des 1. Januars 1970 vergangen sind.
pow-Methode | Gibt den um einen angegebenen Exponenten potenzierten Wert eines Ausdrucks zurück.
random-Methode | Gibt eine Pseudo-Zufallszahl zwischen 0 und 1 zurück.
replace-Methode | Gibt eine Kopie der Zeichenfolge mit unter Verwendung regulärer Ausdrücke ersetztem Text zurück.
reverse-Methode | Gibt ein Array-Objekt mit den Elementen in umgekehrter Reihenfolge zurück.
round-Methode | Gibt einen angegebenen numerischen Ausdruck auf die nächste Ganzzahl gerundet zurück.
search-Methode | Gibt die Position der ersten Entsprechung einer Teilzeichenfolge in einer regulären Ausdrucksuche zurück.
setDate-Methode | Setzt das numerische Datum des Date-Objekts unter Verwendung der Ortszeit.
setFullYear-Methode | Setzt den Wert des Jahres im Date-Objekt unter Verwendung der Ortszeit.
setHours-Methode | Setzt den Stundenwert im Date-Objekt unter Verwendung der Ortszeit.
setMilliseconds-Methode | Setzt den Millisekundenwert im Date-Objekt unter Verwendung der Ortszeit.
setMinutes-Methode | Setzt den Minutenwert im Date-Objekt unter Verwendung der Ortszeit.
setMonth-Methode | Setzt den Wert des Monats im Date-Objekt unter Verwendung der Ortszeit.
setSeconds-Methode | Setzt den Sekundenwert im Date-Objekt unter Verwendung der Ortszeit.
setTime-Methode | Setzt die Werte für das Datum und die Zeit im Date-Objekt.
setUTCDate-Methode | Setzt das numerische Datum im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCFullYear-Methode | Setzt den Wert des Jahres im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCHours-Methode | Setzt den Stundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMilliseconds-Methode | Setzt den Millisekundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMinutes-Methode | Setzt den Minutenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCMonth-Methode | Setzt den Wert des Monats im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setUTCSeconds-Methode | Setzt den Sekundenwert im Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC).
setYear-Methode | Setzt den Wert des Jahres im Date-Objekt.
sin-Methode | Gibt den Sinus einer Zahl zurück.
slice-Methode (Array) | Gibt einen Abschnitt eines Datenfeldes zurück.
slice-Methode (String) | Gibt einen Abschnitt einer Zeichenfolge zurück.
small-Methode | Setzt HTML-<SMALL>-Tags um einen Text in einem String-Objekt.
sort-Methode | Gibt ein Array-Objekt mit den Elementen in sortierter Reihenfolge zurück.
split-Methode | Gibt das Datenfeld der Zeichenfolgen zurück, wenn eine Zeichenfolge in Teilzeichenfolgen separiert wird.
sqrt-Methode | Gibt die Quadratwurzel einer Zahl zurück.
strike-Methode | Setzt HTML-<STRIKE>-Tags um einen Text in einem String-Objekt.
sub-Methode | Setzt HTML-<SUB>-Tags um einen Text in einem String-Objekt.
substring-Methode | Gibt die Teilzeichenfolge an der angegebenen Position in einem String-Objekt zurück.
substr-Methode | Gibt eine Teilzeichenfolge zurück, die an angegebener Stelle beginnt und die angegebene Länge hat.
sup-Methode | Setzt HTML-<SUP>-Tags um einen Text in einem String-Objekt.
tan-Methode | Gibt den Tangens einer Zahl zurück.
test-Methode | Gibt einen Booleschen Wert zurück, der angibt, ob ein Muster in der gesuchten Zeichenfolge vorhanden ist.
toArray-Methode | Gibt das aus einem VBArray konvertierte Standard-JScript-Datenfeld zurück.
toGMTString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung der GMT (Greenwich Mean Time) an.
toLocaleString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung des aktuellen Gebietsschemas zurück.
toLowerCase-Methode | Gibt eine Zeichenfolge zurück, bei der alle alphabetischen Zeichen zu Kleinbuchstaben konvertiert wurden.
toString-Methode | Gibt eine Zeichenfolgendarstellung eines Objekts zurück.
toUpperCase-Methode | Gibt eine Zeichenfolge zurück, bei der alle alphabetischen Zeichen zu Großbuchstaben konvertiert wurden.
toUTCString-Methode | Gibt das in eine Zeichenfolge konvertierte Datum unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
unbound-Methode | Gibt den höchsten Indexwert zurück, der in der angegebenen Dimension eines VBArrays verwendet wird.
unescape-Methode | Dekodiert String-Objekte, die mit der escape-Methode kodiert wurden.
UTC-Methode | Gibt die Anzahl Millisekunden zwischen Mitternacht, 1. Januar 1970 gemäß koordinierter Weltzeit (Universal Coordinated Time=UTC) (oder GMT) und dem angegebenen Datum zurück.
valueOf-Methode | Gibt den einfachen Wert des angegebenen Objekts zurück.
Sprachelement | Beschreibung
ActiveXObject-Objekt | Aktiviert und gibt eine Referenz auf ein Automatisierungsobjekt zurück.
Array-Objekt | Ermöglicht das Erstellen von Datenfeldern beliebigen Datentyps.
Boolean-Objekt | Erstellt einen neuen Booleschen Wert.
Date-Objekt | Ermöglicht grundlegende Speicherungs- und Erfassungsmöglichkeiten von Datums- und Zeitvariablen.
Dictionary-Objekt | Objekt zum Speichern von Schlüssel/Element-Paaren.
Enumerator-Objekt | Bietet die Möglichkeit, die Elemente einer Auflistung aufzuzählen.
Error-Objekt | Ein Objekt, das Informationen zu Fehlern enthält, die beim Ausführen von JScript-Code auftreten.
FileSystemObject-Objekte | Bieten den Zugang zum Dateisystem eines Computers.
Function-Objekt | Erstellt eine neue Funktion.
Global-Objekt | Ein integriertes Objekt, dessen Zweck das Zusammenfassen globaler Methoden in einem Objekt ist.
Math-Objekt | Ein integriertes Objekt mit mathematischen Grundfunktionen und Konstanten.
Number-Objekt | Eine Objektdarstellung des numerischen Datentyps und Platzhalter für numerische Konstanten.
Object-Objekt | Bietet allen JScript-Objekten eine gemeinsame Funktionalität.
RegExp-Objekt | Speichert Informationen zu Mustersuchen regulärer Ausdrücke.
Regular Expression-Objekt | Enthält das Muster eines regulären Ausdrucks.
String-Objekt | Ermöglicht das Verändern und Formatieren von Zeichenfolgen sowie das Festlegen und Suchen von Teilzeichenfolgen innerhalb von Zeichenfolgen.
VBArray-Objekt | Bietet Zugriff auf sichere Visual Basic-Datenfelder.
Sprachelement | Beschreibung
Additionsoperator (+) | Addiert zwei Zahlen oder verkettet zwei Zeichenfolgen.
Bitweiser AND-Operator (&) | Führt eine bitweise AND-Verknüpfung auf zwei Ausdrücken durch.
Bitweiser Left Shift-Operator (<<) | Verschiebt die Bits eines Ausdrucks nach links.
Bitweiser NOT-Operator (~) | Führt eine bitweise Negation an einem Ausdruck durch.
Bitweiser OR-Operator (|) | Führt eine bitweise OR-Verknüpfung auf zwei Ausdrücken durch.
Bitweiser Right Shift-Operator (>>) | Verschiebt die Bits eines Ausdrucks nach rechts.
Bitweiser XOR-Operator (^) | Führt eine bitweise exklusive OR- Verknüpfung auf zwei Ausdrücken durch.
Dekrementoperator (--) | Dekrementiert eine Variable um eins.
delete-Operator | Löscht eine Eigenschaft aus einem Objekt, oder entfernt ein Element aus einem Datenfeld.
Divisionsoperator (/) | Dividiert zwei Zahlen und gibt ein numerisches Ergebnis zurück.
Gleichheitsoperator (==) | Vergleicht zwei Ausdrücke miteinander auf Gleichheit.
Größer als-Operator (>) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert größer ist.
Größer gleich-Operator | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert größer ist oder beide gleich sind.
Identitätsoperator (===) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob sie den gleichen Wert und Datentyp aufweisen.
Inkrementoperator (++) | Inkrementiert eine Variable um eins.
instanceof-Operator | Gibt einen Booleschen Wert zurück, der angibt, ob ein Objekt eine Instanz einer bestimmten Klasse ist.
Kleiner als-Operator (<) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert kleiner ist.
Kleiner gleich-Operator (<=) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob ein Wert kleiner ist oder beide gleich sind.
Komma-Operator (,) | Bewirkt das sequenzielle Ausführen zweier Ausdrücke.
Logischer AND-Operator (&&) | Führt eine logische Konjunktion zweier Ausdrücke durch.
Logischer NOT-Operator (!) | Führt eine logische Negation auf einem Ausdruck durch.
Logischer OR-Operator (||) | Führt eine logische Disjunktion auf zwei Ausdrücken durch.
Modulo-Operator (%) | Dividiert zwei Zahlen und gibt den Restwert zurück.
Multiplikationsoperator (*) | Multipliziert zwei Zahlen miteinander.
new-Operator | Erstellt ein neues Objekt.
Nicht-Identitätsoperator (!==) | Vergleicht zwei Ausdrücke miteinander, um zu bestimmen, ob sie einen unterschiedlichen Wert und Datentyp aufweisen.
Operatorvorrang | Eine Auflistung mit Informationen zum Ausführungsvorrang von JScript-Operatoren.
Subtraktionsoperator (-) | Führt eine Subtraktion von zwei Ausdrücken durch.
Trinärer Bedingungsoperator (?:) | Führt in Abhängigkeit einer Bedingung eine von zwei Anweisungen aus.
typeof-Operator | Gibt eine Zeichenfolge zurück, die den Datentyp eines Ausdrucks angibt.
Unärer Negationsoperator (-) | Zeigt den negativen Wert eines numerischen Ausdrucks an.
Ungleichheitsoperator (!=) | Vergleicht zwei Ausdrücke miteinander auf Ungleichheit.
Verbundzuweisungsoperatoren | Führt sämtliche Verbundzuweisungsoperatoren auf.
Vergleichsoperatoren | Gibt einen Booleschen Wert zurück, der das Ergebnis des Vergleichs angibt.
void-Operator | Verhindert bei einem Ausdruck die Rückgabe eines Wertes.
Vorzeichenloser Right Shift-Operator (>>>) | Verschiebt die Bits eines Ausdrucks ohne Vorzeichen nach rechts.
Zuweisungsoperator (=) | Weist einer Variablen einen Wert zu.
Sprachelement | Beschreibung
$1...$9-Eigenschaften | Gibt die neun zuletzt gespeicherten Teile zurück, die während des Mustervergleichs gefunden wurden.
arguments-Eigenschaft | Gibt ein Datenfeld zurück, das alle Argumente enthält, die an die derzeit ausgeführte Funktion übergeben werden.
caller-Eigenschaft | Gibt eine Referenz auf die Funktion zurück, die die aktuelle Funktion aufgerufen hat.
constructor-Eigenschaft | Gibt die Funktion an, die ein Objekt erstellt.
description-Eigenschaft | Setzt die mit einem bestimmten Fehler zugewiesene beschreibende Zeichenfolge oder gibt diese zurück.
E-Eigenschaft | Gibt die Eulersche Konstante, die Basis des natürlichen Logarithmus, zurück.
index-Eigenschaft | Gibt die Zeichenposition zurück, wo die erste erfolgreiche Entsprechung einer gesuchten Zeichenfolge beginnt.
Infinity-Eigenschaft | Gibt den Anfangswert von Number.POSITIVE_INFINITY zurück
input-Eigenschaft | Gibt die Zeichenfolge zurück, nach der gesucht wurde.
lastIndex-Eigenschaft (RegExp) | Gibt die Zeichenposition zurück, wo die letzte erfolgreiche Entsprechung in einer gesuchten Zeichenfolge beginnt.
length-Eigenschaft (Array) | Bestimmt einen ganzzahligen Wert, der um eins höher ist als das höchste in einem Datenfeld definierte Element.
length-Eigenschaft (Function) | Enthält die Zahl der Argumente, mit denen eine Funktion definiert wird.
length-Eigenschaft (String) | Gibt die Länge eines String-Objekts zurück.
LN2-Eigenschaft | Gibt den natürlichen Logarithmus von 2 zurück.
LN10-Eigenschaft | Gibt den natürlichen Logarithmus von 10 zurück.
LOG2E-Eigenschaft | Gibt den Logarithmus der Eulerschen Konstante e zur Basis 2 zurück.
LOG10E-Eigenschaft | Gibt den Logarithmus der Eulerschen Konstante e zur Basis 10 zurück.
MAX_VALUE-Eigenschaft | Gibt die größte in JScript darstellbare Zahl zurück.
MIN_VALUE-Eigenschaft | Gibt die der Null am nächsten kommenden Zahl zurück, die in JScript dargestellt werden kann.
NaN-Eigenschaft (Global) | Gibt den Sonderwert NaN zurück, der angibt, dass ein Ausdruck keine Zahl ist.
NaN-Eigenschaft (Number) | Gibt den Sonderwert NaN zurück, der angibt, dass ein Ausdruck keine Zahl ist.
NEGATIVE_INFINITY-Eigenschaft | Gibt einen negativeren Wert als die größte negative Zahl (-Number.MAX_VALUE) zurück, die in JScript darstellbar ist.
number-Eigenschaft | Setzt den einem bestimmten Fehler zugewiesenen numerischen Wert oder gibt diesen zurück.
PI-Eigenschaft | Gibt das Verhältnis eines Kreisumfangs zum Kreisdurchmesser zurück, was ungefähr 3,141592653589793 entspricht.
POSITIVE_INFINITY-Eigenschaft | Gibt einen größeren Wert als die größte Zahl (Number.MAX_VALUE) zurück, die in JScript darstellbar ist.
prototype-Eigenschaft | Gibt eine Referenz auf den Prototyp einer Objektklasse zurück.
source-Eigenschaft | Gibt eine Kopie des Textes des Musters regulärer Ausdrücke zurück.
SQRT1_2-Eigenschaft | Gibt die Quadratwurzel von 0,5 (oder 1 geteilt durch die Quadratwurzel von 2) zurück.
SQRT2-Eigenschaft | Gibt die Quadratwurzel von 2 zurück.
Sprachelement | Beschreibung
/*..*/ (Mehrzeilige Kommentaranweisung) | Veranlasst den JScript-Parser, mehrzeilige Kommentare zu ignorieren.
// (Einzeilige Kommentaranweisung) | Veranlasst den JScript-Parser, einzeilige Kommentare zu ignorieren.
break-Anweisung | Beendet die aktuelle Schleife oder in Verbindung mit einem Label die zugehörige Anweisung.
catch-Anweisung | Enthält Anweisungen, die beim Auftreten von Fehlern im Code innerhalb eines try-Blocks ausgeführt werden.
@cc_on-Anweisung | Aktiviert die Unterstützung der bedingten Kompilierung.
continue-Anweisung | Beendet die aktuelle Iteration einer Schleife und beginnt eine neue Iteration.
do...while-Anweisung | Führt einen Anweisungsblock einmal aus und wiederholt dann die Ausführung der Schleife, bis ein bedingter Ausdruck mit false ausgewertet wird.
for...in-Anweisung | Führt eine oder mehrere Anweisungen für die einzelnen Elemente eines Objekts oder Datenfeldes aus.
for-Anweisung | Führt einen Anweisungsblock aus, solange eine Bedingung true ist.
function-Anweisung | Deklariert eine neue Funktion.
if...else-Anweisung | Bedingte Ausführung einer Gruppe von Anweisungen, abhängig vom Wert eines Ausdruckes.
@if-Anweisung | Bedingte Ausführung einer Gruppe von Anweisungen, abhängig vom Wert eines Ausdruckes.
Labeled-Anweisung | Stellt einen Bezeichner für eine Anweisung bereit.
return-Anweisung | Verlässt die aktuelle Funktion und gibt einen Wert dieser Funktion zurück.
@set-Anweisung | Erstellt Variablen, die in bedingten Kompilierungsanweisungen verwendet werden.
switch-Anweisung | Aktiviert die Ausführung einer oder mehrerer Anweisungen, wenn der Wert eines angegebenen Ausdrucks einem Label entspricht.
this-Anweisung | Verweist auf das aktuelle Objekt.
throw-Anweisung | Löst eine Fehlerbedingung aus, die von einer try...catch-Anweisung behandelt werden kann.
try-Anweisung | Implementiert die Fehlerbehandlung für JScript.
var-Anweisung | Deklariert eine Variable.
while-Anweisung | Führt eine Anweisung aus, bis eine angegebene Bedingung false ist.
with-Anweisung | Legt das standardmäßig zu verwendende Objekt für eine Anweisung fest.

©1998 Microsoft Corporation. Alle Rechte vorbehalten. Rechtliche Hinweise.


Informationen über Leistungsmerkmale

Informationen über Leistungsmerkmale 		JScript-Sprachverzeichnis
Versionsinformationen

JScript-Funktionen - ECMA
JScript-Funktionen - Nicht-ECMA
Laufzeitmerkmale von Microsoft Scripting


Alphabetische Liste der Schlüsselwörter

Alphabetische Liste der Schlüsselwörter 		JScript-Sprachverzeichnis
Versionsinformationen

$1...$9-Eigenschaften
/*..*/ (mehrzeilige Kommentaranweisung)
// (einzeilige Kommentaranweisung)
abs-Methode
acos-Methode
ActiveXObject-Objekt
Additionsoperator (+)
anchor-Methode
arguments-Eigenschaft
Array-Objekt
asin-Methode
atan-Methode
atan2-Methode
atEnd-Methode
Bedingte Kompilierung
big-Methode
Bitweiser AND-Operator (&)
Bitweiser Left Shift-Operator (<<)
Bitweiser NOT-Operator (~)
Bitweiser OR-Operator (|)
Bitweiser Right Shift-Operator (>>)
Bitweiser XOR-Operator (^)
blink-Methode
bold-Methode
Boolean-Objekt
break-Anweisung
caller-Eigenschaft
catch-Anweisung
@cc_on-Anweisung
ceil-Methode
charAt-Methode
charCodeAt-Methode
compile-Methode
concat-Methode (Array)
concat-Methode (String)
constructor-Eigenschaft
continue-Anweisung
cos-Methode
Date-Objekt
Datentypkonvertierung
Dekrementoperator (--)
delete-Operator
description-Eigenschaft
Dictionary-Objekt
dimensions-Methode
Divisionsoperator (/)
do...while-Anweisung
E-Eigenschaft
Enumerator-Objekt
Error-Objekt
escape-Methode
eval-Methode
exec-Methode
exp-Methode
FileSystemObject-Objekte
fixed-Methode
floor-Methode
fontcolor-Methode
fontsize-Methode
for...in-Anweisung
for-Anweisung
fromCharCode-Methode
function-Anweisung
Function-Objekt
getDate-Methode
getDay-Methode
getFullYear-Methode
getHours-Methode
getItem-Methode
getMilliseconds-Methode
getMinutes-Methode
getMonth-Methode
GetObject-Funktion
getSeconds-Methode
getTime-Methode
getTimezoneOffset-Methode
getUTCDate-Methode
getUTCDay-Methode
getUTCFullYear-Methode
getUTCHours-Methode
getUTCMilliseconds-Methode
getUTCMinutes-Methode
getUTCMonth-Methode
getUTCSeconds-Methode
getVarDate-Methode
getYear-Methode
Gleichheitsoperator (==)
Global-Objekt
Größer als-Operator (>)
Größer gleich-Operator (>=)
Identitätsoperator (===)
if...else-Anweisung
@if-Anweisung
index-Eigenschaft
indexOf-Methode
Infinity-Eigenschaft
Inkrementoperator (++)
input-Eigenschaft
instanceof-Operator
isFinite-Methode
isNaN-Methode
italics-Methode
item-Methode
join-Methode
Labeled-Anweisung
lastIndex-Eigenschaft
lastIndexOf-Methode
lbound-Methode
length-Eigenschaft (Array)
length-Eigenschaft (Function)
length-Eigenschaft (String)
link-Methode
LN2-Eigenschaft
LN10-Eigenschaft
log-Methode
LOG2E-Eigenschaft
LOG10E-Eigenschaft
Logischer AND-Operator (&&)
Logischer NOT-Operator (!)
Logischer OR-Operator (||)
Kleiner als-Operator (<)
Kleiner gleich-Operator (<=)
Komma-Operator (,)
match-Methode
Math-Objekt
MAX_VALUE-Eigenschaft
max-Methode
MIN_VALUE-Eigenschaft
min-Methode
Modulo-Operator (%)
moveFirst-Methode
moveNext-Methode
Multiplikationsoperator (*)
NaN-Eigenschaft (Global)
NaN-Eigenschaft (Number)
NEGATIVE_INFINITY-Eigenschaft
new-Operator
Nicht-Identitätsoperator (!==)
number-Eigenschaft
Number-Objekt
Object-Objekt
Operatorvorrang
parse-Methode
parseFloat-Methode
parseInt-Methode
PI-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
pow-Methode
prototype-Eigenschaft
random-Methode
RegExp-Objekt
Regular Expression-Objekt
replace-Methode
return-Anweisung
reverse-Methode
round-Methode
ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion
search-Methode
@set-Anweisung
setDate-Methode
setFullYear-Methode
setHours-Methode
setMilliseconds-Methode
setMinutes-Methode
setMonth-Methode
setSeconds-Methode
setTime-Methode
setUTCDate-Methode
setUTCFullYear-Methode
setUTCHours-Methode
setUTCMilliseconds-Methode
setUTCMinutes-Methode
setUTCMonth-Methode
setUTCSeconds-Methode
setYear-Methode
sin-Methode
slice-Methode (Array)
slice-Methode (String)
small-Methode
sort-Methode
source-Eigenschaft
split-Methode
sqrt-Methode
SQRT1_2-Eigenschaft
SQRT2-Eigenschaft
strike-Methode
String-Objekt
sub-Methode
substr-Methode
substring-Methode
Subtraktionsoperator (-)
sup-Methode
switch-Anweisung
Syntax regulärer Ausdrücke
tan-Methode
test-Methode
this-Anweisung
throw-Anweisung
toArray-Methode
toGMTString-Methode
toLocaleString-Methode
toLowerCase-Methode
toString-Methode
toUpperCase-Methode
toUTCString-Methode
Trinärer Bedingungsoperator (?:)
try-Anweisung
typeof-Operator
ubound-Methode
Unärer Negationsoperator (-)
unescape-Methode
Ungleichheitsoperator (!=)
UTC-Methode
valueOf-Methode
var-Anweisung
Variablen für die bedingte Kompilierung
VBArray-Objekt
Verbundzuweisungsoperatoren
Vergleichsoperatoren
void-Operator
Vorzeichenloser Right Shift-Operator (>>>)
while-Anweisung
with-Anweisung
Zuweisungsoperator (=)


Funktionen

Funktionen 		JScript-Sprachverzeichnis
Versionsinformationen

GetObject-Funktion
ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion


Methoden

Methoden 		JScript-Sprachverzeichnis
Versionsinformationen

abs-Methode
acos-Methode
anchor-Methode
asin-Methode
atan-Methode
atan2-Methode
AtEnd-Methode
big-Methode
blink-Methode
bold-Methode
ceil-Methode
charAt-Methode
charCodeAt-Methode
compile-Methode
concat-Methode (Array)
concat-Methode (String)
cos-Methode
dimensions-Methode
escape-Methode
eval-Methode
exec-Methode
exp-Methode
fixed-Methode
floor-Methode
fontcolor-Methode
fontsize-Methode
fromCharCode-Methode
getDate-Methode
getDay-Methode
getFullYear-Methode
getHours-Methode
getItem-Methode
getMilliseconds-Methode
getMinutes-Methode
getMonth-Methode
getSeconds-Methode
getTime-Methode
getTimezoneOffset-Methode
getUTCDate-Methode
getUTCDay-Methode
getUTCFullYear-Methode
getUTCHours-Methode
getUTCMilliseconds-Methode
getUTCMinutes-Methode
getUTCMonth-Methode
getUTCSeconds-Methode
getVarDate-Methode
getYear-Methode
indexOf-Methode
isFinite-Methode
isNaN-Methode
italics-Methode
item-Methode
join-Methode
lastIndexOf-Methode
lbound-Methode
link-Methode
log-Methode
match-Methode
max-Methode
min-Methode
moveFirst-Methode
moveNext-Methode
parse-Methode
parseFloat-Methode
parseInt-Methode
pow-Methode
random-Methode
replace-Methode
reverse-Methode
round-Methode
search-Methode
setDate-Methode
setFullYear-Methode
setHours-Methode
setMilliseconds-Methode
setMinutes-Methode
setMonth-Methode
setSeconds-Methode
setTime-Methode
setUTCDate-Methode
setUTCFullYear-Methode
setUTCHours-Methode
setUTCMilliseconds-Methode
setUTCMinutes-Methode
setUTCMonth-Methode
setUTCSeconds-Methode
setYear-Methode
sin-Methode
slice-Methode (Array)
slice-Methode (String)
small-Methode
sort-Methode
split-Methode
sqrt-Methode
strike-Methode
sub-Methode
substring-Methode
substr-Methode
sup-Methode
tan-Methode
test-Methode
toArray-Methode
toGMTString-Methode
toLocaleString-Methode
toLowerCase-Methode
toString-Methode
toUpperCase-Methode
toUTCString-Methode
ubound-Methode
unescape-Methode
UTC-Methode
valueOf-Methode


Objekte

Objekte 		JScript-Sprachverzeichnis
Versionsinformationen

ActiveXObject-Objekt
Array-Objekt
Boolean-Objekt
Date-Objekt
Dictionary-Objekt
Enumerator-Objekt
Error-Objekt
FileSystemObject-Objekte
Function-Objekt
Global-Objekt
Math-Objekt
Number-Objekt
Object-Objekt
RegExp-Objekt
Regular Expression-Objekt
String-Objekt
VBArray-Objekt


Operatoren

Operatoren 		JScript-Sprachverzeichnis
Versionsinformationen

Additionsoperator (+)
Bitweiser AND-Operator (&)
Bitweiser Left Shift-Operator (<<)
Bitweiser NOT-Operator (~)
Bitweiser OR-Operator (|)
Bitweiser Right Shift-Operator (>>)
Bitweiser XOR-Operator (^)
Dekrementoperator (--)
delete-Operator
Divisionsoperator (/)
Gleichheitsoperator (==)
Größer als-Operator (>)
Größer gleich-Operator (>=)
Identitätsoperator (===)
Inkrementoperator (++)
instanceof-Operator
Kleiner als-Operator (<)
Kleiner gleich-Operator (<=)
Komma-Operator (,)
Logischer AND-Operator (&&)
Logischer NOT-Operator (!)
Logischer OR-Operator (||)
Modulo-Operator (%)
Multiplikationsoperator (*)
new-Operator
Nicht-Identitätsoperator (!==)
Operatorvorrang
Subtraktionsoperator (-)
Trinärer Bedingungsoperator (?:)
typeof-Operator
Unärer Negationsoperator (-)
Ungleichheitsoperator (!=)
Verbundzuweisungsoperatoren
Vergleichsoperatoren
void-Operator
Vorzeichenloser Right Shift-Operator (>>>)
Zuweisungsoperator (=)


Eigenschaften

Eigenschaften 		JScript-Sprachverzeichnis
Versionsinformationen

$1...$9-Eigenschaften
arguments-Eigenschaft
caller-Eigenschaft
constructor-Eigenschaft
description-Eigenschaft
E-Eigenschaft
index-Eigenschaft
Infinity-Eigenschaft
input-Eigenschaft
lastIndex-Eigenschaft
length-Eigenschaft (Array)
length-Eigenschaft (Function)
length-Eigenschaft (String)
LN10-Eigenschaft
LN2-Eigenschaft
LOG10E-Eigenschaft
LOG2E-Eigenschaft
MAX_VALUE-Eigenschaft
MIN_VALUE-Eigenschaft
NaN-Eigenschaft (Global)
NaN-Eigenschaft (Number)
NEGATIVE_INFINITY-Eigenschaft
number-Eigenschaft
PI-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
prototype-Eigenschaft
source-Eigenschaft
SQRT1_2-Eigenschaft
SQRT2-Eigenschaft


Anweisungen

Anweisungen 		JScript-Sprachverzeichnis
Versionsinformationen

break-Anweisung
catch-Anweisung
@cc_on-Anweisung
continue-Anweisung
do...while-Anweisung
for...in-Anweisung
for-Anweisung
function-Anweisung
if...else-Anweisung
@if-Anweisung
Kommentaranweisungen
Labeled-Anweisung
return-Anweisung
@set-Anweisung
switch-Anweisung
this-Anweisung
throw-Anweisung
try-Anweisung
var-Anweisung
while-Anweisung
with-Anweisung


JScript-Tutorium

JScript-Tutorium
JScript-Sprachverzeichnis

Was ist JScript?
JScript-Grundlagen
Schreiben von JScript-Code
JScript-Variablen
JScript-Datentypen
JScript-Operatoren
Steuern des Programmablaufs
JScript-Funktionen
JScript-Objekte
Reservierte Schlüsselwörter von JScript
JScript für Fortgeschrittene
Rekursion
Gültigkeitsbereich von Variablen
Kopieren, Übergeben und Vergleichen von Daten
Verwenden von Datenfeldern
Erstellen erweiterter Objekte
Sonderzeichen
Beseitigung von Fehlern aus Skripten
Verwenden von JScript im Internet Explorer


Was ist JScript?

Was ist JScript?
 JScript-Tutorium
Weiter

JScript ist die Microsoft-Implementierung der Sprachspezifikation ECMA 262. Es handelt sich um eine vollständige Implementierung zuzüglich einiger Erweiterungen, die die Funktionen von Microsoft Internet Explorer nutzen. Dieses Tutorium will Ihnen die ersten Schritte mit JScript erläutern.

Benutzerfreundlich und leicht erlernbar
JScript ist eine interpretierte objektbasierte Skriptsprache. Obgleich sie über einen geringeren Funktionsumfang als größere objektorientierte Sprachen wie C++ und Java verfügt, ist JScript für die beabsichtigten Zwecke mehr als nur ausreichend leistungsstark.

JScript ist weder eine Kleinausgabe noch eine Vereinfachung einer anderen Sprache (sie ist z. B. nur entfernt und indirekt mit Java verwandt). Sie hat jedoch Einschränkungen. So können Sie keine selbstständigen Anwendungen in ihr schreiben, und sie bietet nur begrenzte Funktionen zum Lesen und Schreiben von Dateien. Darüber hinaus können JScript-Skripten nur bei vorhandenem Interpreter ausgeführt werden, entweder über einen Web-Server oder einen Web-Browser.

JScript ist eine lose typisierte Sprache. Das heißt, dass Sie die Datentypen der Variablen nicht explizit deklarieren müssen. Darüber hinaus führt JScript in vielen Fällen Konvertierungen automatisch nach Bedarf durch. Wenn Sie z. B. versuchen, eine Zahl einem Element hinzuzufügen, das aus Text besteht (eine Zeichenfolge), wird die Zahl in Text konvertiert.

Das weitere Lernprogramm bietet eine Übersicht über die JScript-Funktionen. Ausführliche Informationen zur Sprachimplementierung finden Sie im JScript-Sprachverzeichnis.

Hinweis Der Code in vielen Beispielen dieses Tutoriums ist mitunter expliziter und weniger dicht angeordnet als der Code, den Sie auf tatsächlichen Web-Seiten finden. Die meisten Beispiele sind auch recht einfach. Die verfolgte Absicht ist das Verdeutlichen der Konzepte, nicht das Ausdrücken einer optimalen Codierung hinsichtlich Prägnanz und Stil. Es ist auf jeden Fall eine gute Idee, Code zu schreiben, den Sie lesen und leicht verstehen können, und zwar sechs Monate, nachdem Sie ihn geschrieben haben.


Schreiben von JScript-Code

Schreiben von JScript-Code
JScript-Tutorium
Zurück
Weiter

Wie viele andere Programmiersprachen wird Microsoft JScript im Textformat geschrieben und ist in Anweisungen, Blöcke von zusammengehörigen Anweisungen und Kommentare unterteilt. In einer Anweisung können Sie Variablen, Daten (wie Zeichenfolgen und Zahlen) und Ausdrücke verwenden.

Anweisungen
Eine Anweisung im JScript-Code enthält ein oder mehrere Elemente und Symbole in einer Zeile. Eine neue Zeile leitet eine neue Anweisung ein, aber Sie sollten Anweisungen explizit mit einem Semikolon (;) abschließen, dem JScript-Endezeichen.

Vogel1 = "Meise";
var Heute = new Date();
Eine von geschweiften Klammern ({}) eingeschlossene Gruppe von JScript-Anweisungen wird als Block bezeichnet. Anweisungsblöcke werden beispielsweise in Funktionen und Bedingungen verwendet.

Im folgenden Beispiel beginnt die erste Anweisung mit der Definition einer Funktion, die aus einem Block von fünf Anweisungen besteht. Die letzten drei Anweisungen, die nicht von Klammern eingeschlossen werden, sind kein Block und nicht Teil der Funktionsdefinition.

function convert(Zoll)  {
    Fuss = Zoll / 12;  // Diese fünf Anweisungen stehen in einem Block.
    Meilen = Fuss / 5280;
    nautischeMeilen = Fuss / 6080;
    cm = Zoll * 2.54;
    Meter = Zoll / 39.37;
}
km = Meter / 1000;  // Diese drei Anweisungen stehen nicht in einem Block.
kRadius = km;
mRadius = Meilen;
Kommentare
Ein einzeiliger JScript-Kommentar beginnt mit zwei Schrägstrichen (//). Ein mehrzeiliger Kommentar beginnt mit einem Schrägstrich und einem Sternchen (/*) und endet mit der umgekehrten Kombination (*/).

eineGuteIdee = "Kommentieren Sie Ihren Code.";  //  Dies ist eine einzeiliger Kommentar.

/*
Dies ist ein mehrzeiliger Kommentar, der das vorherige Code-Beispiel erläutert.

Die Anweisung weist der Variablen eineGuteIdee einen Wert zu. Der Wert, der zwischen
den Anführungszeichen steht, wird Literal genannt. Ein Literal enthält
direkt die Informationen selbst, nicht einen indirekten Verweis auf die
Informationen. (Die Anführungszeichen sind nicht Teil des Literals.)
*/

//  Ein weiterer mehrzeiliger Kommentar, als Folge von einzeiligen Kommentaren geschrieben.
//  Nachdem die Anweisung ausgeführt wurde, können Sie auf den Inhalt der Variablen eineGuteIdee
//  verweisen, indem Sie den Namen verwenden, wie in der nächsten Anweisung gezeigt. In dieser
//  wird der Variablen eineGuteIdee ein Zeichenfolgenliteral hinzugefügt, um eine neue Variable
//  zu erstellen.

var erweiterteIdee = eineGuteIdee + "Kann man immer brauchen.";
Zuweisungen und Gleichheit
Das Gleichheitszeichen (=) wird in JScript verwendet, um einen Wert zuzuweisen. Der JScript-Code

eineGanzzahl = 3;
besagt "Weise der Variablen eineGanzzahl den Wert 3 zu" oder "eineGanzzahl nimmt den Wert 3 an". Wenn Sie zwei Werte vergleichen möchten, um festzustellen, ob diese gleich sind, verwenden Sie zwei Gleichheitszeichen (==). Eine genaue Beschreibung finden Sie unter Steuern des Programmablaufs.

Ausdrücke
Ein Ausdruck in JScript kann als regulärer Boolescher oder numerischer Ausdruck gelesen werden. Ausdrücke enthalten Symbolzeichen wie "+" anstatt Wörter wie "addiere". Jede gültige Kombination von Werten, Variablen, Operatoren und Ausdrücken bildet einen Ausdruck.

var einAusdruck = "3 * (4 / 5)";
var einZweiterAusdruck = "Math.PI * radius * 2";
var einDritterAusdruck = einZweiterAusdruck + "%" + einAusdruck;
var einVierterAusdruck = "(" + einZweiterAusdruck + ") % (" + einAusdruck + ")";


JScript-Variablen

JScript-Variablen
 JScript-Tutorium
Zurück
Weiter

In Microsoft JScript werden Variablen verwendet, um Werte in Ihren Skripten zu speichern. Die Variablen bieten daher die Möglichkeit, Werte durch die Angabe von Namen abzufragen und zu verändern. Bei effizienter Nutzung kann dies zum besseren Verständnis des Verhaltens eines Skripts dienen.
Deklarieren von Variablen
Obwohl nicht erforderlich, werden Variablen normalerweise vor ihrer Verwendung deklariert, und zwar mit der var-Anweisung. Wirklich erforderlich ist die Verwendung der var-Anweisung bei der Deklaration von Variablen, die lokal für eine Funktion sind. Lokale Variablen gelten nur innerhalb der Funktion. In allen anderen Fällen wird die Verwendung der var-Anweisung empfohlen, um Variablen zu deklarieren.

Die folgenden Code-Beispiele enthalten Variablendeklarationen:

var mim = "Ein Mann, ein Plan, ein Kanal, Panama!";  // Die Variable mim enthält den Datentyp "String".
// Der Satz in den Anführungszeichen, dessen Wert mim zugeordnet wird, ist ein Zeichenfolgenliteral.

var ror = 3;        // Die Variable ror enthält einen numerischen Typ.
var nen = true;        // Die Variable nen enthält den Datentyp "Boolean".
var fif = 2,718281828;        // Die Variable fif enthält einen numerischen Typ.
Benennen von Variablen
JScript unterscheidet zwischen Groß- und Kleinschreibung. Daher unterscheidet sich die Deklaration der Variable meinZaehler von der Variable MEINZaehler. Darüber hinaus müssen bei der Benennung von Variablen bestimmte Richtlinien beachtet werden:
  • Das erste Zeichen muss ein Buchstabe (Groß- oder Kleinbuchstabe), ein Unterstrich (_) oder ein Dollarzeichen ($) sein.
  • Für die weiteren Zeichen sind Buchstaben, Zahlen, Unterstriche oder Dollarzeichen zulässig.
  • Der Variablenname darf kein reserviertes Wort sein.
Einige Beispiele für gültige Variablennamen:
  • _Seitenzahl
  • Teil9
  • Anzahl_Elemente
Einige ungültige Variablennamen:
  • 99Luftballons // Beginnt mit einer Zahl.
  • Smith&Wesson // Ein kaufmännisches Und-Zeichen (&) ist kein gültiges Zeichen für Variablennamen.
Wenn Sie eine Variable deklarieren und initialisieren, ihr aber keinen bestimmten Wert zuweisen möchten, können Sie ihr den speziellen Wert null zuweisen.
var zaz = null;
var nichtsehrviel = 3 * zaz;        // An diesem Punkt wird nichtsehrviel zu 0.
Wenn Sie eine Variable deklarieren, ohne ihr einen Wert zuzuweisen, existiert sie zwar, ist aber undefined.
var godot;
var wartenAuf = 1 * godot;  // Weist wartenAuf den Wert NaN zu, da godot nicht definiert ist.
Sie können eine Variable implizit deklarieren (ohne var zu verwenden), indem Sie ihr einen Wert zuweisen. Sie können allerdings keine Variable verwenden, die noch nie deklariert wurde. Verwenden Sie dennoch eine noch nicht deklarierte Variable, tritt ein Laufzeitfehler auf.
lel = "";  // Die Variable lel ist implizit deklariert.

var durcheinander = vyv + zez;  // Löst einen Fehler aus, da vyv und zez nicht existieren.
Erzwungene Konvertierungen
Auf Grund der wenig restriktiven Struktur von JScript verfügen Variablen in JScript technisch gesehen über keinen Typ. Sie haben denselben Typ wie die Daten, die sie enthalten. Unter bestimmten Bedingungen ist es möglich, eine automatische Konvertierung einer Variablen oder eines Datenelements in einen anderen Typ zu erzwingen. Zahlen können sehr leicht in Zeichenfolgen eingefügt werden, allerdings können Zeichenfolgen nicht direkt in Zahlen eingefügt werden, weshalb explizite Konvertierungsfunktionen parseInt() und parseFloat() zur Verfügung gestellt wurden.
var von = 1;
var bis = 10;
var tueDies = "Zählen von ";
tueDies += von + " bis " + bis;
Nachdem dieser Code ausgeführt wurde, enthält die Variable tueDies "Zählen von 1 bis 10". Die numerischen Daten wurden in eine Zeichenfolge umgewandelt.
var undNun = 0;
undNun += 1 + "10";	// Da "10" eine Zeichenfolge ist,
            // hat += (Operator) eine Verkettung zur Folge.
Nachdem dieser Code ausgeführt wurde, enthält die Variable undNun "0110". Folgende Schritte werden durchgeführt, um dieses Ergebnis zu erhalten:
  1. Die Typen von 1 und "10" werden überprüft. Die "10" ist eine Zeichenfolge, die 1 eine Zahl. Also wird die Zahl in eine Zeichenfolge umgewandelt.
  2. Da beide Werte vor und nach dem Additionsoperator Zeichenfolgen sind, werden diese miteinander verkettet. Das Ergebnis lautet "110".
  3. Die Typen der Werte vor und nach += (Operator) werden überprüft. undNun enthält eine Zahl und "110" ist eine Zeichenfolge, also wird die Zahl in eine Zeichenfolge konvertiert.
  4. Da nun vor und nach += (Operator) Zeichenfolgen stehen, werden diese verkettet. Das Ergebnis lautet "0110".
  5. Dieses Ergebnis wird in undNun gespeichert.
var undDann = 0;
undDann += 1 + parseInt("10");        // In diesem Fall führt += (Operator) eine Addition aus.
Nachdem der Code ausgeführt wird, enthält die undDann-Variable die Ganzzahl 11.


JScript-Datentypen

JScript-Datentypen
 JScript-Tutorium
Zurück
Weiter

Was sind JScript-Datentypen?
Microsoft JScript unterstützt sechs Datentypen. Die Haupttypen sind Zahlen, Zeichenfolgen, Objekte und Boolesche Werte. Die anderen beiden sind null und undefined.
String-Datentyp
Zeichenfolgen werden durch Hochkommata oder Anführungszeichen gekennzeichnet. (Verwenden Sie Hochkommata, um Zeichenfolgen einzugeben, die Anführungszeichen enthalten.) Eine Zeichenfolge ist bei JScript ebenfalls ein Objekt, jedoch handelt es sich um einen Spezialfall mit besonderen Eigenschaften. Nachstehend sind einige Beispiele für Zeichenfolgen aufgeführt:
"Die Kuh sprang über den Mond."
'"Aus dem Weg!" schrie der Techniker.'
"42"
Eine Zeichenfolge kann null oder mehr Unicode-Zeichen enthalten. Enthält sie kein Zeichen, wird sie als Nullzeichenfolge ("") bezeichnet.
Datentypen für Zahlen
JScript unterstützt Ganz- und Fließkommazahlen. Ganzzahlen können positiv, 0 oder negativ sein; eine Fließkommazahl kann ein Dezimalkomma, ein "e" (Groß- oder Kleinschreibung), das für die Exponenzialschreibweise zur Basis 10 verwendet wird, oder beides enthalten. Diese Zahlen entsprechen dem Standard IEEE 754 für die numerische Darstellung. Darüber hinaus gibt es einige Zahlenwerte, bei denen es sich um Sonderfälle handelt:
  • NaN bzw. "Not a Number"
  • Plus-unendlich
  • Minus-unendlich
  • Plus 0
  • Minus 0
Ganzzahlen können mit der Basis 10 (dezimal), 8 (oktal) oder 16 (hexadezimal) dargestellt werden.

Ganzzahlen im Oktalsystem werden mit einer "0" zu Beginn dargestellt und können die Ziffern von 0 bis 7 enthalten. Wenn eine Zahl eine "0" am Beginn enthält und die Ziffern "8" und/oder "9" besitzt, ist sie eine Dezimalzahl. Eine Zahl, die sonst eine oktale Zahl wäre, aber den Buchstaben "e" (oder "E") enthält, erzeugt einen Fehler.

Ganzzahlen im Hexadezimalsystem ("hex") werden mit "0x" (das "X" kann in Groß- oder Kleinschrift angezeigt werden) eingeleitet und können die Ziffern 0 bis 9 und die Buchstaben A bis F (Groß- oder Kleinschreibung) enthalten. Der Buchstabe "e" ist eine mögliche Ziffer in der hexadezimalen Schreibweise und gibt keinen Exponenten an. Die Buchstaben A bis F werden verwendet, um die Zahlen 10 bis 15 zur Basis 10 darzustellen. 0xF ist daher äquivalent zu 15, und 0x10 ist äquivalent zu 16.

Zahlen im Oktal- und Hexadezimalsystem können negativ sein, aber keine Brüche darstellen. Eine Zahl, die mit einer einzelnen "0" beginnt und ein Dezimalkomma enthält, ist eine dezimale Fließkommazahl. Wenn eine Zahl, die mit "0x" oder "00" beginnt, ein Dezimalkomma enthält, werden alle Stellen rechts vom Dezimalkomma ignoriert.

Einige Beispielzahlen:

.0001; 0.0001; 1e-4; 1.0e-4  // Vier Fließkommazahlen, die alle äquivalent sind.
3.45e2                       // Eine Fließkommazahl, äquivalent zu 345.
42                           // Eine Ganzzahl.
0377                         // Eine Ganzzahl im Oktalsystem, äquivalent zu 255.
00.0001                      // Da Zahlen im Oktalsystem keine dezimalen Teile haben, ist dies äquivalent zu 0.
0378                         // Eine Ganzzahl, äquivalent zu 378.
0Xff                         // Eine Ganzzahl im Hexadezimalsystem, äquivalent zu 255.
0x37CF                       // Eine Ganzzahl im Hexadezimalsystem, äquivalent zu 14287.
0x3e7                        // Eine Ganzzahl im Hexadezimalsystem, äquivalent zu 999.
0x3.45e2                     // Da hexadezimale Zahlen keine dezimalen Teile haben, ist dies äquivalent zu 3.
Boolean
Die möglichen Booleschen Werte sind true und false. Dies sind spezielle Werte, die nicht gleich 1 und 0 sind.

Hinweis In einem Vergleich wird ein zum Ergebnis 0 führender Ausdruck als false und jede Anweisung, die zu einem Ergebnis ungleich 0 führt, als true interpretiert. Daher ergibt der folgende Ausdruck den Wert true:

(false == 0)

Weitere Informationen über Vergleiche finden Sie unter Steuern des Programmablaufs.

Datentyp "undefined"
Ein nicht definierter Wert ist einfach ein Wert, der einer Variablen automatisch nach dem Anlegen zugewiesen worden ist, aber bevor ihr ein Wert zugewiesen wird.
null-Datentypen
Ein null-Wert hat keinen Wert und entspricht keiner Bedeutung.


JScript-Operatoren

JScript-Operatoren 		JScript-Tutorium
Zurück
Weiter

JScript verfügt über eine Reihe von Operatoren wie arithmetische, logische, bitweise und Zuweisungs-Operatoren. Weiterhin gibt es einige sonstige Operatoren, die nicht kategorisiert werden können.

Arithmetisch | Logisch | Bitweise | Zuweisung | Sonstige
Beschreibung | Symbol | Beschreibung | Symbol | Beschreibung | Symbol | Beschreibung | Symbol | Beschreibung | Symbol
Unäre Negation - Logisches NOT ! Bitweises NOT ~ Zuweisung = delete delete
Inkrement ++ Kleiner als < Bitweises Left Shift << Verbundzuweisung OP= typeof typeof
Dekrement -- Größer als > Bitweises Right Shift >> void void
Multiplikation * Kleiner gleich <= Vorzeichenloses Right Shift >>>
Division / Größer gleich >= Bitweises AND &
Modulo % Gleichheit == Bitweises XOR ^
Addition + Ungleichheit != Bitweises OR |
Subtraktion - Logisches AND &&
Logisches OR ||
Bedingung (trinär) ?:
Komma ,
Identität ===
Nicht-Identität !==

Operatorvorrang
Operatoren werden in JScript in einer bestimmten Rangfolge ausgewertet. Diese wird Operatorvorrang genannt. Die folgende Tabelle listet die Operatoren in der Reihenfolge ihres Vorrangs von oben nach unten auf. Operatoren in derselben Zeile werden von links nach rechts ausgewertet.

Operator | Beschreibung
. [] () Feldzugriff, Datenfeldindizierung und Funktionsaufrufe
++ -- - ~ ! typeof new void delete | unäre Operatoren, Rückgabedatentyp, Objekterstellung, nicht definierte Werte
* / % Multiplikation, Division, Modulo-Division
+ - + Addition, Subtraktion, Zeichenfolgenverkettung
<< >> >>> Bit-Verschiebung
< <= > >= Kleiner als, Kleiner gleich, Größer als, Größer gleich
== != === !== Gleichheit, Ungleichheit, Identität, Nicht-Identität
& Bitweises AND
^ Bitweises XOR
| Bitweises OR
&& Logisches AND
|| Logisches OR
?: Bedingungen
= OP= | Zuweisungen, Zuweisungen mit Operation
, Mehrfache Auswertung

Sie verändern die Reihenfolge der Abarbeitung, indem Sie Klammern verwenden. Der Ausdruck in den Klammern wird abgearbeitet, bevor das Ergebnis für den verbleibenden Teil der Anweisung verwendet wird.

Ein Operator mit höherem Vorrang wird vor einem Operator mit niedrigerem Vorrang bearbeitet. Beispiele:

z = 78 * (96 + 3 + 45)
Dieser Ausdruck enthält fünf Operatoren: =, *, (), + und +. Gemäß dem Vorrang werden sie in der folgenden Reihenfolge ausgewertet: (), *, +, +, =.
  1. Die Auswertung des Ausdrucks in der Klammer erfolgt zuerst: Es sind zwei Additionsoperatoren mit gleichem Operatorvorrang vorhanden: 96 und 3 werden addiert, und 45 wird zu der Summe addiert. Das Ergebnis ist 144.
  2. Als Nächstes folgt die Multiplikation: 78 und 144 werden multipliziert. Das Ergebnis ist 11232.
  3. Zuletzt erfolgt die Zuweisung: 11232 wird z zugewiesen.


Steuern des Programmablaufs
 JScript-Tutorium
Zurück
Weiter

Steuern des Programmablaufs
Recht häufig muss ein Skript verschiedene Aufgaben unter verschiedenen Bedingungen erfüllen. Sie können z. B. ein Skript schreiben, das die Zeit stündlich prüft und einige Parameter im Verlauf des Tages entsprechend ändert. Sie können auch ein Skript schreiben, das bestimmte Arten der Eingabe akzeptiert und dann entsprechend reagiert. Oder Sie können ein Skript schreiben, das eine angegebene Aktion wiederholt.

Es gibt verschiedene Bedingungstypen, die Sie überprüfen können. Alle Bedingungstests in Microsoft JScript sind vom Typ Boolean, so dass das Ergebnis eines Tests true oder false ist. Sie können nach Wunsch Werte überprüfen, die vom Typ Boolean, Number oder String sind.

JScript bietet Steuerungsstrukturen für viele verschiedene Möglichkeiten. Die einfachste dieser Strukturen ist die Bedingungsanweisung.

Verwenden von Bedingungsanweisungen
JScript unterstützt die Bedingungsanweisungen if und if...else. In if-Anweisungen wird eine Bedingung getestet. Passiert die Bedingung den Test, wird der von Ihnen geschriebene JScript-Code ausgeführt. (Bei der if...else-Anweisung wird ein anderer Code ausgeführt, wenn die Bedingung den Test nicht passiert.) Die einfachste Form einer if-Anweisung kann gänzlich in einer Zeile geschrieben werden. Wesentlich häufiger sind jedoch mehrzeilige if- und if...else-Anweisungen.

Die folgenden Beispiele zeigen Syntaxgefüge, die mit den Anweisungen if und if...else verwendet werden können. Das erste Beispiel zeigt die einfachste Form eines Booleschen Tests. Falls das Element in Klammern mit true ausgewertet wird (und nur dann), erfolgt die Ausführung der Anweisung bzw. des Anweisungsblocks hinter if.

// Die Funktion "zerschmeisse()" wird an einer anderen Stelle im Code definiert.
if (neuesSchiff)
   zerschmeisse(sektflasche,bug);  // Boolescher Test, ob neuesSchiff wahr ist.

// Bei diesem Beispiel misslingt der Test, wenn nicht beide Bedingungen wahr sind.
if (schale.farbe == "Tiefgelb " && schale.textur == "Große und kleine Falten")
{
        dieAntwort = ("Ist es eine Galia-Melone? <br> ");
}

// Bei diesem Beispiel ist der Test erfolgreich, wenn eine von beiden Bedingungen wahr ist.
var dieReaktion = "";
if ((lbsGewicht > 15) || (lbsGewicht > 45))
{
    dieReaktion = ("Oh, was für ein süßes Kätzchen! <br>");
}
else
    theReaktion = ("Da haben Sie aber eine ganz schön große Katze! <br>");
Bedingungsoperator
JScript unterstützt auch ein implizites Bedingungsformat. Dieses verwendet ein Fragezeichen nach der zu testenden Bedingung (an Stelle des Wortes if vor der Bedingung) und gibt zwei Alternativen an, von denen eine verwendet wird, wenn die Bedingung erfüllt wird. Die andere wird verwendet, wenn dem nicht so ist. Die Alternativen werden durch einen Doppelpunkt getrennt.
var stunden = "";

// Der Code gibt an, dass "stunden" entweder den Inhalt von "dieStunde" oder
// "dieStunde - 12" enthält.

stunden += (dieStunde >= 12) ? " PM" : " AM";

Tipp Wenn Sie mehrere Bedingungen gemeinsam testen wollen und wissen, dass eine nicht bzw. eher zutrifft als eine der anderen, können Sie abhängig davon, ob Sie die Tests mit OR (||) oder AND (&&) verknüpft haben, die Ausführung des Skripts beschleunigen, indem Sie diese Bedingung an die erste Stelle in der Bedingungsanweisung setzen. Wenn z. B. drei Bedingungen alle wahr sein müssen (unter Verwendung von &&) und der zweite Test misslingt, dann wird die dritte Bedingung nicht getestet.

Auch wenn nur eine von mehreren Bedingungen wahr sein muss (unter Verwendung von ||), wird das Testen angehalten, sobald eine der Bedingungen den Test bestanden hat. Dies ist besonders wirkungsvoll, wenn zu den zu testenden Bedingungen die Ausführung von Funktionsaufrufen oder von anderem Code zählt.

Ein Beispiel für den Nebeneffekt dieses Abkürzungsverfahrens zeigt das folgende Codebeispiel: "alsZweites" wird nicht ausgeführt, wenn "zuerst()" 0 oder false zurückgibt.

if ((zuerst() == 0) || (alsZweites() == 0))
  // Beliebiger Code
Verwenden von Wiederholungen bzw. Schleifen
Es gibt mehrere Möglichkeiten, eine Anweisung oder einen Anweisungsblock wiederholt auszuführen. Im Allgemeinen wird die wiederholte Ausführung Schleife genannt. Diese wird normalerweise durch einen Test mehrerer Variablen gesteuert, deren Wert sich bei jedem Ausführen der Schleife ändert. Microsoft JScript unterstützt viele Typen von Schleifen: for-Schleifen, for...in-Schleifen, while-Schleifen, do...while-Schleifen und switch-Schleifen.
Verwenden von for-Schleifen
Die for-Anweisung gibt eine Zählervariable, eine Testbedingung und eine Aktion an, die den Zähler aktualisiert. Unmittelbar vor jedem Ausführen der Schleife (Durchlauf oder Iteration genannt) wird die Bedingung getestet. Nach der Ausführung der Schleife wird die Zählervariable aktualisiert, ehe der nächste Durchlauf beginnt.

Sollte die Bedingung für die Schleife nie erfüllt werden, wird die Schleife zu keiner Zeit ausgeführt. Wird die Testbedingung stets erfüllt, entsteht eine Endlosschleife. Während ersteres in manchen Fällen wünschenswert ist, so gilt dies nicht für letzteres. Seien Sie deshalb beim Schreiben der Schleifenbedingungen sorgfältig.

/*
Der Aktualisierungsausdruck ("iZaehler++" in den folgenden Beispielen) wird am Ende der
Schleife ausgeführt, nachdem der Anweisungsblock, der den Hauptteil der Schleife ausmacht,
ausgeführt wurde und bevor die Bedingung getestet wird.
*/

var wieweit = 11;  // Begrenzt die Schleife auf 11.

var summe = new Array(wieweit);  // Erstellt ein Datenfeld mit Namen "summe" und 11 Elementen: von 0 bis 10.
var dieSumme = 0;
summe[0] = 0;

for(var iZaehler = 1; iZaehler < wieweit; iZaehler++)  {        // Zählt in diesem Fall von 1 bis 10.
dieSumme += iZaehler;
summe[iZaehler] = dieSumme;
}

var neueSumme = 0;
for(var iZaehler = 1; iZaehler > wieweit; iZaehler++)  {        // Dieser Teil wird nicht ausgeführt.
neueSumme += iZaehler;
}

var summe = 0;
for(var iZaehler = 1; iZaehler > 0; iZaehler++)  {        // Dies ist eine Endlosschleife.
summe += iZaehler;
}
Verwenden von for...in-Schleifen
JScript bietet eine besondere Schleife zum Durchlaufen aller Eigenschaften eines Objekts. Der Schleifenzähler in einer for...in-Schleife durchläuft alle Indizes in dem Datenfeld. Er ist zudem eine Zeichenfolge und keine Zahl.
for (j in tagliatelleVerde)  // "tagliatelleVerde" ist ein Objekt mit mehreren Eigenschaften
{
// Verschiedene JScript-Code-Anweisungen.
}
Verwenden von while-Schleifen
Die while-Schleife ist einer for-Schleife sehr ähnlich. Im Gegensatz zu dieser verfügt die while-Schleife nicht über eine integrierte Zählervariable oder einen Aktualisierungsausdruck. Wenn es in Ihrem Code bereits eine sich ändernde Bedingung gibt, die in dem einer Variablen zugewiesenen Wert wiedergegeben wird, und Sie diese zur sich wiederholenden Ausführung einer Anweisung oder eines Anweisungsblocks verwenden wollen, dann verwenden Sie die while-Schleife.
var dieMomente = "";
var derZaehler = 42;        // Initialisiert die Zählervariable.
while (derZaehler >= 1)  {
    if (derZaehler > 1)  {
        dieMomente = "Nur noch " + derZaehler + " Augenblicke verbleiben!";
}
    else  {
        dieMomente = "Nur noch ein Augenblick übrig!";
    }
derZaehler--;        // Aktualisiert die Zählervariable.
}
dieMomente = "ABSCHUSS!";

Hinweis Da while-Schleifen nicht über explizit integrierte Zählervariablen verfügen, sind sie noch anfälliger für Endlosschleifen als andere Typen. Darüber hinaus ist es, teilweise weil es nicht immer einfach ist herauszufinden, wo und wann die Schleifenbedingung aktualisiert wird, nur allzu leicht, eine while-Bedingung zu schreiben, in der die Bedingung tatsächlich nie aktualisiert wird. Seien Sie beim Schreiben von while-Schleifen extrem sorgfältig.

Verwenden der Anweisungen "break" und "continue"
Microsoft JScript enthält eine Anweisung zum Anhalten der Ausführung einer Schleife. Die break-Anweisung kann zum Anhalten der Ausführung verwendet werden, wenn eine (vermutlich besondere) Bedingung erfüllt wird. Mit der continue-Anweisung können Sie sofort zur nächsten Iteration springen, wobei der Rest des Codeblocks übersprungen, die Zählervariable jedoch wie gewöhnlich aktualisiert wird, wenn es sich bei der Schleife um eine for- oder for...in-Schleife handelt.
var derKommentar = "";
var derRest = 0;
var dieFlucht = 3;
var pruefMich = 27;
for (kZaehler = 1; kZaehler <= 10; kZaehler++)
{
    derRest = pruefMich % kZaehler;
    if (derRest == dieFlucht)
      {
            break;  // Verlässt die Schleife beim ersten Mal, wenn der Divisionsrest dem Wert von "dieFlucht" entspricht.
      }

derKommentar = pruefMich + " geteilt durch " + kZaehler + " hinterlässt einen Rest von  " + derRest;
}

for (kZaehler = 1; kZaehler <= 10; kZaehler++)
{
   derRest = pruefMich % kZaehler;
   if (derRest != dieFlucht)

   {
      continue;  // Wählt nur die Reste, die gleich "dieFlucht" sind, und ignoriert alle anderen.
   }
// JScript-Code, der die ausgewählten Reste verwendet.
}

var dieMomente = "";
var derZaehler = 42;  // Der Zähler ist initialisiert.
while (derZaehler >= 1)  {
// if (derZaehler < 10)  {  // Achtung!
// Diese Verwendung von "continue" generiert eine Endlosschleife!
// continue;
// }
    if (derZaehler > 1)  {
        dieMomente = "Nur noch " + derZaehler + " Augenblicke verbleiben!";
}
    else  {
        dieMomente = "Nur ein Augenblick übrig!";
    }
derZaehler--;  // Der Zähler wird aktualisiert.
}
derZaehler = "ABSCHUSS!";


JScript-Funktionen

JScript-Funktionen
 JScript-Tutorium
Zurück
Weiter

Was ist eine Funktion?
Microsoft JScript-Funktionen führen Aktionen durch. Sie können außerdem Ergebnisse zurückgeben, zum Beispiel Ergebnisse von Berechnungen oder Vergleichen.

Funktionen verbinden mehrere Operationen unter einem Namen, wodurch Sie Ihren Code "kompakter" gestalten können. Sie können eine Gruppe von Anweisungen schreiben, sie benennen und alle Anweisungen in dieser Gruppe jederzeit ausführen, indem Sie die Gruppe aufrufen und die notwendigen Informationen übergeben.

Sie übergeben Informationen an eine Funktion, indem Sie die Informationen hinter dem Namen der Funktion in Klammern hinzufügen. An die Funktion übergebene Informationen werden Argumente oder Parameter genannt. Einige Funktionen erhalten keine Argumente, manche nur ein Argument oder auch mehrere Argumente. Es gibt sogar Funktionen, bei denen die Anzahl übergebener Argumente davon abhängt, wie Sie die Funktion verwenden.

JScript unterstützt zwei Arten von Funktionen: die in die Sprache integrierten und die von Ihnen erstellten Funktionen.

Spezielle integrierte Funktionen
Die JScript-Sprache enthält zahlreiche integrierte Funktionen. Einige ermöglichen Ihnen, Ausdrücke und spezielle Zeichen zu verwenden, und konvertieren Zeichenfolgen in numerische Werte.

Beispielsweise werden escape() und unescape() zur Konvertierung von Zeichen verwendet, die spezielle Bedeutungen in HTML-Code haben und nicht einfach in den Text eingefügt werden können. Ein Beispiel dafür sind die spitzen Klammern "<" und ">" (so genannte HTML-Tags).

Die escape-Funktion erhält als Argument jedes dieser speziellen Zeichen und gibt den Escape-Code für dieses Zeichen zurück. Jeder Escape-Code enthält ein Prozentzeichen (%) gefolgt von einer zweistelligen Zahl. Die unescape-Funktion stellt das genaue Gegenteil dar. Sie erhält als Argument ein Prozentzeichen und eine zweistellige Zahl und gibt ein Zeichen zurück.

Eine weitere hilfreiche integrierte Funktion ist eval(), die jeden gültigen mathematischen Ausdruck auswertet, der als Zeichenfolge übergeben wird. Die eval()-Funktion erhält ein Argument (den auszuwertenden Ausdruck).

var einAusdruck = "6 * 9 % 7";
var gesamt = eval(einAusdruck);        // Weist der Variablen gesamt den Wert 5 zu.
var undNochEinAusdruck = "6 * (9 % 7)";
total = eval(undNochEinAusdruck)        // Weist der Variablen gesamt den Wert 12 zu.

var gesamtheit = eval("...umgeben von sinkenden Schiffen.");        // Löst einen Fehler aus.
Weitere Informationen über diese und andere integrierte Funktionen finden Sie im JScript-Sprachverzeichnis.
Erstellen eigener Funktionen
Sie können eigene Funktionen erstellen und dort verwenden, wo Sie sie benötigen. Eine Funktionsdefinition enthält eine Funktionsanweisung und einen Block von JScript-Anweisungen.

Die pruefeDreieck-Funktion im folgenden Beispiel verwendet als Argumente die Längen der Seiten eines Dreiecks und errechnet, ob das Dreieck ein rechtwinkliges Dreieck ist, indem es überprüft, ob die drei Seitenlängen den Satz des Pythagoras erfüllen. (Das Quadrat der Länge der Hypotenuse eines rechtwinkligen Dreiecks ist gleich der Summe der Quadrate der Längen der anderen beiden Seiten.) Die pruefeDreieck-Funktion ruft ein oder zwei andere Funktionen auf, um diesen Test durchzuführen.

Beachten Sie die Verwendung einer sehr kleinen Zahl ("epsilon") als Testvariable in der Fließkommazahlversion des Tests. Auf Grund von Rundungsfehlern ist es nicht ratsam, einen direkten Vergleich durchzuführen, ob das Quadrat über der Hypotenuse gleich der Summe der anderen beiden Quadrate ist, es sei denn, die Länge aller drei Seiten ist jeweils eine Ganzzahl. Da ein direkter Test genauer ist, entscheidet der Code in diesem Beispiel, ob ein solcher Test angebracht ist, und führt ihn gegebenenfalls durch.

var epsilon = 0,0000000000001;  // Eine sehr kleine Zahl zum Testen.
var dreieck = false;

function pruefeGanzzahl(a, b, c)  {  // Eine Testfunktion für Ganzzahlen.
    if ( (a*a) == ((b*b) + (c*c)) )  {  // Der Test.
    dreieck = true;
    }
}  // Ende der Testfunktion für Ganzzahlen.

function pruefeFliesskomma(a, b, c)  {  // Eine Testfunktion für Fließkommazahlen.
var pruefung = ((a*a) - ((b*b) + (c*c)))  // Erstellt die Testzahl.
    if (pruefung < 0)  {  // Der Test erfordert den absoluten Wert, pruefung muss invertiert werden, wenn der Wert negativ ist.
    pruefung *= -1;
    }
    if (epsilon > pruefung)  {  // Dann ist er sehr nahe dran!
    dreieck = true;
    }
}  // Ende der Testfunktion für Fließkommazahlen.

function pruefeDreieck(a, b, c)  {  // Die Funktion zur Dreiecksüberprüfung. Als Erstes sollte die längste Seite zur Position "a" bewegt werden.
var d = 0;  // Erstellt eine temporäre Variable.
    if (c > b)  {  // Wenn c > b, dann austauschen.
    d = c;
    c = b;
    b = d;
    }  // Andernfalls ignorieren.
    if (b > a)  {  // Wenn b > a, dann austauschen.
    d = b;
    b = a;
    a = d;
    }  // Andernfalls ignorieren.

// Seite "a" ist nun die Hypotenuse, falls es eine gibt.

    if (((a%1) == 0) && ((b%1) == 0) && ((c%1) == 0))  {  // Testen aller 3 Werte. Sind es Ganzzahlen?
    pruefeGanzzahl(a, b, c);  // Falls ja, präzise Überprüfung verwenden.
    }
    else
        pruefeFliesskomma(a, b, c);  // Falls nein, näherungsweise Überprüfung.
}  // Ende der Funktion zur Dreiecksüberprüfung.

// Die nächsten drei Anweisungen weisen Beispielwerte für den Test zu.
var seiteA = 5;
var seiteB = 5;
var seiteC = Math.sqrt(50);

pruefeDreieck(seiteA, seiteB, seiteC);  // Ruft die Funktion auf. Nach dem Aufruf enthält dreieck das Ergebnis.


JScript-Objekte

JScript-Objekte
JScript-Tutorium
Zurück
Weiter

Was sind Objekte?
Objekte in Microsoft JScript sind Sammlungen von Eigenschaften und Methoden. Eine Methode ist eine Funktion, die ein Element eines Objekts ist. Eine Eigenschaft ist ein Wert oder eine Gruppe von Werten (in Form eines Datenfeldes oder Objekts) und gleichzeitig ein Element eines Objekts. JScript unterstützt drei Arten von Objekten: integrierte Objekte, von Ihnen erstellte Objekte und Browser-Objekte, die an anderer Stelle behandelt werden.

Objekte als Datenfelder
In JScript werden Objekte und Datenfelder gleich behandelt. Sie können auf jedes Element eines Objekts (seine Eigenschaften und Methoden) entweder über den Namen (der Name des Objekts, gefolgt von einem Punkt und dem Namen der Eigenschaft) oder über den Datenfeldindex verweisen. Die Indexzählung beginnt in JScript mit 0. Auf den Index kann auch mit seinem Namen verwiesen werden.

Es gibt also verschiedene Möglichkeiten, um auf eine Eigenschaft zu verweisen. Alle folgenden Anweisungen sind äquivalent.

dieBreite = Spaghetti.Breite;
dieBreite = Spaghetti[3];  // [3] ist der "Breite"-Index.
dieBreite = Spaghetti["Breite"];
Es ist zwar möglich, Klammern für den Verweis auf eine Eigenschaft zu verwenden, aber es können keine Punkte (.) mit Indexzahlen verwendet werden. Die folgende Anweisung führt zu diesem Fehler.

dieBreite = Spaghetti.3;
Wenn ein Objekt ein anderes Objekt als Eigenschaft besitzt, setzt sich die Benennungsvereinbarung dem Schema entsprechend fort.

var init4 = HeuteErledigen.Einkaufsliste[3].substring(0,1);
            // Datenfeld "Einkaufsliste" ist eine Eigenschaft von HeuteErledigen.
Da Objekte andere Objekte als Eigenschaften besitzen können, können Sie Felder mit mehr als einem Index erstellen, die nicht direkt unterstützt werden. Der folgende Code erstellt eine Multiplikationstabelle für Werte von 0 multipliziert mit 0 bis 16 multipliziert mit 16.

var mehrfTabelle = new Array(17);  // Erstellt die Umgebung für die Tabelle.
for (var j = 0; j < mehrfTabelle.length; j++)  {  // Vorbereiten zum Auffüllen mit Zeilen.
    var Zeile = new Array(17);  // Erstellt eine Zeile.
    for (var i = 0; i < Zeile.length; i++)  {  // Vorbereiten zum Auffüllen der Zeile.
    Zeile[i] = (i + " mal " + j + " = " + i*j);  // Erstellen und Einfügen eines Wertes.
    }
mehrfTabelle[j] = Zeile;  // Stellt die gefüllte Zeile in die Tabelle.
}
Verwenden Sie mehrere Klammerpaare, um auf eines der Elemente eines Datenfeldes dieser Art zu verweisen.
var multipliziere3x7 = mehrfTabelle[3][7];
Die folgende Anweisung führt zu einem Fehler.
var multipliziere3x7 = mehrfTabelle[3, 7];


Reservierte Schlüsselwörter von JScript

Reservierte Schlüsselwörter von JScript
 JScript-Tutorium
Zurück
Weiter

In JScript gibt es eine Anzahl reservierter Schlüsselwörter. Es gibt davon drei Typen: für JScript reservierte Schlüsselwörter, zukünftige reservierte Schlüsselwörter und zu vermeidende Wörter.

JScript-Schlüsselwörter
break | false | in | this | void
continue | for | new | true | while
delete | Function | Null | typeof | with
else | if | return | var

JScript-Zukünftige Schlüsselwörter
case | debugger | export | super
catch | default | extends | switch
class | do | finally | throw
const | enum | import | try

Zu vermeidende Wörter sind alle Namen integrierter Objekte und Funktionen von JScript. Wörter wie String oder parseInt sind darin eingeschlossen.

Wenn Sie eines der Schlüsselwörter aus den ersten beiden Kategorien verwenden, führt dies beim ersten Laden Ihres Skripts zu einem Kompilierungsfehler. Wenn Sie ein reserviertes Schlüsselwort der dritten Gruppe verwenden, können Probleme während der Ausführung auftreten, wenn Sie versuchen, Ihre Variable und den ursprünglichen Bezeichner gleichen Namens im selben Skript zu verwenden. Beispielsweise verhält sich das folgende Skript nicht so, wie Sie erwarten würden:

var String;
var text = new String("Dies ist eine Zeichenfolge");
In diesem Fall erhalten Sie eine Fehlermeldung, dass String kein Objekt ist. In vielen Fällen, wo ein bereits vorhandener Bezeichner verwendet wird, ist dies nicht so offensichtlich.


Rekursion

Rekursion
 JScript-Tutorium
Zurück
Weiter

Rekursion ist eine wichtige Programmiertechnik. Sie wird dazu verwendet, eine Funktion aus sich selbst heraus aufzurufen. Ein Beispiel ist die Berechnung von Fakultäten. Die Fakultäten von 0 und 1 sind beide als 1 definiert. Die Fakultäten höherer Zahlen werden durch Multiplikation der aufeinander folgenden Zahlen (1 * 2 * ..., immer um 1 erhöht, bis die gewünschte Zahl erreicht ist) berechnet.

Im folgenden Absatz wird in Worten eine Funktion beschrieben, die eine Fakultät berechnet.

"Wenn die Zahl kleiner als Null ist, gibt es keine Fakultät. Wenn sie keine Ganzzahl ist, soll sie auf die nächstkleinere Ganzzahl abgerundet werden. Ist die Zahl gleich Null oder Eins, so ist die Fakultät Eins. Ist die Zahl größer als Eins, so wird sie mit der Fakultät der nächstkleineren Zahl multipliziert."

Um die Fakultät jeder Zahl zu berechnen, die größer als 1 ist, müssen Sie die Fakultät für mindestens eine andere Zahl berechnen. Dazu verwenden Sie die gleiche Funktion, in der Sie sich gerade befinden. Sie müssen die Funktion nur mit der nächstkleineren Zahl aufrufen, bevor sie für die aktuelle Zahl ausgeführt werden kann. Dieses ist ein Beispiel für eine Rekursion.

Allerdings kann die Rekursion auch schnell zu Problemen führen. Es ist einfach, eine rekursive Funktion zu erstellen, die nie zu einem endgültigen Ergebnis kommt und nie einen Endpunkt erreicht. So eine Rekursion veranlasst den Computer, eine so genannte "Endlosschleife" auszuführen. Beispiel: Entfernen Sie die erste Regel (die mit den negativen Zahlen) aus der verbalen Beschreibung für die Berechnung einer Fakultät, und versuchen Sie die Fakultät einer negativen Zahl zu berechnen. Dieses misslingt, da Sie zur Berechnung der Fakultät von beispielsweise -24 erst die Fakultät von -25 berechnen müssen, dazu wiederum die Fakultät von -26 usw. Offensichtlich führt dies zu keinem Ende.

Deshalb ist es sehr wichtig, rekursive Funktionen mit größter Vorsicht zu entwickeln. Wenn auch nur die geringste Möglichkeit für eine Endlosrekursion besteht, können Sie die Funktion die Anzahl der Durchläufe zählen lassen und sie, falls sie zu oft aufgerufen wird, automatisch beenden.

Hier ist nun die Funktion zur Berechnung der Fakultät, diesmal in JScript-Code.

function fakultaet(eineZahl)  {
eineZahl = Math.floor(eineZahl);  // Ist die Zahl keine Ganzzahl, dann abrunden
if (eineZahl < 0)  {  // Eine Zahl kleiner als 0 ist nicht zulässig.
    return "Keine definierte Größe";
    }
      if ((eineZahl == 0) || (eineZahl == 1))  {  // Ist die Zahl 0 oder 1, so ist die Fakultät gleich 1.
      return 1;
      }
        else return (eineZahl * fakultaet(eineZahl - 1));  // Rekursiver Aufruf bis zum Ende.
}


Gültigkeitsbereich von Variablen

Gültigkeitsbereich von Variablen
 JScript-Tutorium
Zurück
Weiter

Microsoft JScript kennt zwei Gültigkeitsbereiche: global und lokal. Wenn Sie eine Variable außerhalb einer Funktionsdefinition deklarieren, ist diese Variable global, und ihr Wert kann im gesamten Programm abgerufen und verändert werden. Wenn Sie eine Variable innerhalb einer Funktionsdefinition deklarieren, ist diese Variable lokal. Sie wird jedesmal erstellt und zerstört, wenn die Funktion ausgeführt wird. Ein Zugriff von außen auf die Variable ist nicht möglich.

Eine lokale Variable kann den gleichen Namen wie eine globale Variable haben, allerdings sind beide vollständig voneinander getrennt. Folglich hat eine Änderung des Wertes der einen Variablen keinen Einfluss auf den Wert der anderen. In der Funktion, in der die lokale Variable deklariert wurde, ist nur dieser lokale Wert gültig.

var einZentaur = "ein Pferd mit einem Reiter";  // Globale Definition von einZentaur.

// JScript-Code aus Gründen der Übersichtlichkeit ausgelassen.
function InteressanteFunktion()  // In dieser Funktion ist eine lokale Variable einZentaur deklariert.
{

// JScript-Code aus Gründen der Übersichtlichkeit ausgelassen.
var einZentaur = "Ein Zentaur ist ein berittener Krieger der Skythen";

// JScript-Code aus Gründen der Übersichtlichkeit ausgelassen.
  einZentaur += ", aber eigentlich nur ";  // Mit lokaler Variablen verketten.

// JScript-Code aus Gründen der Übersichtlichkeit ausgelassen.
}  // Ende der Funktion.

var nichtsBesonderes = InteressanteFunktion();
einZentaur += ", aus der Ferne von einem unbeteiligten Dritten betrachtet.";

/*
Innerhalb der Funktion enthält die Variable "Ein Zentaur ist ein berittener Krieger der Skythen, aber eigentlich nur ", außerhalb der Funktion enthält sie den Rest des Satzes:
"ein Pferd mit einem Reiter, aus der Ferne von einem unbeteiligten Dritten betrachtet."
*/
Beachten Sie, dass sich Variablen so verhalten, als ob sie am Beginn des jeweiligen Gültigkeitsbereiches deklariert wurden. Dies führt eventuell zu einem unerwarteten Verhalten.

var eineZahl = 100;
var mitZusatz = 0;

mitZusatz += eineZahl;  // mitZusatz hat jetzt den Wert 100.
tweak();
mitZusatz += eineZahl;  // mitZusatz hat jetzt den Wert 200.

function tweak()  {
var neueSache = 0;  // Explizite Deklaration der Variablen neueSache.
// Wäre die nächste Anweisung nicht auskommentiert, würde sie einen Fehler verursachen.
// neueSache = eineZahl;
// Die nächste Anweisung weist der lokalen Variable eineZahl den Wert 42 zu und deklariert sie implizit.
neueZahl = 42;
if (false)  {
    var eineZahl;  // Diese Anweisung wird nie ausgeführt.
    eineZahl = "Hallo!";  // Diese Anweisung wird nie ausgeführt.
    }  // Ende der Bedingung.
}  // Ende der Funktionsdefinition.
Die auskommentierte Anweisung versucht, den Wert der lokalen Variable eineZahl der lokalen Variable neueSache zuzuweisen. Dies schlägt fehl, obwohl die lokale Variable eineZahl an einer anderen Stelle in der gleichen Funktion definiert und daher in der gesamten Funktion bekannt ist. Da der Variablen eineZahl an der Stelle im Code, an der diese Anweisung ausgeführt werden soll, kein Wert zugewiesen ist, ist sie undefined.


Kopieren, Übergeben und Vergleichen von Daten

Kopieren, Übergeben und Vergleichen von Daten
 JScript-Tutorium
Zurück
Weiter

In Microsoft JScript hängt die Verarbeitung von Daten vom jeweiligen Datentyp ab.
Nach Wert oder Nach Referenz
Zahlen und Boolesche Werte (true und false) werden nach Wert kopiert, übergeben und verglichen. Wenn Sie nach Wert kopieren oder übergeben, reservieren Sie Speicherplatz im Arbeitsspeicher des Computers und legen den Wert des Originals in diesem ab. Wenn Sie dann das Original ändern, ist die Kopie nicht betroffen (und umgekehrt), da es sich um zwei getrennte Einheiten handelt.

Objekte, Datenfelder und Funktionen werden in den meisten Fällen nach Referenz kopiert, übergeben und verglichen. Wenn Sie nach Referenz kopieren oder übergeben, erstellen Sie im Wesentlichen einen Zeiger auf das Original und verwenden diesen Zeiger, als wäre er eine Kopie. Wenn Sie dann das Original ändern, dann ändern Sie sowohl dieses als auch die Kopie (und umgekehrt). Es handelt sich hier nur um eine Einheit. Die "Kopie" ist im Grunde keine Kopie, sondern eine weitere Referenz auf die Daten.

Hinweis Sie können dieses Verhalten für Objekte und Datenfelder ändern, in dem Sie die assign( )-Methode für diese angeben.
Zeichenfolgen werden schließlich nach Referenz kopiert und übergeben, jedoch nach Wert verglichen.

Tipp Auf Grund der Art und Weise, in der ASCII- und ANSI-Zeichen aufgebaut sind, ist bei einem Vergleich "Zoo" kleiner als "aardvark". Das bedeutet, dass Großbuchstaben in der Reihenfolge vor Kleinbuchstaben rangieren.

Übergeben von Parametern an Funktionen

Wenn Sie einen Parameter an eine Funktion nach Wert übergeben, erstellen Sie eine getrennte Kopie des Parameters, d. h. eine Kopie, die nur innerhalb der Funktion vorhanden ist. Wenn Sie andererseits einen Parameter nach Referenz übergeben und die Funktion den Wert des Parameters ändert, wird dieser überall im Skript geändert.

Testen von Daten
Wenn Sie einen Test nach Wert durchführen, vergleichen Sie zwei verschiedene Elemente, um herauszufinden, ob sie gleich sind. In der Regel wird dieser Vergleich auf einer Byte-für-Byte-Basis durchgeführt. Wenn Sie nach Referenz testen, prüfen Sie, ob zwei Elemente Zeiger auf das gleiche Originalelement sind. Ist dies der Fall, sind sie gleich. Ist dies nicht der Fall, selbst wenn sie Byte für Byte exakt dieselben Werte enthalten sollten, dann sind sie nicht gleich.

Das Kopieren und Übergeben von Zeichenfolgen nach Referenz belegt weniger Arbeitsspeicher. Da Sie aber Zeichenfolgen nach ihrer Erstellung nicht ändern können, ist es möglich, sie nach Wert zu vergleichen. Dadurch können Sie zwei Zeichenfolgen auf denselben Inhalt überprüfen, wenn eine völlig getrennt von der anderen erstellt wurde.


Verwenden von Datenfeldern

Verwenden von Datenfeldern
 JScript-Tutorium
Zurück
Weiter

Datenfeldindizierung
In JScript sind Datenfelder sparse. Das heißt, bei einem Datenfeld mit den drei Elementen Nummer 0, 1, und 2 können Sie Element 50 erstellen, ohne auf Elemente 3 bis 49 Rücksicht zu nehmen. Verfügt das Datenfeld über eine automatisch erstellte Zeichenfolge mit variabler Länge (siehe die Erklärung der automatischen Überwachung der Datenfeldlänge unter integrierte Objekte), dann wird die Längenvariable nicht auf 4, sondern auf 51 gesetzt. Sie können natürlich auch Datenfelder erstellen, in denen die Zählung der Elemente lückenlos ist, doch müssen Sie dies nicht tun. In JScript müssen Ihre Datenfelder nämlich keineswegs numerierte Indizes haben.

In JScript sind Objekte und Datenfelder im Grunde identisch miteinander. Der eigentliche Unterschied besteht nicht in den Daten, sondern in der Art und Weise, wie die Elemente eines Datenfelds oder die Eigenschaften und Methoden eines Objekts adressiert werden.

Adressieren von Datenfeldern
Es gibt zwei Hauptmethoden, um die Elemente eines Datenfeldes zu adressieren. Normalerweise werden dazu Klammern verwendet. Sie umschließen entweder einen numerischen Wert oder einen Ausdruck der eine nicht negative Ganzzahl darstellt. Im folgenden Beispiel wird davon ausgegangen, dass die Variable EingabeNr definiert ist, und dass ihr an einer anderen Stelle im Skript ein Wert zugewiesen ist.
dieAuflistung = adressBuch[EingabeNr];
dieErsteZeile = dieAuflistung[1];
Diese Adressiermethode entspricht der Methode zum Adressieren von Objekten, obwohl bei der Methode zum Adressieren von Objekten das auf den Punkt folgende Element der Name einer tatsächlichen Eigenschaft sein muss. Ist diese Eigenschaft nicht vorhanden, dann generiert der Code einen Fehler.

Die zweite Möglichkeit, ein Datenfeld zu adressieren, besteht darin, ein Objekt/Datenfeld zu erstellen, das nummerierte Eigenschaften enthält, und die Nummern dann in einer Schleife zu erzeugen. Das folgende Beispiel generiert zwei Datenfelder, einen für den Namen und einen für die Adresse, aus einer Liste in adressBuch. Jede davon enthält vier Eigenschaften: Eine Instanz von derName, beispielsweise erstellt aus den Eigenschaften [Name1] bis [Name4] von dieAuflistung, könnte "G." "Edward" "Heatherington" "IV" oder "George" "" "Sand" "" enthalten.

dieAuflistung = adressBuch[EingabeNr];
for (i = 1; i < 4; i++)  {
derName[i] = dieAuflistung["Name" + i];
dieAdresse[i] = dieAuflistung["Adresse" + i];
}
Während diese Instanz kurz ist und problemlos in der "Punkt"-Schreibweise hätte geschrieben werden können (also durch Adressieren von dieAuflistung, derName und dieAdresse als Objekte und nicht als Datenfelder), ist dies nicht immer möglich. Manchmal ist die jeweilige Eigenschaft möglicherweise bis zur Laufzeit nicht vorhanden, oder es gibt keine Möglichkeit, im Voraus festzustellen, welche es sein wird. Wenn beispielsweise das Datenfeld adressBuch nach dem Nachnamen geodnet wäre anstatt nach nummerierten Listen, würde der Benutzer wahrscheinlich "im Fluge" Namen eingeben, während das Skript ausgeführt wird, um darin nach Leuten zu suchen. Das folgende Beispiel geht vom Vorhandensein geeigneter Funktionsdefinitionen an einer anderen Stelle im Skript aus:
dieAuflistung = adressBuch[getName()];
diePersAuflistung = dieAuflistung[getVorname()];
Hierbei handelt es sich um assoziatives Adressieren des Datenfeldes, d. h. Adressierung mittels völlig arbiträrer Zeichenfolgen. Objekte in JScript sind eigentlich assoziative Datenfelder. Obwohl Sie die "Punkt"-Schreibweise verwenden können, was häufig der Fall ist, sind Sie keineswegs daran gebunden. Da auf die Elemente jedes JScript-Objekts mit Hilfe von Datenfeld-Schreibweisen zugegriffen werden kann, kann ein JScript-Objekt als assoziatives Datenfeld verwendet werden.

Der folgende Code erstellt und initialisiert die häufigste Form eines Datenfelds.

var mein_datenfeld = new Array("Athen", "Belgrad", "Chicago");
Jedes Element dieses Datenfeldes wird durch die Verwendung seiner Elementnummer adressiert, in diesem Fall 0, 1 oder 2. Mit Hilfe der for...in-Anweisung kann das Datenfeld, bei 0 beginnend und bei 2 endend, durchlaufen werden. Beispiel:

for (Schlüssel in mein_datenfeld)
  response.write("Wert des Elements ist " + mein_datenfeld[key] + "<BR>);
Der folgende Code erstellt und initialisiert ein assoziatives Datenfeld, das drei Elemente enthält:
var mein_datenfeld = {"a" : "Athen" , "b" : "Belgrad", "c" : "Chicago"};
In diesem Datenfeld werden Elemente unter Verwendung der Suchzeichenfolge ("a", "b" oder "c"), und nicht der Nummer des Datenfeldelements (0, 1 oder 2) adressiert. So können Sie Datenfelder mit intuitiveren Adressiermethoden erstellen und nutzen. Der oben demonstrierte Code der for...in-Anweisung kann auch zum Verwenden dieses Datenfeldes verwendet werden.


Erstellen erweiterter Objekte

Erstellen erweiterter Objekte
 JScript-Tutorium
Zurück
Weiter

Verwenden von Konstruktoren zum Erstellen von Objekten
In Microsoft JScript verwenden Sie Konstruktoren zum Erstellen und Aufbauen einer Klasse von Objekten. Sie rufen einen Konstruktor mit der new-Anweisung auf. Dieser gibt das jeweilige Konstrukt zurück.

Mit Hilfe des besonderen Konstruktors Function können Sie Funktionen erstellen, die anonym sind. Diese Funktionen haben keinen Namen. Sie können den Function-Konstruktor verwenden, um eine Funktion "mal eben schnell" zu erstellen, z. B. als eine der Anweisungen innerhalb einer anderen Funktion. Eine solche Funktion, die nur an einer Stelle aufgerufen wird, braucht keinen Namen.

Im folgenden Beispiel erzeugt eine solche anonyme Funktion eine Zeile einer "Name und Emailadresse"-Auflistung. Sie überprüft den Wert der vornameZuerst-Variablen, um festzulegen, ob der Vor- oder Nachname zuerst gesetzt werden soll, sowie der emailNameZuerst-Variablen, um festzulegen, ob der Name oder die Emailadresse zuerst gesetzt werden soll. Bei diesem Beispiel wird davon ausgegangen, dass die Werte von vornameZuerst und emailNameZuerst an einer anderen Stelle im Skript festgelegt wurden.

for (j = 1; j < adressListe.length; j++)
{
eineZeile = new Function(emailNameZuerst, vornameZuerst, adressListe, j, derName = new Function(vornameZuerst, adressListe, j, var derName=(adressListe[j].vorname + adressListe[j].zuname);
if(vornameZuerst)
      {
      derName=(adressListe[j].vorname + adressListe[j].zuname);
      },) ;
if (emailNameZuerst)
      {
dieListe = adressListe[j].emailName + ":\t" + derName
      } else dieListe = derName + ":\t" + adressListe[j].emailName; return dieListe;)
document.write(eineZeile + "<br>");
}
Schreiben von Konstruktoren
Um eigene Konstruktoren zu schreiben, müssen Sie das Schlüsselwort this innerhalb des Konstruktors verwenden, um auf das neu erstellte Objekt zu verweisen. Der Konstruktor initialisiert das Objekt.

Der Konstruktor im nächsten Beispiel beginnt zwar mit dem Index 0, jedoch ist dies nicht erforderlich. Sie können mit 1 als ersten Index beginnen, wenn Sie z. B. einen Parameter wünschen, der die tatsächliche Zahl der Indizes des Datenfelds oder des Objekts angibt. Im Beispiel heißt dieser laenge, um ihn von dem automatisch verwalteten Parameter length des integrierten Array( )-Objekts zu unterscheiden. Wenn Sie Code schreiben, der einem Datenfeld Eigenschaften hinzufügt, müssen Sie den Parameter laenge (bzw. das verwendete Äquivalent) aktualisieren, da dieser nicht von JScript verwaltet wird. Beachten Sie, dass selbst dieses überaus einfache Beispiel die Objekt (Punkt)- und Datenfeld (Klammern)-Schreibweisen verwendet, um auf das aktuelle Objekt zu verweisen.

function zeichenfolgenDatenfeld(groesse) {
this.laenge = groesse;
for (iNum = 0; iNum < groesse; i++) {
this[iNum] = "";
}
}

// Verwendet den Konstruktor zum Erstellen und Initialisieren eines Datenfelds.
meinDatenfeld = new zeichenfolgenDatenfeld(63);
Verwenden von Prototypen zum Erstellen von Objekten
Wenn Sie eine Objektdefinition schreiben, können Sie Prototypeigenschaften zum Erstellen von Eigenschaften verwenden, die gemeinschaftlich in allen Objekten enthalten sind, die von der Definition generiert wurden. Prototypeigenschaften werden nach Referenz in die einzelnen Objekte einer Klasse kopiert, so dass sie dieselben Werte für alle Objekte der Klasse enthalten. Sie können jedoch den Wert einer Prototypeigenschaft eines Objekts ändern. Der neue Wert setzt den Standardwert außer Kraft, jedoch nur in diesem einen Fall. Andere Objekte, die Elemente der Klasse sind, sind von der Änderung nicht betroffen.

Mittels dieses Prinzips können Sie weitere Eigenschaften für Objekte definieren, die zur JScript-Sprache gehören und über Prototypen verfügen. Wenn Sie z. B. eine spezielle Konstante für eine Berechnung benötigen und diese Konstante nicht zu denen der Objekte Math und Number gehört, können Sie diese selbst definieren und dann den entsprechenden Objektprototypen oder der Prototypeigenschaft Ihrer Objektklasse zuweisen.

Math.prototype.Avogadro = 6.0232E23;
function wievieleMolekuele(gewGramm,molGew) {
return ((gewGramm/molGew) * Math.prototype.Avogadro);
}
document.write("Es sind " + wievieleMolekuele(window.prompt("Wie viel Gramm?",0),window.prompt
("Wie hoch ist das Molekulargewicht?",0)) +
 " Moleküle in dieser Menge.");
Deutlicher wird es vielleicht, wenn Sie eine Funktion definieren, sie String.prototype als Methode zuweisen, und sie dann auf eine beliebige Zeichenfolge in Ihrem Skript anwenden. Das folgende Beispiel setzt das Vorhandensein eines Periodensystem-Datenfelds mit dem Namen "dieElemente" voraus, das an anderer Stelle im Skript definiert wurde und Symbole für die Elemente, ihre Namen, ihr Atomgewicht und weitere relevante Informationen enthält.

function atomName(dasSymbol) {
return(dieElemente[dasSymbol].fullName);
}

String.prototype.atomName = atomName;

function dekodiereFormel(dieFormel) {
var aktuellesStueck = "";
var dekodierteFormel = "";
for (i = 1; i = dieFormel.length ; i++);
if (aktuellesStueck ...
// Codeanweisungen zum Trennen der Formelzeichenfolge in ein Datenfeld aus Symbolen und Zahlen.
// Durchläuft als Schleife das Formeldatenfeld und assembliert die dekodierte Zeichenfolge. Jeder Ausdruck ist:
dekodierteFormel += dieFormel[n].number
dekodierteFormel += " ";
dekodierteFormel += dieFormel[n].symbol.prototype.atomName;
dekodierteFormel += " "
// Ende der Schleife.

return dekodierteFormel;
}

dekodiereFormel(window.prompt("Formel?","Al2O3"));


Sonderzeichen
 JScript-Tutorium
Zurück
Weiter

Sonderzeichen
JScript enthält Sonderzeichen, mit deren Hilfe Sie Zeichen in Zeichenfolgen einfügen können, die Sie nicht direkt eingeben können. Alle diese Zeichen beginnen mit einem umgekehrten Schrägstrich (Backslash). Dieser ist ein Escape-Zeichen, mit dem Sie JScript informieren, dass das nächste Zeichen ein Sonderzeichen ist.

Escape-Sequenz | Zeichen
\b | Rückschritt
\f | Seitenvorschub
\n | Zeilenvorschub (neue Zeile)
\r | Wagenrücklauf
\t | Horizontaler Tabstopp (Strg-I)
\' Einfaches Anführungszeichen
\" Doppeltes Anführungszeichen
\\ Umgekehrter Schrägstrich (Backslash)

Da der umgekehrte Schrägstrich selbst als Escape-Zeichen verwendet wird, dürfen Sie direkt in ein Skript nicht nur einen davon eingeben. Wenn Sie einen umgekehrten Schrägstrich schreiben wollen, müssen zwei davon hintereinander eingeben (\\).

document.write('Der Pfad der Grafik ist C:\\webstuff\\mypage\\gifs\\garden.gif.');
document.write('Die Unterschrift heißt "Nach dem Schnee von \'97. ist Klaus\' Haus bedeckt."');
Mit Hilfe dieser Escape-Sequenzen können Sie das Formatieren von Text zwischen den Tags <PRE> und <XMP> und, zu einem gewissen Grad, in den Feldern von Alert-, Prompt- und Confirm-Meldungsfeldern steuern.


Beseitigen von Fehlern aus Skripten

Beseitigen von Fehlern aus Skripten
 JScript-Tutorium
Zurück
Weiter

Alle Programmiersprachen haben Fallen, in die Sie tappen können, wenn Sie nicht sorgfältig genug sind. Und sie bieten auch bestimmte Überraschungen. Nehmen Sie z. B. den Wert null: Der Wert null in Microsoft JScript unterscheidet sich von dem der Sprachen C oder C++.

Hier folgen nun einige Problembereiche beim Schreiben von Skripten in JScript.

Syntaxfehler
Da die Syntax von Programmiersprachen weitaus strenger ist als die natürlicher Sprachen, muss den Details beim Schreiben von Skripten ein besonderes Augenmerk gelten. Wenn Sie wollen, dass ein bestimmter Parameter eine Zeichenfolge darstellt, treffen Sie auf Schwierigkeiten, wenn Sie vergessen, diesen bei der Eingabe mit Anführungszeichen zu umgeben.
Reihenfolge der Skriptinterpretation
Die JScript-Interpretation ist Teil des HTML-Analyseprozesses eines Web-Browsers. Wenn Sie also ein Skript zwischen die <HEAD>-Tags in einem Dokument setzen, wird dieses interpretiert, bevor die <BODY>-Tags interpretiert werden. Wenn Sie über Objekte verfügen, die innerhalb des <BODY>-Tags erstellt werden, dann sind diese zu dem Zeitpunkt nicht vorhanden, an dem das <HEAD>-Tag analysiert wird. Sie können vom Skript nicht verändert werden.
Automatische Typumwandlung
JScript ist ein lose typisierte Sprache mit automatischer Typumwandlung. Demzufolge werden die Ausdrücke im folgenden Beispiel, trotz der Tatsache, dass Werte mit verschiedenen Typen nicht gleich sind, zu true ausgewertet.
"100" == 100
false == 0
Operatorvorrang
Wenn eine bestimmte Operation während der Auswertung eines Ausdrucks durchgeführt wird, so hat das mehr mit dem Operatorvorrang als mit der Position des Ausdrucks zu tun. Deshalb wird in dem folgenden Beispiel die Multiplikation vor der Subtraktion ausgeführt, obgleich diese in dem Ausdruck auf die Subtraktion folgt.
derRadius = einPerimeterPunkt - derMittelpunkt * derKorrekturFaktor;
Verwenden von for...in-Schleifen mit Objekten
Wenn Sie die Eigenschaften eines Objekts mit einer for...in-Schleife durchlaufen, können Sie nicht unbedingt die Reihenfolge vorhersagen oder steuern, in der die Felder des Objekts der Schleifenzählvariable zugewiesen werden. Darüber hinaus kann die Reihenfolge in verschiedenen Implementierungen der Sprache unterschiedlich sein.
Schlüsselwort "with"
Die Anweisung with ist nützlich zum Adressieren von Eigenschaften, die bereits in einem bestimmten Objekt vorhanden sind, jedoch nicht geeignet zum Hinzufügen von Eigenschaften zu einem Objekt. Um neue Eigenschaften in einem Objekt zu erstellen, müssen Sie speziell auf das Objekt verweisen.
Schlüsselwort "this"
Obgleich Sie das Schlüsselwort this innerhalb der Definition eines Objekts verwenden, um auf das Objekt selbst zu verweisen, können Sie this oder ähnliche Schlüsselwörter gewöhnlich nicht verwenden, um auf die gegenwärtig ausgeführte Funktion zu verweisen, wenn diese Funktion keine Objektdefinition ist. Wenn die Funktion einem Objekt als Methode zugewiesen werden soll, können Sie das Schlüsselwort this innerhalb der Funktion zum Verweisen auf das Objekt verwenden.
Schreiben eines Skripts, das ein Skript schreibt
Das </SCRIPT>-Tag beendet das aktuelle Skript, wenn der Interpreter darauf trifft. Um "</SCRIPT>" selbst anzuzeigen, schreiben Sie dies als mindestens zwei Zeichenfolgen, z. B. als "</SCR" und "IPT>", die Sie danach in der Anweisung, die diese ausschreibt, miteinander verketten können.
Implizite Fensterverweise
Da mehr als ein Fenster gleichzeitig geöffnet sein kann, weist jeder implizite Fensterverweis auf das aktuelle Fenster. Für andere Fenster müssen Sie einen expliziten Verweis verwenden.


Anzeigen von Informationen im Browser

Anzeigen von Informationen im Browser
 JScript-Tutorium
Zurück
Weiter

Microsoft JScript bietet zwei Möglichkeiten, Daten direkt in einem Browser anzuzeigen. Sie können die Methoden write( ) und writeln( ) verwenden, die Methoden des document-Objekts sind. Sie können Informationen auch in Formularen innerhalb des Browsers oder in Verwenden von Meldungsfeldern anzeigen.
Verwenden von document.write( ) und document.writeln( )
Die geläufigste Art, Informationen anzuzeigen, ist die write( )-Methode des document-Objekts. Sie benötigt ein Argument, d. h. eine Zeichenfolge, die im Browser angezeigt wird. Die Zeichenfolge kann entweder Nur-Text- oder HTML-Format haben.

Die Zeichenfolgen können von einzelnen oder doppelten Anführungszeichen umgeben werden. Dadurch können Sie Text zitieren, der Anführungszeichen oder Apostrophs enthält.

document.write("Pi entspricht etwa " + Math.PI);
document.write( );

Tipp Die folgende einfache Funktion zeigt, wie Sie es umgehen können, jedesmal "document.write" einzugeben, wenn etwas im Browser-Fenster angezeigt werden soll. Diese Funktion informiert Sie nicht darüber, dass etwas, das Sie versuchen zu schreiben, nicht definiert ist, sondern erlaubt das Aufrufen des Befehls "w();", der eine Leerzeile anzeigt.
function w(m)  {		// Schreibt die Funktion.
m = "" + m + "";        //  Stellt sicher, dass die Variable m eine Zeichenfolge ist.
if ("undefined" != m)  {        //  Testet auf leeren write-Befehl oder andere nicht definierte Elemente.
    document.write(m);
    }
document.write("<br>");
}

w('<IMG SRC="horse.gif">');
w();
w("Dies ist der Stich eines Pferdes.");
w();

Die writeln( )-Methode ist nahezu identisch mit der write( )-Methode, außer, dass sie ein Zeilenvorschubzeichen an die Zeichenfolge anfügt, die Sie eingeben. In HTML führt dies in der Regel nur zu einem Leerzeichen hinter dem Element. Wenn Sie jedoch die Tags <PRE> und <XMP> verwenden, wird das Zeilenvorschubzeichen ausdrücklich interpretiert und vom Browser angezeigt.

Wenn Sie die write( )-Methode aufrufen, öffnet und löscht sie das Dokument, wenn sich das Dokument beim Aufrufen der write( )-Methode nicht im Prozess des Öffnens und Analysierens befindet, weshalb dies gefährlich werden kann. Das folgende Beispiel zeigt ein Skript, das einmal pro Minute die Zeit anzeigen soll, dies aber nach dem ersten Mal nicht mehr tun kann, da es sich selbst löscht.

<HTML>
<HEAD>
<SCRIPT LANGUAGE="JScript">
function singOut()  {
var derMoment = new Date();
var dieStunde = derMoment.getHours();
var dieMinute = derMoment.getMinutes();
var dieZeitverschiebung = (derMoment.getTimezoneOffset() / 60);
dieStunde -= dieZeitverschiebung;
if (dieStunde > 23)  {
dieStunde -= 24
}
document.write(dieStunde + " Stunden, " + dieMinute + " Minuten, Koordinierte Weltzeit.");
window.setTimeout("singOut();", 60000);
}
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT>
singOut();
</SCRIPT>
</BODY>
</HTML>
Wenn Sie die alert()-Methode des window-Objekts an Stelle von document.write() verwenden, funktioniert das Skript.
window.alert(dieStunde + " Stunden, " + dieMinute + "  Minuten, Koordinierte Weltzeit.");
window.setTimeout("singOut();", 60000);
}
Löschen des aktuellen Dokuments
Die clear()-Methode des document-Objekts leert das aktuelle Dokument. Diese Methode löscht auch Ihr Skript (samt dem Rest des Dokuments). Seien Sie deshalb beim Verwenden dieser Methode vorsichtig.
document.clear();


Verwenden von Meldungsfeldern

Verwenden von Meldungsfeldern
 JScript-Tutorium
Zurück

Verwenden von Alert-, Confirm- und Prompt-Meldungsfeldern
Verwenden Sie Alert-, Confirm- und Prompt-Meldungsfelder, um von dem Benutzer eine Eingabe zu erhalten. Die Felder sind Methoden des Benutzeroberflächenobjekts window. Da sich das window-Objekt oben in der Objekthierarchie befindet, müssen Sie eigentlich nicht den vollständigen Namen (z. B. window.alert()) eines dieser Meldungsfelder verwenden. Doch es empfiehlt sich, dies dennoch zu tun, da Sie so daran erinnert werden, zu welchem Objekt diese gehören.

Alert-Meldungsfeld
Die alert-Methode hat ein Argument, nämlich die Textzeichenfolge, die Sie dem Benutzer anzeigen wollen. Die Zeichenfolge entspricht nicht HTML. Das Meldungsfeld enthält die Schaltfläche OK, damit der Benutzer es schließen kann. Es ist gebunden, d. h., der Benutzer muss das Meldungsfeld vor dem Fortfahren schließen.
window.alert("Willkommen! Klicken Sie auf OK, um fortzufahren.");
Confirm-Meldungsfeld
Mit Hilfe des Confirm-Meldungsfelds können Sie dem Benutzer eine Frage stellen, die mit Ja oder Nein beantwortet werden muss. Es gibt dem Benutzer außerdem die Möglichkeit, entweder auf OK oder auf Abbrechen zu klicken. Die confirm-Methode gibt true oder false zurück. Dieses Meldungsfeld ist auch gebunden. Der Benutzer muss reagieren (auf eine Schaltfläche klicken, um es zu schließen), bevor er fortfahren kann.
var wahrheitWerdeGesagt = window.confirm("Klicken Sie auf OK, um fortzufahren. Klicken Sie auf Abbrechen, um abzubrechen.");
if (wahrheitWerdeGesagt) {
window.alert("Willkommen auf unserer Web-Seite!");
}  else  window.alert("Erstmal Tschüss!");
Prompt-Meldungsfeld
Das Prompt-Meldungsfeld enthält ein Textfeld, in das der Benutzer eine Antwort auf Ihre Eingabeaufforderung eingeben kann. Dieses Feld hat die Schaltflächen OK und Abbrechen. Wenn Sie ein zweites Zeichenfolgenargument angeben, zeigt das Prompt-Meldungsfeld diese zweite Zeichenfolge in einem Textfeld als Standardantwort. Ansonsten ist der Standardtext "<undefined>".

Wie die Methoden alert( ) und confirm( ) zeigt prompt ein gebundenes Meldungsfeld an, das der Benutzer vor dem Fortfahren schließen muss.

var dieAntwort = window.prompt("Willkommen?","Geben Sie hier Ihren Namen ein.");


Referenz für die JScript-Laufzeitbibliothek

Referenz für die JScript-Laufzeitbibliothek 		JScript-Sprachverzeichnis
Versionsinformationen

Informationen über Leistungsmerkmale

Alphabetische Liste der Schlüsselwörter

Methoden

Objekte

Eigenschaften

Willkommen bei der Referenz für die JScript-Laufzeitbibliothek

Diese kompakten Informationsblöcke unterstützen Sie beim Arbeiten in den zahlreichen unterschiedlichen Bereichen der Jscript-Laufzeitbibliothek.

Sie finden eine alphabetische Auflistung sämtlicher Bereiche der Jscript-Laufzeitbibliothek unter der alphabetischen Liste der Schlüsselwörter. Wenn Sie jedoch lediglich zu einer Kategorie, wie z. B. Objekte, etwas nachschlagen möchten, sehen Sie, dass die einzelnen Sprachkategorien jeweils eigene, kompaktere Bereiche enthalten.

Die Funktionsweise ist denkbar einfach. Klicken Sie auf eine der links angezeigten Überschriften, um eine Auflistung der in dieser Kategorie enthaltenen Elemente einzublenden. Wählen Sie aus dieser Auflistung anschließend das gewünschte Thema aus. Nachdem Sie das gewünschte Thema eingeblendet haben, können Sie problemlos zu anderen thematisch verknüpften Bereichen wechseln.

Tauchen Sie also ein! Lesen Sie Wissenswertes über Anweisungen, sinnieren Sie über die Methoden, oder probieren Sie einige Funktionen aus. Sie werden feststellen, dass die Jscript-Laufzeitbibliothek ausgesprochen vielseitig ist!

Funktionen | Beschreibung
Laufzeitmerkmale von Microsoft Scripting | Auflistung der Funktionen, die derzeit in der Laufzeitbibliothek von Microsoft Scripting integriert sind.
Sprachelement | Beschreibung
Add-Methode (Dictionary) | Fügt einem Dictionary-Objekt ein Schlüssel/Element-Paar hinzu.
Add-Methode (Folders) | Fügt einen neuen Folder der Folders-Auflistung hinzu.
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger unmittelbar vor der Zeilenendemarkierung einer TextStream-Datei befindet; andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet; andernfalls False.
Attributes-Eigenschaft | Setzt Datei- oder Ordnerattribute bzw. gibt sie zurück.
AvailableSpace-Eigenschaft | Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf einem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
BuildPath-Methode | Hängt einen Namen an einen vorhandenen Pfad an.
Close-Methode | Schließt eine geöffnete TextStream-Datei.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurück.
CompareMode-Eigenschaft | Setzt den Vergleichsmodus zum Vergleichen von Zeichenfolgenschlüsseln in einem Dictionary-Objekt und gibt diesen zurück.
Copy-Methode | Kopiert eine angegebene Datei bzw. einen angegebenen Ordner aus einem Speicherort in einen anderen.
CopyFile-Methode | Kopiert eine oder mehrere Dateien aus einem Speicherort in einen anderen.
CopyFolder-Methode | Kopiert einen Ordner rekursiv aus einem Speicherort in einen anderen.
Count-Eigenschaft | Gibt die Zahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurück.
CreateFolder-Methode | Erstellt einen Ordner.
CreateTextFile-Methode | Erstellt eine Datei mit dem angegebenen Namen und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen bzw. in die Datei geschrieben werden kann.
DateCreated-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde.
DateLastAccessed-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde.
DateLastModified-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an dem die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde.
Delete-Methode | Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
DeleteFile-Methode | Löscht eine angegebene Datei.
DeleteFolder-Methode | Löscht einen angegebenen Ordner samt Inhalt.
Dictionary-Objekt | Objekt zum Speichern von Datenschlüssel/Element-Paaren.
Drive-Eigenschaft | Gibt den Buchstaben des Laufwerks zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet.
Drive-Objekt | Bietet Zugriff auf die Eigenschaften eines bestimmten Festplatten- oder Netzlaufwerks.
DriveExists-Methode | Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, bzw. andernfalls False.
DriveLetter-Eigenschaft | Gibt den Laufwerkbuchstaben eines physischen lokalen Laufwerks oder eines Netzlaufwerks zurück.
Drives-Auflistung | Schreibgeschützte Auflistung aller verfügbaren Laufwerke.
Drives-Eigenschaft | Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
DriveType-Eigenschaft | Gibt einen Wert zurück, der den Typ des angegebenen Laufwerks anzeigt.
Exists-Methode | Gibt True zurück, wenn im Dictionary-Objekt ein angegebener Schlüssel vorhanden ist, bzw. andernfalls False.
File-Objekt | Bietet Zugriff auf alle Eigenschaften einer Datei.
FileExists-Methode | Gibt True zurück, wenn die angegebene Datei vorhanden ist, bzw. andernfalls False.
Files-Auflistung | Auflistung aller File-Objekte in einem Ordner.
Files-Eigenschaft | Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner samt der Dateien enthält, einschließlich der Dateien, deren Attribute "Hidden" (Versteckt) und "System" gesetzt sind.
FileSystem-Eigenschaft | Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
FileSystemObject-Objekt | Bietet den Zugang zum Dateisystem eines Computers.
FolderExists-Methode | Gibt True zurück, wenn der angegebene Ordner vorhanden ist, bzw. andernfalls False.
Folder-Objekt | Bietet Zugriff auf alle Eigenschaften eines Ordners.
Folders-Auflistung | Auflistung aller Folder-Objekte innerhalb eines Folder-Objekts.
FreeSpace-Eigenschaft | Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf einem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
GetAbsolutePathName-Methode | Gibt aus einer vorliegenden Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
GetBaseName-Methode | Gibt eine Zeichenfolge zurück, die den Basisnamen einer Datei (ohne Dateinamenerweiterung) oder den eines Ordners in einer vorliegenden Pfadangabe enthält.
GetDrive-Methode | Gibt ein Drive-Objekt zurück, das dem Laufwerk in einem angegebenen Pfad entspricht.
GetDriveName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des Laufwerks im angegebenen Pfad enthält.
GetExtensionName-Methode | Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfads enthält.
GetFile-Methode | Gibt ein File-Objekt zurück, das der Datei im angegebenen Pfad entspricht.
GetFileName-Methode | Gibt den letzten Dateinamen oder Ordner des angegebenen Pfades zurück, der nicht Teil der Laufwerksangabe ist.
GetFolder-Methode | Gibt ein Folder-Objekt zurück, das dem Ordner im angegebenen Pfad entspricht.
GetParentFolderName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Datei bzw. des letzten Ordners im angegebenen Pfad enthält.
GetSpecialFolder-Methode | Gibt den angegebenen Systemordner zurück.
GetTempName-Methode | Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück.
IsReady-Eigenschaft | Gibt True zurück, wenn das angegebene Laufwerk zugriffsbereit ist, bzw. andernfalls False.
IsRootFolder-Eigenschaft | Gibt True zurück, wenn der angegebene Ordner das Stammverzeichnis ist, bzw. andernfalls False.
Item-Eigenschaft | Setzt ein Element für einen angegebenen Schlüssel in einem Dictionary-Objekt oder gibt dieses zurück.
Items-Methode | Gibt ein Datenfeld zurück, das alle Elemente eines Dictionary-Objekts enthält.
Key-Eigenschaft | Setzt einen Schlüssel in einem Dictionary-Objekt.
Keys-Methode | Gibt ein Datenfeld zurück, das alle vorhandenen Schlüssel eines Dictionary-Objekts enthält.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einer TextStream-Datei zurück.
Move-Methode | Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
MoveFile-Methode | Verschiebt eine oder mehrere Dateien aus einem Speicherort in einen anderen.
MoveFolder-Methode | Verschiebt einen oder mehrere Ordner aus einem Speicherort in einen anderen.
Name-Eigenschaft | Setzt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners oder gibt diesen zurück.
OpenAsTextStream-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen, in sie geschrieben oder an die Datei angefügt werden kann.
OpenTextFile-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen, in sie geschrieben oder an die Datei angefügt werden kann.
ParentFolder-Eigenschaft | Gibt das Folder-Objekt. des übergeordneten Ordners der angegebenen Datei bzw. des angegebenen Ordners zurück.
Path-Eigenschaft | Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerks zurück.
Read-Methode | Liest eine angegebene Zahl von Zeichen aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest eine gesamte TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine gesamte Zeile einer TextStream-Datei (bis zum Zeilenumbruchzeichen) und gibt die resultierende Zeichenfolge zurück.
Remove-Methode | Entfernt ein Schlüssel/Element-Paar aus einem Dictionary-Objekt.
RemoveAll-Methode | Entfernt sämtliche Schlüssel/Element-Paare aus einem Dictionary-Objekt.
RootFolder-Eigenschaft | Gibt ein Folder-Objekt zurück, das das Stammverzeichnis eines angegebenen Laufwerks darstellt.
SerialNumber-Eigenschaft | Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
ShareName-Eigenschaft | Gibt den innerhalb eines Netzwerks gültigen Freigabenamen eines angegebenen Laufwerks zurück.
ShortName-Eigenschaft | Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
ShortPath-Eigenschaft | Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Size-Eigenschaft | Gibt die Größe (in Byte) der angegebenen Datei bzw. des angegebenen Ordners an.
Skip-Methode | Überspringt beim Lesen einer TextStream-Datei die angegebene Zahl von Zeichen.
SkipLine-Methode | Übergeht die nächste Zeile beim Lesen einer TextStream-Datei.
SubFolders-Eigenschaft | Gibt eine Folders-Auflistung zurück, die alle Ordner in dem angegebenen Ordner samt den Ordnern enthält, deren Attribute "Hidden" (Versteckt) und "System" gesetzt sind.
TextStream-Objekt | Erleichtert den sequenziellen Zugriff auf eine Datei.
TotalSize-Eigenschaft | Gibt den gesamten Speicherplatz (in Byte) eines Laufwerks oder Netzlaufwerks zurück.
Type-Eigenschaft | Gibt Informationen zum Datei- oder Ordnertyp zurück.
VolumeName-Eigenschaft | Setzt den Datenträgernamen des angegebenen Laufwerks bzw. gibt diesen zurück.
Write-Methode | Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.
WriteBlankLines-Methode | Schreibt eine angegebene Zahl von Zeilenumbruchzeichen in eine TextStream-Datei.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge samt Zeilenumbruchzeichen in eine TextStream-Datei.
Sprachelement | Beschreibung
Add-Methode (Dictionary) | Fügt einem Dictionary-Objekt ein Schlüssel/Element-Paar hinzu.
Add-Methode (Folders) | Fügt einen neuen Folder der Folders-Auflistung hinzu.
BuildPath-Methode | Hängt einen Namen an einen vorhandenen Pfad an.
Close-Methode | Schließt eine geöffnete TextStream-Datei.
CopyFile-Methode | Kopiert eine oder mehrere Dateien aus einem Speicherort in einen anderen.
CopyFolder-Methode | Kopiert einen Ordner rekursiv aus einem Speicherort in einen anderen.
Copy-Methode | Kopiert eine angegebene Datei bzw. einen angegebenen Ordner aus einem Speicherort in einen anderen.
CreateFolder-Methode | Erstellt einen Ordner.
CreateTextFile-Methode | Erstellt eine Datei mit dem angegebenen Namen und gibt das TextStream-Objekt zurück, mit dem aus der Datei gelesen bzw. in die Datei geschrieben werden kann.
DeleteFile-Methode | Löscht eine angegebene Datei.
DeleteFolder-Methode | Löscht einen angegebenen Ordner samt Inhalt.
Delete-Methode | Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
DriveExists-Methode | Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, bzw. andernfalls False.
Exists-Methode | Gibt True zurück, wenn im Dictionary-Objekt ein angegebener Schlüssel vorhanden ist, bzw. andernfalls False.
FileExists-Methode | Gibt True zurück, wenn die angegebene Datei vorhanden ist, bzw. andernfalls False.
FolderExists-Methode | Gibt True zurück, wenn der angegebene Ordner vorhanden ist, bzw. andernfalls False.
GetAbsolutePathName-Methode | Gibt aus einer vorliegenden Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
GetBaseName-Methode | Gibt eine Zeichenfolge zurück, die den Basisnamen einer Datei (ohne Dateinamenerweiterung) oder den eines Ordners in einer vorliegenden Pfadangabe enthält.
GetDrive-Methode | Gibt ein Drive-Objekt zurück, das dem Laufwerk im angegebenen Pfad entspricht.
GetDriveName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des Laufwerks im angegebenen Pfad enthält.
GetExtensionName-Methode | Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfads enthält.
GetFile-Methode | Gibt ein File-Objekt zurück, das der Datei im angegebenen Pfad entspricht.
GetFileName-Methode | Gibt den letzten Dateinamen oder Ordner des angegebenen Pfades zurück, der nicht Teil der Laufwerksangabe ist.
GetFolder-Methode | Gibt ein Folder-Objekt zurück, das dem Ordner im angegebenen Pfad entspricht.
GetParentFolderName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Datei bzw. des letzten Ordners im angegebenen Pfad enthält.
GetSpecialFolder-Methode | Gibt den angegebenen Systemordner zurück.
GetTempName-Methode | Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück.
Items-Methode | Gibt ein Datenfeld zurück, das alle Elemente eines Dictionary-Objekts enthält.
Keys-Methode | Gibt ein Datenfeld zurück, das alle vorhandenen Schlüssel eines Dictionary-Objekts enthält.
Move-Methode | Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
MoveFile-Methode | Verschiebt eine oder mehrere Dateien aus einem Speicherort in einen anderen.
MoveFolder-Methode | Verschiebt einen oder mehrere Ordner aus einem Speicherort in einen anderen.
OpenAsTextStream-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen, in sie geschrieben oder an die Datei angefügt werden kann.
OpenTextFile-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen, in sie geschrieben oder an die Datei angefügt werden kann.
Read-Methode | Liest eine angegebene Zahl von Zeichen aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest eine gesamte TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine gesamte Zeile einer TextStream-Datei (bis zum Zeilenumbruchzeichen) und gibt die resultierende Zeichenfolge zurück.
Remove-Methode | Entfernt ein Schlüssel/Element-Paar aus einem Dictionary-Objekt.
RemoveAll-Methode | Entfernt sämtliche Schlüssel/Element-Paare aus einem Dictionary-Objekt.
Skip-Methode | Überspringt beim Lesen einer TextStream-Datei die angegebene Zahl von Zeichen.
SkipLine-Methode | Übergeht die nächste Zeile beim Lesen einer TextStream-Datei.
Write-Methode | Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.
WriteBlankLines-Methode | Schreibt eine angegebene Zahl von Zeilenumbruchzeichen in eine TextStream-Datei.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge mit Zeilenumbruchzeichen in eine TextStream-Datei.
Sprachelement | Beschreibung
Dictionary-Objekt | Objekt zum Speichern von Schlüssel/Element-Paaren.
Drive-Objekt | Bietet Zugriff auf die Eigenschaften eines bestimmten Festplatten- oder Netzlaufwerks.
Drives-Auflistung | Schreibgeschützte Auflistung aller verfügbaren Laufwerke.
File-Objekt | Bietet Zugriff auf alle Eigenschaften einer Datei.
Files-Auflistung | Auflistung aller File-Objekte in einem Ordner.
FileSystemObject-Objekt | Bietet den Zugang zum Dateisystem eines Computers.
Folder-Objekt | Bietet Zugriff auf alle Eigenschaften eines Ordners.
Folders-Auflistung | Auflistung aller Folder-Objekte innerhalb eines Folder-Objekts.
TextStream-Objekt | Erleichtert den sequenziellen Zugriff auf eine Datei.
Sprachelement | Beschreibung
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger unmittelbar vor der Zeilenendemarkierung einer TextStream-Datei befindet; andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet; andernfalls False.
Attributes-Eigenschaft | Setzt Datei- oder Ordnerattribute bzw. gibt sie zurück.
AvailableSpace-Eigenschaft | Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf einem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurück.
CompareMode-Eigenschaft | Setzt den Vergleichsmodus zum Vergleichen von Zeichenfolgenschlüsseln in einem Dictionary-Objekt und gibt diesen zurück.
Count-Eigenschaft | Gibt die Zahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurück.
DateCreated-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde.
DateLastAccessed-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde.
DateLastModified-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an dem die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde.
Drive-Eigenschaft | Gibt den Buchstaben des Laufwerks zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet.
DriveLetter-Eigenschaft | Gibt den Laufwerkbuchstaben eines physischen lokalen Laufwerks oder eines Netzlaufwerks zurück.
Drives-Eigenschaft | Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
DriveType-Eigenschaft | Gibt einen Wert zurück, der den Typ des angegebenen Laufwerks anzeigt.
Files-Eigenschaft | Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner samt der Dateien enthält, sowie einschließlich der Dateien, deren Attribute "Hidden" (Versteckt) und "System" gesetzt sind.
FileSystem-Eigenschaft | Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
FreeSpace-Eigenschaft | Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf einem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
IsReady-Eigenschaft | Gibt True zurück, wenn das angegebene Laufwerk zugriffsbereit ist, bzw. andernfalls False.
IsRootFolder-Eigenschaft | Gibt True zurück, wenn der angegebene Ordner das Stammverzeichnis ist, bzw. andernfalls False.
Item-Eigenschaft | Setzt ein Element für einen angegebenen Schlüssel in einem Dictionary-Objekt oder gibt dieses zurück.
Key-Eigenschaft | Setzt einen Schlüssel in einem Dictionary-Objekt.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einer TextStream-Datei zurück.
Name-Eigenschaft | Setzt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners oder gibt diesen zurück.
ParentFolder-Eigenschaft | Gibt das Ordnerobjekt des übergeordneten Ordners der angegebenen Datei bzw. des angegebenen Ordners zurück.
Path-Eigenschaft | Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerks zurück.
RootFolder-Eigenschaft | Gibt ein Folder-Objekt zurück, das das Stammverzeichnis im angegebenen Pfad darstellt.
SerialNumber-Eigenschaft | Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
ShareName-Eigenschaft | Gibt den innerhalb eines Netzwerks gültigen Freigabenamen eines angegebenen Laufwerks zurück.
ShortName-Eigenschaft | Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
ShortPath-Eigenschaft | Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Size-Eigenschaft | Gibt die Größe (in Byte) der angegebenen Datei bzw. des angegebenen Ordners an.
SubFolders-Eigenschaft | Gibt eine Folders-Auflistung zurück, die alle Ordner in dem angegebenen Ordner samt den Ordnern enthält, deren Attribute "Hidden" (Versteck) und "System" gesetzt sind.
TotalSize-Eigenschaft | Gibt den gesamten Speicherplatz (in Byte) eines Laufwerks oder Netzlaufwerks zurück.
Type-Eigenschaft | Gibt Informationen zum Datei- oder Ordnertyp zurück.
VolumeName-Eigenschaft | Setzt den Datenträgernamen des angegebenen Laufwerks bzw. gibt diesen zurück.

©1998 Microsoft Corporation. Alle Rechte vorbehalten. Rechtliche Hinweise.


Informationen über Leistungsmerkmale

Informationen über Leistungsmerkmale 		Referenz für die JScript-Laufzeitbibliothek
Versionsinformationen

Laufzeitmerkmale von Microsoft Scripting


Alphabetische Liste der Schlüsselwörter

Alphabetische Liste der Schlüsselwörter 		Referenz für die JScript-Laufzeitbibliothek
Versionsinformationen

Add-Methode (Dictionary)
Add-Methode (Folders)
AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Attributes-Eigenschaft
AvailableSpace-Eigenschaft
BuildPath-Methode
Close-Methode
Column-Eigenschaft
CompareMode-Eigenschaft
CopyFile-Methode
CopyFolder-Methode
Copy-Methode
Count-Eigenschaft
CreateFolder-Methode
CreateTextFile-Methode
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
DeleteFile-Methode
DeleteFolder-Methode
Delete-Methode
Dictionary-Objekt
Drive-Eigenschaft
DriveExists-Methode
DriveLetter-Eigenschaft
Drive-Objekt
Drives-Auflistung
Drives-Eigenschaft
DriveType-Eigenschaft
Exists-Methode
FileExists-Methode
File-Objekt
Files-Auflistung
Files-Eigenschaft
FileSystem-Eigenschaft
FileSystemObject-Objekt
FolderExists-Methode
Folder-Objekt
Folders-Auflistung
FreeSpace-Eigenschaft
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Item-Eigenschaft
Items-Methode
Key-Eigenschaft
Keys-Methode
Line-Eigenschaft
MoveFile-Methode
MoveFolder-Methode
Move-Methode
Name-Eigenschaft
OpenAsTextStream-Methode
OpenTextFile-Methode
ParentFolder-Eigenschaft
Path-Eigenschaft
ReadAll-Methode
ReadLine-Methode
Read-Methode
RemoveAll-Methode
Remove-Methode
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SkipLine-Methode
Skip-Methode
SubFolders-Eigenschaft
TextStream-Objekt
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft
WriteBlankLines-Methode
WriteLine-Methode
Write-Methode


Methoden

Methoden 		Referenz für die JScript-Laufzeitbibliothek
Versionsinformationen

Add-Methode (Dictionary)
Add-Methode (Folders)
BuildPath-Methode
Close-Methode
CopyFile-Methode
CopyFolder-Methode
Copy-Methode
CreateFolder-Methode
CreateTextFile-Methode
DeleteFile-Methode
DeleteFolder-Methode
Delete-Methode
DriveExists-Methode
Exists-Methode
FileExists-Methode
FolderExists-Methode
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
Items-Methode
Keys-Methode
MoveFile-Methode
MoveFolder-Methode
Move-Methode
OpenAsTextStream-Methode
OpenTextFile-Methode
ReadAll-Methode
ReadLine-Methode
Read-Methode
RemoveAll-Methode
Remove-Methode
SkipLine-Methode
Skip-Methode
WriteBlankLines-Methode
WriteLine-Methode
Write-Methode


Objekte

Objekte 		Referenz für die JScript-Laufzeitbibliothek
Versionsinformationen

Dictionary-Objekt
Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
FileSystemObject-Objekt
Folder-Objekt
Folders-Auflistung
TextStream-Objekt


Eigenschaften

Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek
Versionsinformationen

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Attributes-Eigenschaft
AvailableSpace-Eigenschaft
Column-Eigenschaft
CompareMode-Eigenschaft
Count-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
DriveLetter-Eigenschaft
Drives-Eigenschaft
DriveType-Eigenschaft
Files-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft
Line-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft


FileSystemObject-Objekt-Tutorium

FileSystemObject-Objekt-Tutorium
 Referenz für die JScript-Laufzeitbibliothek

Das FileSystemObject-Objektmodell
Einführung zum FileSystemObject und zur Referenz für die JScript-Laufzeitbibliothek
FileSystemObject-Objekte
Programmieren des FileSystemObject-Objekts
Arbeiten mit Laufwerken und Ordnern
Arbeiten mit Dateien
FileSystemObject-Beispielcode


Das FileSystemObject-Objektmodell

Microsoft® Scripting-Bibliothek - FileSystemObject
Das FileSystemObject-Objektmodell
 Weiter

Beim Schreiben von Skripten für Active Server Pages, dem Windows Scripting Host oder anderen Anwendungen, bei denen Scripting verwendet werden kann, ist das Hinzufügen, Verschieben, Ändern, Erstellen bzw. Löschen von Ordnern (Verzeichnissen) und Dateien auf dem Webserver sehr häufig relevant. Darüber hinaus kann es auch notwendig sein, über Informationen zu sowie Möglichkeiten zum Bearbeiten von Laufwerken zu verfügen, die im Webserver eingebunden sind.

Unter Verwendung des in den nachstehenden Abschnitten beschriebenen FileSystemObject-Objektmodells (FSO) erlaubt Ihnen das Scripting das Arbeiten mit Laufwerken, Ordnern und Dateien:

  • Einführung zum FileSystemObject und zur Referenz für die JScript-Laufzeitbibliothek

  • FileSystemObject-Objekte

  • Programmieren des FileSystemObject-Objekts

  • Arbeiten mit Laufwerken und Ordnern

  • Arbeiten mit Dateien

  • FileSystemObject-Beispielcode


Einführung zum FileSystemObject und zur Referenz für die JScript-Laufzeitbibliothek

Microsoft® Scripting-Bibliothek - FileSystemObject
Einführung zum FileSystemObject und zur Referenz für die JScript-Laufzeitbibliothek
 Zurück
Weiter

Das FileSystemObject-Objektmodell (FSO) ermöglicht Ihnen die Verwendung der vertrauten Objekt.Methode-Syntax mit einer umfangreichen Gruppe von Eigenschaften, Methoden und Ereignissen, um Ordner sowie Dateien verarbeiten zu können.

Verwenden Sie dieses objektbasierte Werkzeug mit:
  • HTML zum Erstellen von Webseiten

  • Windows Scripting Host zum Erstellen von Stapelverarbeitungsdateien für Microsoft Windows

  • Script Control zum Bereitstellen einer Scriptingfunktionalität für in anderen Sprachen entwickelte Anwendungen

Da die clientseitige Verwendung von FSO nicht unbedenkliche Sicherheitslücken bei möglichen unbefugten Zugriffen auf das lokale Dateisystem des Clients bieten, wird in dieser Dokumentation davon ausgegangen, dass die Verwendung des FSO-Objektmodells dem Erstellen von Skripten dient, die von serverseitigen Internet-Webseiten ausgeführt werden. Da die Serverseite verwendet wird, kann auf Grund der Sicherheitseinstellungen des Internet Explorer keine clientseitige Verwendung des FileSystemObject-Objekts erfolgen. Durch Deaktivierung dieser Standardeinstellungen besteht die Möglichkeit, auf das Dateisystem eines lokalen Computers unbefugten Zugriff zu gewähren, das zur vollständigen Zerstörung der Dateisystemintegrität, Datenverlusten oder weitaus größeren Folgen führen kann.

Das FSO-Objektmodell ermöglicht serverseitigen Anwendungen das Erstellen, Ändern, Verschieben und Löschen von Ordnern bzw. das Überprüfen, ob und wo bestimmte Ordner vorhanden sind. Darüber hinaus können Sie Angaben zu Ordnern suchen, wie beispielsweise deren Namen oder deren Erstellungs- bzw. Änderungsdatum.

Das FSO-Objektmodell erleichtert zudem die Verarbeitung von Dateien. Bei der Verarbeitung von Dateien ist das oberste Ziel, Daten in einem kapazitäts- und ressourceneffizienten Format zu speichern, auf das problemlos zugegriffen werden kann. Sie müssen in der Lage sein, Dateien zu erstellen, Daten einzufügen bzw. zu ändern und auszugeben (lesen). Da das Speichern von Daten in Datenbanken, wie zum Beispiel in Access oder SQL Server, einen enormen Verwaltungsaufwand für die Anwendung nach sich zieht, stellen Binär- oder Textdateien die wohl effizienteste Lösung dar. Möglicherweise benötigen Sie diesen Verwaltungsaufwand aber auch nicht, oder die Anforderungen an den Datenzugriff sehen den Einsatz sämtlicher integrierter Funktionen einer komplexen Datenbankanwendung nicht vor.

Das in der Scripting-Typbibliothek (Scrrun.dll) integrierte FSO-Objektmodell unterstützt das Erstellen und Bearbeiten von Textdateien mit Hilfe des TextStream-Objekts. Das Erstellen und Bearbeiten von Binärdateien wird derzeit zwar noch nicht unterstützt, jedoch ist dies für zukünftige Entwicklungen geplant.


FileSystemObject-Objekte

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-Objekte
 Zurück
Weiter

Das FileSystemObject-Objektmodell (FSO) enthält die nachstehenden Objekte und Auflistungen.

Objekt/Auflistung | Beschreibung
FileSystemObject | Hauptobjekt. Enthält Methoden und Eigenschaften sowohl zum Erstellen, Löschen sowie Abrufen von Informationen zu als auch allgemein zum Ändern von Laufwerken, Ordnern und Dateien. Zahlreiche der mit diesem Objekt verknüpften Methoden entsprechen denen in anderen FSO-Objekten; die Bereitstellung dient lediglich einer benutzerfreundlicheren Handhabung.
Drive | Objekt. Enthält Methoden und Eigenschaften zum Abrufen von Informationen zu einem systemintegrierten Laufwerk, wie beispielsweise dem Freigabenamen oder dem verfügbaren Speicherplatz. Beachten Sie dabei jedoch, dass ein "Laufwerk" nicht notwendigerweise mit einer Festplatte gleichgesetzt werden kann, da es sich auch um ein CD-ROM-, ein RAM-Laufwerk oder Ähnliches handeln kann. Ein Laufwerk muss nicht physikalisch im System integriert sein, da es sich auch um ein logisches Laufwerk handeln kann, das über ein Netzwerk eingebunden ist.
Drives | Auflistung. Stellt eine Übersicht der in das System eingebundenen physikalischen oder logischen Laufwerke bereit. Die Drives-Auflistung umfasst alle Laufwerke, ungeachtet des Typs. In Laufwerken mit austauschbaren Datenträgern müssen keine Datenträger eingelegt sein, damit diese in der Auflistung angezeigt werden.
File | Objekt. Enthält Methoden und Eigenschaften zum Erstellen, Löschen sowie Verschieben von Dateien. Darüber hinaus können Sie Systemabfragen nach einem Dateinamen, -pfad sowie anderen Eigenschaften durchführen.
Files | Auflistung. Stellt eine Übersicht sämtlicher in einem Ordner enthaltenen Dateien bereit.
Folder | Objekt. Enthält Methoden und Eigenschaften zum Erstellen, Löschen sowie Verschieben von Ordnern. Darüber hinaus können Sie Systemabfragen nach einem Ordnernamen, -pfad sowie anderen Eigenschaften durchführen.
Folders | Auflistung. Stellt eine Übersicht sämtlicher in einem Folder-Objekt enthaltenen Ordner bereit.
TextStream | Objekt. Ermöglicht Ihnen das Lesen und Schreiben von Textdateien.


Programmieren des FileSystemObject-Objekts

Microsoft® Scripting-Bibliothek - FileSystemObject
Programmieren des FileSystemObject-Objekts
 Zurück
Weiter

So programmieren Sie mit dem FileSystemObject-Objektmodell (FSO):

  • Verwenden Sie die CreateObject-Methode, um ein FileSystemObject-Objekt zu erstellen.
  • Wenden Sie die gewünschte Methode auf das neu erstellte Objekt an.
  • Greifen Sie auf die Eigenschaften des Objekts zu.
Das FSO-Objektmodell ist in der Scripting-Typbibliothek enthalten, die sich in der Datei Scrrun.dll befindet. Die Datei Scrrun.dll muss sich daher im entsprechenden Systemverzeichnis auf dem Webserver befinden, um das FSO-Objektmodell verwenden zu können.

Erstellen eines FileSystemObject-Objekts
Erstellen Sie mit der CreateObject-Methode zunächst ein FileSystemObject-Objekt. Verwenden Sie anschließend den folgenden Code in VBScript, um eine Instanz von FileSystemObject zu erstellen:

Dim fso
Set fso = CreateObject("Scripting.FileSystemObject")
Dieser Beispielcode zeigt, wie eine Instanz von FileSystemObject erstellt wird.

In JScript verwenden Sie den folgenden Code für die Erstellung:

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
In beiden Fällen ist Scripting der Name der Typbibliothek und FileSystemObject der Name des zu erstellenden Objekts. Sie können nur jeweils eine Instanz des FileSystemObject-Objekts erstellen, unabhängig von der Anzahl der Versuche.

Verwenden der Appropriate-Methode
Verwenden Sie dann die gewünschte Methode des FileSystemObject-Objekts. Wenn Sie beispielsweise ein neues Objekt erstellen möchten, verwenden Sie entweder CreateTextFile oder CreateFolder (das FSO-Objektmodell unterstützt keine Vorgänge zum Erstellen oder Löschen von Laufwerken).

Sie löschen Objekte, indem Sie die DeleteFile- und DeleteFolder-Methoden des FileSystemObject-Objekts oder die Delete-Methode der File- und Folder-Objekte verwenden. Sie können Dateien und Ordner auch kopieren oder verschieben, indem Sie die entsprechenden Methoden einsetzen.

Hinweis Im FileSystemObject-Objektmodell sind einige Funktionalitätsmerkmale redundant. Beispielsweise können Sie eine Datei über die CopyFile-Methode des FileSystemObject-Objekts oder die Copy-Methode des File-Objekts kopieren. Die Funktionsweise ist bei beiden Methoden gleich; es sind zwei verschiedene Methoden vorhanden, um eine gewisse Flexibilität beim Programmieren zu gewährleisten.

Zugreifen auf vorhandene Laufwerke, Dateien und Ordner
Verwenden Sie die entsprechende "Get"-Methode des FileSystemObject-Objekts, um auf die vorhandenen Laufwerke, Dateien oder Ordner zugreifen zu können:

  • GetDrive
  • GetFolder
  • GetFile
So können Sie auf eine vorhandene Datei unter VBScript zugreifen:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.GetFile("c:\test.txt")
Für JScript verwenden Sie hierfür den folgenden Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.GetFile("c:\\test.txt");
Verwenden Sie die "Get"-Methoden nicht für neu erstellte Objekte, da die "create"-Funktionen bereits einen Zeiger auf das Objekt zurückgeben. Wenn Sie beispielsweise mit der CreateFolder-Methode einen neuen Order erstellen, verwenden Sie nicht die GetFolder-Methode, wie z. B. Name, Path oder Size, um auf die zugehörigen Eigenschaften zuzugreifen. Setzen Sie einfach eine Variable auf die CreateFolder-Funktion, um einen Zeiger auf den neu erstellten Ordner zu setzen, und greifen Sie dann auf die Eigenschaften, Methoden und Ereignisse zu. Verwenden Sie in VBScript den folgenden Code:

Sub CreateFolder Dim fso, fldr Set fso = CreateObject("Scripting.FileSystemObject")
  Set fldr = fso.CreateFolder("C:\DerTest")
  Response.write "Erstellter Ordner: " & fldr.Name
End Sub
Verwenden Sie die folgende Syntax, um in JScript eine Variable auf die CreateFolder-Funktion zu setzen:

function CreateFolder()
{
  var fso, fldr;
  fso = ActiveXObject("Scripting.FileSystemObject");
  fldr = fso.CreateFolder("C:\\DerTest");
  Response.write("Erstellter Ordner: " + fldr.Name);
}
Zugreifen auf die Eigenschaften des Objekts
Nachdem Sie über einen Zeiger auf das Objekt verfügen, können Sie auf dessen Eigenschaften zugreifen. Wenn Sie beispielsweise den Namen eines bestimmten Ordners abrufen möchten, erstellen Sie zunächst eine Instanz des Objekts und dann mit der entsprechenden Methode (in diesem Fall mit der GetFolder-Methode, da der Ordner bereits vorhanden ist) einen zugehörigen Zeiger.

Verwenden Sie diesen Code, um in VBScript einen Zeiger auf die GetFolder-Methode zu legen:

Set fldr = fso.GetFolder("c:\")

Für JScript verwenden Sie hierfür den folgenden Code:

var fldr = fso.GetFolder("c:\\");
Da Sie jetzt über einen Zeiger auf das Folder-Objekt verfügen, können Sie seine Name-Eigenschaft überprüfen. Verwenden Sie hierfür in VBScript den folgenden Code:

Response.write "Ordnername: " & fldr.Name
Zur Überprüfung einer Name-Eigenschaft in JScript verwenden Sie die folgende Syntax:

Response.write("Ordnername: " + fldr.Name);
Verwenden Sie die folgende VBScript-Syntax, um herauszufinden, wann eine Datei zuletzt geändert wurde:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
' Lädt ein zu durchsuchendes Dateiobjekt.
Set f1 = fso.GetFile("c:\detlog.txt")
' Gibt die Informationen aus.
Response.write "Datei zuletzt geändert: " & f1.DateLastModified
Für JScript verwenden Sie hierfür den folgenden Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
// Lädt ein zu durchsuchendes Dateiobjekt.
f1 = fso.GetFile("c:\\detlog.txt");
// Gibtt die Informationen aus.
Response.write("Datei zuletzt geändert: " + f1.DateLastModified);


Arbeiten mit Laufwerken und Ordnern

Microsoft® Scripting-Bibliothek - FileSystemObject
Arbeiten mit Laufwerken und Ordnern
 Zurück
Weiter

So wie Sie mit Laufwerken und Ordnern im Windows Explorer interaktiv arbeiten, können Sie mit dem FileSystemObject-Objektmodell (FSO) auf programmiertechnischer Ebene arbeiten. Sie können unter anderem Ordner kopieren und verschieben sowie Informationen zu Laufwerken und Ordnern abrufen.

Abrufen von Informationen zu Laufwerken
Mit dem Drive-Objekt können Sie sich Informationen zu den verschiedenen in das System eingebundenen physikalischen oder Netzlaufwerken anzeigen lassen. Durch die zugehörigen Eigenschaften erhalten Sie die folgenden Informationen:

  • Gesamtgröße des Laufwerks in Byte (TotalSize-Eigenschaft)
  • Verfügbarer Speicherplatz auf dem Laufwerk in Byte (AvailableSpace- oder FreeSpace-Eigenschaft)
  • Zugeordneter Laufwerksbuchstabe (DriveLetter-Eigenschaft)
  • Laufwerkstyp, wie beispielsweise austauschbarer oder fester Datenträger, Netzwerk-, CD-ROM- bzw. RAM-Laufwerk (DriveType-Eigenschaft)
  • Seriennummer des Laufwerks (SerialNumber-Eigenschaft)
  • Mit dem Laufwerk verwendetes Dateisystem, wie z. B. FAT, FAT32, NTFS etc. (FileSystem-Eigenschaft)
  • Status zur Verfügbarkeit des Laufwerks (IsReady-Eigenschaft)
  • Freigabe- und/oder Datenträgername (ShareName- und VolumeName-Eigenschaft)
  • Pfad oder Stammverzeichnis des Laufwerks (Path- und RootFolder-Eigenschaft)
Praktische Beispiele zur Verwendung dieser Eigenschaften mit FileSystemObject finden Sie unter Beispielcode.

Beispiel zur Verwendung des Drive-Objekts
Verwenden Sie das Drive-Objekt, um Informationen zu einem Laufwerk zu erhalten. Im nachstehenden Code befindet sich kein Referenz auf ein tatsächliches Drive-Objekt; verwenden Sie daher die GetDrive-Methode, um eine Referenz auf ein vorhandenes Drive-Objekt zu erhalten (in diesem Fall auf "drv").

Das folgende Beispiel zeigt die Verwendung des Drive-Objekts in VBScript:

Sub ZeigeLaufwerkInfo(drvPfad)
  Dim fso, drv, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set drv = fso.GetDrive(fso.GetDriveName(drvPfad))
  s = "Laufwerk" & UCase(drvPfad) & " - "
  s = s & drv.VolumeName & "<br>"
  s = s & "Speicherplatz gesamt: " & FormatNumber(drv.TotalSize / 1024, 0)
  s = s & " KB" & "<br>"
  s = s & "Freier Speicherplatz: " & FormatNumber(drv.FreeSpace / 1024, 0)
  s = s & " KB" & "<br>"
  Response.write s
End Sub
Der folgende Code zeigt die gleiche Funktionalität in JScript:
function ZeigeLaufwerkInfo1(drvPfad)
{
  var fso, drv, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  drv = fso.GetDrive(fso.GetDriveName(drvPfad));
  s += "Laufwerk " + drvPfad.toUpperCase()+ " - ";
  s += drv.VolumeName + "<br>";
  s += "Speicherplatz gesamt: " + drv.TotalSize / 1024;
  s += " KB" + "<br>";
  s += "Freier Speicherplatz: " + drv.FreeSpace / 1024;
  s += " KB" + "<br>"; Response.write(s);
}
Arbeiten mit Ordnern
In der nachstehenden Tabelle werden allgemeine Aufgaben mit Ordnern sowie zugehörige ausführbare Methoden beschrieben.

Aufgabe | Methode
Erstellt einen Ordner. | FileSystemObject.CreateFolder
Löscht einen Ordner. | Folder.Delete oder FileSystemObject.DeleteFolder
Verschiebt einen Ordner. | Folder.Move oder FileSystemObject.MoveFolder
Kopiert einen Ordner. | Folder.Copy oder FileSystemObject.CopyFolder
Ruft einen Ordnernamen ab. | Folder.Name
Sucht, ob ein Ordner auf einem Laufwerk vorhanden ist. | FileSystemObject.FolderExists
Lädt eine Instanz eines vorhandenen Folder-Objekts. | FileSystemObject.GetFolder
Sucht den Namen des übergeordneten Ordners eines angegebenen Ordners. | FileSystemObject.GetParentFolderName
Sucht den Pfad von Systemordnern. | FileSystemObject.GetSpecialFolder

Informationen zur Anzahl der in FileSystemObject verwendeten Methoden und Eigenschaften finden Sie unter Beispielcode.

Das nachstehende Beispiel zeigt die Verwendung der Folder- und FileSystemObject-Objekte, um in VBScript Ordner zu bearbeiten und Informationen zu diesen zu erhalten:

Sub ZeigeLaufwerkInfo()
  Dim fso, fldr, s ' Gibt eine Instanz des FileSystemObject-Objekts aus.
  Set fso = CreateObject("Scripting.FileSystemObject")
  ' Lädt das Drive-Objekt.
  Set fldr = fso.GetFolder("c:")
  ' Gibt den Namen des übergeordneten Ordners aus.
  Response.write "Name des übergeordneten Ordners: " & fldr & "<br>"
  ' Gibt den Laufwerksnamen aus.
  Response.write "Enthalten auf Laufwerk " & fldr.Drive & "<br>"
  ' Gibt den Dateinamen aus.
  If fldr.IsRootFolder = True Then Response.write "Dies ist der Hauptordner." & ""<br>"<br>"
  Else Response.write "Dieser Ordner ist nicht der Hauptordner." & "<br><br>"
  End If ' Create a new folder with the FileSystemObject object.
  fso.CreateFolder ("C:\Phish")
  Response.write "Ordner C:\Phish erstellt" & "<br>"
  ' Gibt den Basisnamen des Verzeichnisses aus.
  Response.write "Basisname= " & fso.GetBaseName("c:\Phish") & "<br>"
  ' Löscht das neu erstellte Verzeichnis.
  fso.DeleteFolder ("C:\Phish")
  Response.write "Ordner C:\Phish gelöscht" & "<br>"
End Sub
Dieses Beispiel zeigt die Verwendung der Folder- und FileSystemObject-Objekte in JScript:
function ShowFolderInfo()
{
  var fso, fldr, s = ""; // Lädt die Instanz von FileSystemObject.
  fso = new ActiveXObject("Scripting.FileSystemObject"); // Lädt das Drive-Objekt.
  fldr = fso.GetFolder("c:"); // Gibt den Namen des übergeordneten Ordners aus.
  Response.write("Name des übergeordneten Ordners: " + fldr + "<br>"); // Gibt Laufwerksnamen aus.
  Response.write("Enthalten auf Laufwerk " + fldr.Drive + "<br>"); // Gibt den Dateinamen aus.
  if (fldr.IsRootFolder)
    Response.write("Dies ist der Hauptordner.");
  else Response.write("Dieser Ordner ist nicht der Hauptordner.");
  Response.write("<br><br>"); // Erstellt einen neuen Ordner mit dem FileSystemObject-Objekt.
  fso.CreateFolder ("C:\\Bogus");
  Response.write("Ordner C:\\Bogus erstellt" + "<br>"); // Gibt den Basisnamen des Verzeichnisses aus.
  Response.write("Basisname = " + fso.GetBaseName("c:\\bogus") + "<br>"); // Löscht den neu erstellten Ordner.
  fso.DeleteFolder ("C:\\Bogus"); Response.write("Ordner C:\\Bogus gelöscht" + "<br>");
}


Arbeiten mit Dateien

Microsoft® Scripting-Bibliothek - FileSystemObject
Arbeiten mit Dateien
 Zurück
Weiter

Beim Bearbeiten von Dateien sind die nachstehenden beiden Hauptkategorien zu unterscheiden:

  • Erstellen, Hinzufügen bzw. Entfernen von Daten sowie Lesen von Dateien
  • Verschieben, Kopieren und Löschen von Dateien
Erstellen von Dateien
Es gibt drei Möglichkeiten, eine leere Textdatei (auch als "TextStream" bezeichnet) zu erstellen.

Die erste Möglichkeit besteht in der Verwendung der CreateTextFile-Methode. Das folgende Beispiel zeigt das Erstellen einer Textdatei mit dieser Methode für VBScript:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.CreateTextFile("c:\testdatei.txt", True)
Für diese Methode unter JScript verwenden Sie diesen Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.CreateTextFile("c:\\testdatei.txt", true);
Praktische Beispiele zur Verwendung der CreateTextFile-Methode mit FileSystemObject finden Sie unter Beispielcode.

Die zweite Möglichkeit zum Erstellen einer Textdatei ist die Verwendung der OpenTextFile-Methode des FileSystemObject-Objekts mit gesetztem ForWriting-Attribut. In VBScript sieht der Code folgendermaßen aus:

Dim fso, ts
Const ZumSchreiben = 2
Set fso = CreateObject("Scripting. FileSystemObject")
Set ts = fso.OpenTextFile("c:\test.txt", ZumSchreiben, True)
Zum Erstellen einer Textdatei mit dieser Methode unter JScript verwenden Sie diesen Code:

var fso, ts;
var ZumSchreiben= 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
ts = fso.OpenTextFile("c:\\test.txt", ZumSchreiben, true);
Eine dritte Möglichkeit ist die Verwendung der OpenAsTextStream-Methode mit gesetztem ForWriting-Attribut. Verwenden Sie in VBScript für diese Methode den folgenden Code:

Dim fso, f1, ts
Const ZumSchreiben = 2
Set fso = CreateObject("Scripting.FileSystemObject")
fso.CreateTextFile ("c:\test1.txt")
Set f1 = fso.GetFile("c:\test1.txt")
Set ts = f1.OpenAsTextStream(ZumSchreiben, True)
Verwenden Sie in JScript den Code des folgenden Beispiels:

var fso, f1, ts;
var ZumSchreiben = 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CreateTextFile ("c:\\test1.txt");
f1 = fso.GetFile("c:\\test1.txt");
ts = f1.OpenAsTextStream(ZumSchreiben, true);
Hinzufügen von Daten in eine Datei
Nachdem Sie eine Textdatei erstellt haben, fügen Sie entsprechend der folgenden drei Schritte Daten ein:

  1. Öffnen Sie die Textdatei.
  2. Schreiben Sie die Daten.
  3. Schließen Sie die Datei.
Verwenden Sie zum Öffnen einer vorhandenen Datei entweder die OpenTextFile-Methode des FileSystemObject-Objekts oder die OpenAsTextStream-Methode des File-Objekts.

Verwenden Sie zum Schreiben von Daten in eine geöffnete Textdatei die Write-, WriteLine- oder die WriteBlankLines-Methode des TextStream-Objekts, je nach der entsprechenden, in der folgenden Tabelle aufgeführten, Aufgabe.

Aufgabe | Methode
Schreibt Daten in eine geöffnete Textdatei ohne nachstehendes Zeilenumbruchzeichen. | Write
Schreibt Daten in eine geöffnete Textdatei mit nachstehendem Zeilenumbruchzeichen. | WriteLine
Schreibt eine oder mehrere Leerzeilen in eine geöffnete Textdatei. | WriteBlankLines

Praktische Beispiele zur Verwendung der Write-, WriteLine- und WriteBlankLines-Methoden mit FileSystemObject finden Sie unter Beispielcode.

Verwenden Sie zum Schließen einer geöffneten Datei die Close-Methode des TextStream-Objekts.

Praktische Beispiele zur Verwendung der Close-Methode mit FileSystemObject finden Sie unter Beispielcode.

Hinweis Das Zeilenumbruchzeichen enthält ein oder mehrere Zeichen (je nach Betriebssystem), die die Einfügemarke am Beginn einer neuen Zeile positionieren (Wagenrücklauf/Zeilenvorschub). Achten Sie darauf, dass einige Zeichenfolgen diese nicht darstellbaren Zeichen bereits aufweisen.

Das folgende VBScript-Beispiel zeigt, wie eine Datei geöffnet wird, die drei Schreibmethoden zum Hinzufügen von Daten verwendet werden und die Datei anschließend geschlossen wird:

Sub ErstelleDatei()
  Dim fso, tf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set tf = fso.CreateTextFile("c:\testdatei.txt", True)
  ' Schreibt eine Zeile mit einem Zeilenumbruchzeichen.
  tf.writeLine("Test 1, 2, 3.")
  ' Schreibt drei Zeilenumbruchzeichen in die Datei.
  tf.writeBlankLines(3)
  ' Schreibt eine Zeile.
  tf.write ("Dies ist ein Test.")
  tf.Close
End Sub
Dieses Beispiel zeigt die Verwendung dieser drei Methoden in JScript:

function ErstelleDatei()
{
  var fso, tf; fso = new ActiveXObject("Scripting.FileSystemObject");
  tf = fso.CreateTextFile("c:\\testdatei.txt", true); // Schreibt eine Zeile mit einem Zeilenumbruchzeichen.
  tf.writeLine("Test 1, 2, 3.") ; // Schreibt drei Zeilenumbruchzeichen in die Datei.
  tf.writeBlankLines(3) ; // Schreibt eine Zeile.
  tf.write ("Dies ist ein Test."); tf.Close();
}
Lesen von Dateien
Verwenden Sie zum Lesen von Daten in einer Textdatei die Read-, ReadLine- oder ReadAll-Methode des TextStream-Objekts. Die folgende Tabelle erläutert die für die verschiedenen Aufgaben einzusetzenden Methoden.

Aufgabe | Methode
Liest eine bestimmte Zeichenanzahl aus einer Datei. | Read
Liest eine vollständige Zeile (bis zum Zeilenumbruchzeichen, aber nicht einschließlich des Zeichens). | ReadLine
Liest den gesamten Inhalt einer Textdatei. | ReadAll

Praktische Beispiele zur Verwendung der ReadAll- und ReadLine-Methoden mit FileSystemObject finden Sie unter Beispielcode.

Wenn Sie die Read- oder ReadLine-Methode verwenden und einen bestimmten Datenbereich überspringen möchten, verwenden Sie die Skip- oder SkipLine-Methode. Der resultierende Text dieser Lesemethoden wird in einer Zeichenfolge gespeichert, die dann z. B. in einem Steuerelement angezeigt, nach Zeichenfolgenfunktionen analysiert (z. B. Left, Right und Mid) oder verkettet werden kann.

Das folgende VBScript-Beispiel zeigt das Öffnen einer Datei, das Schreiben sowie das Lesen aus dieser:

Sub LeseDateien
  Dim fso, f1, ts, s
  Const ZumLesen = 1
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testdatei.txt", True)
  Response.write "Schreibvorgang in Datei <br>"
  ' Schreibt eine Zeile.
  f1.writeLine "Hallo Welt"
  f1.writeBlankLines(1)
  f1.Close
  ' Liest den Inhalt der Datei.
  Response.write "Lesevorgang aus Datei <br>"
  Set ts = fso.OpenTextFile("c:\testdatei.txt", ZumLesen)
  s = ts.ReadLine
  Response.write "Dateiinhalt = '" & s & "'"
  ts.Close
End Sub
Dieser Code zeigt die gleichen Vorgänge in JScript:

function ReadFiles()
{
  var fso, f1, ts, s;
  var ZumLesen = 1;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testdatei.txt", true);
  Response.write("Schreibvorgang in Datei <br>");
  // Schreibt eine Zeile.
  f1.writeLine("Hallo Welt");
  f1.writeBlankLines(1); f1.Close();
  Response.write("Lesevorgang aus Datei <br>");
  ts = fso.OpenTextFile("c:\\testdatei.txt", ZumLesen);
  // Liest den Inhalt der Datei.
  s = ts.ReadLine();
  Response.write("Dateiinhalt = '" + s + "'"); ts.Close();
}
Verschieben, Kopieren und Löschen von Dateien
Das FSO-Objektmodell verfügt - wie in der Tabelle nachstehend beschrieben - über jeweils zwei Methoden zum Verschieben, Kopieren und Löschen von Dateien.

Aufgabe | Methode
Verschiebt eine Datei | File.Move oder FileSystemObject.MoveFile
Kopiert eine Datei | File.Copy oder FileSystemObject.CopyFile
Löscht eine Datei | File.Delete oder FileSystemObject.DeleteFile

Die beiden Möglichkeiten zum Löschen einer Datei mit FileSystemObject finden Sie unter Beispielcode.

Das folgende VBScript-Beispiel erstellt eine Textdatei im Hauptordner von Laufwerk C:, schreibt Daten in die Datei, verschiebt diese anschließend in das Verzeichnis \tmp, erstellt eine Kopie im Verzeichnis \temp und löscht dann die Kopien in beiden Verzeichnissen.

Erstellen Sie im Hauptordner von Laufwerk C: die beiden Verzeichnisse \tmp und \temp, um das folgende Beispiel ausführen zu können:

Sub ManipDateien
 Dim fso, f1, f2, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testdatei.txt", True)
  Response.write "Schreibvorgang in Datei <br>"
  ' Schreibt eine Zeile.
  f1.write ("Dies ist ein Test.")
  ' Schließt die Datei für Schreibvorgang.
  f1.Close
  Response.write "Datei verschieben nach c:\tmp <br>"
  ' Erstellt einen Zeiger auf die Datei im Hauptordner von C:\.
  Set f2 = fso.GetFile("c:\testdatei.txt")
  ' Verschiebt die Datei in das \tmp-Verzeichnis.
  f2.Move ("c:\tmp\testdatei.txt")
  Response.write "Datei kopieren nach c:\temp <br>"
  ' Kopiert die Datei nach \temp.
  f2.Copy ("c:\temp\testdatei.txt")
  Response.write "Löschen von Dateien <br>"
  ' Erstellt Zeiger zum aktuellen Speicherort der Dateien.
  Set f2 = fso.GetFile("c:\tmp\testdatei.txt")
  Set f3 = fso.GetFile("c:\temp\testdatei.txt")
  ' Löscht diese Dateien.
  f2.Delete
  f3.Delete
  Response.write "Ich habe fertig!"
End Sub
Dieser Code zeigt die gleichen Vorgänge in JScript:

function ManipDateien()
{
  var fso, f1, f2, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testdatei.txt", true);
  Response.write("Schreibvorgang in Datei <br>");
  // Schreibt eine Zeile.
  f1.write("Dies ist ein Test.");
  // Schließt die Datei für Schreibvorgang.
  f1.Close();
  Response.write("Datei verschieben nach c:\\tmp <br>");
  // Erstellt einen Zeiger auf die Datei im Hauptordner von C:\.
  f2 = fso.GetFile("c:\\testdatei.txt");
  // Verschiebt die Datei in das \tmp-Verzeichnis.
  f2.Move ("c:\\tmp\\testdatei.txt");
 Response.write(""Datei kopieren nach c:\\temp <br>");
  // Kopiert die Datei nach \temp.
  f2.Copy ("c:\\temp\\testdatei.txt");
  Response.write("Löschen von Dateien <br>");
  // Erstellt Zeiger zum aktuellen Speicherort der Dateien.
  f2 = fso.GetFile("c:\\tmp\\testdatei.txt");
  f3 = fso.GetFile("c:\\temp\\testdatei.txt");
  // Löscht diese Dateien.
  f2.Delete();
  f3.Delete();
  Response.write("Ich habe fertig!");
}


FileSystemObject-Beispielcode

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-
Beispielcode
 Zurück

Der in diesem Abschnitt beschriebene Beispielcode stellt ein reales Beispiel dar, das der Veranschaulichung zahlreicher im FileSystemObject-Objektmodell verfügbaren Funktionsmerkmale dient. Dieser Code zeigt das Zusammenwirken aller Funktionen des Objektmodells und soll Ihnen den effektiven Einsatz in Ihrem eigenen Code verständlich darlegen.

Beachten Sie, dass dieser Code recht allgemein gehalten ist, zusätzlicher Code benötigt und hier und da etwas "geschraubt" werden müsste, um ihn tatsächlich auf Ihrem Computer ausführen zu können. Diese Änderungen sind auf Grund der unterschiedlichen Möglichkeiten notwendig, die beim Zusammenwirken zwischen Active Server Pages und Windows Scripting Host für die Ein- und Ausgabe zum Benutzer verwendet werden.

Gehen Sie folgendermaßen vor, um diesen Code auf einer Active Server Page auszuführen:

  1. Erstellen Sie eine herkömmliche Webseite mit der Dateinamenerweiterung .asp.
  2. Kopieren Sie den nachstehenden Beispielcode in diese Datei zwischen die <BODY>...</BODY>-Tags.
  3. Schließen Sie den gesamten Code in <%...%>-Tags ein.
  4. Verschieben Sie die Option Explicit-Anweisung von der aktuellen Codeposition ganz nach oben an den HTML-Seitenanfang vor das eröffnende <HTML>-Tag.
  5. Setzen Sie <%...%>-Tags um die Option Explicit-Anweisung, um sicherzustellen, dass sie serverseitig ausgeführt wird.
  6. Fügen Sie den nachstehenden Code an das untere Ende des Beispielcodes:
Sub Drucke(x)
  Response.write "<PRE><FONT FACE=""Courier New"" SIZE=""1"">"
  Response.write x Response.write "</FONT></PRE>"
End Sub
Main
Der Code weiter oben fügt eine Ausgabeprozedur hinzu, die zwar serverseitig ausgeführt, deren Ergebnisse jedoch clientseitig angezeigt werden. Fügen Sie den folgenden Code am Ende des Beispielcodes ein, um diesen auf dem Windows Scripting Host auszuführen:
Sub Drucke(x)
    WScript.Echo x
End Sub
Main
Der Code ist im nachstehenden Abschnitt enthalten:

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' FileSystemObject-Beispielcode
'
' Copyright 1998 Microsoft Corporation. Alle Rechte vorbehalten.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Option Explicit

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Informationen zur Codequalität:
'
' 1) Der folgende Code führt zahlreiche Zeichenfolgeänderungen
'    durch, indem kurze Zeichenfolgen mit & (Operator) verkettet
'    werden. Da diese Verkettung jedoch aufwändig ist, handelt es sich
'    um eine sehr ineffiziente Lösung zum Schreiben von Code.
'    Andererseits kann ein derartiger Code sehr gut gepflegt werden; er
'    wird hier verwendet, da dieses Programm zahlreiche Festplatten-
'    vorgänge durchführt und die Festplatte sehr viel langsamer
'    arbeitet als die für die Verkettung von Zeichenfolgen
'    notwendigen Speichervorgänge. Beachten Sie, dass es sich um einen
'    Beispiel- und nicht um tatsächlichen Produktcode handelt.
'
' 2) Option Explicit wird verwendet, da der Zugriff auf deklarierte
'    Variablen schneller als der auf nicht deklarierte ist. Darüber
'    hinaus wird verhindert, dass sich Fehler in den Code einschleichen,
'    wie z. B. Rechtschreibfehler (DriveTypeCDORM an Stelle von
'    DriveTypeCDROM).
'
' 3) Fehlerbehandlungsmethoden wurde nicht integriert, um diesen Code
'    lesbarer zu gestalten. Es wurden zwar Vorkehrungen getroffen, dass
'    in allgemeinen Fällen keine Fehler auftreten, jedoch ist dies je
'    nach verwendetem Dateisystemen unterschiedlich. Verwenden Sie in
'    Ihrem Produktcode On Error Resume Next sowie das Error-Objekt,
'    um mögliche Fehler aufzufangen.

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Einige hilfreiche globale Variablen
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Dim TabStop
Dim NewLine

Const TestDrive = "C"
Const TestFilePath = "C:\Test"

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Von Drive.DriveType zurückgegebene Konstanten
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const DriveTypeRemovable = 1
Const DriveTypeFixed = 2
Const DriveTypeNetwork = 3
Const DriveTypeCDROM = 4
Const DriveTypeRAMDisk = 5

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Von File.Attributes zurückgegebene Konstanten
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const FileAttrNormal  = 0
Const FileAttrReadOnly = 1
Const FileAttrHidden = 2
Const FileAttrSystem = 4
Const FileAttrVolume = 8
Const FileAttrDirectory = 16
Const FileAttrArchive = 32
Const FileAttrAlias = 64
Const FileAttrCompressed = 128

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Konstanten zum Öffnen von Dateien
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const OpenFileForReading = 1
Const OpenFileForWriting = 2
Const OpenFileForAppending = 8

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowDriveType
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den Laufwerkstyp eines angegebenen
' Drive-Objekts beschreibt.
'
' Zeigt Folgendes
'
' - Drive.DriveType
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowDriveType(Drive)

    Dim S 	Select Case Drive.DriveType
    Case DriveTypeRemovable
        S = "Wechselmedium"
    Case DriveTypeFixed
        S = "Fest"
    Case DriveTypeNetwork
        S = "Netzwerk"
    Case DriveTypeCDROM
        S = "CD-ROM"
    Case DriveTypeRAMDisk
        S = "RAM-Laufwerk"
    Case Else
        S = "Unbekannt"
    End Select

    ShowDriveType = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowFileAttr
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die Datei- oder Ordnerattribute
' beschreibt.
'
' Zeigt Folgendes
'
' - File.Attributes
' - Folder.Attributes
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowFileAttr(File) ' File kann Datei oder Ordner sein

    Dim S 	Dim Attr

    Attr = File.Attributes

    If Attr = 0 Then
        ShowFileAttr = "Normal"
        Exit Function
    End If

    If Attr And FileAttrDirectory  Then S = S & "Verzeichnis "
    If Attr And FileAttrReadOnly   Then S = S & "Schreibgeschützt"
    If Attr And FileAttrHidden     Then S = S & "Versteckt"
    If Attr And FileAttrSystem     Then S = S & "System"
    If Attr And FileAttrVolume     Then S = S & "Datenträger"
    If Attr And FileAttrArchive    Then S = S & "Archiv"
    If Attr And FileAttrAlias      Then S = S & "Alias"
    If Attr And FileAttrCompressed Then S = S & "Komprimiert"

    ShowFileAttr = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateDriveInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status der verfügbaren
' Laufwerke beschreibt.
'
' Zeigt Folgendes
'
' - FileSystemObject.Drives
' - Iteration der Drives-Auflistung
' - Drives.Count
' - Drive.AvailableSpace
' - Drive.DriveLetter
' - Drive.DriveType
' - Drive.FileSystem
' - Drive.FreeSpace
' - Drive.IsReady
' - Drive.Path
' - Drive.SerialNumber
' - Drive.ShareName
' - Drive.TotalSize
' - Drive.VolumeName
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateDriveInformation(FSO)

    Dim Drives
    Dim Drive
    Dim S

    Set Drives = FSO.Drives

    S = "Anzahl der Laufwerke:" & TabStop & Drives.Count & NewLine & NewLine

    ' Erstellt die erste Zeile des Berichts.
    S = S & String(2, TabStop) & "Laufwerk"
    S = S & String(3, TabStop) & "Datei"
    S = S & TabStop & "Gesamter"
    S = S & TabStop & "Freier"
    S = S & TabStop & "Verfügbarer"
    S = S & TabStop & "Seriennummer" & NewLine

    ' Erstellt die zweite Zeile des Berichts.
    S = S & "Laufwerkbuchstabe"
    S = S & TabStop & "Pfad"
    S = S & TabStop & "Typ"
    S = S & TabStop & "Bereit ?"
    S = S & TabStop & "Name"
    S = S & TabStop & "System"
    S = S & TabStop & "Speicherplatz"
    S = S & TabStop & "Speicherplatz"
    S = S & TabStop & "Speicherplatz"
    S = S & TabStop & "Nummer" & NewLine

    ' Trennlinie.
    S = S & String(105, "-") & NewLine

    For Each Drive In Drives

        S = S & Drive.DriveLetter
        S = S & TabStop & Drive.Path
        S = S & TabStop & ShowDriveType(Drive)
        S = S & TabStop & Drive.IsReady

        If Drive.IsReady Then 		If DriveTypeNetwork = Drive.DriveType Then
                S = S & TabStop & Drive.ShareName
            Else
                S = S & TabStop & Drive.VolumeName
            End If

            S = S & TabStop & Drive.FileSystem
            S = S & TabStop & Drive.TotalSize
            S = S & TabStop & Drive.FreeSpace
            S = S & TabStop & Drive.AvailableSpace
            S = S & TabStop & Hex(Drive.SerialNumber)

        End If

        S = S & NewLine

    Next

    GenerateDriveInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFileInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status einer Datei
' beschreibt.
'
' Zeigt Folgendes
'
' - File.Path
' - File.Name
' - File.Type
' - File.DateCreated
' - File.DateLastAccessed
' - File.DateLastModified
' - File.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFileInformation(File)

    Dim S

    S = NewLine & "Pfad:" & TabStop & File.Path
    S = S & NewLine & "Name:" & TabStop & File.Name
    S = S & NewLine & "Typ:" & TabStop & File.Type
    S = S & NewLine & "Attribute:" & TabStop & ShowFileAttr(File)
    S = S & NewLine & "Erstellt:" & TabStop & File.DateCreated
    S = S & NewLine & "Letzter Zugriff:" & TabStop & File.DateLastAccessed
    S = S & NewLine & "Letzte Änderung:" & TabStop & File.DateLastModified
    S = S & NewLine & "Größe" & TabStop & File.Size & NewLine

    GenerateFileInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFolderInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status eines Ordners
' beschreibt.
'
' Zeigt Folgendes
'
' - Folder.Path
' - Folder.Name
' - Folder.DateCreated
' - Folder.DateLastAccessed
' - Folder.DateLastModified
' - Folder.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFolderInformation(Folder)

    Dim S

    S = "Pfad:" & TabStop & Folder.Path
    S = S & NewLine & "Name:" & TabStop & Folder.Name
    S = S & NewLine & "Attribute:" & TabStop & ShowFileAttr(Folder)
    S = S & NewLine & "Erstellt:" & TabStop & Folder.DateCreated
    S = S & NewLine & "Letzter Zugriff:" & TabStop & Folder.DateLastAccessed
    S = S & NewLine & "Letzte Änderung:" & TabStop & Folder.DateLastModified
    S = S & NewLine & "Größe:" & TabStop & Folder.Size & NewLine

    GenerateFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateAllFolderInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status eines Ordners mit
' allen Dateien und Unterordnern beschreibt.
'
' Zeigt Folgendes
'
' - Folder.Path
' - Folder.SubFolders
' - Folders.Count
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateAllFolderInformation(Folder)

    Dim S
    Dim SubFolders
    Dim SubFolder
    Dim Files
    Dim File

    S = "Ordner:" & TabStop & Folder.Path & NewLine & NewLine

    Set Files = Folder.Files

    If 1 = Files.Count Then
        S = S & "Es ist 1 Datei vorhanden" & NewLine
    Else
        S = S & "Es sind " & Files.Count & "Dateien vorhanden" & NewLine
    End If

    If Files.Count <> 0 Then

        For Each File In Files
            S = S & GenerateFileInformation(File)
        Next

    End If

    Set SubFolders = Folder.SubFolders

    If 1 = SubFolders.Count Then
        S = S & NewLine & "Es ist 1 Unterordner vorhanden" & NewLine & NewLine
    Else
        S = S & NewLine & "Es sind" & SubFolders.Count & "Unterordner vorhanden" & NewLine & NewLine
    End If

    If SubFolders.Count <> 0 Then

        For Each SubFolder In SubFolders
            S = S & GenerateFolderInformation(SubFolder)
        Next

        S = S & NewLine

        For Each SubFolder In SubFolders
            S = S & GenerateAllFolderInformation(SubFolder)
        Next

    End If

    GenerateAllFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateTestInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status des Ordners
' C:\Test mit allen Dateien und Unterordnern beschreibt.
'
' Zeigt Folgendes
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.GetFolder
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateTestInformation(FSO)

    Dim TestFolder
    Dim S

    If Not FSO.DriveExists(TestDrive) Then Exit Function
    If Not FSO.FolderExists(TestFilePath) Then Exit Function

    Set TestFolder = FSO.GetFolder(TestFilePath)

    GenerateTestInformation = GenerateAllFolderInformation(TestFolder)

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' DeleteTestDirectory
'
' Zweck:
'
' Bereinigt das Testverzeichnis.
'
' Zeigt Folgendes
'
' - FileSystemObject.GetFolder
' - FileSystemObject.DeleteFile
' - FileSystemObject.DeleteFolder
' - Folder.Delete
' - File.Delete
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub DeleteTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolder
    Dim File

    ' Zwei Möglichkeiten, eine Datei zu löschen:

    FSO.DeleteFile(TestFilePath & "\Phish\BathtubGin.txt")

    Set File = FSO.GetFile(TestFilePath & "\Phish\LawnBoy.txt")
    File.Delete

    ' Zwei Möglichkeiten, einen Ordner zu löschen:

    FSO.DeleteFolder(TestFilePath & "\Phish")

    FSO.DeleteFile(TestFilePath & "\Liesmich.txt")

    Set TestFolder = FSO.GetFolder(TestFilePath)
    TestFolder.Delete

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' CreateLyrics
'
' Zweck:
'
' Erstellt mehrere Textdateien in einem Ordner.
'
'
' Zeigt Folgendes
'
' - FileSystemObject.CreateTextFile
' - TextStream.writeLine
' - TextStream.write
' - TextStream.writeBlankLines
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub CreateLyrics(Folder)

    Dim TextStream

    Set TextStream = Folder.CreateTextFile("BathtubGin.txt")

    TextStream.write("Bathtub Gin ") ' Beachten Sie, dass in der Datei kein Zeilenvorschub hinzugefügt wird.
    TextStream.writeLine("(von Trey Anastasio)")
    TextStream.writeBlankLines(1)
    TextStream.writeLine("Here comes the joker with his silly grin,")
    TextStream.writeLine("He carries a martini made of bathtub gin.")
    TextStream.writeBlankLines(2)

    TextStream.Close

    Set TextStream = Folder.CreateTextFile("LawnBoy.txt")
    TextStream.writeLine("Lawn Boy (von Anastasio/Marshall)")
    TextStream.writeLine("")
    TextStream.writeLine("Throughout the night when there's no direct light")
    TextStream.writeLine("And a thin veil of clouds keeps the stars out of sight")
    TextStream.writeBlankLines(2)
    TextStream.Close

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GetLyrics
'
' Zweck:
'
' Blendet den Inhalt der Liedtexte ein.
'
'
' Zeigt Folgendes
'
' - FileSystemObject.OpenTextFile
' - FileSystemObject.GetFile
' - TextStream.ReadAll
' - TextStream.Close
' - File.OpenAsTextStream
' - TextStream.AtEndOfStream
' - TextStream.ReadLine
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GetLyrics(FSO)

    Dim TextStream
    Dim S
    Dim File

    ' Es gibt verschiedene Möglichkeiten, eine Textdatei zu öffnen und die Daten dieser Datei zu lesen. 	' Hier sind zwei Möglichkeiten:

    Set TextStream = FSO.OpenTextFile(TestFilePath & "\Phish\BathtubGin.txt", OpenFileForReading)

    S = TextStream.ReadAll & NewLine & NewLine
    TextStream.Close

    Set File = FSO.GetFile(TestFilePath & "\Phish\LawnBoy.txt")
    Set TextStream = File.OpenAsTextStream(OpenFileForReading)
    Do 	While Not TextStream.AtEndOfStream
        S = S & TextStream.ReadLine & NewLine
    Loop
    TextStream.Close

    GetLyrics = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' BuildTestDirectory
'
' Zweck:
'
' Erstellt eine Verzeichnishierarchie, um FileSystemObject zu
' beschreiben.
'
' Die Hierarchie wird in dieser Reihenfolge erstellt:
'
' C:\Test
' C:\Test\Liesmich.txt
' C:\Test\Phish
' C:\Test\Phish\BathtubGin.txt
' C:\Test\Phish\LawnBoy.txt
'
'
' Zeigt Folgendes
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.CreateFolder
' - FileSystemObject.CreateTextFile
' - Folders.Add
' - Folder.CreateTextFile
' - TextStream.writeLine
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function BuildTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolders
    Dim SubFolder
    Dim TextStream

    ' Bricht ab, wenn (a) das Laufwerk nicht vorhanden oder (b) das zu erstellende Verzeichnis bereits vorhanden ist.

    If Not FSO.DriveExists(TestDrive) Then
        BuildTestDirectory = False
        Exit Function
    End If

    If FSO.FolderExists(TestFilePath) Then
        BuildTestDirectory = False
        Exit Function
    End If

    Set TestFolder = FSO.CreateFolder(TestFilePath)

    Set TextStream = FSO.CreateTextFile(TestFilePath & "\Liesmich.txt")
    TextStream.writeLine("Meine Liedtextsammlung")
    TextStream.Close

    Set SubFolders = TestFolder.SubFolders

    Set SubFolder = SubFolders.Add("Phish")

    CreateLyrics SubFolder

    BuildTestDirectory = True

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Die Hauptroutine
'
' Zunächst wird ein Testverzeichnis mit einigen Unterordnern und
' Dateien erstellt.
' Anschließend werden Informationen über die verfügbaren
' Festplattenlaufwerke sowie das Testverzeichnis erstellt und danach
' alles wieder entfernt.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub Main

    Dim FSO

    ' Einrichten globaler Daten.
    TabStop = Chr(9)
    NewLine = Chr(10)

    Set FSO = CreateObject("Scripting.FileSystemObject")

    If Not BuildTestDirectory(FSO) Then
        Drucke "Testverzeichnis kann nicht erstellt werden oder bereits vorhanden. Fortsetzung nicht möglich."
        Exit Sub
    End If

    Print GenerateDriveInformation(FSO) & NewLine & NewLine

    Print GenerateTestInformation(FSO) & NewLine & NewLine

    Print GetLyrics(FSO) & NewLine & NewLine

    DeleteTestDirectory(FSO)

End Sub


Integrierte Objekte

Integrierte Objekte
 JScript-Tutorium
Zurück

Microsoft JScript stellt neun integrierte ("eingebaute") Objekte zur Verfügung: Array, Boolean, Date, Function, Global, Math, Number, Object und String. Jedes dieser integrierten Objekte besitzt zugehörige Methoden und Eigenschaften, die im JScript-Sprachverzeichnis detailliert beschrieben werden. Einige dieser Objekte werden auch hier beschrieben.

Array-Objekt
Auf die Indizes eines Datenfeldes, welche dieselben Eigenschaften wie ein Objekt haben, kann mit einer Zahl (oder mit einem Namen, sofern Sie Namen zugewiesen haben) verwiesen werden. Sie erstellen ein neues Datenfeld, indem Sie die new-Anweisung und den Konstruktor Array() verwenden, wie im folgenden Beispiel.

var dieMonate = new Array(12)  {
dieMonate[0] = "Jan";
dieMonate[1] = "Feb";
dieMonate[2] = "Mär";
dieMonate[3] = "Apr";
dieMonate[4] = "Mai";
dieMonate[5] = "Jun";
dieMonate[6] = "Jul";
dieMonate[7] = "Aug";
dieMonate[8] = "Sep";
dieMonate[9] = "Okt";
dieMonate[10] = "Nov";
dieMonate[11] = "Dez";
}
Wenn Sie ein Datenfeld mit dem Schlüsselwort Array erstellen, fügt JScript eine length-Eigenschaft mit Nur-Schreibzugriff zu diesem Datenfeld hinzu. Diese Eigenschaft zeichnet die Anzahl der Einträge in das Datenfeld auf. Wenn Sie keine Zahl angeben, wird die Länge auf 0 gesetzt, und das Datenfeld besitzt keine Einträge. Wenn Sie eine Zahl angeben, werden entsprechend viele Elemente initialisiert. Wenn Sie mehr als einen Parameter angeben, werden diese als Einträge für das Datenfeld interpretiert, und die Anzahl der Parameter wird wie im folgenden Beispiel (welches äquivalent zum vorherigen Beispiel ist) der length-Eigenschaft zugewiesen.

var dieMonate = new Array("Jan", "Feb", "Mär", "Apr", "Mai", "Jun", "Jul", "Aug", "Sep", "Okt", "Nov", "Dez");
JScript ändert automatisch den Wert von length, wenn Sie Elemente zu einem Datenfeld hinzufügen, das mit dem Schlüsselwort Array erstellt wurde.

String-Objekt
In JScript sind Zeichenfolgen Objekte. Bei jeder Deklaration einer Zeichenfolgenvariablen oder Verwendung eines Zeichenfolgenliterals erstellen Sie eigentlich ein neues String-Objekt. Das String-Objekt besitzt bestimmte integrierte Methoden, die Sie für Ihre Zeichenfolgen verwenden können. Eine dieser Methoden ist die Substring-Methode, die einen Teil der Zeichenfolge zurückgibt. Sie erhält zwei Werte als Argumente.

eineZeichenfolge = "0123456789";
var einStueck = eineZeichenfolge.substring(4, 7);  // Setzt einStueck auf "456".
var anderesStueck = eineZeichenfolge.substring(7, 4);  // Setzt anderesStueck auf "456".

// Verwenden des vorherigen Beispiels zur Datenfelderstellung:
ersterBuchstabe = dieMonate[5].substring(0,1);  // Setzt die Variable ersterBuchstabe auf "J".
Eine weitere Eigenschaft des String-Objekts ist die length-Eigenschaft. Diese Eigenschaft enthält die Anzahl der Zeichen in einer Zeichenfolge, die bei einer leeren Zeichenfolge 0 ist. Dies ist ein numerischer Wert, der direkt in Berechnungen verwendet werden kann.
var wieLang = "Hallo Welt".length  // Setzt die Variable wieLang auf 10.
Math-Objekt
Das Math-Objekt unterstützt eine Reihe von vordefinierten Eigenschaften und Methoden. Die Eigenschaften sind bestimmte Zahlen. Eine dieser Eigenschaften ist der Wert von Pi (näherungsweise 3,14159...). Im folgenden Beispiel wird diese Eigenschaft (die Math.PI-Eigenschaft) gezeigt.
// Eine Radiusvariable ist bereits deklariert, und ein numerischer Wert zugewiesen.
var kreisFlaeche = Math.PI * radius * radius;
// Beachten Sie die Großschreibung von Math und PI.
Eine der integrierten Methoden des Math-Objekts ist die Potenzierungsmethode (oder pow), die eine Zahl in eine bestimmte Potenz erhebt. Das folgende Beispiel verwendet sowohl Pi als auch die Potenzierung.

// Diese Formel errechnet das Volumen bei einem gegebenen Radius.
volumen = (4/3)*(Math.PI*Math.pow(radius,3));
Date-Objekt
Verwenden Sie das Date-Objekt, um das heutige Datum abzufragen und um die Unterschiede zwischen Datumsangaben zu errechnen. Das Objekt unterstützt eine Reihe von vordefinierten Eigenschaften und Methoden. Im Allgemeinen stellt das Date-Objekt Wochentag, Monat, Tag und Jahr sowie die Zeit in Stunden, Minuten und Sekunden zur Verfügung. Diese Informationen basieren auf der Anzahl der Millisekunden seit dem 1. Januar 1970, 00:00:00.000 GMT. GMT steht für "Greenwich Mean Time"; der bevorzugte Begriff in diesem Zusammenhang ist UTC oder "Coordinated Universal Time", der sich auf Signale nach dem Weltzeitstandard bezieht.

Anmerkung In Bezug auf JScript beginnt die Zeit um Mitternacht am 1. Januar 1970. Sie können mit JScript kein Date-Objekt erstellen, das einen weiter in der Vergangenheit liegenden Zeitpunkt darstellt. Wenn Sie weiter in der Vergangenheit liegende Zeitpunkte benötigen, müssen Sie dafür eigenen Code schreiben.

Verwenden sie den new-Operator, um ein neues Date-Objekt zu erstellen. Das folgende Beispiel errechnet die Anzahl der vergangenen und noch verbleibenden Tage im aktuellen Jahr.

/*
Dieses Beispiel verwendet das Datenfeld der Monatsnamen, das bereits definiert wurde.
Die erste Anweisung weist das heutige Datum im Format "Tag Monat Datum 00:00:00 Jahr"
der Variablen dasIstHeute hinzu.
*/
var dasIstHeute = new Date();

var heute = new Date();  // Erhält das heutige Datum.

// Jahr, Monat und Tag abrufen.
var diesesJahr = heute.getYear() + 1900;
var dieserMonat = dieMonate[heute.getMonth()];
var dieserTag = heute.getDate() + " " + dieserMonat + "," + (parseInt(heute.getYear()) + 1900);

// Anzahl der bisher vergangenen Tage ermitteln.
dieserTag = Math.round(Date.parse(dieserTag)/8.64e7);

// Anzahl der bisher in diesem Jahr vergangenen Tage ermitteln.
var ersterTag = "1 Jan " + diesesJahr;
ersterTag = Math.floor(Date.parse(ersterTag)/8.64e7);

// Wiederholung für das Ende des Jahres, falls es ein Schaltjahr ist.
var letzterTag = "31 Dez " + diesesJahr;
letzterTag = Math.floor(Date.parse(letzterTag)/8.64e7);

// Anzahl der Tage im Jahr berechnen.
var tageImJahr = (letzterTag - ersterTag) + 1;

// Vergangene und verbleibenen Tage ermitteln.
var vergangeneTage = dieserTag - ersterTag;
var uebrigeTage = tageImJahr - vergangeneTage;

// Kommentare vorbereiten.
var kommentar1 = vergangeneTage + " Tage sind in diesem Jahr vergangen.";
var kommentar2 = "Daher bleiben noch " + uebrigeTage + " Tage im Jahr " + diesesJahr + " übrig.";

// Spezialfälle: Start und Ende des Jahres und einzelner Tag.
if (vergangeneTage == 0)  {
kommentar1 = "Es ist der 1. Januar " + diesesJahr + ".";
}
if (vergangeneTage == 1) {
kommentar1 = "Es ist nur ein Tag vergangen.";
}
if(vergangeneTage == tageImJahr) {
kommentar1 = diesesJahr + " ist fast vorbei.";
}

if (uebrigeTage == 0)  {
kommentar2 = "Alles Gute für das neue Jahr!";
}
if (uebrigeTage == 1)  {
kommentar2 = "Es verbleibt nur noch ein Tag im Jahr " + diesesJahr + ".";
}
if (uebrigeTage == tageImJahr)  {
kommentar2 = "Frohes neues Jahr!";
}
Number-Objekt
Zusätzlich zu den speziellen numerischen Eigenschaften (z. B. PI), die im Math-Objekt vorhanden sind, werden weitere Eigenschaften in Microsoft JScript durch das Number-Objekt bereitgestellt.

Eigenschaft | Beschreibung
MAX_VALUE Größte mögliche Zahl, ungefähr 1,79E+308; kann positiv oder negativ sein. (Der Wert variiert leicht von System zu System.)
MIN_VALUE | Kleinste mögliche Zahl, ungefähr 2,22E-308; kann positiv oder negativ sein. (Der Wert variiert leicht von System zu System.)
NaN | Spezieller nichtnumerischer Wert, "not a number".
POSITIVE_INFINITY Jeder positive Wert, der größer als Number.MAX_VALUE ist,
wird automatisch in diesen Wert konvertiert; repräsentiert als "Inf".
NEGATIVE_INFINITY Jeder negative Wert, der größer als -Number.MAX_VALUE ist,
wird automatisch in diesen Wert konvertiert; repräsentiert als "-Inf".

Number.NaN ist eine spezielle Eigenschaft, die als "not a number" definiert ist. Eine Division durch Null z. B. ergibt NaN. Der Versuch eine Zeichenfolge zu verarbeiten, die nicht als Zahl analysiert werden kann, ergibt ebenfalls Number.NaN. NaN ist ungleich zu jeder Zahl, auch zu sich selbst. Um auf ein NaN-Ergebnis zu testen, benutzen Sie nicht einen Vergleich mit Number.NaN; verwenden Sie stattdessen die isNaN()-Funktion.


Erstellen eigener Objekte

Erstellen eigener Objekte
 JScript-Tutorium
Zurück

Um Instanzen eines Objekts zu erstellen, müssen Sie dieses zuerst definieren, indem Sie ihm Eigenschaften und gegebenenfalls Methoden zuweisen. Das folgende Beispiel definiert beispielsweise ein Pasta-Objekt. Mit dem Schlüsselwort this verweisen Sie dabei auf das aktuelle Objekt.
function pasta( getreide, getreide2, breite, form, formnum, laenge, ei )
{
  this.length = 7;   // Anzahl der Eigenschaften in diesem Objekt (length ausgenommen).
  this.getreide = getreide;   // Herstellungsmaterial (Zeichenfolge)
  this.getreide2 = getreide2;   // Weitere Zutaten  (Zeichenfolge)
  this.breite = breite;     // Breite  (Zahl)
  this.form = form;   // Aussehen  (Zeichenfolge)
  this.formnum = formnum;  // Eine der "registrierten" Formen? (Zahl)
  this.laenge = laenge;    // Länge (Zahl)
  this.ei = ei;  // Wird Eigelb als Bindemittel verwendet? (Boolescher Wert)
}
Nachdem Sie ein Objekt definiert haben, erstellen Sie mit dem new-Operator zugehörige Instanzen.
var spaghetti = new pasta("Weizen", "", 0.2, "rund", 9, 30, true);
var linguini = new pasta("Weizen", "", 0.3, "oval", 17, 30, true);
Sie können Eigenschaften zu einer Instanz eines Objekts hinzufügen, um diese Instanz zu ändern. Jedoch werden diese Eigenschaften nicht Teil der Definition dieses Objekts, und sie erscheinen auch nicht in anderen Instanzen, es sei denn, Sie fügen diese explizit hinzu. Wenn Sie eine zusätzliche Eigenschaft in allen Instanzen eines Objekts anzeigen möchten, müssen Sie diese zur Objektdefinition hinzufügen.
// Zusätzliche Eigenschaften für spaghetti.
spaghetti.farbe = "strohgelb";
spaghetti.trockenkoch = 7;
spaghetti.frischkoch = 0.5;

var essSpass = new pasta("Reis", "", 3, "flach", , 12, false);
/*
Keine der Definitionen der Objekte essSpass, linguini und pasta
besitzt die drei zusätzlichen Eigenschaften des Objekts spaghetti
*/
Einfügen von Methoden in die Definition
Sie können Methoden in die Definition eines Objekts einfügen. Im folgenden Beispiel wird ein Objekt erstellt, das aus einem Datenfeld vom Typ String und einer Methode besteht. Die Methode fügt eine Zeichenfolge zum Datenfeld hinzu und vergrößert es dadurch. Beachten Sie, dass durch diese Vorgehensweise jede Instanz des Objekts unbegrenzt erweitert werden kann.
function elementHinzufuegen(neuesElement)  // Definiert eine Funktion, um die Liste zu vergrößern.
{
    this.length += 1;  // Vergrößert das Datenfeld um ein Element.
    this[(this.length-1)] = neuesElement;  // Fügt das neue Element hinzu, behält die Elementnummerierung bei.
}

function einkaufsliste(erstesElement) // Definiert das Objekt "einkaufsliste".
{
    this.length = 2;   // Anzahl der Eigenschaften in diesem Objekt (length ausgenommen).
    this.elementHinzufuegen = elementHinzufuegen;   // Schließt die Funktion elementHinzufuegen als Methode ein.
    this[(this.length-1)] = erstesElement;  // Das erste Element erhält die Nummer 1.
}

var meineListe = new einkaufsliste("Milch");
meineListe.elementHinzufuegen("Eier");  // Methode zum Hinzufügen von Eiern (wird zu Element 2).
meineListe.elementHinzufuegen("Brot");  // Brot wird Element 3.
Zu diesem Zeitpunkt enthält das Datenfeld folgende Elemente:
  • meineListe.length ist 4
  • meineListe.elementHinzufuegen ist die elementHinzufuegen-Funktion
  • meineListe[1] ist Milch
  • meineListe[2] ist Eier
  • meineListe[3] ist Brot
Beachten Sie, dass die Indizierung nicht exakt der von Ihnen erwarteten entspricht, wenn sie streng numerisch behandelt worden wäre. Wenn Sie eine for...in-Schleife auf dieses Datenfeld ausführen, durchläuft die Schleife die obige Reihenfolge, wobei die Schleifenvariable den Startwert "length" und nicht 0 aufweist.


FileSystemObject-Glossar

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-Glossar 		Referenz für die JScript-Laufzeitbibliothek

Auflistung
Ein Objekt, das eine Gruppe zusammengehöriger Objekte enthält. Die Position eines Objekts in der Auflistung kann sich bei Änderungen in der Auflistung ebenfalls ändern, weshalb die Position von allen Objekten in der Auflistung variieren kann.

Datenfeld
Eine Gruppe sequenziell indizierter Elemente, die denselben Datentyp enthalten. Jedes Element eines Datenfelds hat eine Indexnummer, die es eindeutig kennzeichnet. An einem Datenfeldelement vorgenommene Änderungen wirken sich nicht auf andere Elemente aus.

Laufzeitfehler
Ein Fehler, der beim Ausführen von Code auftritt. Laufzeitfehler treten auf, wenn eine Anweisung versucht, einen ungültigen Vorgang durchzuführen.

Typbibliothek
Eine Datei oder Komponente innerhalb einer anderen Datei, die Standardbeschreibungen verfügbarer Objekte, Eigenschaften sowie Methoden enthält.

Zeichenfolgenausdruck
Alle Ausdrücke, die zu einer Sequenz aufeinander folgender Zeichen führen. Elemente eines Zeichenfolgenausdrucks können eine Funktion enthalten, die eine Zeichenfolge, ein Literal, eine Konstante oder eine Variable zurückgeben.


JScript-Glossar

JScript-Glossar 		JScript-Sprachverzeichnis

ASCII-Zeichensatz
Ein dem ASCII (American Standard Code for Information Interchange)-Code entsprechender 7-Bit-Zeichensatz, der weit verbreitete Verwendung zum Darstellen der auf einer Standard-US-Tastatur vorhandenen Symbole gefunden hat. Der ASCII-Zeichensatz ist mit den ersten 128 Zeichen (0-127) des ANSI-Zeichensatzes identisch.

Ausdruck
Eine Kombination aus Schlüsselwörtern, Operatoren, Variablen und Konstanten, die eine Zeichenfolge, eine Zahl oder ein Objekt ergeben. Ein Ausdruck kann zum Ausführen einer Berechnung, zum Verändern von Zeichen oder zum Testen von Daten verwendet werden.

Automatisierungsobjekt
Ein Objekt, das für andere Anwendungen oder Programmierwerkzeuge über Automatisierungsschnittstellen sichtbar ist.

Benutzerdefiniertes Objekt
Ein vom Benutzer im Quellcode erstelltes Objekt.

Bitweiser Vergleich
Ein Bit-für-Bit-Vergleich der Bits an identischen Positionen in zwei numerischen Ausdrücken.

Boolescher Ausdruck
Ein Ausdruck, der als Ergebnis entweder True oder False haben kann. Nicht-Boolesche Ausdrücke werden gegebenenfalls zu Booleschen Werten nach den folgenden Regeln konvertiert:
  • Alle Objekte werden als True angenommen.
  • Zeichenfolgen sind ausschließlich dann False, wenn sie leer sind.
  • Null und undefined werden als False angenommen.
  • Zahlen werden dann und nur dann als False angesehen, wenn sie 0 sind.

Eigenschaft
Ein benanntes Attribut eines Objekts. Mit Eigenschaften werden Objektcharakteristika, wie z. B. Größe, Farbe und Bildschirmposition, oder der Status eines Objekts, wie z. B. aktiviert oder deaktiviert, definiert.

Elementar
Ein Datentyp, der Teil der JScript-Sprache ist und von einem Wert geändert wird. Datentypen, die in JScript als elementare Datentypen angesehen werden, sind Number, Boolean, String und Function. Object und Array zählen nicht zu den elementaren Datentypen.

Gebietsschema
Der Oberbegriff für die Informationen, die sprach- und landesspezifisch sind. Ein Gebietsschema hat Auswirkungen auf die Sprache der vordefinierten Programmierelemente und auf andere Einstellungen, die vom Gebietsschema abhängig sind. Das Gebietsschema ist in den folgenden beiden Bereichen von Bedeutung:
  • Das Code-Gebietsschema hat Auswirkungen auf die Sprache der Programmierelemente, z. B. die Schlüsselwörter, und definiert gebietsbezogene Einstellungen, z. B. Dezimal- und Listentrennzeichen, Datumsformate und Sortierreihenfolgen von Zeichen.
  • Das System-Gebietsschema hat Auswirkungen auf das Verhalten von gebietsbezogenen Funktionen, zum Beispiel bei der Anzeige von Zahlen oder der Konvertierung von Zeichenfolgen in Datumsangaben. Sie stellen das System-Gebietsschema mit Hilfe der Dienstprogramme in der Systemsteuerung des Betriebssystems ein.

Gültigkeitsbereich
Definiert die Sichtbarkeit von Variablen, Prozeduren oder Objekten. In Prozeduren deklarierte Variablen sind nur innerhalb der Prozedur sichtbar und verlieren zwischen den Aufrufen ihren Wert.

Integriertes Objekt
Ein Objekt, das Bestandteil der standardmäßigen JScript-Sprache ist. Diese Objekte sind für alle Skripte verfügbar. Die integrierten Objekte in JScript sind Array, Boolean, Date, Function, Global, Math, Number, Object, RegExp, Regular Expression sowie String.

Klasse
Die formale Definition eines Objekts. Die Klasse dient als Vorlage zum Erzeugen einer Instanz eines Objekts zur Laufzeit. In der Klasse werden die Eigenschaften eines Objekts und die zum Steuern des Verhaltens des Objekts verwendeten Methoden definiert.

Kommentar
Text, der vom Programmierer in den Code eingefügt wird, um die Funktionsweise des Codes zu erläutern. In JScript beginnt eine Kommentarzeile im Allgemeinen mit einem doppelten Schrägstrich (//). Verwenden Sie /* und */, um mehrzeilige Kommentare zu erstellen.

Konstruktor
Eine JScript-Funktion mit zwei speziellen Funktionsmerkmalen:
  • Wird durch den Operator new aufgerufen.
  • Durch das Schlüsselwort this wird die Adresse eines neu erstellten Objekts übergeben.
Verwenden Sie Konstruktoren, um neue Objekte zu initialisieren.

Koordinierte Weltzeit (Universal Coordinated Time=UTC)
Die koordinierte Weltzeit stellt eine festgelegte Standardweltzeit dar. Früher als Greenwich Mean Time (GMT) bekannt.

Laufzeitfehler
Ein Fehler, der beim Ausführen von Code auftritt. Laufzeitfehler treten auf, wenn eine Anweisung versucht, einen ungültigen Vorgang durchzuführen.

Mantelobjekt
Ein Objekt, das angelegt wird, um eine objektähnliche Schnittstelle für andere Datentypen bereitzustellen. Die Objekte Number und Boolean sind Beispiele für Mantelobjekte.

Null
Ein Wert, der anzeigt, dass eine Variable keine gültigen Daten enthält. Null ist das Ergebnis von:
  • Einer expliziten Zuweisung von null zu einer Variablen.
  • Jeder Operation zwischen Ausdrücken, die null enthalten.

Numerischer Ausdruck
Jeder Ausdruck, der als eine Zahl angesehen werden kann. Elemente des Ausdrucks können beliebige Kombinationen aus Schlüsselwörtern, Variablen, Konstanten und Operatoren sein, die als Ergebnis eine Zahl haben. Unter bestimmten Umständen können Zeichenfolgen in Zahlen konvertiert werden, sofern dies möglich ist.

Ortszeit
Die Zeit auf einem Computer, entweder einem Client oder einem Server, auf dem ein Skript ausgeführt wird.

undefined
Ein besonderer Wert, der einer Variablen automatisch nach dem Anlegen zugewiesen worden ist, aber bevor ihr ein Wert zugewiesen wird.

Variable
Eine Position, die für das Speichern und Ändern von benannten Werten verwendet wird. Da JScript eine wenig restriktive Sprache ist, kann eine einzige Variable verschiedene Datentypen im gesamten Skript enthalten.

Verbundanweisung
Mehrere Anweisungen, die in geschweiften Klammern ({}) eingeschlossen sind. Diese kann verwendet werden, um mehrere Tasks dann durchzuführen, wenn eine Einzelanweisung erwartet wird.

Vergleichsoperator
Ein Zeichen oder Symbol zum Anzeigen einer Beziehung zwischen zwei oder mehr Werten oder Ausdrücken. Zu diesen Operatoren zählen: kleiner als (<), kleiner gleich (<=), größer als (>), größer gleich (>=), ungleich (!=) sowie gleich (==).

Zeichencode
Eine Zahl, die ein bestimmtes Zeichen eines Zeichensatzes, wie z. B. des ASCII-Zeichensatzes, darstellt.

Zeichenfolgenvergleich
Ein Vergleich von zwei Zeichenfolgen. Alle Zeichenfolgenvergleiche erfolgen binär, sofern in der Funktion, die den Vergleich durchführt, nichts anderes angegeben wird. Für Deutsch wird bei binären Vergleichen zwischen Groß- und Kleinschreibung unterschieden, bei Textvergleichen nicht.


Verhalten der Operatoren

Verhalten der Operatoren 		JScript-Sprachverzeichnis
Version 1

In der folgenden Tabelle wird das Verhalten der meisten Microsoft JScript-Operatoren beschrieben. Die Spalten und Reihen stellen die unterschiedlichen Arten von möglichen Ausdrücken auf beiden Seiten eines Operators in JScript dar; die Einträge in der Tabelle beschreiben das Verhalten.

Dabei zeigt ein E einen Laufzeitfehler an. Ein N zeigt ein numerisches oder im Falle von logischen Operatoren ein Boolesches Ergebnis an.

obj | As | Ns | Num | Bool | Undef | Null
obj | N | E | N | N | N | E | E
As | E | E | E | E | E | E | E
Ns | N | E | N | N | N | E | E
Num | N | E | N | N | N | E | E
Bool | N | E | N | N | N | E | E
Undef | E | E | E | E | E | E | E
Null | E | E | E | E | E | E | E

obj = Object, as = alphanumerische Zeichenfolge, ns = numerische Zeichenfolge, num = Zahl, bool = Boolean, undef = undefined, null = Wert Null.


concat-Methode (Array)

concat-Methode (Array) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Array-Objekt zurück, das aus zwei aneinander gehängten Array-Objekten besteht.
Syntax
Datenfeld1.concat(Datenfeld2)

Die Syntax der concat-Methode hat folgende Komponenten:

Komponente | Beschreibung
Datenfeld1 | Erforderlich. Ein Array-Objekt zum Verketten mit Datenfeld2.
Datenfeld2 | Erforderlich. Ein Array-Objekt zum Verketten mit dem Ende von Datenfeld1.

Anmerkungen
Die concat-Methode gibt ein Array-Objekt zurück, das die Verkettung von Datenfeld1 und Datenfeld2 enthält.

Falls ein Objektverweis aus Datenfeld1 oder Datenfeld2 in das Ergebnis kopiert wird, zeigt der Objektverweis des Ergebnisses immer noch auf dasselbe Objekt. Änderungen an diesem Objekt werden in beiden Datenfeldern wiedergegeben.

Das folgende Beispiel zeigt die Verwendung der concat-Methode:

function ConcatArrayDemo()
{
  var a, b, c;
  a = new Array(0,1,2,3,4);
  b = new Array(5,6,7,8,9);
  c = a.concat(b);
  return(c);
}


concat-Methode (Array)

Microsoft® JScrip®
concat-Methode (Array)
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
String-Objekt


concat-Methode (Array)

concat-Methode (Array)
Siehe auch 		JScript-Sprachverzeichnis

concat-Methode (String)
join-Methode


join-Methode

join-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein String-Objekt zurück, das aus allen verketteten Elementen eines Datenfelds besteht.
Syntax

Datenfeldobj.join(Begrenzungszeichen)

Bei dem Argument Begrenzungszeichen handelt es sich um ein String-Objekt, das zur Begrenzung eines Datenfeldelements von dem nächsten in dem entstehenden String-Objekt verwendet wird. Bei einer Auslassung werden die Datenfeldelemente durch eine leere Zeichenfolge getrennt.

Anmerkungen
Die join-Methode liefert ein String-Objekt, in dem jedes Element in eine Zeichenfolge konvertiert und mit den anderen Elementen verkettet wird.

Das folgende Beispiel zeigt die Verwendung der join-Methode:

function JoinDemo()
{
  var a, b;
  a = new Array(0,1,2,3,4);
  b = a.join("-");
  return(b);
}


join-Methode

join-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt


join-Methode

join-Methode
Siehe auch 		JScript-Sprachverzeichnis

Array-Objektmethoden
String-Objekt


length-Eigenschaft (Array)

length-Eigenschaft (Array) 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Bestimmt einen ganzzahligen Wert, der um eins höher ist als das höchste in einem Datenfeld definierte Element.
Syntax

NumVar = DatenfeldObj.length

Anmerkungen
Da die Elemente in einem Datenfeld nicht zusammenhängend sein müssen, stellt die length-Eigenschaft nicht unbedingt die Anzahl der Elemente in dem jeweiligen Datenfeld dar. So enthält beispielsweise nach der folgenden Datenfelddefinition mein_datenfeld.length den Wert 7 und nicht den Wert 2:
var mein_Datenfeld = new Array( );
mein_datenfeld[0] = "Test";
mein_datenfeld[6] = "weiterer Test";
Wird ein Wert, der kleiner ist als der bestehende, der length-Eigenschaft zugewiesen, so wird das Datenfeld abgeschnitten, und jedes Element mit einem Index, der größer oder gleich dem neuen Wert der length-Eigenschaft ist, geht verloren.

Wird ein höherer Wert als der bestehende der length-Eigenschaft zugewiesen, so wird das Datenfeld erweitert, und jedes neu erzeugte Element hat den Wert undefined.

Das folgende Beispiel zeigt die Verwendung der length-Eigenschaft:

function LengthDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.length;
  return(l);
}


length-Eigenschaft (Array)

length-Eigenschaft (Array)
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt


length-Eigenschaft (Array)

length-Eigenschaft (Array)
Siehe auch 		JScript-Sprachverzeichnis

length-Eigenschaft (Function)
length-Eigenschaft (String)


Reverse-Methode

reverse-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Array-Objekt mit den Elementen in umgekehrter Reihenfolge zurück.
Syntax
Datenfeldobj.reverse()
Anmerkungen
Mit der reverse-Methode können die Elemente eines Array-Objekts invertiert werden. Dabei wird kein neues Array-Objekt während der Ausführung erstellt.

Ist das Datenfeld nicht zusammenhängend, so werden durch die reverse-Methode Elemente erzeugt, die die Lücken in dem Datenfeld füllen. Jedes dieser so erstellten Elemente hat den Wert undefined.

Das folgende Beispiel zeigt die Verwendung der reverse-Methode:

function ReverseDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.reverse();
  return(l);
}


reverse-Methode

reverse-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt


reverse-Methode

reverse-Methode
Siehe auch 		JScript-Sprachverzeichnis

Array-Objektmethoden


slice-Methode (Array)

slice-Methode (Array) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Abschnitt eines Datenfeldes zurück.
Syntax
DatenfeldObj.slice(Beginn, [Ende])

Die Syntax der slice-Methode hat folgende Komponenten:

Komponente | Beschreibung
DatenfeldObj | Erforderlich. Ein Array-Objekt.
Beginn | Erforderlich. Der nullbasierte Index des Beginns des angegebenen Abschnitts von DatenfeldObj.
Ende | Optional. Der nullbasierte Index des Endes des angegebenen Abschnitts von DatenfeldObj.

Anmerkungen
Die slice-Methode gibt ein Array-Objekt zurück, das den angegebenen Abschnitt von DatenfeldObj enthält.

Die slice-Methode kopiert bis zum Element, das durch Ende angegeben wird, aber nicht einschließlich dieses Elements. Falls negativ, gibt Ende einen Versatz vom Ende von DatenfeldObj an. Darüber hinaus ist es nicht nullbasiert. Falls weggelassen, wird die Extrahierung bis zum Ende von DatenfeldObj fortgesetzt.

Im folgenden Beispiel werden alle Elemente außer dem letzten von meinDatenfeld in neuesDatenfeld kopiert:

neuesDatenfeld = meinDatenfeld.slice(0, -1)
Falls ein Objektverweis aus DatenfeldObj in das Ergebnis kopiert wird, zeigt der Objektverweis des Ergebnisses immer noch auf dasselbe Objekt. Änderungen an diesem Objekt spiegeln sich in beiden Datenfeldern wieder.


slice-Methode

slice-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
String-Objekt


slice-Methode

slice-Methode
Siehe auch 		JScript-Sprachverzeichnis

slice-Methode (String)


sort-Methode

sort-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung

Gibt ein Array-Objekt zurück, in dem die Elemente sortiert sind.

Syntax
Datenfeldobj.sort(Sortierfunktion)

Das Argument Sortierfunktion ist der Name der Funktion zur Bestimmung der Reihenfolge der Elemente. Ohne Angabe werden die Elemente in aufsteigender ASCII-Zeichen-Rangfolge sortiert.

Anmerkungen
Die sort-Methode sortiert innerhalb des Array-Objekts. Während der Ausführung wird kein neues Array-Objekt erstellt.

Geben Sie eine Funktion im Argument Sortierfunktion an, so muss sie die folgenden Werte zurückgeben:

  • Einen negativen Wert, wenn das erste übergebene Argument kleiner als das zweite übergebene Argument ist.
  • Null, wenn beide Argumente gleich sind.
  • Einen positiven Wert, wenn das erste Argument größer als das zweite ist.

Das folgende Beispiel zeigt die Verwendung der sort-Methode:

function SortDemo()
{
  var a, l;
  a = new Array("X" ,"y" ,"d", "Z", "v","m","r");
  l = a.sort();
  return(l);
}


sort-Methode

sort-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt


sort-Methode

sort-Methode
Siehe auch 		JScript-Sprachverzeichnis

Array-Objektmethoden


Drives-Auflistung

Drives-Auflistung 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Schreibgeschützte Auflistung aller verfügbaren Laufwerke.
Anmerkungen
In Laufwerken mit austauschbaren Datenträgern muss kein Datenträger eingelegt sein, damit diese in der Drives-Auflistung angezeigt werden.

Das folgende Beispiel verdeutlicht das Abrufen der Drives-Auflistung unter Verwendung der Drives-Eigenschaft und dem Durchlaufen der Auflistung mit dem Enumerator-Objekt:

function GibLaufwerksListeAus()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Laufwerk nicht bereit]";
    s +=  n + "<br>";
  }
  return(n);
}


Drives-Auflistung

Drives-Auflistung
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Eigenschaft
File-Objekt
Files-Auflistung
Folder-Objekt
Folders-Auflistung


Drives-Auflistungsmethoden

Drives-Auflistung
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Die Drives-Auflistung verfügt über keine Methoden.


Drives-Auflistungseigenschaften

Drives-Auflistung
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Count-Eigenschaft
Item-Eigenschaft


Files-Auflistung

Files-Auflistung 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Auflistung aller File-Objekte in einem Ordner.
Anmerkungen
Das folgende Beispiel verdeutlicht das Abrufen der Files-Auflistung und das Durchlaufen der Auflistung mit dem Enumerator-Objekt und der for-Anweisung:
function GibOrdnerDateiListeAus(ordnerAng)
{
  var fso, f, f1, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(ordnerAng);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
      s += fc.item();
      s += "<br>";
  }
  return(n);
}


Files-Auflistung

Files-Auflistung
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Auflistung
File-Objekt
Folder-Objekt
Folders-Auflistung


Files-Auflistungsmethoden

Files-Auflistung
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Die Files-Auflistung verfügt über keine Methoden.


Files-Auflistungseigenschaften

Files-Auflistung
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Count-Eigenschaft
Item-Eigenschaft


Folders-Auflistung

Folders-Auflistung 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Auflistung aller in einem Folder-Objekt enthaltenen Folder-Objekte.
Anmerkungen
Das folgende Beispiel verdeutlicht das Abrufen der Folders-Auflistung und das Durchlaufen der Auflistung mit dem Enumerator-Objekt und der for-Anweisung:
function GibOrdnerListeAus(ordnerAng)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(ordnerAng);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(n);
}


Folders-Auflistung

Folders-Auflistung
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
Folder-Objekt
SubFolders-Eigenschaft


Folders-Auflistungsmethoden

Folders-Auflistung
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Folders)


Folders-Auflistungseigenschaften

Folders-Auflistung
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Count-Eigenschaft
Item-Eigenschaft


Bedingte Kompilierung

Bedingte Kompilierung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Ermöglicht die Verwendung neuer JScript-Sprachfunktionen ohne Verzicht auf die Kompatibilität mit Browsern, die diese Funktionen nicht unterstützen.
Anmerkungen
Die bedingte Kompilierung wird aktiviert durch Verwendung der @cc_on-Anweisung oder einer @if- bzw. @set-Anweisung außerhalb eines Kommentars. Bei einigen typischen Anwendungsfällen der bedingten Kompilierung werden neue Merkmale in JScript verwendet, wobei das Skript eine Fehlersuchfunktion enthält und die Codeausführung verfolgt wird.

Es wird ausdrücklich empfohlen, bedingten Kompilierungscode in Kommentare zu setzen:

/*@cc_on @*/
/*@if (@_jscript_Version == 4)
   alert("JScript Version 4");
   @else @*/
   alert("neueres Skriptmodul erforderlich.");
/*@end @*/
In diesem Beispiel werden spezielle Kommentarbegrenzungen verwendet, die nur eingesetzt werden, wenn die bedingte Kompilierung durch die @cc_on-Anweisung aktiviert ist. Bei Skriptmodulen, die die bedingte Kompilierung nicht verstehen, wird lediglich eine Mitteilung angezeigt, dass ein neues Skriptmodul erforderlich ist.


Bedingte Kompilierung

Bedingte Kompilierung
Siehe auch 		JScript-Sprachverzeichnis

@cc_on-Anweisung
@if-Anweisung
@set-Anweisung
Variablen für die bedingte Kompilierung


Variablen für die bedingte Kompilierung

Variablen für die bedingte Kompilierung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Folgende vordefinierte Variablen stehen für die bedingte Kompilierung zur Verfügung. Ist eine Variable nicht true, so ist sie nicht festgelegt und verhält sich beim Zugriff als NaN.

Variable | Beschreibung
@_win32 | true bei Ausführung auf einem Win32-System.
@_win16 | true bei Ausführung auf einem Win16-System.
@_mac | true bei Ausführung auf einem Apple Macintosh-System.
@_alpha | true bei Ausführung auf einem DEC Alpha-Prozessor.
@_x86 | true bei Ausführung auf einem Intel-Prozessor.
@_mc680x0 | true bei Ausführung auf einem Motorola 680x0-Prozessor.
@_PowerPC | true bei Ausführung auf einem Motorola PowerPC-Prozessor.
@_jscript | Stets true.
@_jscript_build | Enthält die Build-Nummer des JScript-Skriptmoduls.
@_jscript_version | Enthält die JScript-Versionsnummer im Format "Hauptversion.Nebenversion".


Variablen für die bedingte Kompilierung

Variablen für die bedingte Kompilierung
Siehe auch 		JScript-Sprachverzeichnis

Bedingte Kompilierung
@cc_on-Anweisung
@if-Anweisung
@set-Anweisung


jscopy

Copyright

Die in diesen Unterlagen enthaltenen Angaben und Daten können ohne vorherige Ankündigung geändert werden. Die hierin genannten Namen von Firmen, Produkten, Personen, Charakteren und/oder Daten sind fiktiv und sollen in keiner Weise reale Individuen, Firmen, Produkte oder Ereignisse darstellen, falls dies nicht ausdrücklich angemerkt ist. Die Benutzerinnen und Benutzer sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Ohne ausdrückliche schriftliche Erlaubnis von Microsoft Corporation darf kein Teil dieser Unterlagen für irgendwelche Zwecke vervielfältigt oder übertragen werden, unabhängig davon, auf welche Weise oder mit welchen Mitteln, elektronisch oder mechanisch, dies geschieht.

Microsoft verfügt möglicherweise über Patente, angemeldete Patente, Marken, Urheberrechte oder andere geistige Eigentumsrechte an Inhalten in diesen Unterlagen. Durch die Bereitstellung dieser Unterlagen erhalten Sie keinerlei Lizenzrechte an diesen Patenten, Marken, Urheberrechten oder anderem geistigen Eigentum, es sei denn, dies wurde explizit in einem schriftlichen Lizenzvertrag mit Microsoft vereinbart.

© 1991-1998 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, MS, MS-DOS, ActiveX, JScript, Microsoft Press, Visual Basic, Windows, Windows NT, Win32 und Win32s sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Andere hierin genannte Produkt- oder Firmennamen können Marken der jeweiligen Eigentümer sein.


getDate-Methode

getDate-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Gibt den Tag des Monats aus einem Date-Objekt unter Verwendung der Ortszeit zurück.

Syntax
DatumsObjName.getDate()
Anmerkungen
Verwenden Sie die getUTCDate-Methode, um den Tag des Monats des Datums gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen.

Der Rückgabewert ist eine Ganzzahl von 1 bis 31, die den Tag des Monats in dem Date-Objekt darstellt.

Das folgende Beispiel zeigt die Verwendung der getDate-Methode:

function DatumsDemo()
{
  var d, s = "Heutiges Datum: ";
  d = new Date();
  s += d.getDate() + ".";
  s += (d.getMonth() + 1) + ".";
  s += d.getYear();
  return(s);
}


getDate-Methode

getDate-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getDate-Methode

getDate-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCDate-Methode
setDate-Methode
setUTCDate-Methode


getDay-Methode

getDay-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Wert des Wochentags aus einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
DatumsObj.getDay()
Anmerkungen
Verwenden Sie die getUTCDay-Methode, um den Tag gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen.

Der ganzzahlige Wert aus der getDay-Methode liegt im Bereich von 0 bis 6 und entspricht einem Wochentag nach der folgenden Liste:

0 = Sonntag
1 = Montag
2 = Dienstag
3 = Mittwoch
4 = Donnerstag
5 = Freitag
6 = Samstag

Das folgende Beispiel zeigt die Verwendung der getDay-Methode:

function DatumsDemo()
{
  var d, tag, x, s = "Heutiger Wochentag: ";
  var x = new Array("Sonntag", "Montag", "Dienstag");
  var x = x.concat("Mittwoch","Donnerstag", "Freitag");
  var x = x.concat("Samstag");
  d = new Date();
  tag = d.getDay();
  return(s += x[tag]);
}


getDay-Methode

getDay-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getDay-Methode

getDay-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCDay-Methode


getFullYear-Methode

getFullYear-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert des Jahres im Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getFullYear()
Anmerkungen
Um das Jahr gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen, verwenden Sie die getUTCFullYear-Methode.

Mit der getFullYear-Methode wird das Jahr als absolute Zahl ausgegeben. So wird zum Beispiel das Jahr 1976 als 1976 ausgegeben. Dadurch werden Probleme bei Daten vermieden, die am Ende des 20. Jahrhunderts vorkommen.

Das folgende Beispiel zeigt die Verwendung der GetFullYear-Methode:

function DatumsDemo()
{
  var d, s = "Heutiges UTC-Datum: ";
  d = new Date();
  s += d.getDate() + ".";
  s += (d.getMonth() + 1) + ".";
  s += d.getFullYear();
  return(s);
}


getFullYear-Methode

getFullYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getFullYear-Methode

getFullYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCFullYear-Methode
setFullYear-Methode
setUTCFullYear-Methode


getHours-Methode

getHours-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Stunden in einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getHours()
Anmerkungen
Verwenden Sie die getUTCHours-Methode, um den Stundenwert gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen.

Mit der getHours-Methode wird eine Ganzzahl zwischen 0 und 23 ausgegeben, die die Anzahl der seit Mitternacht vergangenen Stunden anzeigt. Eine Null kann dabei in zwei Situationen vorkommen: Bei einer Zeit vor 1:00 Uhr oder wenn die Uhrzeit nicht im Date-Objekt gespeichert war, als das Objekt erstellt wurde. Welche der beiden Situationen vorliegt, lässt sich nur durch Prüfung der Minuten und Sekunden auf Nullwerte feststellen. Wenn beides Nullwerte sind, so lässt sich nahezu sicher annehmen, dass die Zeit nicht im Date-Objekt gespeichert war.

Das folgende Beispiel zeigt die Verwendung der getHours-Methode:

function ZeitDemo()
{
  var d, s = "Aktuelle Ortszeit: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getHours-Methode

getHours-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getHours-Methode

getHours-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCHours-Methode
setHours-Methode
setUTCHours-Methode


getMilliseconds-Methode

getMilliseconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Millisekunden in einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getMilliseconds()
Anmerkungen
Um die Zahl der Millisekunden gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen, verwenden Sie die getUTCMilliseconds-Methode.

Der zurückgegebene Millisekundenwert kann 0 bis 999 betragen.

Das folgende Beispiel zeigt die Verwendung der getMilliseconds-Methode:

function ZeitDemo()
{
  var d, s = "Aktuelle Ortszeit: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getMilliseconds-Methode

getMilliseconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getMilliseconds-Methode

getMilliseconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCMilliseconds-Methode
setMilliseconds-Methode
setUTCMilliseconds-Methode


getMinutes-Methode

getMinutes-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Minuten in einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getMinutes()
Anmerkungen
Verwenden Sie die getUTCMinutes-Methode, um den Wert für die Minuten gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) abzurufen.

Die getMinutes-Methode gibt einen ganzzahligen Wert zwischen 0 und 59 entsprechend dem im Date-Objekt gespeicherten Wert für die Minuten zurück. Der Wert Null (0) wird in zwei Fällen zurückgegeben: Die aktuelle Zeit beträgt weniger als 1 Minute nach der vollen Stunde, oder die Zeit beim Erstellen des Objektes ist nicht im Date-Objekt gespeichert worden. Welcher Fall eingetreten ist, kann nur durch zusätzliches Überprüfen der Stunden und Sekunden festgestellt werden. Sind alle Werte Null, so ist es fast sicher, dass die Zeit nicht im Date-Objekt gespeichert worden ist.

Das folgende Beispiel zeigt die Verwendung der getMinutes-Methode:

function ZeitDemo()
{
  var d, s = "Aktuelle Ortszeit: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getMinutes-Methode

getMinutes-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getMinutes-Methode

getMinutes-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCMinutes-Methode
setMinutes-Methode
setUTCMinutes-Methode


getMonth-Methode

getMonth-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Wert für den Monat in einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getMonth()
Anmerkungen
Verwenden Sie die getUTCMonth-Methode, um den Wert für den Monat gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu erhalten.

Die getMonth-Methode gibt einen ganzzahligen Wert zwischen 0 und 11 entsprechend dem im Date-Objekt gespeicherten Wert für die Monate zurück. Der zurückgegebene ganzzahlige Wert ist nicht der herkömmliche Wert für den Monat, sondern der herkömmliche Wert abzüglich eins. Wenn "5. Jan 1996, 08:47:00" in einem Date-Objekt gespeichert ist, gibt getMonth 0 zurück.

Das folgende Beispiel zeigt die Verwendung der getMonth-Methode:

function DatumsDemo()
{
  var d, s = "Heutiges Datum: ";
  d = new Date();
  s += d.getDate() + ".";
  s += (d.getMonth() + 1) + ".";
  s += d.getYear();
  return(s);
}


getMonth-Methode

getMonth-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getMonth-Methode

getMonth-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCMonth-Methode
setMonth-Methode
setUTCMonth-Methode


getSeconds-Methode

getSeconds-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Sekunden in einem Date-Objekt unter Verwendung der Ortszeit zurück.
Syntax
objDate.getSeconds()
Anmerkungen
Verwenden Sie die getUTCSeconds-Methode, um den Wert für die Sekunden gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu erhalten.

Die getSeconds-Methode gibt einen ganzzahligen Wert zwischen 0 und 59 entsprechend dem im Date-Objekt gespeicherten Wert für die Sekunden zurück. Der Wert Null (0) wird in zwei Fällen zurückgegeben: Die aktuelle Minute ist seit weniger als 1 Sekunde angebrochen, oder die Zeit beim Erstellen des Objekts ist nicht im Date-Objekt gespeichert worden. Welcher Fall eingetreten ist, kann nur durch zusätzliches Überprüfen der Stunden und Minuten festgestellt werden. Sind alle Werte Null, so ist es fast sicher, dass die Zeit nicht im Date-Objekt gespeichert worden ist.

Das folgende Beispiel zeigt die Verwendung der getSeconds-Methode:

function ZeitDemo()
{
  var d, s = "Aktuelle Ortszeit: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


getSeconds-Methode

getSeconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getSeconds-Methode

getSeconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getUTCSeconds-Methode
setSeconds-Methode
setUTCSeconds-Methode


getTime-Methode

getTime-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Zeit zurück, die in einem Date-Objekt gespeichert ist.
Syntax
objDate.getTime()
Anmerkungen
Die getTime-Methode gibt einen ganzzahligen Wert zurück, der der Anzahl vergangener Millisekunden zwischen Mitternacht, 1. Januar 1970, und dem Wert der Zeit im Date-Objekt entspricht. Der Datumsbereich umfasst etwa 285.616 Jahre von beiden Seiten von Mitternacht, 01. Januar 1970, aus. Negative Zahlen verweisen auf Daten vor 1970.

Bei mehrfachen Daten- und Zeitkalkulationen ist es häufig sinnvoll, Variablen zu definieren, die gleich der Anzahl von Millisekunden innerhalb eines Tages, einer Stunde oder einer Minute sind. Beispiele:

var MinMilli = 1000 * 60
var StdMilli = MinMilli * 60
var TagMilli = StdMilli * 24
Das folgende Beispiel zeigt die Verwendung der getTime-Methode:
function GetTimeDemo()
{
  var d, s, t;
  var MinMilli = 1000 * 60
  var StdMilli = MinMilli * 60
  var TagMilli = StdMilli * 24
  d = new Date();
  t = d.getTime();
  s = "Es sind "
  s += Math.round(t / TagMilli) + " Tage seit dem 1.1.70 vergangen.";
  return(s);
}


getTime-Methode

getTime-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getTime-Methode

getTime-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
setTime-Methode


getTimezoneOffset-Methode

getTimezoneOffset-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Gibt den Zeitunterschied in Minuten zwischen dem Hostcomputer und der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.

Syntax
objDate.getTimezoneOffset()
Anmerkungen
Die getTimezoneOffset-Methode gibt einen ganzzahligen Wert für die Anzahl der Minuten zurück, die zwischen der Zeit der Arbeitsstation und der koordinierten Weltzeit (UTC) liegen. Diese Werte beziehen sich auf den Computer, auf dem das Skript ausgeführt wird. Bei einem Aufruf aus einem Serverskript werden die Werte des Servers zurückgegeben. Bei einem Aufruf aus einem Clientskript werden die Werte des Clients zurückgegeben.

Diese Zahl ist positiv, wenn Sie hinter der UTC zurück liegen (z. B. Pazifische Zeit), und die Zahl ist negativ, wenn Sie der UTC voraus sind (z. B. Japan).

Beispiel: Ein Client in Los Angeles stellt am 1. Dezember eine Verbindung zu einem Server in New York City her. getTimezoneOffset gibt 480 zurück, wenn die Ausführung auf dem Client erfolgt, oder 300, wenn sie auf dem Server erfolgt.

Das folgende Beispiel zeigt die Verwendung der getTimezoneOffset-Methode:

function TZDemo()
{
  var d, tz, s = "Aktuelle Ortszeit ist ";
  d = new Date();
  tz = d.getTimezoneOffset();
  if (tz < 0)
    s += tz / 60 + " Stunden vor GMT.";
  else if (tz == 0)
    s += "GMT.";
  else
    s += tz / 60 + " Stunden vor GMT.";
  return(s);
}


getTimezoneOffset-Methode

getTimezoneOffset-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getTimezoneOffset-Methode

getTimezoneOffset-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden


getUTCDate-Methode

getUTCDate-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Tag des Monats in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCDate()
Anmerkungen
Um den Tag des Monats in Bezug auf die Ortszeit zu erhalten, verwenden Sie die getDate-Methode.

Der Rückgabewert ist eine Ganzzahl zwischen 1 und 31, die den Tag des Monats in dem Date-Objekt darstellt.

Das folgende Beispiel zeigt die Verwendung der getUTCDate-Methode:

function UTCDatumsDemo()
{
  var d, s = "Heutiges UTC-Datum: ";
  d = new Date();
  s += d.getUTCDate() + ".";
  s += (d.getUTCMonth() + 1) + ".";
  s += d.getUTCFullYear();
  return(s);
}


getUTCDate-Methode

getUTCDate-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCDate-Methode

getUTCDate-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getDate-Methode
setDate-Methode
setUTCDate-Methode


getUTCDay-Methode

getUTCDay-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert eines Wochentages in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCDay()
Anmerkungen
Um den Wochentag unter Verwendung der Ortszeit abzurufen, verwenden Sie die getDay-Methode.

Der von der getUTCDay-Methode zurückgegebene Wert ist eine Ganzzahl zwischen 0 und 6, die den Wochentag wiedergibt. Die Werte entsprechen den folgenden Wochentagen:

0 = Sonntag
1 = Montag
2 = Dienstag
3 = Mittwoch
4 = Donnerstag
5 = Freitag
6 = Samstag
Das folgende Beispiel zeigt die Verwendung der getUTCDay-Methode:
function UTCDatumsDemo()
{
  var d, tag, x, s = "Heute ist ";
  var x = new Array("Sonntag", "Montag", "Dienstag");
  x = x.concat("Mittwoch","Donnerstag", "Freitag");
  x = x.concat("Samstag");
  d = new Date();
  tag = d.getUTCDay();
  return(s += x[day] + ".");
}


getUTCDay-Methode

getUTCDay-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCDay-Methode

getUTCDay-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getDay-Methode


getUTCFullYear-Methode

getUTCFullYear-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert des Jahres in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCFullYear()
Anmerkungen
Um das Jahr unter Verwendung der Ortszeit abzurufen, verwenden Sie die getFullYear-Methode.

Die getUTCFullYear-Methode gibt das Jahr als Absolutwert zurück. Dadurch werden Probleme mit Datumsangaben am Ende des 20. Jahrhunderts vermieden.

Das folgende Beispiel zeigt die Verwendung der getUTCFullYear-Methode:

function UTCDatumsDemo()
{
  var d, s = "Heutiges UTC-Datum: ";
  d = new Date();
  s += d.getUTCDate() + ".";
  s += (d.getUTCMonth() + 1) + ".";
  s += d.getUTCFullYear();
  return(s);
}


getUTCFullYear-Methode

getUTCFullYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCFullYear-Methode

getUTCFullYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getFullYear-Methode
setFullYear-Methode
setUTCFullYear-Methode


getUTCHours-Methode

getUTCHours-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Stundenwert in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCHours()
Anmerkungen
Um die Zahl der seit Mitternacht vergangenenen Stunden unter Verwendung der Ortszeit abzurufen, verwenden Sie die getHours-Methode.

Die getUTCHours-Methode gibt eine Ganzzahl zwischen 0 und 23 zurück, die die Zahl der seit Mitternacht vergangenen Stunden angibt. Der Wert Null (0) wird in zwei Fällen zurückgegeben: Die Zeit liegt vor 01:00:00 Uhr, oder es wurde keine Zeit im Date-Objekt gespeichert, als das Objekt erstellt wurde. Welcher Fall eingetreten ist, kann nur durch zusätzliches Überprüfen der Minuten und Sekunden festgestellt werden. Sind alle Werte Null (0), so ist es fast sicher, dass die Zeit nicht im Date-Objekt gespeichert worden ist.

Das folgende Beispiel zeigt die Verwendung der getUTCHours-Methode:

function UTCZeitDemo()
{
  var d, s = "Aktuelle koordinierte Weltzeit (UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCHours-Methode

getUTCHours-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCHours-Methode

getUTCHours-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getHours-Methode
setHours-Methode
setUTCHours-Methode


getUTCMilliseconds-Methode

getUTCMilliseconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Millisekunden in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCMilliseconds()
Anmerkungen
Um die Zahl der Millisekunden unter Verwendung der Ortszeit abzurufen, verwenden Sie die getMilliseconds-Methode.

Der zurückgegebene Millisekundenwert kann 0 bis 999 betragen.

Das folgende Beispiel zeigt die Verwendung der getUTCMilliSeconds-Methode:

function UTCZeitDemo()
{
  var d, s = "Aktuelle koordinierte Weltzeit (UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCMilliseconds-Methode

getUTCMilliseconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCMilliseconds-Methode

getUTCMilliseconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMilliseconds-Methode
setMilliseconds-Methode
setUTCMilliseconds-Methode


getUTCMinutes-Methode

getUTCMinutes-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Minuten in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCMinutes()
Anmerkungen
Verwenden Sie die getMinutes-Methode, um die gespeicherte Zahl der Minuten unter Verwendung der Ortszeit abzurufen.

Die getUTCMinutes-Methode gibt einen ganzzahligen Wert zwischen 0 und 59 entsprechend dem im Date-Objekt gespeicherten Wert für die Minuten zurück. Der Wert Null (0) wird in zwei Fällen zurückgegeben: Die aktuelle Zeit beträgt weniger als 1 Minute nach der vollen Stunde, oder es wurde keine Zeit im Date-Objekt gespeichert, als das Objekt erstellt wurde. Welcher Fall eingetreten ist, kann nur durch zusätzliches Überprüfen der Stunden und Sekunden festgestellt werden. Sind alle Werte Null (0), so ist es fast sicher, dass die Zeit nicht im Date-Objekt gespeichert worden ist.

Das folgende Beispiel zeigt die Verwendung der getUTCMinutes-Methode:

function UTCZeitDemo()
{
  var d, s = "Aktuelle koordinierte Weltzeit (UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCMinutes-Methode

getUTCMinutes-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCMinutes-Methode

getUTCMinutes-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMinutes-Methode
setMinutes-Methode
setUTCMinutes-Methode


getUTCMonth-Methode

getUTCMonth-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert des Monats in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCMonth()
Anmerkungen
Um den Monat unter Verwendung der Ortszeit abzurufen, verwenden Sie die getMonth-Methode.

Die getUTCMonth-Methode gibt einen ganzzahligen Wert zwischen 0 und 11 entsprechend dem im Date-Objekt gespeicherten Wert für die Monate zurück. Der zurückgegebene ganzzahlige Wert ist nicht der herkömmliche Wert für den Monat, sondern der herkömmliche Wert abzüglich eins. Wenn "5. Jan 1996, 08:47:00" in einem Date-Objekt gespeichert ist, gibt getUTCMonth 0 zurück.

Das folgende Beispiel zeigt die Verwendung der getUTCMonth-Methode:

function UTCDatumsDemo()
{
  var d, s = "Heutiges UTC-Datum: ";
  d = new Date();
  s += d.getUTCDate() + ".";
  s += (d.getUTCMonth() + 1) + ".";
  s += d.getUTCFullYear();
  return(s);
}


getUTCMonth-Methode

getUTCMonth-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCMonth-Methode

getUTCMonth-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMonth-Methode
setMonth-Methode
setUTCMonth-Methode


getUTCSeconds-Methode

getUTCSeconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert der Sekunden in einem Date-Objekt unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zurück.
Syntax
objDate.getUTCSeconds()
Anmerkungen
Um die Zahl der Sekunden unter Verwendung der Ortszeit abzurufen, verwenden Sie die getSeconds-Methode.

Die getUTCSeconds-Methode gibt einen ganzzahligen Wert zwischen 0 und 59 entsprechend dem im Date-Objekt gespeicherten Wert für die Sekunden zurück. Der Wert Null (0) wird in zwei Fällen zurückgegeben: Die aktuelle Minute ist seit weniger als 1 Sekunde angebrochen, oder es wurde keine Zeit im Date-Objekt gespeichert, als das Objekt erstellt wurde. Welcher Fall eingetreten ist, kann nur durch zusätzliches Überprüfen der Minuten und Stunden festgestellt werden. Sind alle Werte Null (0), so ist es fast sicher, dass die Zeit nicht im Date-Objekt gespeichert worden ist.

Das folgende Beispiel zeigt die Verwendung der getUTCSeconds-Methode:

function UTCZeitDemo()
{
  var d, s = "Aktuelle koordinierte Weltzeit (UTC): ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


getUTCSeconds-Methode

getUTCSeconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getUTCSeconds-Methode

getUTCSeconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getSeconds-Methode
setSeconds-Methode
setUTCSeconds-Methode


getVarDate-Methode

getVarDate-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Wert VT_DATE in einem Date-Objekt zurück.
Syntax
dateobj.getVarDate( )

Das Argument dateobj ist ein beliebiges Date-Objekt.

Anmerkungen
Die getVarDate-Methode wird zur Interaktion mit ActiveX®-Objekten oder anderen Objekten verwendet, die Datumswerte im VT_DATE-Format akzeptieren und zurückgeben.


getVarDate-Methode

getVarDate-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getVarDate-Methode

getVarDate-Methode
Siehe auch 		JScript-Sprachverzeichnis

getDate-Methode
parse-Methode


getYear-Methode

getYear-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Gibt den Wert des Jahres in einem Date-Objekt zurück.

Syntax

objDate.getYear( )
Anmerkungen
Diese Methode ist veraltet und wird nur für die Abwärtskompatibilität bereitgestellt. Verwenden Sie stattdessen die getFullYear-Methode.

Für dieses Jahrhundert ist das Jahr ein zweistelliger Ganzzahlwert, der als Differenz zwischen dem gespeicherten Jahr und 1900 zurückgegeben wird. Für andere Jahrhunderte wird eine 4-stellige Jahreszahl zurückgegeben. 1996 wird z. B. als 96 zurückgegeben, 1825 und 2025 werden dagegen vollständig zurückgegeben.

Das folgende Beispiel zeigt die Verwendung der getYear-Methode:

function DatumsDemo()
{
  var d, s = "Heutiges Datum: ";
  d = new Date();
  s += d.getDate() + ".";
  s += (d.getMonth() + 1) + ".";
  s += d.getYear();
  return(s);
}


getYear-Methode

getYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


getYear-Methode

getYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getFullYear-Methode
getUTCFullYear-Methode
setFullYear-Methode
setUTCFullYear-Methode
setYear-Methode


parse-Methode

parse-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Analysiert eine Zeichenfolge mit einem Datum und liefert die Anzahl der Millisekunden zwischen diesem Datum und Mitternacht des 1. Januars 1970.

Syntax
Date.parse(dateWert)

Das Argument dateWert ist eine Zeichenfolge mit einem Datum in einem Format wie z. B. "5. Januar 1996, 08:47:00" oder ein VT_DATE-Wert, der von einem ActiveX®-Objekt oder einem anderen Objekt abgerufen wurde.

Anmerkungen
Die parse-Methode liefert einen ganzzahligen Wert für die Anzahl der Millisekunden zwischen Mitternacht, 1. Januar 1970, und dem mit dateWert übergebenen Datum.

Die parse-Methode ist eine statische Methode des Date-Objekts. Da sie eine statische Methode ist, wird sie wie im folgenden Beispiel gezeigt aufgerufen und nicht als Methode eines erzeugten Date-Objekts.

var datumsZeichenfolge = "1. November 1997, 10:15";
Date.parse(datumsZeichenfolge)
Folgende Regeln bestimmen, was die parse-Methode erfolgreich analysieren kann:
  • Ein kurzes Datum kann mit "/" oder "-" als Trennzeichen angegeben werden, muss aber dem amerikanischen Standardformat Monat/Tag/Jahr entsprechen.
  • Ein langes Datum der Form "10. Juli 1995" kann mit Jahr, Monat und Tag in beliebiger Reihenfolge angegeben werden, und das Jahr mit 2 oder 4 Stellen. Wenn Sie die 2-stellige Form benutzen, muss die Jahreszahl größer oder gleich 70 sein.
  • Jeder Text in Klammern wird als Kommentar behandelt. Die Klammern können verschachtelt werden.
  • Kommas und Leerzeichen werden als Begrenzungszeichen erkannt. Mehrfache Begrenzungszeichen sind erlaubt.
  • Die Namen der Monate oder Tage müssen mindestens zwei Zeichen lang oder länger sein. Namen mit zwei Zeichen, die nicht eindeutig sind, werden der letzten Übereinstimmung zugeordnet. Beispiel: "Ju" resultiert in Juli, nicht Juni.
  • Ein in Bezug auf den Rest des Datums falsch angegebener Wochentag wird ignoriert. Beispiel: "Dienstag 9. November 1996" wird akzeptiert und analysiert, obwohl der Tag tatsächlich ein Freitag ist. Das resultierende Date-Objekt enthält "Freitag 9. November 1996".
  • Alle Standard-Zeitzonen, UTC (Universal Coordinated Time) und GMT (Greenwich Mean Time) werden von JScript verarbeitet.
  • Stunden, Minuten und Sekunden werden mit Doppelpunkten getrennt, müssen allerdings nicht alle angegeben werden "10:", "10:11" und "10:11:12" sind alle gültig.
  • Wird die 24-Stunden-Zeiteinteilung verwendet, ist der Zusatz von "PM" für Werte größer als 12:00 Uhr falsch. "23:15 PM" ist ein Fehler.
  • Eine Zeichenfolge mit einem ungültigen Datum ist ein Fehler, z. B. sind Zeichenfolgen mit zwei Jahresangaben oder zwei Monatsangaben falsch.
Das folgende Beispiel zeigt die Verwendung der parse-Methode:
function ZeitDemo(Testdatum)
{
  var d, s, t;
  var MinMilli = 1000 * 60
  var StdMilli = MinMilli * 60
  var TagMilli = StdMilli * 24
  d = new Date();
  t = Date.parse(Testdatum);
  s = "Es gibt "
  s += Math.round(Math.abs(t / TagMilli)) + " Tage "
  s += "zwischen " + Testdatum + " und 1.1.70";
  return(s);
}


parse-Methode

parse-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


parse-Methode

parse-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden


setDate-Methode

setDate-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Tag des Monats des Date-Objekts unter Verwendung der Ortszeit.
Syntax
objDate.setDate(TagesZahl)

Das Argument TagesZahl ist ein numerischer Wert, der dem Tag des Monats entspricht.

Anmerkungen
Verwenden Sie die setUTCDate-Methode, um den Wert des Tag des Monats unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Ist der Wert TagesZahl größer als die Anzahl von Tagen des Monats im gespeicherten Date-Objekt oder eine negative Zahl, wird das Datum auf einen Wert gleich TagesZahl minus der Anzahl der Tage des gespeicherten Monats gesetzt. Ist das gespeicherte Datum z. B. der 5. Januar 1996, und wird setDate(32) ausgeführt, ändert sich das Datum in 1. Februar 1996. Negative Zahlen haben ähnliche Auswirkung.

Das folgende Beispiel zeigt die Verwendung der setDate-Methode:

function SetDateDemo(NeuesDatum)
{
  var d, s;
  d = new Date();
  d.setDate(NeuesDatum);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString();
  return(s);
}


setDate-Methode

setDate-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setDate-Methode

setDate-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getDate-Methode
getUTCDate-Methode
setUTCDate-Methode


setFullYear-Methode

setFullYear-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt den Wert des Jahres in einem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setFullYear(JahresZahl[, MonatsZahl[, TagesZahl]])

Die Syntax der setFullYear-Methode hat folgende Komponenten:

Komponente | Beschreibung
JahresZahl | Erforderlich. Ein dem Jahr entsprechender numerischer Wert.
MonatsZahl | Optional. Ein dem Monat entsprechender numerischer Wert. Muss angegeben werden, wenn TagesZahl angegeben wird.
TagesZahl | Optional. Ein dem Tag im Monat entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Wenn darüber hinaus der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert.

Um das Jahr unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen, verwenden Sie die setUTCFullYear-Methode.

Der Bereich der in dem Date-Objekt unterstützten Jahre beträgt ca. 285.616 Jahre in beide Richtungen ab 1970.

Das folgende Beispiel zeigt die Verwendung der setFullYear-Methode:

function SetFullYearDemo(NeuesJahr)
{
  var d, s;
  d = new Date();
  d.setFullYear(NeuesJahr);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString();
  return(s);
}


setFullYear-Methode

setFullYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setFullYear-Methode

setFullYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getFullYear-Methode
getUTCFullYear-Methode
setUTCFullYear-Methode


setHours-Methode

setHours-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Stundenwert in dem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setHours(StdZahl[, MinZahl[, SekZahl[, MilliZahl]]])

Die Syntax der setHours-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
StdZahl | Erforderlich. Ein den Stunden entsprechender numerischer Wert.
MinZahl | Optional. Ein den Minuten entsprechender numerischer Wert. Muss angegeben werden, wenn eines der beiden folgenden Argumente verwendet wird.
SekZahl | Optional. Ein den Sekunden entsprechender numerischer Wert. Muss angegeben werden, wenn das folgende Argument verwendet wird.
MilliZahl | Optional. Ein den Millisekunden entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Verwenden Sie die setUTCHours-Methode, um den Wert der Stunden unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Wenn der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Ist das gespeicherte Datum z. B. "5. Jan 1996, 00:00:00", und wird setHours(30) ausgeführt, ändert sich das Datum in "6. Jan 1996, 06:00:00". Negative Zahlen haben ähnliche Auswirkung.

Das folgende Beispiel zeigt die Verwendung der setHours-Methode:

function SetHoursDemo(nStd, nMin, nSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setHours(nStd, nMin, nSek);
  s = "Die gegenwärtige Einstellung ist " + d.toLocaleString()
  return(s);
}


setHours-Methode

setHours-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setHours-Methode

setHours-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getHours-Methode
getUTCHours-Methode
setUTCHours-Methode


setMilliseconds-Methode

setMilliseconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt den Millisekundenwert in dem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setMilliseconds(MilliZahl)

Das Argument MilliZahl ist ein numerischer Wert, der dem Millisekundenwert entspricht.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Verwenden Sie die setUTCMilliseconds-Methode, um den Millisekundenwert unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Wenn der Wert von MilliZahl größer als 999 oder eine negative Zahl ist, wird die gespeicherte Zahl der Sekunden (und Minuten, Stunden usw., falls erforderlich) um einen entsprechenden Betrag erhöht.

Das folgende Beispiel zeigt die Verwendung der setMilliseconds-Methode:

function SetMillisecondsDemo(nmSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMilliseconds(nmSek);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString() + sep + d.getMilliseconds();
  return(s);
}


getMilliseconds-Methode

setMilliseconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setMilliseconds-Methode

setMilliseconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMilliseconds-Methode
getUTCMilliseconds-Methode
setUTCMilliseconds-Methode


setMinutes-Methode

setMinutes-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Wert der Minuten in dem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setMinutes(MinZahl[, SekZahl[, MilliZahl]])

Die Syntax der setMinutes-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
MinZahl | Erforderlich. Ein den Minuten entsprechender numerischer Wert.
SekZahl | Optional. Ein den Sekunden entsprechender numerischer Wert. Muss angegeben werden, wenn das Argument MilliZahl verwendet wird.
MilliZahl | Optional. Ein den Millisekunden entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Verwenden Sie die setUTCMinutes-Methode, um den Minutenwert unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Wenn der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Ist das gespeicherte Datum z. B. "5. Jan 1996, 00:00:00", und wird setMinutes(90) ausgeführt, ändert sich das Datum in "5. Jan 1996, 01:30:00". Negative Zahlen haben ähnliche Auswirkung.

Das folgende Beispiel zeigt die Verwendung der setMinutes-Methode:

function SetMinutesDemo(nMin, nSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMinutes(nMin, nSek);
  s = "Die gegenwärtige Einstellung ist " + d.toLocaleString()
  return(s);
}


setMinutes-Methode

setMinutes-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setMinutes-Methode

setMinutes-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMinutes-Methode
getUTCMinutes-Methode
setUTCMinutes-Methode


setMonth-Methode

setMonth-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Wert des Monats in dem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setMonth(MonatsZahl[, TagesZahl])

Die Syntax der setMonth-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
MonatsZahl | Erforderlich. Ein dem Monat entsprechender numerischer Wert.
TagesZahl | Optional. Ein dem Tag im Monat entsprechender numerischer Wert. Wenn nicht angegeben, wird der Wert aus einem Aufruf der getDate-Methode verwendet.

Anmerkungen
Verwenden Sie die setUTCMonth-Methode, um den Monatswert unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Ist der Wert von MonatsZahl größer als 11 (Januar entspricht dem Monat 0) oder eine negative Zahl, wird das gespeicherte Jahr entsprechend geändert. Ist das gespeicherte Datum z. B. "5. Jan 1996", und wird setMonth(14) ausgeführt, ändert sich das Datum in "5. Mär 1997".

Das folgende Beispiel zeigt die Verwendung der setMonth-Methode:

function SetMonthDemo(NeuerMonat)
{
  var d, s;
  d = new Date();
  d.setMonth(NeuerMonat);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString();
  return(s);
}


setMonth-Methode

setMonth-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setMonth-Methode

setMonth-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMonth-Methode
getUTCMonth-Methode
setUTCMonth-Methode


setSeconds-Methode

setSeconds-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Sekundenwert in dem Date-Objekt unter Verwendung der Ortszeit.
Syntax
objDate.setSeconds(SekZahl[, MilliZahl])

Die Syntax der setSeconds-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
SekZahl | Erforderlich. Ein den Sekunden entsprechender numerischer Wert.
MilliZahl | Optional. Ein den Millisekunden entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Verwenden Sie die setUTCSeconds-Methode, um den Sekundenwert unter Verwendung der koordinierten Weltzeit (Universal Coordinated Time=UTC) zu setzen.

Wenn der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Ist das gespeicherte Datum z. B. "5. Jan 1996, 00:00:00", und wird setSeconds(150) ausgeführt, ändert sich das Datum in "5. Jan 1996, 00:02:30".

Das folgende Beispiel zeigt die Verwendung der setSeconds-Methode:

function SetSecondsDemo(nSek, nmSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setSeconds(nSek, nmSek);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString() + sep + d.getMilliseconds();
  return(s);
}


setSeconds-Methode

setSeconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setSeconds-Methode

setSeconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getSeconds-Methode
getUTCSeconds-Methode
setUTCSeconds-Methode


setTime-Methode

setTime-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt die Werte für das Datum und die Zeit im Date-Objekt.
Syntax
objDate.setTime(MilliSekunden)

Das Argument MilliSekunden ist ein ganzzahliger Wert für die seit Mitternacht, 1. Januar 1970, Greenwich Mean Time (GMT), vergangenen Millisekunden.

Anmerkungen
Ist MilliSekunden ein negativer Wert, verweist er auf ein Datum vor 1970. Der Bereich verfügbarer Daten umfasst etwa 285.616 Jahre zu beiden Seiten von 1970.

Das Setzen des Datums und der Zeit mit der setTime-Methode ist unabhängig von Zeitzonen.

Das folgende Beispiel zeigt die Verwendung der setTime-Methode:

function SetTimeTest(NeueZeit)
{
  var d, s;
  d = new Date();
  d.setTime(NeueZeit);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString();
  return(s);
}


setTime-Methode

setTime-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setTime-Methode

setTime-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getTime-Methode


setUTCDate-Methode

setUTCDate-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt den Tag des Monats des Date-Objekts gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCDate(TagesZahl)

Das Argument TagesZahl ist ein numerischer Wert, der dem Tag des Monats entspricht.

Anmerkungen
Um den Tag des Monats gemäß der Ortszeit zu setzen, verwenden Sie die setDate-Methode.

Wenn der Wert TagesZahl größer als die Zahl der Tage des im Date-Objekt gespeicherten Monats oder eine negative Zahl ist, wird der Tag des Monats auf einen Wert gesetzt, der TagesZahl minus der Zahl der Tage des gespeicherten Monats entspricht. Wenn z. B. das gespeicherte Datum der 05.01.1996 ist und setUTCDate(32) aufgerufen wird, dann wird das Datum in den 01.02.1996 geändert. Bei negativen Zahlen verhält es sich ähnlich.

Das folgende Beispiel zeigt die Verwendung der setUTCDate-Methode:

function SetUTCDateDemo(neuesDatum)
{
  var d, s;
  d = new Date();
  d.setUTCDate(neuesDatum);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString();
  return(s);
}


setUTCDate-Methode

setUTCDate-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCDate-Methode

setUTCDate-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getDate-Methode
getUTCDate-Methode
setDate-Methode


setUTCFullYear-Methode

setUTCFullYear-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt das Jahr in dem Date-Objekt gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCFullYear(JahresZahl[, MonatsZahl[, TagesZahl]])

Die Syntax der setUTCFullYear-Methode hat folgende Komponenten:

Komponente | Beschreibung
JahresZahl | Erforderlich. Ein dem Jahr entsprechender numerischer Wert.
MonatsZahl | Optional. Ein dem Monat entsprechender numerischer Wert. Muss angegeben werden, wenn TagesZahl angegeben wird.
TagesZahl | Optional. Ein dem Datum entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Wenn darüber hinaus der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert.

Um das Jahr gemäß der Ortszeit zu setzen, verwenden Sie die setFullYear-Methode.

Der Bereich der in dem Date-Objekt unterstützten Jahre beträgt ca. 285.616 Jahre in beide Richtungen ab 1970.

Das folgende Beispiel zeigt die Verwendung der setUTCFullYear-Methode:

function SetUTCFullYearDemo(neuesJahr)
{
  var d, s;
  d = new Date();
  d.setUTCFullYear(neuesJahr);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString();
  return(s);
}


setUTCFullYear-Methode

setUTCFullYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCFullYear-Methode

setUTCFullYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getFullYear-Methode
getUTCFullYear-Methode
setFullYear-Methode


setUTCHours-Methode

setUTCHours-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ändert die in dem Date-Objekt gespeicherten Stunden gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCHours(StdZahl[, MinZahl[, SekZahl[, MilliZahl]]])

Die Syntax der setUTCHours-Methode hat folgende Komponenten:

Komponente | Beschreibung
StdZahl | Erforderlich. Ein dem Stundenwert entsprechender numerischer Wert.
MinZahl | Optional. Ein dem Minutenwert entsprechender numerischer Wert. Muss angegeben werden, wenn entweder SekZahl oder MilliZahl verwendet werden.
SekZahl | Optional. Ein dem Sekundenwert entsprechender numerischer Wert. Muss angegeben werden, wenn das Argument MilliZahl verwendet wird.
MilliZahl | Optional. Ein dem Millisekundenwert entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Um den Stundenwert gemäß der Ortszeit zu setzen, verwenden Sie die setHours-Methode.

Wenn der Wert eines Argument größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Wenn z. B. das gespeicherte Datum "5. Jan 1996, 00:00:00.00" ist und setUTCHours(30) aufgerufen wird, dann wird das Datum in "6. Jan 1996, 06:00:00.00" geändert.

Das folgende Beispiel zeigt die Verwendung der setUTCHours-Methode:

function SetUTCHoursDemo(nStd, nMin, nSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCHours(nStd, nMin, nSek);
  s = "Die gegenwärtige Einstellung ist " + d.toUTCString()
  return(s);
}


setUTCHours-Methode

setUTCHours-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCHours-Methode

setUTCHours-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getHours-Methode
getUTCHours-Methode
setHours-Methode


setUTCMilliseconds-Methode

setUTCMilliseconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ändert den in dem Date-Objekt gespeicherten Millisekundenwert gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCMilliseconds(MilliZahl)

Das Argument MilliZahl ist ein dem Millisekundenwert entsprechender numerischer Wert.

Anmerkungen
Um den Millisekundenwert gemäß der Ortszeit zu setzen, verwenden Sie die setMilliseconds-Methode.

Wenn der Wert MilliZahl größer als 999 oder eine negative Zahl ist, wird die gespeicherte Zahl an Sekunden (Minuten, Stunden usw., falls erforderlich) um den entsprechenden Betrag erhöht.

Das folgende Beispiel zeigt die Verwendung der setUTCMilliseconds-Methode:

function setUTCMillisecondsDemo(nmSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMilliseconds(nmSek);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds();
  return(s);
}


setUTCMilliseconds-Methode

setUTCMilliseconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCMilliseconds-Methode

setUTCMilliseconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMilliseconds-Methode
getUTCMilliseconds-Methode
setMilliseconds-Methode


setUTCMinutes-Methode

setUTCMinutes-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ändert den im Date-Objekt gespeicherten Minutenwert gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCMinutes(MinZahl[, SekZahl[, MilliZahl]])

Die Syntax der setUTCMinutes-Methode hat folgende Komponenten:

Komponente | Beschreibung
MinZahl | Erforderlich. Ein dem Minutenwert entsprechender numerischer Wert.
SekZahl | Optional. Ein dem Sekundenwert entsprechender numerischer Wert. Muss angegeben werden, wenn MilliZahl verwendet wird.
MilliZahl | Optional. Ein dem Millisekundenwert entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Um den Minutenwert gemäß der Ortszeit zu ändern, verwenden Sie die setMinutes-Methode.

Wenn der Wert eines Argument größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Wenn z. B. das gespeicherte Datum "5. Jan 1996, 00:00:00.00" ist und setUTCMinutes(70) aufgerufen wird, dann wird das Datum in "5. Jan 1996, 01:10:00.00" geändert.

Das folgende Beispiel zeigt die Verwendung der setUTCMinutes-Methode:

function SetUTCMinutesDemo(nMin, nSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMinutes(nMin,nSek);
  s = "Die gegenwärtige Einstellung ist " + d.toUTCString()
  return(s);
}


setUTCMinutes-Methode

setUTCMinutes-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCMinutes-Methode

setUTCMinutes-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMinutes-Methode
getUTCMinutes-Methode
setMinutes-Methode


setUTCMonth-Methode

setUTCMonth-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ändert den im Date-Objekt gespeicherten Monat gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCMonth(MonatsZahl[, TagesZahl])

Die Syntax der setUTCMonth-Methode hat folgende Komponenten:

Komponente | Beschreibung
MonatsZahl | Erforderlich. Ein dem Monat entsprechender numerischer Wert.
TagesZahl | Optional. Ein den Tag des Monats angebender numerischer Wert. Falls nicht angegeben, wird der Wert eines Aufrufs der getUTCDate-Methode verwendet.

Anmerkungen
Um den Monat gemäß der Ortszeit zu setzen, verwenden Sie die setMonth-Methode.

Wenn der MonatsZahl-Wert größer als 11 (Januar ist Monat 0) oder eine negative Zahl ist, wird das gespeicherte Jahr entsprechend erhöht oder gesenkt. Wenn z. B. das gespeicherte Datum "5. Jan 1996, 00:00:00.00" ist und setUTCMonth(14) aufgerufen wird, dann wird das Datum in "5. Mär 1997, 00:00:00.00" geändert.

Das folgende Beispiel zeigt die Verwendung der setUTCMonth-Methode:

function SetUTCMonthDemo(neuerMonat)
{
  var d, s;
  d = new Date();
  d.setUTCMonth(neuerMonat);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString();
  return(s);
}


setUTCMonth-Methode

setUTCMonth-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCMonth-Methode

setUTCMonth-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getMonth-Methode
getUTCMonth-Methode
setMonth-Methode


setUTCSeconds-Methode

setUTCSeconds-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ändert den im Date-Objekt gespeicherten Sekundenwert gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.setUTCSeconds(SekZahl[, MilliZahl])

Die Syntax der setUTCSeconds-Methode hat folgende Komponenten:

Komponente | Beschreibung
SekZahl | Erforderlich. Ein dem Sekundenwert entsprechender numerischer Wert.
MilliZahl | Optional. Ein dem Millisekundenwert entsprechender numerischer Wert.

Anmerkungen
Alle set-Methoden, die optionale Argumente einsetzen, verwenden den von den entsprechenden get-Methoden zurückgegebenen Wert, wenn kein optionales Argument angegeben wurde. Wenn z. B. das Argument MonatsZahl optional, aber nicht angegeben ist, verwendet JScript den von der getMonth-Methode zurückgegebenen Wert.

Um den Sekundenwert gemäß der Ortszeit zu setzen, verwenden Sie die setSeconds-Methode.

Wenn der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Wenn z. B. das gespeicherte Datum "5. Jan 1996, 00:00:00.00" ist und setSeconds(150) aufgerufen wird, dann wird das Datum in "5. Jan 1996, 00:02:30.00" geändert.

Das folgende Beispiel zeigt die Verwendung der setSeconds-Methode:

function SetUTCSecondsDemo(nSek, nmSek)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCSeconds(nSek, nmSek);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds;
  return(s);
}


setUTCSeconds-Methode

setUTCSeconds-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setUTCSeconds-Methode

setUTCSeconds-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getSeconds-Methode
getUTCSeconds-Methode
setSeconds-Methode


setYear-Methode

setYear-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt den Wert für das Jahr im Date-Objekt.
Syntax
dateObj.setYear(JahresZahl)

Das Argument JahresZahl ist ein numerischer Wert entsprechend dem Jahr minus 1900.

Anmerkungen
Diese Methode ist veraltet und wird nur für die Abwärtskompatibilität bereitgestellt. Verwenden Sie stattdessen die setFullYear-Methode.

Um das Jahr eines Date-Objekts auf 1997 zu setzen, verwenden Sie SetYear(97). Um das Jahr in einem Bereich von 0 bis 99 zu setzen, verwenden Sie die setFullYear-Methode.

Das folgende Beispiel zeigt die Verwendung der setYear-Methode:

function SetYearDemo(neuesJahr)
{
  var d, s;
  d = new Date();
  d.setYear(neuesJahr);
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString();
  return(s);
}


setYear-Methode

setYear-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


setYear-Methode

setYear-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
getFullYear-Methode
getUTCFullYear-Methode
getYear-Methode
setFullYear-Methode
setUTCFullYear-Methode


toGMTString-Methode

toGMTString-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Konvertiert das Datum in eine Zeichenfolge mit der GMT-Konvention.
Syntax
dateObj.toGMTString( )
Anmerkungen
Die toGMTString-Methode ist veraltet und ist ausschließlich der Abwärtskompatibilität vorbehalten. Es wird empfohlen, die toUTCString-Methode stattdessen zu verwenden.

Die toGMTString-Methode gibt ein String-Objekt im Format der GMT-Konvention zurück. Das Format des Rückgabewerts ist: "05 Jan 1996 00:00:00 GMT".

Das folgende Beispiel zeigt die Verwendung der toGMTString-Methode:

function toGMTStrDemo()
{
  var d, s;
  d = new Date();
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toGMTString();
  return(s);
}


toGMTString-Methode

toGMTString-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


toGMTString-Methode

toGMTString-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
toUTCString-Methode


toLocaleString-Methode

toLocaleString-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Konvertiert das Datum in eine Zeichenfolge mit dem aktuellen Gebietsschema.
Syntax
dateObj.toLocaleString( )
Anmerkungen
Die toLocaleString-Methode gibt ein String-Objekt mit dem Datum im Format des aktuellen Gebietsschemas. Das Format des Rückgabewertes hängt vom lokalen Gebietsschema ab. Beispiel: In den Vereinigten Staaten wird toLocaleString für den 5. Januar 1996 "01/05/96 00:00:00" zurückgeben, in Europa für dasselbe Datum jedoch "05.01.96 00:00:00", weil nach der europäischen Schreibweise der Tag vor dem Monat angegeben wird.

Das folgende Beispiel zeigt die Verwendung der toLocaleString-Methode:

function toLocaleStrDemo()
{
  var d, s;
  d = new Date();
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toLocaleString();
  return(s);
}


toLocaleString-Methode

toLocaleString-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


toLocaleString-Methode

toLocaleString-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden


toUTCString-Methode

toUTCString-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Konvertiert das Datum in eine Zeichenfolge gemäß der koordinierten Weltzeit (Universal Coordinated Time=UTC).
Syntax
objDate.toUTCString()
Anmerkungen
Die toUTCString-Methode gibt ein String-Objekt zurück, das das mittels der UTC-Konvention formatierte Datum in benutzerfreundlich lesbarer Form enthält.

Das folgende Beispiel zeigt die Verwendung der toUTCString-Methode:

function toUTCStrDemo()
{
  var d, s;
  d = new Date();
  s = "Die gegenwärtige Einstellung ist ";
  s += d.toUTCString();
  return(s);
}


toUTCString-Methode

toUTCString-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


toUTCString-Methode

toUTCString-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
toGMTString-Methode


UTC-Methode

UTC-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Berechnet die Millisekundenzahl zwischen Mitternacht, 1. Januar 1970 und dem angegebenen Datum gemäß koordinierter Weltzeit (Universal Coordinated Time=UTC) (oder GMT).

Syntax
Date.UTC(Jahr, Monat, Tag[, Stunden[, Minuten[, Sekunden[,MS]]]])

Die Syntax der UTC-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Jahr | Erforderlich. Die vollständige Jahresangabe ist erforderlich für richtige Jahrhundertdaten. Wenn das Jahr zwischen 0 und 99 angegeben wird, wird Jahr als 1900 + Jahr angenommen.
Monat | Der Monat als ganzzahliger Wert zwischen 0 und 11 (Januar bis Dezember).
Tag | Der Tag als ganzzahliger Wert zwischen 1 und 31.
Stunden | Optional. Muss aber angegeben werden, wenn Minuten auch angegeben ist. Ein ganzzahliger Wert von 0 bis 23 für die Bezeichnung der Stunde.
Minuten | Optional. Muss aber angegeben werden, wenn Sekunden auch angegeben ist. Ein ganzzahliger Wert von 0 bis 59 für die Bezeichnung der Minuten.
Sekunden | Optional. Ein ganzzahliger Wert von 0 bis 59 für die Bezeichnung der Sekunden.
MS | Optional. Ein ganzzahliger Wert von 0 bis 999 für die Bezeichnung der Millisekunden.

Anmerkungen

Die UTC-Methode liefert die Millisekundenzahl zwischen dem 1. Januar 1970, Mitternacht, UTC (Universal Coordinated Time) und dem angegebenen Datum. Dieser Rückgabewert kann in der setTime-Methode und im Date-Objektkonstruktor verwendet werden. Ist der Wert eines Arguments größer als sein Bereich, oder ist er eine negative Zahl, werden andere gespeicherte Werte entsprechend verändert. Wenn Sie z. B. 150 Sekunden angeben, macht JScript daraus 2 Minuten und 30 Sekunden.

Der Unterschied zwischen der UTC-Methode und dem Date-Objektkonstruktor, der ein Datum akzeptiert, liegt darin, dass die UTC-Methode von UTC und der Date-Objektkonstruktor von der Ortszeit ausgeht.

Die UTC-Methode ist eine statische Methode. Ein Date-Objekt muss deswegen vor der Verwendung nicht erstellt werden. Die UTC-Methode wird wie folgt aufgerufen.

var datumsZeichenfolge = "1. November 1997, 10:15";
Date.UTC(datumsZeichenfolge)
Hinweis Liegt das Jahr zwischen 0 und 99, verwenden Sie für das Jahr "1900 + Jahr".

Das folgende Beispiel zeigt die Verwendung der UTC-Methode:

function TageZwischenDateUndHeute(jr, mo, tg)
{
  var d, r, t1, t2, t3;
  var MinMilli = 1000 * 60
  var StdMilli = MinMilli * 60
  var TagMilli = StdMilli * 24
  t1 = Date.UTC(jr, mo, tg)
  d = new Date();
  t2 = d.getTime();
  if (t2 >= t1)
    t3 = t2 - t1;
  else
    t3 = t1 - t2;
  r = Math.round(t3 / TagMilli);
  return(r);
}


UTC-Methode

UTC-Methode
Betrifft 		JScript-Sprachverzeichnis

Date-Objekt


UTC-Methode

UTC-Methode
Siehe auch 		JScript-Sprachverzeichnis

Date-Objektmethoden
setTime-Methode


Add-Methode (Dictionary)

Add-Methode (Dictionary) 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Fügt einem Dictionary-Objekt ein Schlüssel- und Elementpaar hinzu.
Syntax
Objekt.Add (Schlüssel, Element)

Die Add-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Schlüssel | Erforderlich. Der mit dem hinzugefügten Element verknüpfte Schlüssel.
Element | Erforderlich. Das mit dem hinzugefügten Schlüssel verknüpfte Element.

Anmerkungen
Ein Fehler tritt auf, wenn der Schlüssel bereits vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der Add-Methode:

var d;
d = new ActiveXObject("Scripting.Dictionary");
d.Add("a", "Athen");
d.Add("b", "Belgrad");
d.Add("c", "Kairo");


Add-Methode (Dictionary)

Add-Methode (Dictionary)
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


Add-Methode (Dictionary)

Add-Methode (Dictionary)
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Folders)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


CompareMode-Eigenschaft

CompareMode-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Setzt den Vergleichsmodus zum Vergleichen von Zeichenfolgenschlüsseln in einem Dictionary-Objekt und gibt diesen zurück.
Syntax
Objekt.CompareMode[ = Vergleich]

Die CompareMode-Eigenschaft hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Vergleich | Optional. Falls angegeben, ist Vergleich ein Wert, der den Vergleichsmodus darstellt. Akzeptierbare Werte sind 0 (Binär), 1 (Text) und 2 (Datenbank). Werte größer als 2 können für Verweise auf Vergleiche eingesetzt werden, die bestimmte LCIDs (Locale IDs) verwenden.

Anmerkungen
Ein Fehler tritt auf, wenn Sie den Vergleichsmodus eines Dictionary-Objekts ändern wollen, das bereits Daten enthält.

Das folgende Beispiel zeigt die Verwendung der CompareMode-Eigenschaft:

function CompareModeDemo(schluessel)
{
  //Erstellt Variablen.
  var a, d;
  var BinVergleich = 0, TextVergleich = 1;
  d = new ActiveXObject("Scripting.Dictionary");
  //Setzt den Vergleichsmodus auf Text
  d.CompareMode = TextVergleich;
  //Fügt Schlüssel und Elemente hinzu.
  d.Add("a", "Athen");
  d.Add("b", "Belgrad");
  d.Add("c", "Kairo");
  return(d.Item(schluessel));
}


CompareMode-Eigenschaft

CompareMode-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


CompareMode-Eigenschaft

CompareMode-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Key-Eigenschaft


Count-Eigenschaft

Count-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibgeschützte Eigenschaft, die die Zahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurückgibt.
Syntax
Objekt.Count

Objekt ist stets der Name eines Elements aus der Betrifft-Liste.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Count-Eigenschaft:
function CountDemo()
{
  var a, d, i, s;                // Erstellt Variablen.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athen");          // Fügt Schlüssel und Elemente hinzu.
  d.Add ("b", "Belgrad");
  d.Add ("c", "Kairo");
  a = (new VBArray(d.Keys( )));  // Ruft die Schlüssel ab.
  s = "";
  for (i = 0; i < d.Count; i++)  // Durchläuft das Dictionary-Objekt.
  {
     s += a.getItem(i) + " - " + d(a.getItem(i)) + "<br>";
  }
  return(s)    	         // Gibt das Ergebnis zurück.
}


Count-Eigenschaft

Count-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt
Drives-Auflistung
Files-Auflistung
Folders-Auflistung


Count-Eigenschaft

Count-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CompareMode-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft


Exists-Methode

Exists-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt true zurück, wenn ein angegebener Schlüssel in einem Dictionary-Objekt vorhanden ist. Gibt false zurück, wenn dem nicht so ist.
Syntax
Objekt.Exists(Schlüssel)

Die Syntax der Exists-Methode hat diese Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name des Dictionary-Objekts.
Schlüssel | Erforderlich. Der in dem Dictionary-Objekt gesuchte Schlüssel.

Das folgende Beispiel zeigt die Verwendung der Exists-Methode:

function ExistsDemo(k)
{
  var fso, s = "";
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athen");
  d.Add("b", "Belgrad");
  d.Add("c", "Kairo");
  if (d.Exists(k))
    s += "Der angegebene Schlüssel ist vorhanden.";
  else
    s += "Der angegebene Schlüssel ist nicht vorhanden.";
  return(s);
}


Exists-Methode

Exists-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


Exists-Methode

Exists-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Item-Eigenschaft

Item-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Setzt ein Element für einen angegebenen Schlüssel in einem Dictionary-Objekt bzw. gibt diesen zurück. Bei Auflistungen wird ein Element zurückgegeben, das auf den angegebenen Schlüssel basiert. Auf diese Eigenschaft kann lesend und schreibend zugegriffen werden.
Syntax
Objekt.Item(Schüssel)[ = NeuesElement]

Die Item-Eigenschaft hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name einer Auflistung oder eines Dictionary-Objekts.
Schlüssel | Erforderlich. Der mit dem abgerufenen oder hinzugefügten Element verknüpfte Schlüssel.
NeuesElement | Optional. Wird nur für das Dictionary-Objekt verwendet und findet bei Auflistungen keine Anwendung. Falls angegeben, ist NeuesElement der neue Wert, der mit dem angegebenen Schlüssel verknüpft wird.

Anmerkungen
Wenn Schlüssel beim Ändern eines Elements nicht gefunden wird, wird ein neuer Schlüssel erstellt, mit NeuesElement als Element. Wenn Schlüssel beim Versuch, ein vorhandenes Element zurückzugeben, nicht gefunden wird, wird ein neuer Schlüssel erstellt. Das entsprechende Element bleibt dann leer.

Das folgende Beispiel zeigt die Verwendung der Item-Eigenschaft:

function ItemDemo(schluessel)
{
  var a, d;
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athen");
  d.Add("b", "Belgrad");
  d.Add("c", "Kairo");
  a = d.Item(schluessel);
  return(a);
}


Item-Eigenschaft

Item-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt
Drives-Auflistung
Files-Auflistung
Folders-Auflistung


Item-Eigenschaft

Item-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CompareMode-Eigenschaft
Count-Eigenschaft
Key-Eigenschaft


Items-Methode

Items-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Datenfeld zurück, das alle Elemente eines Dictionary-Objekts enthält.
Syntax
Objekt.Items( )

Objekt ist stets der Name des Dictionary-Objekts.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Items-Methode:
function ItemsDemo()
{
  var a, d, i, s;              // Erstellt Variablen.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athen");       // Fügt Schlüssel und Elemente hinzu
  d.Add ("b", "Belgrad");
  d.Add ("c", "Kairo");
  a = (new VBArray(d.Items())).toArray();    // Ruft die Elemente ab.
  s = "";
  for (i in a)               //Durchläuft das Datenfeld.
  {
    s += a[i] + "<br>";
  }
  return(s);           // Gibt das Ergebnis zurück.
}


Items-Methode

Items-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


Items-Methode

Items-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Exists-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Key-Eigenschaft

Key-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Setzt einen Schlüssel in einem Dictionary-Objekt.
Syntax
Objekt.Key(Schlüssel) = NeuSchlüssel

Die Key-Eigenschaft hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Schlüssel | Erforderlich. Der zu ändernde Schlüssel-Wert.
NeuSchlüssel | Erforderlich. Neuer Wert, der den angegebenen Schlüssel ersetzt.

Anmerkungen
Falls Schlüssel beim Ändern eines Schlüssels nicht gefunden wird, wird ein neuer Schlüssel erstellt. Das dazugehörige Element bleibt dann leer.

Das folgende Beispiel zeigt die Verwendung der Key-Eigenschaft:

var d;
d = new ActiveXObject("Scripting.Dictionary");

function EtwasHinzufuegen()
{
  d.Add("a", "Athen");
  d.Add("b", "Belgrad");
  d.Add("c", "Kairo");
}

function SchluesselAendern(alterSchluessel, neuerSchluessel)
{
  var s;
  d.Key("c") = "Ca";
  s = "Schlüssel " + alterSchluessel + " geändert in " + neuerSchluessel;
  return(s);
}


Key-Eigenschaft

Key-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


Key-Eigenschaft

Key-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CompareMode-Eigenschaft
Count-Eigenschaft
Item-Eigenschaft


Keys-Methode

Keys-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Datenfeld zurück, das alle in einem Dictionary-Objekt vorhandenen Schlüssel enthält.
Syntax
Objekt.Keys( )

Objekt ist stets der Name eines Dictionary-Objekts.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Keys-Methode:
function KeysDemo()
{
  var a, d, i, s;              // Erstellt Variablen.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athen");       // Fügt Schlüssel und Elemente hinzu
  d.Add ("b", "Belgrad");
  d.Add ("c", "Kairo");
  a = (new VBArray(d.Keys())).toArray();    // Ruft die Schlüssel ab.
  s = "";
  for (i in a)                 //Durchläuft das Datenfeld.
  {
    s += a[i] + " - " + d(a[i]) + "<br>";
  }
  return(s);           // Gibt das Ergebnis zurück.
}


Keys-Methode

Keys-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


Keys-Methode

Keys-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Remove-Methode
RemoveAll-Methode


Remove-Methode

Remove-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Entfernt ein Schlüssel-/Elementpaar aus einem Dictionary-Objekt.
Syntax
Objekt.Remove(Schlüssel)

Die Syntax der Remove-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Schlüssel | Erforderlich. Der mit dem Schlüssel-/Elementpaar verknüpfte Schlüssel, das aus dem Dictionary-Objekt entfernt werden soll.

Anmerkungen
Ein Fehler tritt auf, wenn das angegebene Schlüssel-/Elementpaar nicht vorhanden ist.

Der folgende Code verdeutlicht die Verwendung der Remove-Methode:

var a, d, i,s;          	 	  // Erstellt Variablen.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athen"); 		 // Fügt Schlüssel und Elemente hinzu.
d.Add ("b", "Belgrad");
d.Add ("c", "Kairo");
...
d.Remove("b") 		 // Entfernt das zweite Paar.


Remove-Methode

Remove-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


RemoveAll-Methode

RemoveAll-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Die RemoveAll-Methode entfernt alle Schlüssel-/Elementpaare aus einem Dictionary-Objekt.
Syntax
Objekt.RemoveAll( )

Objekt ist stets der Name eines Dictionary-Objekts.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der RemoveAll-Methode:

var a, d, i;          	  	 // Erstellt Variablen.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athen");  	    // Fügt Schlüssel und Elemente hinzu.
d.Add ("b", "Belgrad");
d.Add ("c", "Kairo");
...
d.RemoveAll( )  		// Löscht das Dictionary-Objekt.


RemoveAll-Methode

RemoveAll-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt


RemoveAll-Methode

RemoveAll-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode


Remove-Methode

Remove-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
RemoveAll-Methode


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf einem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
Syntax
Objekt.AvailableSpace

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Der von der AvailableSpace-Eigenschaft zurückgegebene Wert entspricht in der Regel dem von der FreeSpace-Eigenschaft zurückgegebenen Wert. Unterschiede zwischen beiden können bei Computersystemen auftreten, die Quoten unterstützen.

Der folgende Code verdeutlich die Verwendung der AvailableSpace-Eigenschaft:

function AvailableSpaceDemo(lwPfad)
{
    var fs, d, s;
    fs = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(lwPfad));
    s = "Laufwerk " + lwPfad.toUpperCase() + " - ";
    s += d.VolumeName + "<br>";
    s += "Freier Speicherplatz: " + d.AvailableSpace/1024 + " KB";
    return(s);
}


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Laufwerksbuchstaben eines physikalischen, lokalen Laufwerks oder eines Netzlaufwerks zurück. Schreibgeschützt.
Syntax
Objekt.DriveLetter

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Die DriveLetter-Eigenschaft gibt eine Nulllängenzeichenfolge ("") zurück, wenn das angegebene Laufwerk nicht mit einem Laufwerksbuchstaben verknüpft ist, z. B. wenn einem Netzlaufwerk kein Laufwerksbuchstabe zugeordnet wurde.

Der folgende Code verdeutlicht die Verwendung der DriveLetter-Eigenschaft:

function DriveLetterDemo(lwPfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(lwPfad));
    s = "Laufwerk " + d.DriveLetter.toUpperCase( ) + ": - ";
    s += d.VolumeName + "<br>";
    s += "Freier Speicherplatz: " + d.AvailableSpace/1024 + " KB";
    return(s);
}


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


DriveType-Eigenschaft

DriveType-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Wert zurück, der den Typ des angegebenen Laufwerks anzeigt.
Syntax
Objekt.DriveType

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der DriveType-Eigenschaft:
function DriveTypeDemo(lwPfad)
{
    var fso, d, s, t;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(lwPfad);
    switch (d.DriveType)
                {
        case 0: t = "Unbekannt"; break;
        case 1: t = "Austauschbar"; break;
        case 2: t = "Fest"; break;
        case 3: t = "Netzwerk"; break;
        case 4: t = "CD-ROM"; break;
        case 5: t = "RAM-Laufwerk"; break;
                }
    s = "Laufwerk " + d.DriveLetter + ": - " + t;
    return(s);
}


DriveType-Eigenschaft

DriveType-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


DriveType-Eigenschaft

DriveType-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


FileSystem-Eigenschaft

FileSystem-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
Syntax
Objekt.FileSystem

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Die verfügbaren Rückgabewerte sind FAT, NTFS und CDFS.

Der folgende Code verdeutlicht die Verwendung der FileSystem-Eigenschaft:

function FileSystemTypeDemo(lwPfad)
{
  var fso,d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(lwPfad);
  s = d.FileSystem;
  return(s);
}


FileSystem-Eigenschaft

FileSystem-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


FileSystem-Eigenschaft

FileSystem-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht. Schreibgeschützt.
Syntax
Objekt.FreeSpace

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Der von der FreeSpace-Eigenschaft zurückgegebene Wert entspricht in der Regel dem von der AvailableSpace-Eigenschaft zurückgegebenen Wert. Unterschiede zwischen beiden können bei Computersystemen auftreten, die Quoten unterstützen.

Der folgende Code verdeutlicht die Verwendung der FreeSpace-Eigenschaft:

function FreeSpaceDemo(lwPfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(lwPfad));
    s = "Laufwerk " + lwPfad.toUpperCase( ) + " - ";
    s += d.VolumeName + "
";
    s += "Freier Speicherplatz: " + d.FreeSpace/1024 + " KB";
    return(s);
}


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


IsReady-Eigenschaft

IsReady-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn das angegebene Laufwerk bereit ist. Ist dem nicht so, wird False zurückgegeben.
Syntax
Objekt.IsReady

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Bei Laufwerken mit austauschbaren Datenträgern und CD-ROM-Laufwerken gibt IsReady nur dann True zurück, wenn ein entsprechender Datenträger eingelegt und zugriffsbereit ist.

Der folgende Code verdeutlicht die Verwendung der IsReady-Eigenschaft:

function DriveIsReadyDemo(lwPfad)
{
    var fso, d, s, t;
    fso = new ActiveXObject("Scripting.FileSystemObject")
    d = fso.GetDrive(lwPfad)
    switch (d.DriveType)
    {
      case 0: t = "Unbekannt"; break;
      case 1: t = "Austauschbar"; break;
      case 2: t = "Fest"; break;
      case 3: t = "Netzwerk"; break;
      case 4: t = "CD-ROM"; break;
      case 5: t = "RAM-Laufwerk"; break;
    }
    s = "Laufwerk " + d.DriveLetter + ": - " + t;
    if (d.IsReady)
    {
        s += "\n" + "Laufwerk ist bereit.";
    }
    else
    {
        s += "<br>" + "Laufwerk ist nicht bereit.";
    }
    return(s);
}


IsReady-Eigenschaft

IsReady-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


IsReady-Eigenschaft

IsReady-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Path-Eigenschaft

Path-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerks zurück.
Syntax
Objekt.Path

Das Objekt ist stets ein File-, Folder- oder Drive-Objekt.

Anmerkungen
Bei Laufwerksbuchstaben ist der Hauptordner nicht enthalten. Der Pfad für das Laufwerk C: ist also C: und nicht C:\.

Der folgende Code verdeutlicht die Verwendung der Path-Eigenschaft mit einem File-Objekt:

function FileAccessInfoDemo(dateiAng)
{
    var fso, d, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = f.Path.toUpperCase() + "\n";
    s += "Erstellt: " + f.DateCreated + "
";
    s += "Letzter Zugriff: " + f.DateLastAccessed + "
";
    s += "Letzte Änderung: " + f.DateLastModified
    return(s);
}


Path-Eigenschaft

Path-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
File-Objekt
Folder-Objekt


Path-Eigenschaft

Path-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
AvailableSpace-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
Files-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft


RootFolder-Eigenschaft

RootFolder-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Folder-Objekt zurück, das den Hauptordner eines angegebenen Laufwerks darstellt. Schreibgeschützt.
Syntax
Objekt.RootFolder

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Mit Hilfe des zurückgegebenen Folder-Objekts kann auf alle Dateien und Ordner auf diesem Laufwerk zugegriffen werden.

Das folgende Beispiel zeigt die Verwendung der RootFolder-Eigenschaft:

function RootFolderDemo(laufw)
{
  var fso,d;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(laufw))
    {
      d = fso.GetDrive(laufw);
      return(d.RootFolder);
    }
  else
    return(false);
}


RootFolder-Eigenschaft

RootFolder-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


RootFolder-Eigenschaft

RootFolder-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
Syntax
Objekt.SerialNumber

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Mit Hilfe der SerialNumber-Eigenschaft können Sie sicherstellen, dass der richtige Datenträger in ein Laufwerk mit austauschbaren Datenträgern eingelegt ist.

Der folgende Code verdeutlicht die Verwendung der SerialNumber-Eigenschaft:

function DriveSerialNumberDemo(lwPfad)
{
    var fso, d, s, t;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(lwPfad)));
    switch (d.DriveType)
    {
      case 0: t = "Unbekannt"; break;
      case 1: t = "Austauschbar"; break;
      case 2: t = "Fest"; break;
      case 3: t = "Netzwerk"; break;
      case 4: t = "CD-ROM"; break;
      case 5: t = "RAM-Laufwerk"; break;
    }
    s = "Laufwerk " + d.DriveLetter + ": - " + t;
    s += "<br>" + "SN: " + d.SerialNumber;
    return(s);
}


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


ShareName-Eigenschaft

ShareName-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Namen des Netzwerkverzeichnisses eines angegebenen Laufwerks zurück.
Syntax
Objekt.ShareName

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Falls das Objekt kein Netzlaufwerk ist, gibt die ShareName-Eigenschaft eine Nulllängenzeichenfolge zurück ("").

Der folgende Code verdeutlicht die Verwendung der ShareName-Eigenschaft:

function DriveShareNameDemo(lwPfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(lwPfad)));
    s = "Laufwerk " + d.DriveLetter + ": - " + d.ShareName;
    return(s);
}


ShareName-Eigenschaft

ShareName-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


ShareName-Eigenschaft

ShareName-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


TotalSize-Eigenschaft

TotalSize-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den gesamten Speicherplatz (in Byte) eines Laufwerks oder Netzlaufwerks zurück.
Syntax
Objekt.TotalSize

Das Objekt ist stets ein Drive-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der TotalSize-Eigenschaft:
function DriveTotalSizeDemo(lwPfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(lwPfad)));
    s = "Laufwerk " + lwPfad + " - ";s +=d.VolumeName + "<>";
    s += "Insgesamt: " + d.TotalSize/1024 + " KB
";
    s += "<br>" + "Verfügbar: " + d.FreeSpace/1024 + " KB";
    return(s);
}


TotalSize-Eigenschaft

TotalSize-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


TotalSize-Eigenschaft

TotalSize-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
VolumeName-Eigenschaft


VolumeName-Eigenschaft

VolumeName-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt den Datenträgernamen des angegebenen Laufwerks bzw. gibt diesen zurück. Lesen/Schreiben.
Syntax
Objekt.VolumeName [= NeuerName]

Die VolumeName-Eigenschaft hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines Drive-Objekts.
NeuerName | Optional. Falls angegeben, ist NeuerName der neue Name des angegebenen Objekts.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der VolumeName-Eigenschaft:
function DriveVolumeNameDemo(lwPfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(lwPfad));
    s = "Laufwerk " + lwPfad + " - ";
    s+= d.VolumeName + "<br>";
    s+= "Insgesamt: "+ d.TotalSize/1024 + " KB <br>";
    s+= "Verfügbar: "+ d.FreeSpace/1024 + " KB";
    return(s);
}


VolumeName-Eigenschaft

VolumeName-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt


VolumeName-Eigenschaft

VolumeName-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft


atEnd-Methode

atEnd-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Booleschen Wert zurück, der angibt, ob sich der Aufzähler am Ende der Auflistung befindet.
Syntax
Enum.atEnd( )

Das Argument Enum ist ein beliebiges Enumerator-Objekt.

Rückgabewert
Die atEnd-Methode gibt true zurück, wenn das aktuelle Element das letzte in der Auflistung ist, die Auflistung leer ist oder das aktuelle Element nicht definiert ist. Ansonsten gibt sie false zurück.
Anmerkungen
In dem folgenden Code-Beispiel, wird die atEnd-Methode verwendet, um festzustellen, ob das Ende einer Liste von Laufwerken erreicht ist:
function atEndDemo()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Laufwerk nicht bereit]";
    s +=  n + "<br>";
  }
  return(s);
}


atEnd-Methode

atEnd-Methode
Betrifft 		JScript-Sprachverzeichnis

Enumerator-Objekt


atEnd-Methode

atEnd-Methode
Siehe auch 		JScript-Sprachverzeichnis

item-Methode
moveFirst-Methode
moveNext-Methode


item-Methode

item-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das aktuelle Element der Auflistung zurück.
Syntax
Enum.item( )

Das Argument Enum ist ein beliebiges Enumerator-Objekt.

Rückgabewert
Die item-Methode gibt das aktuelle Element zurück. Ist die Auflistung leer oder das aktuelle Element nicht definiert, gibt sie undefined zurück.
Anmerkungen

In dem folgenden Code-Beispiel wird die item-Methode verwendet, um ein Element aus der Drives-Auflistung zu erhalten:

function itemDemo()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Laufwerk nicht bereit]";
    s +=  n + "<br>";
  }
  return(s);
}


item-Methode

item-Methode
Betrifft 		JScript-Sprachverzeichnis

Enumerator-Objekt


item-Methode

item-Methode
Siehe auch 		JScript-Sprachverzeichnis

atEnd-Methode
moveFirst-Methode
moveNext-Methode


moveFirst-Methode

moveFirst-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt das aktuelle Element der Auflistung auf das erste Element zurück.
Syntax
Enum.moveFirst( )

Das Argument Enum ist ein beliebiges Enumerator-Objekt.

Anmerkungen
Befinden sich keine Elemente in der Auflistung, wird das aktuelle Element auf undefined gesetzt.

In dem folgenden Beispiel wird die moveFirst-Methode verwendet, um das Auswerten der Elemente der Drives-Auflistung am Anfang der Liste zu beginnen:

function FirstDemo()
{
  var fso, s, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  e.moveFirst();
  s = "";
  do
  {
     x = e.item();
     if (x.IsReady)
     {
       s = x.DriveLetter + ":";
       break;
     }
     else
       if (e.atEnd())
       {
         s = "Keine Laufwerke waren vorhanden";
         break;
       }
     e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


moveFirst-Methode

moveFirst-Methode
Betrifft 		JScript-Sprachverzeichnis

Enumerator-Objekt


moveFirst-Methode

moveFirst-Methode
Siehe auch 		JScript-Sprachverzeichnis

atEnd-Methode
item-Methode
moveNext-Methode


moveNext-Methode

moveNext-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt das aktuelle Element zum nächsten Element der Auflistung.
Syntax
Enum.moveNext( )

Das Argument Enum ist ein beliebiges Enumerator-Objekt.

Anmerkungen
Befindet sich der Aufzähler am Ende der Auflistung, oder ist die Auflistung leer, wird das aktuelle Element auf undefined gesetzt.

In dem folgenden Beispiel wird die moveNext-Methode verwendet, um zu dem nächsten Laufwerk in der Drives-Auflistung zu springen:

function moveNextDemo()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Laufwerk nicht bereit]";
    s +=  n + "<br>";
  }
  return(s);
}


moveNext-Methode

moveNext-Methode
Betrifft 		JScript-Sprachverzeichnis

Enumerator-Objekt


moveNext-Methode

moveNext-Methode
Siehe auch 		JScript-Sprachverzeichnis

atEnd-Methode
item-Methode
moveFirst-Methode


JScript-Fehlermeldungen

JScript-Fehlermeldungen 		Sprachverzeichnis

Fehlercode | Meldung
5 | Ungültiger Prozeduraufruf oder ungültiges Argument
6 | Überlauf
7 | Nicht genügend Speicher
9 | Index außerhalb des gültigen Bereichs
10 | Datenfeld ist unveränderlich oder momentan gesperrt
11 | Division durch Null
13 | Typen unverträglich
14 | Nicht genügend Zeichenfolgenspeicher
17 | Angeforderte Operation kann nicht durchgeführt werden
28 | Nicht genügend Stapelspeicher
35 | Sub- oder Function-Prozedur nicht definiert
48 | Fehler beim Laden einer DLL
51 | Interner Fehler
52 | Fehlerhafte(r) Dateiname oder -nummer
53 | Datei nicht gefunden
54 | Fehlerhafter Dateimodus
55 | Datei ist bereits geöffnet
57 | Fehler beim Lesen von/Schreiben auf Gerät
58 | Datei existiert bereits
61 | Datenträger voll
62 | Eingabe überschreitet Dateiende
67 | Zu viele Dateien
68 | Gerät nicht verfügbar
70 | Zugriff verweigert
71 | Datenträger nicht bereit
74 | Umbenennen bei Angabe unterschiedlicher Laufwerke nicht möglich
75 | Fehler beim Zugriff auf Pfad/Datei
76 | Pfad nicht gefunden
91 | Objektvariable oder Variable für With-Block nicht gesetzt
92 | For-Schleife nicht initialisiert
93 | Ungültige Musterzeichenfolge
94 | Unzulässige Verwendung von Null
322 | Erforderliche temporäre Datei kann nicht angelegt werden
424 | Objekt erforderlich
429 | Automations-Server kann Objekt nicht erstellen
430 | Klasse unterstützt keine Automatisierung
432 | Datei- oder Klassenname während der Automatisierungsoperation nicht gefunden
438 | Objekt unterstützt diese Eigenschaft oder Methode nicht
440 | Automatisierungsfehler
445 | Objekt unterstützt diese Aktion nicht
446 | Objekt unterstützt keine benannten Argumente
447 | Objekt unterstützt die aktuelle Ländereinstellung nicht
448 | Benanntes Argument nicht gefunden
449 | Argument ist nicht optional
450 | Falsche Anzahl an Argumenten oder ungültige Eigenschaftenzuweisung
451 | Objekt ist keine Auflistung
453 | Angegebene DLL-Funktion nicht gefunden
458 | Variable verwendet einen Automatisierungtyp, der in JScript nicht unterstützt wird
501 | Zuweisung an Variable nicht möglich
502 | Objekt nicht sicher für Skriptverarbeitung
503 | Objekt nicht sicher für Initialisierung
504 | Objekt nicht sicher für Erstellung
5000 | Zuweisung an 'this' nicht möglich
5001 | <Element> ist keine Zahl. Zahl erwartet
5002 | <Element> ist keine Funktion. Funktion erwartet
5003 | Kann dem Ergebnis einer Funktion nicht zugewiesen werden
5004 | <Element> ist kein indizierbares Objekt. Objekt kann nicht indiziert werden
5005 | <Element> ist keine Zeichenfolge. Zeichenfolge erwartet
5006 | <Element> ist kein Datumsobjekt. Date-Objekt erwartet
5007 | <Element> ist kein Objekt. Objekt erwartet
5008 | Zuweisung an <Element> nicht möglich. Ungültige Zuweisung
5009 | <Element> ist nicht definiert. Nicht definierter Bezeichner
5010 | <Element> ist nicht vom Typ Boolean. Boolean erwartet
5011 | Code eines freigegebenen Skripts kann nicht ausgeführt werden
5012 | <Element> kann nicht gelöscht werden. Member-Objekt erwartet
5013 | <Element> ist nicht vom Typ VBArray. VBArray erwartet
5014 | <Element> ist kein JScript-Objekt. JScript-Objekt erwartet
5015 | <Element> ist kein Aufzählungsobjekt. Enumerator-Objekt erwartet
5016 | <Element> ist kein Objekt mit regulärem Ausdruck. Regular Expression-Objekt erwartet
5017 | Syntaxfehler in regulärem Ausdruck
5018 | Unerwarteter Quantifier
5019 | Erwartet ']' in regulärem Ausdruck
5020 | Erwartet ')' in regulärem Ausdruck
5021 | Ungültiger Bereich in Zeichensatz


Attributes-Eigenschaft

Attributes-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Setzt die Attribute von Dateien bzw. Ordnern. Je nach Attribut Lesen/Schreiben oder schreibgeschützt.
Syntax
Objekt.Attributes [= NeueAttribute]

Die Attributes-Eigenschaft hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
NeueAttribute | Optional. Falls angegeben, ist NeueAttribute der neue Wert für die Attribute des angegebenen Objekts.

Einstellungen
Das Argument NeueAttribute kann beliebige der folgenden Werte bzw. beliebige Kombinationen der folgende Werte aufweisen:

Konstante | Wert | Beschreibung
Normal | 0 | Normale Datei. Keine Attribute werden gesetzt.
ReadOnly | 1 | Schreibgeschützte Datei. Für das Attribut gilt Lesen/Schreiben.
Hidden | 2 | Versteckte Datei. Für das Attribut gilt Lesen/Schreiben.
System | 4 | Systemdatei. Für das Attribut gilt Lesen/Schreiben.
Volume | 8 | Datenträgerbezeichnung des Festplattenlaufwerks. Das Attribut ist schreibgeschützt.
Directory | 16 | Ordner oder Verzeichnis. Das Attribut ist schreibgeschützt.
Archive | 32 | Datei hat sich nach der letzten Sicherung geändert. Für das Attribut gilt Lesen/Schreiben.
Alias | 64 | Verknüpfung oder Kurzbefehl. Das Attribut ist schreibgeschützt.
Compressed | 128 | Komprimierte Datei. Das Attribut ist schreibgeschützt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Attributes-Eigenschaft mit einer Datei:
function AttributesDemo(dateiAng)
{
  var fso, f, r;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(dateiAng)
  if (f.attributes && 32)
  {
    f.attributes = f.attributes - 32;
    s="Archive-Bit gelöscht.");
  }
  else
  {
    f.attributes = f.attributes + 32;
    s=( "Archive-Bit gesetzt.");
  }
  return(s);
}


Attributes-Eigenschaft

Attributes-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Attributes-Eigenschaft

Attributes-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Copy-Methode

Copy-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
Syntax
Objekt.Copy( Ziel[, überschreiben] )

Die Syntax der Copy-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
Ziel | Erforderlich. Ziel, in das die Datei oder der Ordner kopiert werden soll. Platzhalterzeichen sind nicht erlaubt.
überschreiben | Optional. Boolescher Wert, der True ist (Standard), wenn vorhandene Dateien oder Ordner überschrieben werden sollen. Er ist False, wenn dem nicht so sein soll.

Anmerkungen
Die Ergebnisse der Copy-Methode für ein File oder einen Folder sind identisch mit denen der Operationen, die mit Hilfe von FileSystemObject.CopyFile oder FileSystemObject.CopyFolder durchgeführt werden, bei denen die Datei oder der Ordner, auf die oder den Objekt verweist, als Argument übergeben wird. Beachten Sie jedoch, dass bei diesen alternativen Operationen mehrere Dateien bzw. Ordner kopiert werden können.

Das folgende Beispiel zeigt die Verwendung der Copy-Methode:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\test.txt", true);
f.WriteLine("Dies ist ein Test.");
f.Close();
f = fso.GetFile("c:\\test.txt");
f.Copy ("c:\\windows\\desktop\\test2.txt")


Copy-Methode

Copy-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Copy-Methode

Copy-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFile-Methode
CopyFolder-Methode
Delete-Methode
Move-Methode
OpenAsTextStream-Methode


CreateTextFile-Methode

CreateTextFile-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Erstellt eine Datei mit dem angegebenen Dateinamen und gibt ein TextStream-Objekt zurück, mit dem aus der Datei gelesen bzw. in die Datei geschrieben werden kann.
Syntax
Objekt.CreateTextFile(Dateiname[, Überschreiben[, Unicode]])

Die CreateTextFile-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Objekt ist stets der Name eines FileSystemObject- oder Folder-Objekts.
Dateiname | Erforderlich. Zeichenfolgenausdruck, der die zu erstellende Datei bezeichnet.
Überschreiben | Optional. Boolescher Wert, der angibt, ob eine vorhandene Datei überschrieben werden kann. Der Wert ist true, wenn die Datei überschrieben werden kann. Er ist false, wenn dem nicht so ist. Wird der Wert weggelassen, werden vorhandene Dateien nicht überschrieben.
Unicode | Optional. Boolescher Wert, der angibt, ob die Datei als Unicode- oder ASCII-Datei erstellt wird. Der Wert ist true, wenn die Datei als Unicode-Datei erstellt wird. Er ist false, wenn sie als ASCII-Datei erstellt wird. Bei Weglassen des Wertes wird eine ASCII-Datei erstellt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der CreateTextFile-Methode zum Erstellen und Öffnen einer Textdatei:
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\test.txt", true);
a.WriteLine("Dies ist ein Test.");
a.Close();
Ist das Argument Überschreiben false oder wird es nicht angegeben, tritt für einen bereits vorhandenen Dateinamen ein Fehler auf.


CreateTextFile-Methode

CreateTextFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt
Folder-Objekt


CreateTextFile-Methode

CreateTextFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CreateFolder-Methode
OpenAsTextStream-Methode
OpenTextFile-Methode


DateCreated-Eigenschaft

DateCreated-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Uhrzeit zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde. Schreibgeschützt.
Syntax
Objekt.DateCreated

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der DateCreated-Eigenschaft mit einer Datei:
function DateCreatedDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = "Erstellt: " + f.DateCreated;
    return(s);
}


DateCreated-Eigenschaft

DateCreated-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


DateCreated-Eigenschaft

DateCreated-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Uhrzeit zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde. Schreibgeschützt.
Syntax
Objekt.DateLastAccessed

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der DateLastAccessed-Eigenschaft mit einer Datei:
function DateLastAccessedDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = dateiAng.toUpperCase() + "<br>";
    s += "Erstellt: " + f.DateCreated + "<br>";
    s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
    s += "Letzte Änderung: " + f.DateLastModified
    return(s);
}
Wichtig Das Verhalten dieser Methode hängt von dem verwendeten Betriebssystem ab. Unterstützt dieses keine Zeitinformationen, wird nichts zurückgegeben.


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Uhrzeit zurück, an denen die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde. Schreibgeschützt.
Syntax
Objekt.DateLastModified

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der DateLastModified-Eigenschaft mit einer Datei:
function DateLastModifiedDemo(dateiAng)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(dateiAng);
  s = dateiAng.toUpperCase() + "<br>";
  s += "Erstellt: " + f.DateCreated + "<br>";
  s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
  s += "Letzte Änderung: " + f.DateLastModified;
  return(s);
}


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Delete-Methode

Delete-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
Syntax
Objekt.Delete( erzwingen );

Die Syntax der Delete-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
erzwingen | Optional. Boolescher Wert, der True ist, wenn Dateien oder Ordner mit gesetztem Schreibschutzattribut gelöscht werden sollen. Der Wert ist False (Standard), wenn dem nicht so sein soll.

Anmerkungen
Ein Fehler tritt auf, wenn die angegebene Datei bzw. der angegebene Ordner nicht vorhanden ist.

Die Ergebnisse der Delete-Methode für ein File-Objekt oder ein Folder-Objekt entsprechen denen der Operationen, die mit Hilfe von FileSystemObject.DeleteFile oder FileSystemObject.DeleteFolder durchgeführt werden.

Die Delete-Methode unterscheidet nicht zwischen Ordnern mit oder ohne Inhalt. Die ausgewählten Ordner werden ungeachtet des Inhalts gelöscht.

Das folgende Beispiel zeigt die Verwendung der Delete-Methode:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\test.txt", true);
f.WriteLine("Dies ist ein Test.");
f.Close();
f = fso.GetFile("c:\\test.txt");
f.Delete();


Delete-Methode

Delete-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Delete-Methode

Delete-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
DeleteFile-Methode
DeleteFolder-Methode
Move-Methode
OpenAsTextStream-Methode


Drive-Eigenschaft

Drive-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Buchstaben des Laufwerks zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet. Schreibgeschützt.
Syntax
Objekt.Drive

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Drive-Eigenschaft:
function FileDriveDemo(dateiAng)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(dateiAng);
  s = f.Name + " auf Laufwerk " + f.Drive + "<br>";
  s += "Erstellt: " + f.DateCreated + "<br>";
  s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
  s += "Letzte Änderung: " + f.DateLastModified;
  return(s);
}


Drive-Eigenschaft

Drive-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Drive-Eigenschaft

Drive-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Move-Methode

Move-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
Syntax
Objekt.Move( Ziel );

Die Syntax der Move-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
Ziel | Erforderlich. Ziel, in das die Datei oder der Ordner verschoben werden soll. Platzhalterzeichen sind nicht erlaubt.

Anmerkungen
Die Ergebnisse der Move-Methode für ein File oder einen Folder sind identisch mit denen der Operationen, die mit Hilfe von FileSystemObject.MoveFile oder FileSystemObject.MoveFolder durchgeführt werden. Beachten Sie jedoch, dass bei diesen alternativen Operationen mehrere Dateien bzw. Ordner verschoben werden können.


Move-Methode

Move-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Move-Methode

Move-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
Delete-Methode
MoveFile-Methode
MoveFolder-Methode
OpenAsTextStream-Methode


Name-Eigenschaft

Name-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Setzt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners oder gibt diesen zurück. Lesen/Schreiben.
Syntax
Objekt.Name [= NeuerName]

Die Name-Eigenschaft hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
NeuerName | Optional. Falls angegeben, ist NeuerName der neue Name des angegebenen Objekts.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Name-Eigenschaft:
function FileNameDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = f.Name + " auf Laufwerk " + f.Drive + "<br>";
    s += "Erstellt: " + f.DateCreated + "<br>";
    s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
    s += "Letzte Änderung: " + f.DateLastModified;
    return(s);
}


Name-Eigenschaft

Name-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Name-Eigenschaft

Name-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


OpenAsTextStream-Methode

OpenAsTextStream-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
Syntax
Objekt.OpenAsTextStream([E/A-Modus, [Format]])

Die Syntax der OpenAsTextStream-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines File-Objekts.
E/A-Modus | Optional. Gibt den Ein-/Ausgabemodus an. Es gibt drei mögliche Konstanten: ForReading, ForWriting oder ForAppending.
Format | Optional. Einer von drei Tristate-Werten, mit denen das Format der geöffneten Datei angezeigt wird. Ohne Angabe wird die Datei als ASCII geöffnet.

Einstellungen
Das Argument E/A-Modus kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
ForReading | 1 | Öffnet eine Datei nur zum Lesen. Schreibzugriffe sind nicht möglich.
ForWriting | 2 | Öffnet eine Datei zum Schreiben. Existiert eine Datei mit demselben Namen, wird der vorherige Inhalt überschrieben.
ForAppending | 8 | Öffnet eine Datei und schreibt an das Dateiende.

Das Argument Format kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
TristateUseDefault | -2 | Öffnen der Datei im Format der System-Voreinstellung.
TristateTrue | -1 | Öffnen der Datei im Unicode-Format.
TristateFalse | 0 | Öffnen der Datei im ASCII-Format.

Anmerkungen
Die OpenAsTextStream-Methode bietet dieselbe Funktionalität wie die OpenTextFile-Methode von FileSystemObject. Darüber hinaus kann die OpenAsTextStream-Methode zum Schreiben in eine Datei verwendet werden.

Der folgende Code verdeutlicht das Verwenden der OpenAsTextStream-Methode:

function OpenAsTextStreamDemo( )
{
    var fso, f, ts, s;
    var ForReading = 1, ForWriting = 2, ForAppending = 8;
    var TristateUseDefault = -2, TristateTrue = -1, TristateFalse = 0;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    fso.CreateTextFile( "test1.txt" );           // Erstellt eine Datei.
    f = fso.GetFile("test1.txt");
    ts = f.OpenAsTextStream(ForWriting, TristateUseDefault);
    ts.Write( "Hallo Welt" );
    ts.Close( );
    ts = f.OpenAsTextStream(ForReading, TristateUseDefault);
    s = ts.ReadLine( );
    ts.Close( );
    return(s);
}


OpenAsTextStream-Methode

OpenAsTextStream-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt


OpenAsTextStream-Methode

OpenAsTextStream-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
CreateTextFile-Methode
Delete-Methode
Move-Methode
OpenTextFile-Methode


OpenTextFile-Methode

OpenTextFile-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 2

Siehe auch Betrifft

Beschreibung
Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
Syntax
Objekt.OpenTextFile(Dateiname[, E/A- Modus[, Erstellen[ , Format ]]])

Die Syntax der OpenTextFile-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Das Objekt ist stets der Name eines FileSystemObject.
Dateiname | Erforderlich. Zeichenfolgenausdruck, der die zu öffnende Datei angibt.
E/A-Modus | Optional. Es gibt drei mögliche Konstanten: ForReading, ForWriting oder ForAppending.
Erstellen | Optional. Boolescher Wert, der angibt, ob eine neue Datei erstellt werden soll, wenn der angegebene Dateiname nicht existiert. True, wenn eine neue, False, wenn keine neue Datei erstellt werden soll. Falls ausgelassen, wird keine neue Datei erstellt.
Format | Optional. Einer von drei Tristate-Werten, mit denen das Format der geöffneten Datei angezeigt wird. Ohne Angabe wird die Datei als ASCII geöffnet.

Einstellungen
Das Argument E/A-Modus kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
ForReading | 1 | Öffnet eine Datei nur zum Lesen. Schreibzugriffe sind nicht möglich.
ForWriting | 2 | Öffnet eine Datei zum Schreiben.
ForAppending | 8 | Öffnet eine Datei und schreibt an das Dateiende.

Das Argument Format kann eine der folgenden Einstellungen aufweisen:

Wert | Beschreibung
TristateTrue | Öffnet die Datei als Unicode.
TristateFalse | Öffnet die Datei als ASCII.
TristateUseDefault | Öffnet die Datei mit der Systemvorgabe.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der OpenTextFile-Methode, um eine Datei zum Anfügen von Text zu öffnen:
var fso, a, ForAppending;
ForAppending = 8;
fso = new ActiveXObject("Scripting.FileSystemObject");
a = fso.OpenTextFile("c:\\test.txt", ForAppending, false);
...
a.Close();


OpenTextFile-Methode

OpenTextFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


OpenTextFile-Methode

OpenTextFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CreateTextFile-Methode
OpenAsTextStream-Methode


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das Folder-Objekt des übergeordneten Objekts der angegebenen Datei bzw. des angegebenen Ordners zurück. Schreibgeschützt.
Syntax
Objekt.ParentFolder

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der ParentFolder-Eigenschaft mit einer Datei:
function ParentFolderDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = f.Name + " in " + f.ParentFolder + "<br>";
    s += "Erstellt: " + f.DateCreated + "<br>";
    s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
    s += "Letzte Änderung: " + f.DateLastModified;
    return(s);
}


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


ShortName-Eigenschaft

ShortName-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Syntax
Objekt.ShortName

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der ShortName-Eigenschaft mit einem File-Objekt:
function FileShortNameDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = "Der Kurzname für " +  f.Name;
    s += "<br>";
    s += "ist: " + f.ShortName;
    return(s);
}


ShortName-Eigenschaft

ShortName-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


ShortName-Eigenschaft

ShortName-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


ShortPath-Eigenschaft

ShortPath-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Syntax
Objekt.ShortPath

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der ShortPath-Eigenschaft mit einem File-Objekt:
function FileShortPathDemo(dateiAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(dateiAng);
    s = "Der Kurzpfad für " + f.Name;
    s += "<br>";
    s += "ist: "  + f.ShortPath;
    return(s);
}


ShortPath-Eigenschaft

ShortPath-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


ShortPath-Eigenschaft

ShortPath-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Size-Eigenschaft

Size-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt für File-Objekte die Größe (in Byte) der angegebenen Datei an. Gibt für Folder-Objekte die Größe (in Byte) aller in dem Ordner enthaltenen Dateien und untergeordneten Ordner an.
Syntax
Objekt.Size

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Size-Eigenschaft mit einem Folder-Objekt:
function FolderSizeDemo(ordnerAng)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFolder(ordnerAng);
    s = f.Name + " verwendet " + f.size + " Byte.";
    return(s);
}


Size-Eigenschaft

Size-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Size-Eigenschaft

Size-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


BuildPath-Methode

BuildPath-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Hängt einen Namen an einen vorhandenen Pfad an.
Syntax
Objekt.BuildPath(Pfad, Name)

Die Syntax der BuildPath-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfad | Erforderlich. Vorhandener Pfad, an den der Name angehängt wird. Der Pfad kann absolut oder relativ sein und muss keinen vorhandenen Ordner angeben.
Name | Erforderlich. Name, der an den vorhandenen Pfad angehängt wird.

Anmerkungen
Die BuildPath-Methode fügt, nur falls erforderlich, ein zusätzliches Pfadtrennzeichen zwischen den vorhandenen Pfad und den Namen ein.

Das folgende Beispiel zeigt die Verwendung der BuildPath-Methode:

function GibBuildPathAus(pfad)
{
  var fso, neuerpfad;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  neuerpfad = fso.BuildPath(pfad, "Neuer Ordner");
  return(neuerpfad);
}


BuildPath-Methode

BuildPath-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


BuildPath-Methode

BuildPath-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFileName-Methode
GetParentFolderName-Methode
GetTempName-Methode


CopyFile-Methode

CopyFile-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert eine oder mehrere Dateien aus einem Speicherort in einen anderen.
Syntax
Objekt.CopyFile ( Quelle, Ziel[, Überschreiben] )

Die Syntax der CopyFile-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Das Objekt ist stets der Name eines FileSystemObject.
Quelle | Erforderlich. Zeichenfolge zur Angabe der zu kopierenden Dateien, die Platzhalterzeichen enthalten darf.
Ziel | Erforderlich. Zeichenfolge zur Angabe des Ziels, in das die Dateien aus der Quelle kopiert werden sollen. Platzhalterzeichen sind nicht erlaubt.
Überschreiben | Optional. Boolescher Wert, der angibt, dass vorhandene Dateien überschrieben werden sollen. Ist dieser True, werden vorhandene Dateien überschrieben, ist er False, werden sie nicht überschrieben. Der Standard ist True. Beachten Sie, dass CopyFile fehlschlägt, wenn für Ziel das Schreibschutzattribut gesetzt ist. Dabei ist der Wert von Überschreiben nicht relevant.

Anmerkungen
Platzhalterzeichen dürfen nur in der letzten Pfadkomponente des Arguments Quelle verwendet werden. Dies ist z. B. erlaubt:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\EigeneDateien\\Briefe\\*.doc", "c:\\temp\\")
Dies hingegen nicht:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\EigeneDateien\\*\\R1???97.xls ", "c:\\temp")
Wenn die Quelle Platzhalterzeichen enthält oder das Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass das Ziel ein vorhandener Ordner ist, in den die übereinstimmenden Dateien kopiert werden. Andernfalls ist das Ziel der Name einer zu erstellenden Datei. Folgende drei Situationen können eintreten, wenn eine einzelne Datei kopiert wird.
  • Falls das Ziel nicht vorhanden ist, wird die Quelle kopiert. Dies ist der Normalfall.
  • Falls das Ziel eine vorhandene Datei ist, tritt ein Fehler auf, wenn Überschreiben auf False eingestellt ist. Andernfalls wird versucht, die Quelle über die vorhandene Datei zu kopieren.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Es kommt weiterhin zu einem Fehler, wenn eine Quelle mit Platzhalterzeichen mit keiner der Dateien übereinstimmt. Die CopyFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.


CopyFile-Methode

CopyFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


CopyFile-Methode

CopyFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
CopyFolder-Methode
CreateTextFile-Methode
DeleteFile-Methode
MoveFile-Methode


CopyFolder-Methode

CopyFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert einen Ordner rekursiv aus einem Speicherort in einen anderen.
Syntax
Objekt.CopyFolder ( Quelle, Ziel [, Überschreiben] );

Die Syntax der CopyFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Quelle | Erforderlich. Zeichenfolge zur Angabe der zu kopierenden Ordner, die Platzhalterzeichen enthalten darf.
Ziel | Erforderlich. Zeichenfolge zur Angabe des Ziels, in das die Ordner und untergeordneten Ordner aus der Quelle kopiert werden sollen. Platzhalterzeichen sind nicht erlaubt.
Überschreiben | Optional. Boolescher Wert, der angibt, dass vorhandene Ordner überschrieben werden sollen. Ist dieser True, werden vorhandene Dateien überschrieben, ist er False, werden sie nicht überschrieben. Der Standard ist True.

Anmerkungen
Platzhalterzeichen dürfen nur in der letzten Pfadkomponente des Arguments Quelle verwendet werden. Dies ist z. B. erlaubt:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\EigeneDateien\\Briefe\\*", "c:\\temp\\")
Dies hingegen nicht:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\EigeneDateien\\*\\*", "c:\\temp\\")
Wenn die Quelle Platzhalterzeichen enthält oder das Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass das Ziel ein vorhandener Ordner ist, in den die übereinstimmenden Ordner und Unterordner kopiert werden. Andernfalls ist das Ziel der Name eines zu erstellenden Ordners. Folgende vier Situationen können eintreten, wenn ein einzelner Ordner kopiert wird.
  • Falls das Ziel nicht vorhanden ist, wird der Quellordner mit seinem vollständigen Inhalt kopiert. Dies ist der Normalfall.
  • Falls das Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls das Ziel ein Verzeichnis ist, wird versucht, den Ordner samt Inhalt zu kopieren. Falls eine Datei in Quelle bereits im Ziel vorhanden ist, tritt ein Fehler auf, wenn Überschreiben auf False gesetzt ist. Andernfalls wird versucht, die Quelle über die vorhandene Datei zu kopieren.
  • Falls das Ziel ein schreibgeschütztes Verzeichnis ist, tritt ein Fehler auf, wenn eine vorhandene schreibgeschützte Datei in dieses Verzeichnis kopiert werden soll und Überschreiben auf False eingestellt ist.
Es kommt weiterhin zu einem Fehler, wenn eine Quelle mit Platzhalterzeichen mit keinem der Ordner übereinstimmt.

Die CopyFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.


CopyFolder-Methode

CopyFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


CopyFolder-Methode

CopyFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFile-Methode
Copy-Methode
CreateFolder-Methode
DeleteFolder-Methode
MoveFolder-Methode


CreateFolder-Methode

CreateFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Erstellt einen Ordner.
Syntax
Objekt.CreateFolder(Ordnername)

Die CreateFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Ordnername | Erfoderlich. Zeichenfolgenausdruck, der den zu erstellenden Ordner bezeichnet.

Anmerkungen
Ein Fehler tritt auf, wenn der angegebene Ordner bereits vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der CreateFolder-Methode, um einen neuen Ordner zu erstellen:

var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateFolder("c:\\neuer ordner");


CreateFolder-Methode

CreateFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


CreateFolder-Methode

CreateFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFolder-Methode
DeleteFolder-Methode
MoveFolder-Methode


DeleteFile-Methode

DeleteFile-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Löscht eine angegebene Datei.
Syntax
Objekt.DeleteFile ( Dateiangabe[, Erzwingen] );

Die Syntax der DeleteFile-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Dateiangabe | Erforderlich. Name der zu löschenden Datei. Dateiangabe darf in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Erzwingen | Optional. Boolescher Wert, der True ist, wenn Dateien mit gesetztem Schreibschutzattribut gelöscht werden sollen. Er ist False (Standard), wenn dem nicht so sein soll.

Anmerkungen
Ein Fehler tritt auf, wenn keine übereinstimmenden Dateien gefunden werden. Die DeleteFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der DeleteFile-Methode:

function DeleteFile(dateiAng)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFile(dateiAng);
}


DeleteFile-Methode

DeleteFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


DeleteFile-Methode

DeleteFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFile-Methode
CreateTextFile-Methode
Delete-Methode
DeleteFolder-Methode
MoveFile-Methode


DeleteFolder-Methode

DeleteFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Löscht einen angegebenen Ordner samt Inhalt.
Syntax
Objekt.DeleteFolder ( Ordnerangabe[, Erzwingen] );

Die Syntax der DeleteFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Ordnerangabe | Erforderlich. Name des zu löschenden Ordners. Ordnerangabe darf in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Erzwingen | Optional. Boolescher Wert, der True ist, wenn Ordner mit gesetztem Schreibschutzattribut gelöscht werden sollen. Er ist False (Standard), wenn dem nicht so sein soll.

Anmerkungen
Die DeleteFolder-Methode unterscheidet nicht zwischen Ordnern mit oder ohne Inhalt. Die ausgewählten Ordner werden ungeachtet des Inhalts gelöscht.

Ein Fehler tritt auf, wenn keine übereinstimmenden Ordner gefunden werden. Die DeleteFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der DeleteFolder-Methode:

function DeleteFolder(ordnerAng)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFolder(ordnerAng)
}


DeleteFolder-Methode

DeleteFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


DeleteFolder-Methode

DeleteFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFolder-Methode
CreateFolder-Methode
Delete-Methode
DeleteFile-Methode
MoveFolder-Methode


DriveExists-Methode

DriveExists-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, bzw. andernfalls False.
Syntax
Objekt.DriveExists(Laufwerksangabe)

Die Syntax der DriveExists-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Laufwerksangabe | Erforderlich. Ein Laufwerksbuchstabe bzw. eine vollständige Pfadangabe.

Anmerkungen
Für Laufwerke mit austauschbaren Datenträgern gibt die DriveExists-Methode True zurück, auch wenn kein Datenträger eingelegt ist. Verwenden Sie die IsReady-Eigenschaft des Drive-Objekts, um festzustellen, ob das Laufwerk bereit ist.

Das folgende Beispiel zeigt die Verwendung der DriveExists-Methode:

function BerichtLaufwerkStatus(laufw)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(laufw))
    s += "Laufwerk  " + laufw + " existiert.";
  else
    s += "Laufwerk  " + laufw + " existiert nicht.";
  return(s);
}


DriveExists-Methode

DriveExists-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


DriveExists-Methode

DriveExists-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Auflistung
FileExists-Methode
FolderExists-Methode
GetDrive-Methode
GetDriveName-Methode
IsReady-Eigenschaft


Drives-Eigenschaft

Drives-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
Syntax
Objekt.Drives

Das Objekt ist stets ein FileSystemObject.

Anmerkungen
In Laufwerken mit austauschbaren Datenträgern muss kein Datenträger eingelegt sein, damit diese in der Drives-Auflistung angezeigt werden.

Sie können die Elemente der Drives-Auflistung mit dem Enumerator-Objekt und der for-Anweisung durchlaufen:

function GibLaufwerksListeAus()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Laufwerk nicht bereit]";
    s +=  n + "<br>";
  }
  return(s);
}


Drives-Eigenschaft

Drives-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


Drives-Eigenschaft

Drives-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drives-Auflistung
Files-Eigenschaft
SubFolders-Eigenschaft


FileExists-Methode

FileExists-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn die angegebene Datei vorhanden ist. Gibt False zurück, wenn dem nicht so ist.
Syntax
Objekt.FileExists(Dateiangabe)

Die Syntax der FileExists-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Dateiangabe | Erforderlich. Der Name der Datei, deren Vorhandensein bestimmt werden soll. Ein vollständiger Pfad (entweder absolut oder relativ) muss angegeben werden, wenn anzunehmen ist, dass die Datei nicht in dem aktuellen Ordner vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der FileExists-Methode:

function BerichtDateiStatus(dateiAng)
{
  var fso, s = dateiAng;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FileExists(dateiAng))
    s += " existiert.";
  else
    s += " existiert nicht.";
  return(s);
}


FileExists-Methode

FileExists-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


FileExists-Methode

FileExists-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

DriveExists-Methode
FolderExists-Methode
GetFile-Methode
GetFileName-Methode


FolderExists-Methode

FolderExists-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn der angegebene Ordner vorhanden ist. Gibt False zurück, wenn dem nicht so ist.
Syntax
Objekt.FolderExists(Ordnerangabe)

Die Syntax der FolderExists-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Ordnerangabe | Erforderlich. Der Name des Ordners, dessen Vorhandensein bestimmt werden soll. Ein vollständiger Pfad (entweder absolut oder relativ) muss angegeben werden, wenn anzunehmen ist, dass der Ordner nicht in dem aktuellen Ordner vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der FolderExists-Methode:

function BerichtOrdnerStatus(ordner)
{
  var fso, s = ordner;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(ordner))
    s += " existiert.";
  else
    s += " existiert nicht.";
  return(s);
}


FolderExists-Methode

FolderExists-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


FolderExists-Methode

FolderExists-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

DriveExists-Methode
FileExists-Methode
GetFolder-Methode
GetParentFolderName-Methode


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt aus einer angegebenen Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
Syntax
Objekt.GetAbsolutePathName(Pfadangabe)

Die Syntax der GetAbsolutePathName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfadangabe | Erforderlich. Pfadangabe, die in einen vollständigen und eindeutigen Pfad geändert werden soll.

Anmerkungen
Ein Pfad ist vollständig und eindeutig, wenn er einen vollständigen Verweis auf das Stammverzeichnis des angegebenen Laufwerks enthält. Ein vollständiger Pfad darf nur mit einem Pfadtrennzeichen (\) enden, wenn er das Stammverzeichnis eines zugeordneten Laufwerks angibt.

Für die folgende Tabelle, die die Funktionsweise der GetAbsolutePathName-Methode verdeutlichen soll, wird angenommen, dass c:\EigeneDateien\Berichte das aktuelle Verzeichnis ist.

Pfadangabe | Rückgabepfad
"c:" | "c:\ EigeneDateien\Berichte"
"c:.." | "c:\EigeneDateien"
"c:\\" | "c:\"
"c:*.*\\Mai97" | "c:\EigeneDateien\Berichte\*.*\Mai97"
"Regiona1" | "c:\EigeneDateien\Berichte\Regiona1"
"c:\\..\\..\\EigeneDateien" | "c:\EigeneDateien"

Das folgende Beispiel zeigt die Verwendung der GetAbsolutePathName-Methode:

function ZeigeAbsolutenPfadAn(pfad)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetAbsolutePathName(pfad);
  return(s);
}


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetBaseName-Methode

GetBaseName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Basisnamen der letzten Komponente (ohne Dateinamenserweiterung) eines Pfades enthält.
Syntax
Objekt.GetBaseName(Pfad)

Die Syntax der GetBaseName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren Basisname zurückgegeben werden soll.

Anmerkungen
Die GetBaseName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn keine Komponente mit dem Pfad-Argument übereinstimmt.
Hinweis Die GetBaseName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.

Das folgende Beispiel zeigt die Verwendung der GetBaseName-Methode:

function ZeigeBasisNameAn(dateiAng)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetBaseName(dateiAng);
  return(s);
}


GetBaseName-Methode

GetBaseName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetBaseName-Methode

GetBaseName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetDrive-Methode

GetDrive-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Drive-Objekt zurück, das dem Laufwerk in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetDrive (Laufwerksangabe);

Die Syntax der GetDrive-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Laufwerksangabe | Erforderlich. Das Argument Laufwerksangabe kann ein Laufwerksbuchstabe (c), ein Laufwerksbuchstabe mit angefügtem Doppelpunkt (c:), ein Laufwerksbuchstabe mit angefügtem Doppelpunkt und Pfadtrennzeichen (c:\) oder eine Netzlaufwerksangabe (\\Computer2\Freigabe1) sein.

Anmerkungen
Bei Netzlaufwerken wird geprüft, ob diese vorhanden sind.

Ein Fehler tritt auf, wenn Laufwerksangabe nicht einem dieser erlaubten Formate entspricht oder nicht vorhanden ist.

Verwenden Sie zum Aufrufen der GetDrive-Methode für eine normale Pfadzeichenfolge die folgende Sequenz, um eine Zeichenfolge abzurufen, die als Laufwerksangabe geeignet ist:

LaufwerkAng = GetDriveName(GetAbsolutePathName(Path))
Das folgende Beispiel zeigt die Verwendung der GetDrive-Methode:
function ZeigeFreienSpeicherplatzAn(pfad)
{
  var fso, d, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(pfad));
  s = "Laufwerk " + pfad.toUpperCase( ) + " - ";
  s += d.VolumeName + "<br>";
  s += "Freier Speicherplatz: " + d.FreeSpace/1024 + " KB";
  return(s);
}


GetDrive-Methode

GetDrive-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetDrive-Methode

GetDrive-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetDriveName-Methode

GetDriveName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Namen des Laufwerks in einem angegebenen Pfad enthält.
Syntax
Objekt.GetDriveName(Pfad)

Die Syntax der GetDriveName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren Laufwerksnamen zurückgegeben werden soll.

Anmerkungen
Die GetDriveName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn das Laufwerk nicht bestimmt werden kann.
Hinweis Die GetDriveName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.

Das folgende Beispiel zeigt die Verwendung der GetDriveName-Methode:

function GibLaufwerksBuchstabenAus(pfad)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(pfad)));
  return(s);
}


GetDriveName-Methode

GetDriveName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetDriveName-Methode

GetDriveName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetExtensionName-Methode

GetExtensionName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfades enthält.
Syntax
Objekt.GetExtensionName(Pfad)

Die Syntax der GetExtensionName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren Erweiterungsname zurückgegeben werden soll.

Anmerkungen
Bei Netzlaufwerken gilt das Stammverzeichnis (\) als Komponente.

Die GetExtensionName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn keine Komponente mit dem Pfad-Argument übereinstimmt.

Das folgende Beispiel zeigt die Verwendung der GetExtensionName-Methode:

function ZeigeErweiterungsNameAn(dateiAng)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetExtensionName(dateiAng);
  return(s);
}


GetExtensionName-Methode

GetExtensionName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetExtensionName-Methode

GetExtensionName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFile-Methode

GetFile-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein File-Objekt zurück, das der Datei in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetFile(Dateiangabe)

Die Syntax der GetFile-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Dateiangabe | Erforderlich. Dateiangabe ist der Pfad (absolut oder relativ) zu einer bestimmten Datei.

Anmerkungen
Ein Fehler tritt auf, wenn die angegebene Datei nicht vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der GetFile-Methode:

function ZeigeDateiZugriffInfoAn(dateiAng)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(dateiAng);
  s = f.Path.toUpperCase() + "<br>";
  s += "Erstellt: " + f.DateCreated + "<br>";
  s += "Letzter Zugriff: " + f.DateLastAccessed + "<br>";
  s += "Letzte Änderung: " + f.DateLastModified;
  return(s);
}


GetFile-Methode

GetFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetFile-Methode

GetFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFileName-Methode

GetFileName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die letzte Komponente des angegebenen Pfades zurück, die nicht Teil der Laufwerksangabe ist.
Syntax
Objekt.GetFileName(Pfadangabe)

Die Syntax der GetFileName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfadangabe | Erforderlich. Der Pfad (absolut oder relativ) zu einer bestimmten Datei.

Anmerkungen
Die GetFileName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn die Pfadangabe nicht mit einer benannten Komponente endet.
Hinweis Die GetFileName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.

Das folgende Beispiel zeigt die Verwendung der GetFileName-Methode:

function ZeigeDateiNameAn(dateiAng)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetFileName(dateiAng);
  return(s);
}


GetFileName-Methode

GetFileName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetFileName-Methode

GetFileName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFolder-Methode

GetFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Folder-Objekt zurück, das dem Ordner in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetFolder(Ordnerangabe)

Die Syntax der GetFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Ordnerangabe | Erforderlich. Ordnerangabe ist der Pfad (absolut oder relativ) zu einem bestimmten Ordner.

Anmerkungen
Ein Fehler tritt auf, wenn der angegebene Ordner nicht vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der GetFolder-Methode:

function GibOrdnerListeAus(ordnerAng)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(ordnerAng);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


GetFolder-Methode

GetFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetFolder-Methode

GetFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetParentFolderName-Methode

GetParentFolderName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Komponente in einem angegebenen Pfad enthält.
Syntax
Objekt.GetParentFolderName(Pfad)

Die Syntax der GetParentFolderName-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren übergeordneter Ordnername zurückgegeben werden soll.

Anmerkungen
Die GetParentFolderName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn es keinen übergeordneten Ordner für die Komponente gibt, die im Pfad-Argument angegeben ist.
Hinweis Die GetParentFolderName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.

Das folgende Beispiel zeigt die Verwendung der GetParentFolderName-Methode:

function ZeigeUebergeordnOrdnerNameAn(dateiAng)
{
 var fso, s = "";
 fso = new ActiveXObject("Scripting.FileSystemObject");
 s += fso.GetParentFolderName(dateiAng);
 return(s);
}


GetParentFolderName-Methode

GetParentFolderName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetParentFolderName-Methode

GetParentFolderName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetSpecialFolder-Methode

GetSpecialFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den angegebenen Systemordner zurück.
Syntax
Objekt.GetSpecialFolder(Ordnerangabe)

Die Syntax der GetSpecialFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Ordnerangabe | Erforderlich. Der Name des zurückzugebenden Systemordners. Möglich ist eine der Konstanten, die im Abschnitt "Einstellungen" gezeigt werden.

Einstellungen
Das Argument Ordnerangabe kann einen der folgenden Werte aufweisen:

Konstante | Wert | Beschreibung
WindowsFolder | 0 | Der Ordner Windows enthält die Dateien, die vom Betriebssystem Windows installiert werden.
SystemFolder | 1 | Der Ordner System enthält Bibliotheken, Schriften und Gerätetreiber.
TemporaryFolder | 2 | Im Ordner Temp werden temporäre Dateien gespeichert. Den Pfad finden Sie in der Umgebungsvariable TMP.

Das folgende Beispiel zeigt die Verwendung der GetSpecialFolder-Methode:

var fso, tempdatei;
fso = new ActiveXObject("Scripting.FileSystemObject");

function ErstelleTempDatei()
{
  var tordner, tdatei, tname, fname, TemporaryFolder = 2;
  tordner = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tdatei = tordner.CreateTextFile(tname);
  return(tdatei);
}
tempdatei = ErstelleTempDatei();
tempdatei.writeline("Hallo Welt");
tempdatei.close();


GetSpecialFolder-Methode

GetSpecialFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetSpecialFolder-Methode

GetSpecialFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetTempName-Methode


GetTempName-Methode

GetTempName-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück, die bzw. der nützlich beim Durchführen von Operationen ist, die eine temporäre Datei oder einen temporären Ordner erfordern.
Syntax
Objekt.GetTempName ( );

Das optionale Objekt ist stets der Name eines FileSystemObject.

Anmerkungen
Die GetTempName-Methode erstellt keine Datei. Sie stellt nur einen temporären Dateinamen bereit, der zusammen mit CreateTextFile zum Erstellen einer Datei verwendet werden kann.

Das folgende Beispiel zeigt die Verwendung der GetTempName-Methode:

var fso, tempdatei;
fso = new ActiveXObject("Scripting.FileSystemObject");

function ErstelleTempDatei()
{
  var tordner, tdatei, tname, fname, TemporaryFolder = 2;
  tordner = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tdatei = tordner.CreateTextFile(tname);
  return(tdatei);
}
tempdatei = ErstelleTempDatei();
tempdatei.writeline("Hallo Welt");
tempdatei.close();


GetTempName-Methode

GetTempName-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


GetTempName-Methode

GetTempName-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode


MoveFile-Methode

MoveFile-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt eine oder mehrere Dateien aus einem Speicherort in einen anderen.
Syntax
Objekt.MoveFile (Quelle, Ziel);

Die Syntax der MoveFile-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Quelle | Erforderlich. Der Pfad zu den zu verschiebenden Dateien. Das Argument Quelle darf nur in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Ziel | Erforderlich. Der Pfad, in den die Dateien verschoben werden. Das Argument Ziel darf keine Platzhalterzeichen enthalten.

Anmerkungen
Wenn die Quelle Platzhalterzeichen enthält oder das Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass das Ziel einen vorhandenen Ordner angibt, in den die übereinstimmenden Dateien bewegt werden sollen. Andernfalls ist Ziel der Name der zu erstellenden Zieldatei. Beim Verschieben einer einzelnen Datei können folgende drei Situationen eintreten:
  • Wenn Ziel nicht vorhanden ist, wird die Datei verschoben. Dies ist der Normalfall.
  • Falls das Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Ein Fehler tritt weiterhin auf, wenn ein in Quelle verwendetes Platzhalterzeichen mit keiner der Dateien übereinstimmt. Die MoveFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.
Wichtig Diese Methode erlaubt nur das Verschieben von Dateien zwischen Datenträgern, wenn dies vom Betriebssystem unterstützt wird.

Das folgende Beispiel zeigt die Verwendung der MoveFile-Methode:

function BewegeDatei2Desktop(dateiAng)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFile(dateiAng, "c:\\windows\\desktop\\");
}


MoveFile-Methode

MoveFile-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


MoveFile-Methode

MoveFile-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFile-Methode
DeleteFile-Methode
GetFile-Methode
GetFileName-Methode
Move-Methode
MoveFolder-Methode
OpenTextFile-Methode


MoveFolder-Methode

MoveFolder-Methode 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt einen oder mehrere Ordner aus einem Speicherort in einen anderen.
Syntax
Objekt.MoveFolder ( Quelle, Ziel );

Die Syntax der MoveFolder-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject.
Quelle | Erforderlich. Der Pfad zu den zu verschiebenden Ordnern. Das Argument Quelle darf nur in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Ziel | Erforderlich. Der Pfad, in den die Ordner verschoben werden sollen. Das Argument Ziel darf keine Platzhalterzeichen enthalten.

Anmerkungen
Wenn die Quelle Platzhalterzeichen enthält oder das Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass das Ziel einen vorhandenen Ordner angibt, in den die übereinstimmenden Dateien bewegt werden sollen. Andernfalls ist Ziel der Name des zu erstellenden Zielordners. Beim Verschieben eines einzelnen Ordners können folgende drei Situationen eintreten:
  • Wenn Ziel nicht vorhanden ist, wird der Ordner verschoben. Dies ist der Normalfall.
  • Falls das Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Ein Fehler tritt weiterhin auf, wenn ein in Quelle verwendetes Platzhalterzeichen mit keinem der Ordner übereinstimmt. Die MoveFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.
Wichtig Diese Methode erlaubt nur das Verschieben von Ordnern zwischen Datenträgern, wenn dies vom Betriebssystem unterstützt wird.

Das folgende Beispiel zeigt die Verwendung der MoveFolder-Methode:

function BewegeOrdner2Desktop(ordnerAng)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFolder(ordnerAng, "c:\\windows\\desktop\\");
}


MoveFolder-Methode

MoveFolder-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt


MoveFolder-Methode

MoveFolder-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

CopyFile-Methode
DeleteFile-Methode
GetFile-Methode
GetFileName-Methode
Move-Methode
MoveFile-Methode
OpenTextFile-Methode


Type-Eigenschaft

Type-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Informationen zum Datei- oder Ordnertyp zurück. Für Dateien mit z. B. der Endung .TXT wird "Text Document" zurückgegeben.
Syntax
Objekt.Type

Das Objekt ist stets ein File- oder Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Type-Eigenschaft, es wird ein Ordnertyp zurückgegeben. Geben Sie in diesem Beispiel für die Prozedur den Pfad des Papierkorbs oder eines anderen eindeutigen Ordners an.
function FileTypeDemo(ordnerAng)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(ordnerAng))
    f = fso.GetFolder(ordnerAng);
  else if (fso.FileExists(ordnerAng))
    f = fso.GetFile(ordnerAng);
  else
    s = "Datei oder Ordner existiert nicht.";
  s = f.Name + " ist ein " + f.Type;
  return(s);
}


Type-Eigenschaft

Type-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

File-Objekt
Folder-Objekt


Type-Eigenschaft

Type-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft


GetObject-Funktion

GetObject-Funktion 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Gibt einen Verweis auf ein Automatisierungsobjekt von einer Datei zurück.
Syntax
GetObject([Pfadname] [, Klasse])

Die Syntax der GetObject-Funktion besteht aus folgenden Komponenten:

Komponente | Beschreibung
Pfadname | Optional. Der vollständige Pfad und Name der Datei, die das abzurufende Objekt enthält. Wird Pfadname weggelassen, ist Klasse erforderlich.
Klasse | Optional. Klasse des Objekts.

Das Argument Klasse verwendet die Syntax Progname.Objekttyp und hat die folgenden Komponenten:

Komponente | Beschreibung
Progname | Erforderlich. Name des Programms, welches das Objekt zur Verfügung stellt.
Objekttyp | Erforderlich. Typ oder Klasse des zu erzeugenden Objekts.

Anmerkungen
Verwenden Sie die GetObject-Funktion, um auf ein Automatisierungsobjekt von einer Datei zuzugreifen. Weisen Sie das durch GetObject zurückgegebene Objekt der Objektvariablen zu. Beispiele:
var CADObjekt;
CADObjekt = GetObject("C:\\CAD\\SCHEMA.CAD");
Wird dieser Code ausgeführt, so startet das in Pfadname angegebene Programm, und das Objekt in der angegebenen Datei wird aktiviert. Ist Pfadname eine Zeichenfolge der Länge Null (""), so gibt GetObject eine neue Objektinstanz vom angegebenen Typ zurück. Wird das Argument Pfadname nicht angegeben, so gibt GetObject ein momentan aktives Objekt vom angegebenen Typ zurück. Existiert kein Objekt des angegebenen Typs, so tritt ein Fehler auf.

Bei einigen Programmen können Sie einen Teil einer Datei aktivieren. Fügen Sie hinter dem Dateinamen ein Ausrufungszeichen (!) gefolgt von der Zeichenfolge hinzu, die den Namen des zu aktivierenden Teils enthält. Weitere Informationen zum Erstellen dieser Zeichenfolge finden Sie in der Dokumentation der Anwendung, die das Objekt erstellt hat.

In einem Zeichenprogramm zum Beispiel kann es mehrere Ebenen einer Zeichnung geben, die in einer Datei gespeichert sind. Mit der folgenden Anweisung können Sie eine Ebene in einer Zeichnung mit dem Namen SCHEMA.CAD aktivieren:

var EbenenObjekt = GetObject("C:\\CAD\\SCHEMA.CAD!Ebene3");
Wenn Sie die Objektklasse nicht angeben, wird das zu startende Programm und das zu aktivierende Objekt automatisch anhand des Dateinamens festgelegt. Einige Dateien unterstützen jedoch mehr als nur eine Objektklasse. Beispielsweise kann eine Zeichnung drei unterschiedliche Objekttypen unterstützen: ein Application-Objekt, ein Drawing-Objekt und ein Toolbar-Objekt, alle jeweils als Bestandteil der gleichen Datei. Um anzugeben, welches Objekt Sie in einer Datei aktivieren möchten, verwenden Sie das optionale Argument Klasse. Beispiele:
var MeinObjekt;
MeinObjekt = GetObject("C:\\ZEICHNUNGEN\\BEISPIEL.DRW", "FIGMENT.DRAWING");
Im vorhergehenden Beispiel ist FIGMENT der Name des Zeichenprogrammes und DRAWING einer der unterstützten Objekttypen. Sobald ein Objekt aktiviert ist, beziehen Sie sich darauf im Programm durch die von Ihnen definierte Objektvariable. Im letzten Beispiel greifen Sie auf Eigenschaften und Methoden des neuen Objekts über die Objektvariable MeinObjekt zu. Beispiele:
MeinObjekt.Line(9, 90);
MeinObjekt.InsertText(9, 100, "Hallo Welt.");
MeinObjekt.SaveAs("C:\\ZEICHNUNGEN\\BEISPIEL.DRW");
Hinweis Verwenden Sie die GetObject-Funktion, wenn eine aktuelle Instanz des Objekts vorhanden ist, oder wenn Sie das Objekt mit einer bereits geladenen Datei erstellen wollen. Falls keine aktuelle Instanz vorhanden ist und Sie das Objekt nicht mit einer geladenen Datei erstellen wollen, verwenden Sie das ActiveXObject-Objekt.

Wenn sich ein Objekt als Einzelinstanzobjekt registriert hat, wird nur eine einzige Instanz dieses Objekts erstellt, unabhängig davon, wie oft ActiveXObject ausgeführt wird. Bei einem Einzelinstanzobjekt gibt GetObject bei einem Syntaxaufruf mit der Zeichenfolge der Länge Null ("") stets die gleiche Instanz zurück, und es tritt ein Fehler auf, wenn das Argument Pfadname nicht mit eingegeben wird.


GetObject-Funktion

GetObject-Funktion
Siehe auch 		JScript-Sprachverzeichnis

ActiveXObject-Objekt


ScriptEngine-Funktion

ScriptEngine-Funktion 		JScript-Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit der gerade verwendeten Skriptsprache zurück.
Syntax
ScriptEngine( )
Rückgabewerte
Die ScriptEngine-Funktion kann jeden der folgenden Werte zurückgeben:

Zeichenfolge | Beschreibung
JScript | Gibt an, dass Microsoft ® JScript das verwendete Skriptmodul ist.
VBA | Gibt an, dass Microsoft Visual Basic® für Applikationen das verwendete Skriptmodul ist.
VBScript | Gibt an, dass Microsoft Visual Basic Scripting Edition das verwendete Skriptmodul ist.

Anmerkungen
Der folgende Code zeigt die Verwendung der ScriptEngine-Funktion:
function GibSkriptModulInfoAus()
{
    var s;
    s = ""; // Build-Zeichenfolge mit erforderlichen Informationen.
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineBuildVersion-Funktion

ScriptEngineBuildVersion-Funktion 		JScript-Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.
Syntax
ScriptEngineBuildVersion( )
Rückgabewerte
Der Rückgabewert entspricht direkt der Versionsinformation, die in der DLL für die benutzte Skriptsprache enthalten ist.
Anmerkungen
Der folgende Code zeigt die Verwendung der ScriptEngineBuildVersion-Funktion:
function GibSkriptModulInfoAus()
{
    var s;
    s = ""; // Build-Zeichenfolge mit erforderlichen Informationen.
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineBuildVersion-Funktion

ScriptEngineBuildVersion-Funktion
Siehe auch 		JScript-Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngine-Funktion

ScriptEngine-Funktion
Siehe auch 		JScript-Sprachverzeichnis

ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngineMajorVersion-Funktion

ScriptEngineMajorVersion-Funktion 		JScript-Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
Syntax
ScriptEngineMajorVersion( )
Rückgabewerte
Der Rückgabewert entspricht direkt der Versionsinformation, die in der DLL für die benutzte Skriptsprache enthalten ist.
Anmerkungen
Der folgende Code zeigt die Verwendung der ScriptEngineMajorVersion-Funktion:
function GibSkriptModulInfoAus()
{
    var s;
    s = ""; // Build-Zeichenfolge mit erforderlichen Informationen.
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineMajorVersion-Funktion

ScriptEngineMajorVersion-Funktion
Siehe auch 		JScript-Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngineMinorVersion-Funktion

ScriptEngineMinorVersion-Funktion 		JScript-Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
Syntax
ScriptEngineMinorVersion( )
Rückgabewerte
Der Rückgabewert entspricht direkt der Versionsinformation, die in der DLL für die benutzte Skriptsprache enthalten ist.
Anmerkungen
Der folgende Code zeigt die Verwendung der ScriptEngineMinorVersion-Funktion:
function GibSkriptModulInfoAus()
{
    var s;
    s = ""; // Build-Zeichenfolge mit erforderlichen Informationen.
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


ScriptEngineMinorVersion-Funktion

ScriptEngineMinorVersion-Funktion
Siehe auch 		JScript-Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion


Add-Methode (Folders)

Add-Methode (Folders) 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Fügt der Folders-Auflistung einen neuen Ordner hinzu.
Syntax
Objekt.Add(Ordnername);

Die Add-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name einer Folders-Auflistung.
Ordnername | Erforderlich. Der Name des neuen hinzuzufügenden Folder-Objekts.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der Add-Methode zum Erstellen eines neuen Ordners:
function FuegeNeuenOrdnerHinzu(pfad,Ordnername)
{
  var fso, f, fc, nf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(pfad);
  fc = f.SubFolders;
  if (Ordnername != "" )
    nf = fc.Add(Ordnername);
  else
    nf = fc.Add("Neuer Ordner")
}
Falls Ordnername bereits existiert, tritt ein Fehler auf.


Add-Methode (Folders)

Add-Methode (Folders)
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Folders-Auflistung


Add-Methode (Folders)

Add-Methode (Folders)
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)


Files-Eigenschaft

Files-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner samt der Dateien enthält, deren Attribute "Hidden" (Versteckt) und "System" gesetzt sind.
Syntax
Objekt.Files

Das Objekt ist stets ein Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der Files-Eigenschaft:
function GibOrdnerDateiListeAus(ordnerAng)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(ordnerAng);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Files-Eigenschaft

Files-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Folder-Objekt


Files-Eigenschaft

Files-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn der angegebene Ordner das Stammverzeichnis ist. Gibt False zurück, wenn dem nicht so ist.
Syntax
Objekt.IsRootFolder

Das Objekt ist stets ein Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der IsRootFolder-Eigenschaft:
function ZeigeVerzeichnisTiefeAn(pfadAng)
{
  var fso, f, n, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(pfadAng);
  n = 0;
  if (f.IsRootFolder)
      s = "Der angegebene Ordner ist nicht das Stammverzeichnis."
  else
  {
    do
    {
      f = f.ParentFolder;
      n++;
    }
    while (!f.IsRootFolder)
    s = " Der angegebene Ordner ist " + n + " Ebenen tief verschachtelt."
  }
  return(s);
}


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Folder-Objekt


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


SubFolders-Eigenschaft

SubFolders-Eigenschaft 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Folders-Auflistung zurück, die alle Ordner in dem angegebenen Ordner samt derjenigen enthält, deren Attribute "Hidden" (Versteckt) und "System" gesetzt sind.
Syntax
Objekt.SubFolders

Das Objekt ist stets ein Folder-Objekt.

Anmerkungen
Der folgende Code verdeutlicht die Verwendung der SubFolders-Eigenschaft:
function GibOrdnerListeAus(ordnerAng)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(ordnerAng);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (;!fc.atEnd(); fc.moveNext())
    {
      s += fc.item();
      s += "<br>";
    }
    return(s);
}


SubFolders-Eigenschaft

SubFolders-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

Folder-Objekt


SubFolders-Eigenschaft

SubFolders-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
Type-Eigenschaft


Referenz für die Microsoft® JScript-Laufzeitbibliothek

Referenz für die JScript-Laufzeitbibliothek 		JScript-Sprachverzeichnis
Versionsinformationen

Informationen über
Leistungsmerkmale
Alphabetische Liste
der Schlüsselwörter
Methoden
Objekte
Eigenschaften
©1998 Microsoft Corporation. Alle Rechte vorbehalten. Rechtliche Hinweise.


arguments-Eigenschaft

arguments-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Datenfeld zurück, das alle Argumente enthält, die an die derzeit ausgeführte Funktion übergeben werden.
Syntax
Funktion.arguments[ ]

Das Argument Funktion ist der Name der momentan ausgeführten Funktion.

Anmerkungen
Die arguments-Eigenschaft ermöglicht eine elegante Lösung, wie Funktionen eine variable Anzahl von Argumenten verarbeiten können. Die length-Eigenschaft des Datenfeldes enthält die Anzahl der Argumente, die an die Funktion übergeben werden.

Das folgende Beispiel zeigt die Verwendung der arguments-Eigenschaft:

function ArgTest()
{
   var i, s, numargs = ArgTest.arguments.length;
   s = numargs;
   if (numargs < 2)
     s += " Argument wurde an ArgTest übergeben. Es war ";
   else
     s += " Argumente wurden an ArgTest übergeben. Es waren " ;

   for (i = 0; i < numargs; i++)
     {
       s += ArgTest.arguments[i] + " ";
     }
   return(s);
}


arguments-Eigenschaft

arguments-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Function-Objekt


arguments-Eigenschaft

arguments-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung
length-Eigenschaft (Array)


caller-Eigenschaft

caller-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt einen Verweis auf die Funktion zurück, die die aktuelle Funktion aufgerufen hat.
Syntax
Funktionsname.caller
Anmerkungen
Die caller-Eigenschaft ist für eine Funktion nur definiert, während diese Funktion ausgeführt wird. Falls die Funktion von der obersten Ebene eines JScript-Programms aufgerufen wird, enthält caller den Wert Null.

Wenn die caller-Eigenschaft in einem Zeichenfolgenkontext verwendet wird, ist das Ergebnis das gleiche wie Funktionsname.toString, d. h. der dekompilierte Text der Funktion wird angezeigt.

Das folgende Beispiel zeigt die Verwendung der caller-Eigenschaft:

function RufeEbeneAuf()
{
  if (CallLevel.caller == null)
    return("RufeEbeneAuf wurde von der obersten Ebene aufgerufen.");
  else
    return("RufeEbeneAuf wurde von einer anderen Funktion aufgerufen.");
}


caller-Eigenschaft

caller-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Function-Objekt


caller-Eigenschaft

caller-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung


length-Eigenschaft (Function)

length-Eigenschaft (Function) 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Enthält die Zahl der Argumente, mit denen eine Funktion definiert wird.
Syntax
Funktionsname.length

Das Argument Funktionsname ist erforderlich und trägt den Namen der betreffenden Funktion.

Anmerkungen
Die length-Eigenschaft einer Funktion wird vom Skriptmodul mit der Zahl der Argumente in der Definition der Funktion initialisiert, wenn eine Instanz der Funktion erstellt wird.

Was passiert, wenn eine Funktion mit der Zahl von Argumenten aufgerufen wird, die sich vom Wert der length-Eigenschaft unterscheidet, hängt von der Funktion ab.

Das folgende Beispiel zeigt die Verwendung der length-Eigenschaft:

function ArgTest(a, b)
{
   var i, s = " Die ArgTest-Funktion erwartete ";
   var numargs = ArgTest.arguments.length;
   var expargs = ArgTest.length;
   if (expargs < 2)
     s += expargs + " Argument. ";
   else
     s += expargs + " Argumente. ";
   if (numargs < 2)
     s += numargs + " wurde übergeben.";
   else
     s += numargs + " wurden übergeben.";
   return(s);
}


length-Eigenschaft

length-Eigenschaft (Function)
Betrifft 		JScript-Sprachverzeichnis

Function-Objekt


length-Eigenschaft (Function)

length-Eigenschaft (Function)
Siehe auch 		JScript-Sprachverzeichnis

arguments-Eigenschaft
length-Eigenschaft (Array)
length-Eigenschaft (String)


escape-Methode

escape-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Kodiert String-Objekte, so dass sie auf allen Computern gelesen werden können.
Syntax
escape(Zeichenfolge)

Das Argument Zeichenfolge ist das zu kodierende String-Objekt.

Anmerkungen
Die escape-Methode gibt ein neues String-Objekt (im Unicode-Format) zurück, das den Inhalt von Zeichenfolge enthält. Alle Leerzeichen, Satzzeichen, Buchstaben mit Akzenten und anderen Nicht-ASCII-Zeichen werden durch %xx Codierungen ersetzt, wobei xx das Äquivalent der Hexadezimalnummer des Zeichens ist. Ein Leerzeichen wird beispielsweise als "%20" zurückgegeben.

Zeichen, deren Wert größer als 255 ist, werden im Format %u xxxx gespeichert.


escape-Methode

escape-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


escape-Methode

escape-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekt
unescape-Methode


eval-Methode

eval-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Wertet und führt JScript-Code aus.
Syntax
eval(CodeZeichenfolge)

Das CodeZeichenfolge-Argument ist ein String-Objekt, das gültigen JScript-Code enthält. Die Zeichenfolge wird vom JScript-Parser analysiert und ausgeführt.

Anmerkungen
Die eval-Funktion ermöglicht dynamisches Ausführen von JScript-Quellcode. Beispielsweise erzeugt der folgende Code eine neue Variable Datum1, die ein Date-Objekt enthält:
eval("var Datum1 = new Date();");
Der an die eval-Methode übergebene Code wird in dem gleichen Kontext wie der Aufruf der eval-Methode ausgeführt.


eval-Methode

eval-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


eval-Methode

eval-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekt


Infinity-Eigenschaft

Infinity-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Anfangswert von Number.POSITIVE_INFINITY zurück
Syntax
Infinity
Anmerkungen
Die Infinity-Eigenschaft ist ein Element des Global-Objekts. Sie steht zur Verfügung, sobald das Skriptmodul initialisiert ist.


Infinity-Eigenschaft

Infinity-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


Infinity-Eigenschaft

Infinity-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

NEGATIVE_INFINITY-Eigenschaft
POSITIVE_INFINITY-Eigenschaft


isFinite-Methode

isFinite-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Booleschen Wert zurück, der angibt, ob die angegebene Zahl endlich ist.
Syntax
isFinite(Zahl)

Das Argument Zahl ist der erforderliche numerische Wert.

Anmerkungen
Die isFinite-Methode gibt True zurück, falls Zahl einen anderen Wert als NaN, minus-unendlich oder plus-unendlich hat. In diesen drei Fällen wird False zurückgegeben.


isFinite-Methode

isFinite-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


isFinite-Methode

isFinite-Methode
Siehe auch 		JScript-Sprachverzeichnis

isNaN-Methode


isNaN-Methode

isNaN-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt einen Booleschen Wert zurück, der angibt, ob ein Wert der reservierte Wert NaN (not a number) ist.
Syntax
isNaN(NumWert)

Das Argument NumWert ist der Wert, der auf NaN getestet werden soll.

Anmerkungen
Die isNaN-Funktion gibt True zurück, falls der Wert NaN ist. Andernfalls wird False zurückgegeben. Diese Funktion wird typischerweise verwendet, um Rückgabewerte der parseInt- und parseFloat-Methoden zu testen.

Alternativ kann auch eine Variable mit sich selbst verglichen werden. Falls dies ungleich ergibt, ist sie NaN. Dies entsteht dadurch, dass NaN der einzige Wert ist, der ungleich sich selbst ist.


isNaN-Methode

isNaN-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


isNaN-Methode

isNaN-Methode
Siehe auch 		JScript-Sprachverzeichnis

isFinite-Methode
NaN-Eigenschaft (Global)
parseFloat-Methode
parseInt-Methode


NaN-Eigenschaft (Global)

NaN-Eigenschaft (Global) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Sonderwert NaN zurück, der angibt, dass ein Ausdruck keine Zahl ist.
Syntax
NaN
Anmerkungen
Die NaN-Eigenschaft (Not a Number) ist ein Element des Global-Objekts. Sie steht zur Verfügung, sobald das Skriptmodul initialisiert ist.


NaN-Eigenschaft (Global)

NaN-Eigenschaft (Global)
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


NaN-Eigenschaft (Global)

NaN-Eigenschaft (Global)
Siehe auch 		JScript-Sprachverzeichnis

isNaN-Methode


parseFloat-Methode

parseFloat-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die aus einer Zeichenfolge konvertierte Fließkommazahl zurück.
Syntax
parseFloat(NumZeichenfolge)

Das Argument NumZeichenfolge ist eine Zeichenfolge, die eine Fließkommazahl enthält.

Anmerkungen
Die parseFloat-Methode gibt einen numerischen Wert zurück, der gleich der in NumZeichenfolge enthaltenen Zahl ist. Falls kein Präfix von NumZeichenfolge erfolgreich in eine Fließkommazahl umgewandelt werden kann, wird NaN (not a number) zurückgegeben.
parseFloat("abc")    // Gibt NaN zurück.
parseFloat("1.2abc") // Gibt 1.2 zurück.
Eine Überprüfung auf NaN können Sie mit der isNaN-Methode durchführen.


parseFloat-Methode

parseFloat-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


parseFloat-Methode

parseFloat-Methode
Siehe auch 		JScript-Sprachverzeichnis

isNaN-Methode
parseInt-Methode
String-Objekt


parseInt-Methode

parseInt-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt eine aus einer Zeichenfolge konvertierte Ganzzahl zurück.
Syntax
parseInt(NumZeichenfolge, [Radix])

Die Syntax der parseInt-Methode besteht aus folgenden Komponenten:

Komponente | Beschreibung
NumZeichenfolge | Erforderlich. Eine Zeichenfolge, die in eine Zahl konvertiert werden soll.
Radix | Optional. Ein Wert zwischen 2 and 36, der die Basis der in NumZeichenfolge enthaltenen Zahl angibt. Wird dieser Wert nicht angegeben, werden Zeichenfolgen, die mit '0x' beginnen, als hexadezimal angenommen, und alle Zeichenfolgen, die mit '0' beginnen, werden als oktal angenommen. Alle anderen Zeichenfolgen werden als dezimal angenommen.

Anmerkungen
Die parseInt-Methode gibt einen ganzzahligen Wert zurück, der gleich der in NumZeichenfolge enthaltenen Zahl ist. Falls kein Präfix von NumZeichenfolge erfolgreich in eine Ganzzahl umgewandelt werden kann, wird NaN (not a number) zurückgegeben.
parseInt("abc")    // Gibt NaN zurück.
parseInt("12abc") // Gibt 12 zurück.
Eine Überprüfung auf NaN können Sie mit der isNaN-Methode durchführen.


parseInt-Methode

parseInt-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


parseInt-Methode

parseInt-Methode
Siehe auch 		JScript-Sprachverzeichnis

isNaN-Methode
parseFloat-Methode
String-Objekt
valueOf-Methode


unescape-Methode

unescape-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Dekodiert String-Objekte, die mit der escape-Methode kodiert wurden.
Syntax
unescape(Zeichenfolge)

Das Argument Zeichenfolge ist das String-Objekt, das dekodiert werden soll.

Anmerkungen
Die unescape-Methode gibt ein neues String-Objekt zurück, das den Inhalt von Zeichenfolge enthält. Alle im hexadezimalen Format %xx kodierten Zeichen werden durch ihre ASCII-Zeichensatzäquivalente ersetzt.

Im Format %u xxxx kodierte Zeichen (Unicode-Zeichen) werden durch Unicode-Zeichen mit der hexadezimalen Kodierung xxxx ersetzt.


unescape-Methode

unescape-Methode
Betrifft 		JScript-Sprachverzeichnis

Global-Objekt


unescape-Methode

unescape-Methode
Siehe auch 		JScript-Sprachverzeichnis

escape-Methode
String-Objekt


Vergleichsoperatoren

Vergleichsoperatoren 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Booleschen Wert zurück, der das Ergebnis des Vergleichs angibt.
Syntax
Ausdruck1 Vergleichsoperator Ausdruck2

Die Syntax der Vergleichsoperatoren hat die folgenden Komponenten:

Komponente | Beschreibung
Ausdruck1 | Beliebiger Ausdruck.
Vergleichsoperator | Beliebiger Vergleichsoperator.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Beim Zeichenfolgenvergleich verwendet JScript den Unicode-Zeichenwert des Zeichenfolgenausdrucks.

Im Folgenden wird beschrieben, wie die verschiedenen Gruppen von Operatoren sich abhängig vom Typ und Wert der beiden Ausdrücke Ausdruck1 und Ausdruck2 verhalten:

Relationale Operatoren (<, >, <=, >=)

  • Es wird versucht, sowohl Ausdruck1 als auch Ausdruck2 in Zahlen zu konvertieren.
  • Wenn beide Ausdrücke Zeichenfolgen sind, wird ein lexikographischer Zeichenfolgenvergleich durchgeführt.
  • Wenn beide Ausdrücke den Wert NaN haben, wird der Wert False zurückgegeben.
  • Die negative Null entspricht der positiven Null.
  • Die negative Unendlichkeit ist kleiner als jede Zahl, inklusive sich selbst.
  • Die positive Unendlichkeit ist größer als jede Zahl, inklusive sich selbst.
Gleichheit (==, !=)
  • Wenn die Datentypen der beiden Ausdrücke verschieden sind, wird versucht, diese in Zeichenfolgen, Zahlen oder Boolesche Werte zu konvertieren.
  • NaN ist zu keiner Zahl gleich, auch nicht zu sich selbst.
  • Die negative Null entspricht der positiven Null.
  • Null ist sowohl gleich Null als auch gleich undefined.
  • Werte werden als gleich angenommen, wenn es sich dabei um identische Zeichenfolgen, numerisch gleiche Zahlen, das gleiche Objekt oder identische Boolesche Werte handelt, oder sie können, wenn es sich um verschiedene Datentypen handelt, in eine dieser Möglichkeiten gezwungenermaßen konvertiert werden.
  • Bei jedem anderen Vergleich werden die Werte als ungleich angesehen.
Identität (===, !==)
Diese Operatoren verhalten sich wie Gleichheitsoperatoren, außer dass keine Typkonvertierung durchgeführt wird und die Typen identisch sein müssen, um als gleich betrachtet zu werden.


Vergleichsoperatoren

Vergleichsoperatoren
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Microsoft JScript-Funktionen - ECMA

Microsoft JScript-Funktionen
ECMA 		JScript-Sprachverzeichnis

Kategorie | Funktion/Schlüsselwort
Datenfeldverarbeitung Array
join, length, reverse, sort
Zuweisungen Zuweisungsoperator (=)
Verbundzuweisungsoperatoren (OP=)
Boolesche Werte Boolean
Kommentare | /*...*/ oder //
Konstanten/Literale NaN
null
true, false
+Infinity
undefined
Ablaufsteuerung break
continue
for
for...in
if...else
return
while
Datum und Zeit Date
getDate, getDay, getFullYear, getHours, getMilliseconds, getMinutes, getMonth, getSeconds, getTime, getTimezoneOffset, getYear,
getUTCDate, getUTCDay, getUTCFullYear, getUTCHours, getUTCMilliseconds, getUTCMinutes, getUTCMonth, getUTCSeconds,
setDate, setFullYear, setHours, setMilliseconds, setMinutes, setMonth, setSeconds, setTime, setYear,
setUTCDate, setUTCFullYear, setUTCHours, setUTCMilliseconds, setUTCMinutes, setUTCMonth, setUTCSeconds,
toGMTString, toLocaleString, toUTCString, parse, UTC
Deklarationen function
new
this
var
with
Funktionserstellung Function
arguments, length
Globale Methoden Global
escape, unescape
eval
isFinite, isNaN
parseInt, parseFloat
Math Math
abs, acos, asin, atan, atan2, ceil, cos, exp, floor, log, max, min, pow, random,round, sin, sqrt, tan,
E, LN2, LN10, LOG2E, LOG10E, PI, SQRT1_2, SQRT2
Zahlen Number
MAX_VALUE, MIN_VALUE
NaN
NEGATIVE_INFINITY, POSITIVE_INFINITY
Objekterstellung Object
new
constructor, prototype, toString, valueOf
Operatoren Addition (+), Subtraktion (-)
Modulo (%)
Multiplikation (*), Division (/)
Unäre Negation (-)
Gleichheit (==), Ungleichheit (!=)
Kleiner als (<), Kleiner gleich (<=)
Größer als (>)
Größer gleich (>=)
Logisches AND (&&), Logisches OR (||), Logisches NOT (!)
Bitweises AND (&), Bitweises OR (|), Bitweises NOT (~), Bitweises Xor (^)
Bitweises Left Shift (<<), Bitweises Right Shift (>>)
Vorzeichenloses Right Shift (>>>)
Bedingung (?:, trinär)
Komma (,)
delete, typeof, void
Dekrement (--), Inkrement (++)
Objekte Array
Boolean
Date
Function
Global
Math
Number
Object
String
Zeichenfolgen String
charAt, charCodeAt, fromCharCode
indexOf, lastIndexOf
split
toLowerCase, toUpperCase
length


Microsoft JScript-Funktionen - Nicht-ECMA

Microsoft JScript-Funktionen
Nicht-ECMA 		JScript-Sprachverzeichnis

Kategorie | Funktion/Schlüsselwort
Datenfeldverarbeitung concat, slice
VBArray
dimensions, getItem, lbound, toArray, ubound
Bedingte Kompilierung @cc_on- Anweisung
@if-Anweisung
@set-Anweisung
Variablen für die bedingte Kompilierung
Ablaufsteuerung do...while
Labeled
switch
Datum und Zeit getVarDate
Aufzählung Enumerator
atEnd, item, moveFirst, moveNext
Fehlersuche Error
description, number
throw, try...catch
Funktionserstellung | caller
Operatoren Identität (===), Nicht-Identität (!==)
Objekte Enumerator
RegExp
Regular Expression
VBArray
ActiveXObject
GetObject
Reguläre Ausdrücke und Mustervergleich RegExp
index, input, lastIndex, $1...$9, source, compile, exec, test
Syntax regulärer Ausdrücke
Skriptmodul-Identifikation ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion
Zeichenfolgen concat, slice
match, replace, search
anchor, big, blink, bold, fixed, fontcolor, fontsize, italics, link, small, strike, sub, sup


Laufzeitmerkmale von Microsoft Scripting

Laufzeitmerkmale von
Microsoft Scripting 		JScript-Sprachverzeichnis

Kategorie Funktion/Schlüsselwort
Auflistungen Drives
Files
Folders
Datei- und Systemverwaltung
  • Dictionary
    Add, Exists, Items, Keys, Remove, RemoveAll
    Count, Item, Key
  • Drive, File, Folder
    Copy, Delete, Move, OpenAsTextStream
    Attributes, Count, DateCreated, DateLastAccessed, DateLastModified, Drive, ParentFolder, Name, Path, ShortName, ShortPath, Size
    AvailableSpace, DriveLetter, DriveType, FileSystem, FreeSpace, IsReady, RootFolder, SerialNumber, ShareName, TotalSize, VolumeName
  • FileSystemObject
    BuildPath, CopyFile, CopyFolder, CreateFolder, CreateTextFile, DeleteFile, DeleteFolder, DriveExists, FileExists, FolderExists, GetAbsolutePathName, GetBaseName, GetDrive, GetDriveName, GetExtensionName, GetFile, GetFileName, GetFolder, GetParentFolderName, GetSpecialFolder, GetTempName, MoveFile, MoveFolder, OpenTextFile
    Drives
  • TextStream
    Close, Read, ReadAll, ReadLine, Skip, SkipLine, Write, WriteBlankLines, WriteLine
    AtEndOfLine, AtEndOfStream, Column, Line


abs-Methode

abs-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Berechnet den Absolutwert einer Zahl.
Syntax
Math.abs(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen absoluter Wert gesucht wird.

Anmerkungen
Der Rückgabewert ist der absolute Wert des Arguments Zahl.

Das folgende Beispiel demonstriert die Verwendung der abs-Methode:

function VergeichPosNegWert(n)
{
  var s;
  var v1 = Math.abs(n);
  var v2 = Math.abs(-n);
  if (v1 = v2)
    s = "Die absoluten Werte von " + n + " und "
    s += -n + " sind identisch.";
  return(s);
}


abs-Methode

abs-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


abs-Methode

abs-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden


acos-Methode

acos-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Arkuskosinus einer Zahl zurück.
Syntax
Math.acos(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Arkuskosinus gesucht wird.

Anmerkungen
Der Rückgabewert ist der Arkuskosinus des Arguments Zahl.


acos-Methode

acos-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


acos-Methode

acos-Methode
Siehe auch 		JScript-Sprachverzeichnis

asin-Methode
atan-Methode
cos-Methode
Math-Objektmethoden
sin-Methode
tan-Methode


asin-Methode

asin-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Arkussinus einer Zahl zurück.
Syntax
Math.asin(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Arkussinus gesucht wird.

Anmerkungen
Der Rückgabewert ist der Arkussinus seines numerischen Arguments.


asin-Methode

asin-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


asin-Methode

asin-Methode
Siehe auch 		JScript-Sprachverzeichnis

acos-Methode
atan-Methode
cos-Methode
Math-Objektmethoden
sin-Methode
tan-Methode


atan-Methode

atan-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Berechnet den Arkustangens einer Zahl.
Syntax
Math.atan(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Arkustangens gesucht wird.

Anmerkungen
Der Rückgabewert ist der Arkustangens seines numerischen Arguments.


atan2-Methode

atan2-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt den Winkel (in Grad) von der x-Achse zu einem Punkt (y,x) zurück.
Syntax
Math.atan2(y, x)

Die atan2-Methode hat folgende Komponenten:

Komponente | Beschreibung
Math | Erforderlich. Ruft das systeminterne Math-Objekt auf.
x | Erforderlich. Ein numerischer Ausdruck, der die kartesische x-Koordinate darstellt.
y | Erforderlich. Ein numerischer Ausdruck, der die kartesische y-Koordinate darstellt.

Anmerkungen
Der Rückgabewert liegt zwischen -pi und pi und gibt den Winkel des gegebenen (y,x)-Punktes an.


atan2-Methode

atan2-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


atan2-Methode

atan2-Methode
Siehe auch 		JScript-Sprachverzeichnis

atan-Methode
Math-Objektmethoden
tan-Methode


atan-Methode

atan-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


atan-Methode

atan-Methode
Siehe auch 		JScript-Sprachverzeichnis

acos-Methode
asin-Methode
atan2-Methode
cos-Methode
Math-Objektmethoden
sin-Methode
tan-Methode


ceil-Methode

ceil-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die kleinste Ganzzahl zurück, die größer oder gleich dem numerischen Argument ist.
Syntax
Math.ceil(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck.

Anmerkungen
Der Rückgabewert ist ein ganzzahliger Wert gleich der kleinsten Ganzzahl, die größer als oder gleich ihrem numerischen Argument ist.


ceil-Methode

ceil-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


ceil-Methode

ceil-Methode
Siehe auch 		JScript-Sprachverzeichnis

floor-Methode
Math-Objektmethoden


cos-Methode

cos-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Kosinus einer Zahl zurück.
Syntax
Math.cos(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Kosinus gesucht wird.

Anmerkungen
Der Rückgabewert ist der Kosinus des numerischen Arguments.


cos-Methode

cos-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


cos-Methode

cos-Methode
Siehe auch 		JScript-Sprachverzeichnis

acos-Methode
asin-Methode
atan-Methode
Math-Objektmethoden
sin-Methode
tan-Methode


E-Eigenschaft

E-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Eulersche Konstante, die Basis des natürlichen Logarithmus, zurück. Die E-Eigenschaft entspricht näherungsweise dem Wert 2,718.
Syntax
var numVar
numVar = Math.E


E-Eigenschaft

E-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


E-Eigenschaft

E-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

exp-Methode
Math-Objekteigenschaften


exp-Methode

exp-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt e (die Basis des natürlichen Logarithmus) potenziert zurück.
Syntax
Math.exp(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, der den Wert von e darstellt.

Anmerkungen
Der Rückgabewert ist eZahl. Die Konstante e ist die Eulersche Konstante (näherungsweise 2,178) und Zahl ist das gegebene Argument.


exp-Methode

exp-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


exp-Methode

exp-Methode
Siehe auch 		JScript-Sprachverzeichnis

E-Eigenschaft
Math-Objektmethoden


floor-Methode

floor-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Berechnet die größte Ganzzahl, die kleiner oder gleich dem numerischen Argument ist.
Syntax
Math.floor(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck.

Anmerkungen
Der Rückgabewert ist ein ganzzahliger Wert gleich der größten Ganzzahl kleiner oder gleich dem numerischen Argument.


floor-Methode

floor-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


floor-Methode

floor-Methode
Siehe auch 		JScript-Sprachverzeichnis

ceil-Methode
Math-Objektmethoden


LN2-Eigenschaft

LN2-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den natürlichen Logarithmus von 2 zurück.
Syntax
var numVar
numVar = Math.LN2
Syntax
Die LN2-Eigenschaft entspricht näherungsweise dem Wert 0,693.


LN2-Eigenschaft

LN2-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


LN2-Eigenschaft

LN2-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften


LN10-Eigenschaft

LN10-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den natürlichen Logarithmus von 10 zurück.
Syntax
var numVar
numVar = Math.LN10
Anmerkungen
Die LN10-Eigenschaft entspricht näherungsweise dem Wert 2,302.


LN10-Eigenschaft

LN10-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


LN10-Eigenschaft

LN10-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften


log-Methode

log-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den natürlichen Logarithmus einer Zahl zurück.
Syntax
Math.log(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen natürlicher Logarithmus gesucht wird.

Rückgabewert
Der Rückgabewert ist der natürliche Logarithmus von Zahl. Die Basis ist e.


LOG2E-Eigenschaft

LOG2E-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Logarithmus der Eulerschen Konstante e zur Basis 2 zurück.
Syntax
var varName
varName = objName.LOG2E
Anmerkungen
Die LOG2E-Eigenschaft ist eine Konstante, die näherungsweise dem Wert 1,442 entspricht.


LOG2E-Eigenschaft

LOG2E-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


LOG2E-Eigenschaft

LOG2E-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften


LOG10E-Eigenschaft

LOG10E-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Logarithmus der Eulerschen Konstante e zur Basis 10 zurück.
Syntax
var varName
varName = objName.LOG10E
Anmerkungen
Die LOG10E-Eigenschaft ist eine Konstante, die näherungsweise dem Wert 0,434 entspricht.


LOG10E-Eigenschaft

Log10E-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


LOG10E-Eigenschaft

LOG10E-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften


log-Methode

log-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


log-Methode

log-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden


max-Methode

max-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den größeren Wert von zwei angegebenen numerischen Ausdrücken zurück.
Syntax
retVal = Math.max(Zahl1, Zahl2)

Die Syntax der max-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
retVal | Der größere Wert von Zahl1 oder Zahl2.
Zahl1 | Ein numerischer Ausdruck, der mit Zahl2 verglichen wird.
Zahl2 | Ein numerischer Ausdruck, der mit Zahl1 verglichen wird.


max-Methode

max-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


max-Methode

max-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden
min-Methode


min-Methode

min-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die kleinere von zwei angegebenen Zahlen zurück.
Syntax
retVal = Math.min(Zahl1, Zahl2)

Die Syntax der min-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
retVal | Der kleinere Wert von Zahl1 oder Zahl2.
Zahl1 | Ein numerischer Ausdruck, der mit Zahl2 verglichen wird.
Zahl2 | Ein numerischer Ausdruck, der mit Zahl1 verglichen wird.


min-Methode

min-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


min-Methode

min-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden
max-Methode


PI-Eigenschaft

PI-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt das Verhältnis eines Kreisumfangs zum Kreisdurchmesser zurück, etwa 3,141592653589793.
Syntax
var numVar
numVar = Math.PI
Syntax
Die PI-Eigenschaft ist eine Konstante, die näherungsweise dem Wert 3,14159 entspricht.


PI-Eigenschaft

PI-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


PI-Eigenschaft

PI-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften


pow-Methode

pow-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den um einen angegebenen Exponenten potenzierten Wert eines Ausdrucks zurück.
Syntax
Math.pow(Basis, Exponent)

Die Syntax der pow-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Basis | Der Basiswert des Ausdrucks.
Exponent | Der Exponentenwert des Ausdrucks.

Anmerkungen
Im folgenden Beispiel gibt ein numerischer Ausdruck vom Typ BasisExponent den Wert 1000 zurück:
Math.pow(10,3);


pow-Methode

pow-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


pow-Methode

pow-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden


random-Methode

random-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt eine Pseudo-Zufallszahl zwischen 0 und 1 zurück.
Syntax
Math.random( )
Anmerkungen
Die generierte Pseudo-Zufallszahl liegt zwischen 0 und 1, jeweils einschließlich. Der Zufallszahlengenerator erhält seinen Startwert automatisch beim erstmaligen Laden von JScript.


random-Methode

random-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


random-Methode

random-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden


round-Methode

round-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt einen angegebenen numerischen Ausdruck auf die nächste Ganzzahl gerundet zurück.
Syntax
Math.round(Zahl)

Das Argument Zahl ist der auf die nächste Ganzzahl zu rundende Wert.

Anmerkungen
Falls der Dezimalstellenteil von Zahl 0,5 oder größer ist, ist der Rückgabewert gleich der kleinsten Ganzzahl größer als Zahl. Andernfalls gibt round die größte Ganzzahl kleiner als oder gleich Zahl zurück.


round-Methode

round-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


round-Methode

round-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden


sin-Methode

sin-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Sinus einer Zahl zurück.
Syntax
Math.sin(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Sinus gesucht wird.

Anmerkungen
Der Rückgabewert ist der Sinus seines numerischen Arguments.


sin-Methode

sin-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


sin-Methode

sin-Methode
Siehe auch 		JScript-Sprachverzeichnis

acos-Methode
asin-Methode
atan-Methode
cos-Methode
Math-Objektmethoden
tan-Methode


sqrt-Methode

sqrt-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Quadratwurzel einer Zahl zurück.
Syntax
Math.sqrt(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck.

Anmerkungen
Falls Zahl negativ ist, ist der Rückgabewert 0.


SQRT1_2-Eigenschaft

SQRT1_2-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Die Quadratwurzel von 0,5 (oder 1 geteilt durch die Quadratwurzel von 2).
Syntax
var numVar
numVar = Math.SQRT1_2
Anmerkungen
Die SQRT1_2-Eigenschaft ist eine Konstante, die näherungsweise dem Wert 0,707 entspricht.


SQRT1_2-Eigenschaft

SQRT1_2-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


SQRT1_2-Eigenschaft

SQRT1_2-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften
sqrt-Methode
SQRT2-Eigenschaft


SQRT2-Eigenschaft

SQRT2-Eigenschaft 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Quadratwurzel von 2 zurück.
Syntax
var numVar
numVar = Math.SQRT2
Syntax
Die SQRT2-Eigenschaft ist eine Konstante, die näherungsweise dem Wert 1,414 entspricht.


SQRT2-Eigenschaft

SQRT2-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


SQRT2-Eigenschaft

SQRT2-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekteigenschaften
sqrt-Methode
SQRT1_2-Eigenschaft


sqrt-Methode

sqrt-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


sqrt-Methode

sqrt-Methode
Siehe auch 		JScript-Sprachverzeichnis

Math-Objektmethoden
SQRT1_2-Eigenschaft
SQRT2-Eigenschaft


tan-Methode

tan-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Tangens einer Zahl zurück.
Syntax
Math.tan(Zahl)

Das Argument Zahl ist ein numerischer Ausdruck, dessen Tangens gesucht wird.

Anmerkungen
Der Rückgabewert ist der Tangens von Zahl.


tan-Methode

tan-Methode
Betrifft 		JScript-Sprachverzeichnis

Math-Objekt


tan-Methode

tan-Methode
Siehe auch 		JScript-Sprachverzeichnis

acos-Methode
asin-Methode
atan-Methode
atan2-Methode
cos-Methode
Math-Objektmethoden
sin-Methode


MAX_VALUE-Eigenschaft

MAX_VALUE-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt die größte in JScript darstellbare Zahl zurück. Entspricht näherungsweise 1,79E+308.
Syntax
Zahl.MAX_VALUE

Das Argument Zahl ist das Number-Objekt.

Anmerkungen
Es ist nicht erforderlich, das Number-Objekt zu erstellen, bevor auf die MAX_VALUE-Eigenschaft zugegriffen werden kann.


MAX_VALUE-Eigenschaft

MAX_VALUE-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Number-Objekt


MAX_VALUE-Eigenschaft

MAX_VALUE-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

MIN_VALUE-Eigenschaft
NaN-Eigenschaft
NEGATIVE_INFINITY-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
toString-Methode


MIN_VALUE-Eigenschaft

MIN_VALUE-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt die der Null am nächsten kommende Zahl zurück, die in JScript dargestellt werden kann. Entspricht näherungsweise 2,22E-308.
Syntax
Zahl.MIN_VALUE

Das Argument Zahl ist das Number-Objekt.

Anmerkungen
Es ist nicht erforderlich, das Number-Objekt zu erstellen, bevor auf die MIN_VALUE-Eigenschaft zugegriffen werden kann.


MIN_VALUE-Eigenschaft

MIN_VALUE-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Number-Objekt


MIN_VALUE-Eigenschaft

MIN_VALUE-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

MAX_VALUE-Eigenschaft
NaN-Eigenschaft
NEGATIVE_INFINITY-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
toString-Methode


NaN-Eigenschaft (Number)

NaN-Eigenschaft (Number) 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Ein spezieller Wert, der angibt, dass ein arithmetischer Ausdruck einen Wert zurückgegeben hat, der keine Zahl ist.
Syntax
Zahl.NaN

Das Argument Zahl ist das Number-Objekt.

Anmerkungen
Es ist nicht erforderlich, das Number-Objekt zu erstellen, bevor auf die NaN-Eigenschaft zugegriffen werden kann.

Bei einem Vergleich ist NaN zu keinem Wert gleich, auch nicht zu sich selbst. Um zu testen, ob ein Wert äquivalent mit NaN ist, verwenden Sie die isNaN-Funktion.


NaN-Eigenschaft (Number)

NaN-Eigenschaft (Number)
Betrifft 		JScript-Sprachverzeichnis

Number-Objekt


NaN-Eigenschaft (Number)

NaN-Eigenschaft (Number)
Siehe auch 		JScript-Sprachverzeichnis

isNaN-Methode
MAX_VALUE-Eigenschaft
MIN_VALUE-Eigenschaft
NEGATIVE_INFINITY-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
toString-Methode


NEGATIVE_INFINITY-Eigenschaft

NEGATIVE_INFINITY-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt einen negativeren Wert als die größte negative Zahl (-Zahl.MAX_VALUE) zurück, die in JScript darstellbar ist.
Syntax
Zahl.NEGATIVE_INFINITY

Das Argument Zahl ist das Number-Objekt.

Anmerkungen
Es ist nicht erforderlich, das Number-Objekt zu erstellen, bevor auf die NEGATIVE_INFINITY-Eigenschaft zugegriffen werden kann.

JScript zeigt NEGATIVE_INFINITY-Werte als (-)unendlich. Dieser Wert verhält sich mathematisch als unendlich.


NEGATIVE_INFINITY-Eigenschaft

NEGATIVE_INFINITY-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Number-Objekt


NEGATIVE_INFINITY-Eigenschaft

NEGATIVE_INFINITY-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

MAX_VALUE-Eigenschaft
MIN_VALUE-Eigenschaft
NaN-Eigenschaft
POSITIVE_INFINITY-Eigenschaft
toString-Methode


POSITIVE_INFINITY-Eigenschaft

POSITIVE_INFINITY-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt einen größeren Wert als die größte Zahl (Zahl.MAX_VALUE) zurück, die in JScript darstellbar ist.
Syntax
Zahl.POSITIVE_INFINITY

Das Argument Zahl ist das Number-Objekt.

Anmerkungen
Es ist nicht erforderlich, das Number-Objekt zu erstellen, bevor auf die POSITIVE_INFINITY-Eigenschaft zugegriffen werden kann.

JScript zeigt POSITIVE_INFINITY-Werte als unendlich. Dieser Wert verhält sich mathematisch als unendlich.


POSITIVE_INFINITY-Eigenschaft

POSITIVE_INFINITY-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Number-Objekt


POSITIVE_INFINITY-Eigenschaft

POSITIVE_INFINITY-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

MAX_VALUE-Eigenschaft
MIN_VALUE-Eigenschaft
NaN-Eigenschaft
NEGATIVE_INFINITY-Eigenschaft
toString-Methode


ActiveXObject-Objekt

ActiveXObject-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Aktiviert und gibt einen Verweis auf ein Automatisierungsobjekt zurück.
Syntax
var newObject = new ActiveXObject(Servername.Typname[, Speicherort])

Die ActiveXObject-Objektsyntax hat die folgenden Komponenten:

Komponente | Beschreibung
Servername | Erforderlich. Der Name der Anwendung, die das Objekt bereitstellt.
Klassenname | Erforderlich. Der Typ oder die Klasse des zu erstellenden Objekts.
Speicherort | Optional. Der Name des Netzwerkservers, auf dem das Objekt erstellt werden soll.

Anmerkungen
Alle Automatisierungsserver stellen mindestens einen Objekttyp zur Verfügung. Eine Textverarbeitung kann beispielsweise ein Application-Objekt, ein Document-Objekt und ein Toolbar-Objekt bereitstellen.

Um ein Automatisierungsobjekt zu erstellen, weisen Sie das neue ActiveXObject-Objekt einer Objektvariablen zu:

var ExcelTabellenblatt;
ExcelTabellenblatt = new ActiveXObject("Excel.Sheet");
Der Code startet die Anwendung, die das Objekt erstellt (in diesem Fall ein Microsoft Excel-Arbeitsblatt). Anschließend können Sie aus dem Code mit der von Ihnen festgelegten Objektvariablen auf das Objekt zugreifen. In diesem Beispiel können Sie auf Eigenschaften und Methoden des neuen Objekts mit der Objektvariablen ExcelTabellenblatt und anderer Excel-Objekte wie dem Application-Objekt und der ActiveSheet.Cells-Auflistung zugreifen: Beispiele:

// Anzeigen von Excel durch das Application-Oobjekt.
ExcelTabellenblatt.Application.Visible = true;
// Text in die erste Zelle der Tabelle schreiben.
ExcelTabellenblatt.ActiveSheet.Cells(1,1).Value = "Dies ist Spalte A, Zeile 1";
// Tabelle speichern.
ExcelTabellenblatt.SaveAs("C:\\TEST.XLS");
// Excel mit der Quit-Methode des Application-Objekts schließen.
ExcelTabellenblatt.Application.Quit();
// Freigeben der Objektvariablen.
ExcelTabellenblatt = "";
Das Erstellen von Objekten auf einem Remoteserver kann nur durchgeführt werden, wenn die Internetsicherheit deaktiviert wurde. Sie können ein Objekt auf einem entfernten Netzwerkcomputer erstellen, indem Sie den Computernamen an das Servername-Argument von ActiveXObject weiterleiten. Dieser Name entspricht dem Computernamen-Bestandteil im Freigabenamen. Bei der Netzwerkfreigabe "\\meinserver\public" ist der Servername "meinserver". Darüber hinaus können Sie auch den Servernamen unter Verwendung des DNS-Formats oder einer IP-Adresse angeben.

Der nachstehend aufgeführte Code gibt die Versionsnummer einer Excel-Instanz zurück, die auf dem entfernten Netzwerkcomputer "meinserver" ausgeführt wird:

Function HoleVersion {
  var XLApp = CreateObject("Excel.Application", "MeinServer");
  return(XLApp.Version);
}
Ist der angegebene Remoteserver nicht vorhanden, oder kann er nicht gefunden werden, tritt ein Fehler auf.


ActiveXObject-Objekt

ActiveXObject-Objekt
Siehe auch 		JScript-Sprachverzeichnis

GetObject-Funktion


Array-Objekt

Array-Objekt
 JScript-Sprachverzeichnis
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Ermöglicht das Erstellen von Datenfeldern beliebigen Datentyps.
Syntax
new Array()
new Array(Größe)
new Array(Element0, Element1, ..., Elementn)

Die Syntax für die Erstellung von Array-Objekten hat die folgenden Komponenten:

Komponente | Beschreibung
Größe | Die Größe des Datenfelds. Weil Datenfelder nullbasiert sind, haben erstellte Elemente Indizes von 0 bis Größe -1.
Element0,...,ElementN | Die Elemente, die in das Datenfeld gesetzt werden sollen. Auf diese Weise wird ein Datenfeld mit N + 1 Elementen und einer length von N erstellt.

Anmerkungen
Nachdem ein Datenfeld erstellt wurde, kann auf die einzelnen Elemente über die Notation mit eckigen Klammern [] zugegriffen werden: x = meinDatenfeld[4];.
var meinDatenfeld = new Array();
for (i = 0; i < 10; i++)
    {
    meinDatenfeld[i] = i;
    }
x = meinDatenfeld[4];
Da Datenfelder in Microsoft JScript nullbasiert sind, greift die letzte Anweisung im obigen Beispiel auf das fünfte Element des Datenfelds zu. Dieses Element enthält den Wert 4.

Wenn nur ein Argument an den Array-Konstruktor übergeben wird und es sich dabei um eine Zahl handelt, wird eine Konvertierung zu einer Ganzzahl ohne Vorzeichen erzwungen, und dieser Wert wird für die Größe des Datenfelds verwendet. Andernfalls wird der übergebene Parameter als einziges Element des Datenfelds verwendet.


Array-Objekt

Array-Objekt
Siehe auch 		JScript-Sprachverzeichnis

new-Operator


Array-Objektmethoden

Array-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Array.prototype
concat-Methode
join-Methode
reverse-Methode
slice-Methode
sort-Methode

toString-Methode
valueOf-Methode

Keine Elemente von Array.prototype
Das Array-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


Array-Objekteigenschaften

Array-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von Array.prototype
constructor-Eigenschaft
Keine Elemente von Array.prototype
length-Eigenschaft
prototype-Eigenschaft


Boolean-Objekt

Boolean-Objekt 		JScript-Sprachverzeichnis
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Erstellt einen neuen Booleschen Wert.
Syntax
var variablename = new Boolean(Boolwert)

Das optionale Argument Boolwert ist der anfängliche Boolesche Wert des neuen Objekts. Ist dieser Wert nicht vorhanden, oder False, 0, Null, NaN oder eine leere Zeichenfolge, dann ist der anfängliche Wert des Boolean-Objekts False. Andernfalls ist der anfängliche Wert True.

Anmerkungen
Das Boolean-Objekt ist ein Mantelobjekt für den Datentyp Boolean. JScript verwendet das Boolean-Objekt automatisch, wenn ein Boolean-Datentyp zu einem Boolean-Objekt konvertiert wird.

Das Boolean-Objekt wird nur selten explizit aufgerufen.


Boolean-Objekt

Boolean-Objekt
Siehe auch 		JScript-Sprachverzeichnis

new-Operator
var-Anweisung


Boolean-Objektmethoden

Boolean-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Boolean.prototype
toString-Methode
valueOf-Methode
Keine Elemente von Boolean.prototype
Das Boolean-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


Boolean-Objekteigenschaften

Boolean-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von Boolean.prototype
constructor-Eigenschaft
Keine Elemente von Boolean.prototype
prototype-Eigenschaft


Date-Objekt

Date-Objekt 		JScript-Sprachverzeichnis
Version 1

Siehe auch Methoden Eigenschaften

Beschreibung
Ermöglicht grundlegende Speicherungs- und Erfassungsmöglichkeiten von Datums- und Zeitvariablen.
Syntax
var neuesDateObj = new Date()

var neuesDateObj = new Date(DatumWert)
var neuesDateObj = new Date(Jahr, Monat,Datum[, Stunden[, Minuten[, Sekunden[,MS]]]])

Die Syntax für den Konstruktor des Date-Objekts hat die folgenden Komponenten:

Komponente | Beschreibung
DatumWert | Als numerischer Wert entspricht DatumWert der Anzahl von Millisekunden gemäß koordinierter Weltzeit zwischen dem angegebenen Datum und dem 1. Januar 1970 um Mitternacht. Als Zeichenfolge wird DatumWert gemäß den Regeln der parse-Methode analysiert. Das Argument DatumWert kann auch ein VT_DATE-Wert sein, wie er von einigen ActiveX®-Objekten zurückgegeben wird.
Jahr | Erforderlich. Das vollständige Jahr, z. B. 1976 (und nicht 76).
Monat | Erforderlich. Der Monat als eine Ganzzahl zwischen 0 und 11 (Januar bis Dezember).
Datum | Erforderlich. Das Datum als eine Ganzzahl zwischen 1 und 31.
Stunden | Optional. Muss angegeben werden, wenn Minuten angegeben wird. Eine Ganzzahl zwischen 0 und 23 (Mitternacht bis 23 Uhr), die die Stunde angibt.
Minuten | Optional. Muss angegeben werden, wenn Minuten angegeben wird. Eine Ganzzahl zwischen 0 und 59, die die Minuten angibt.
Sekunden | Optional. Muss angegeben werden, wenn MS angegeben wird. Eine Ganzzahl zwischen 0 und 59, die die Sekunden angibt.
MS | Optional. Eine Ganzzahl zwischen 0 und 999, die die Millisekunden angibt.

Anmerkungen
Wenn für die Zahl NaN angegeben wird, bedeutet dies, das Objekt stellt keinen bestimmten Zeitpunkt dar. Wenn der Wert eines Arguments größer als dessen Bereich oder eine negative Zahl ist, werden andere gespeicherte Werte entsprechend geändert. Wenn Sie z. B. 150 Sekunden angeben, macht JScript daraus 2 Minuten und 30 Sekunden.

Ist die Zahl NaN, dann zeigt dies an, dass das Objekt keinen bestimmten Zeitpunkt darstellt. Wenn Sie dem Date-Objekt keine Parameter übergeben, wird es auf die aktuelle Zeit (UTC) initialisiert. Sie müssen dem Objekt einen Wert zuweisen, bevor Sie es verwenden können.

Der Bereich, der in einem Date-Objekt dargestellt werden kann, beträgt etwa 285.616 Jahre vor und nach dem 1. Januar 1970.

Zum Date-Objekt gehören zwei statische Methoden, die aufgerufen werden, ohne ein Date-Objekt zu erstellen: parse und UTC.


Date-Objekt

Date-Objekt
Siehe auch 		JScript-Sprachverzeichnis

new-Operator
var-Anweisung


Date-Objektmethoden

Date-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Date.prototype
getDate-Methode
getDay-Methode
getFullYear-Methode
getHours-Methode
getMilliseconds-Methode
getMinutes-Methode
getMonth-Methode
getSeconds-Methode
getTime-Methode
getTimezoneOffset-Methode
getUTCDate-Methode
getUTCDay-Methode
getUTCFullYear-Methode
getUTCHours-Methode
getUTCMilliSeconds-Methode
getUTCMinutes-Methode
getUTCMonth-Methode
getUTCSeconds-Methode
getVarDate-Methode
getYear-Methode
setDate-Methode
setFullYear-Methode
setHours-Methode
setMilliSeconds-Methode
setMinutes-Methode
setMonth-Methode
setSeconds-Methode
setTime-Methode
setUTCDate-Methode
setUTCFullYear-Methode
setUTCHours-Methode
setUTCMilliseconds-Methode
setUTCMinutes-Methode
setUTCMonth-Methode
setUTCSeconds-Methode
setYear-Methode
toGMTString-Methode
toLocaleString-Methode
toUTCString-Methode

toString-Methode
valueOf-Methode

Keine Elemente von Date.prototype
parse-Methode
UTC-Methode


Date-Objekteigenschaften

Date-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

constructor-Eigenschaft
prototype-Eigenschaft


Dictionary-Objekt

Dictionary-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Ein Objekt, das Datenpaare aus Schlüsseln und Elementen speichert.
Syntax
y = new ActiveXObject("Scripting.Dictionary")
Anmerkungen
Ein Dictionary-Objekt ist vergleichbar mit einem assoziativen Datenfeld in PERL. Elemente können aus beliebigen Daten bestehen und werden in einem Datenfeld gespeichert. Jedes Element wird mit einem eindeutigen Schlüssel verbunden. Der Schlüssel wird zum Auslesen eines einzelnen Elements verwendet und ist gewöhnlich ein ganzzahliger Wert oder eine Zeichenfolge, kann aber jeden Datentyp (außer Array) haben.

Der folgende Code zeigt die Verwendung eines Dictionary-Objekts:

var y = new ActiveXObject("Scripting.Dictionary");
y.add ("a", "test");
if (y.Exists("a"))
  document.write("true");
...


Dictionary-Objekt

Dictionary-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

FileSystemObject-Objekt
TextStream-Objekt


Dictionary-Objektmethoden

Dictionary-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Dictionary-Objekteigenschaften

Dictionary-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Count-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft


Drive-Objekt

Drive-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf die Eigenschaften eines bestimmten Platten- oder Netzlaufwerks.
Anmerkungen
Der folgende Code verdeutlicht die Verwendung des Drive-Objekts, um auf die Laufwerkseigenschaften zuzugreifen:
function ZeigeFreienSpeicherplatz(pfad)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(pfad));
    s = "Drive " + pfad + " - " ;
    s += d.VolumeName + "<br>";
    s += "Freier Speicherplatz: " + d.FreeSpace/1024 + " KB";
    return(s);
}


Drive-Objekt

Drive-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drives-Auflistung
File-Objekt
Files-Auflistung
Folder-Objekt
Folders-Auflistung
GetDrive-Methode


Drive-Objektmethoden

Drive-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Das Drive-Objekt verfügt über keine Methoden.


Drive-Objekteigenschaften

Drive-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


constructor-Eigenschaft

constructor-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt die Funktion an, die ein Objekt erstellt.
Syntax
Objekt.constructor

Das erforderliche Argument Objekt ist der Name eines Objekts oder einer Funktion.

Anmerkungen
Die constructor-Eigenschaft ist ein Element des Prototyps jedes Objekts, das einen Prototyp hat. Das umfasst alle integrierten JScript-Objekte außer den Objekten Global und Math. Die constructor-Eigenschaft enthält einen Verweis auf die Funktion, die Instanzen dieses bestimmten Objekts erstellt. Beispiele:
x = new String("Hi");
if (x.constructor == String)
       // Führt etwas aus (die Bedingung ist wahr).
oder
function MeineFunktion {
    // Hauptteil der Funktion
}

y = new MeineFunktion;
if (y.constructor == MeineFunktion)
       // Führt etwas aus (die Bedingung ist wahr).


constructor-Eigenschaft

constructor-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
Boolean-Objekt
Date-Objekt
Function-Objekt
Math-Objekt
Number-Objekt
Object-Objekt
String-Objekt


constructor-Eigenschaft

constructor-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

prototype-Eigenschaft


prototype-Eigenschaft

prototype-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt einen Verweis auf den Prototyp einer Objektklasse zurück.
Syntax
Objektname.prototype

Das Argument Objektname ist der Name eines Objekts.

Anmerkungen
Mit der prototype-Eigenschaft können Sie einer Objektklasse eine Basismenge an Funktionalität bereitstellen. Neue Instanzen eines Objekts "erben" das Verhalten des Prototyps, der diesem Objekt zugewiesen ist.

Sie möchten z. B. dem Array-Objekt eine Methode hinzufügen, die den Wert des größten Elements des Datenfelds zurückgibt. Deklarieren Sie dazu die Funktion, fügen Sie sie zu Array.prototype hinzu, und verwenden Sie sie anschließend.

function datenfeld_max( )
{
  var i, max = this[0];
  for (i = 1; i < this.length; i++)
  {
     if (max < this[i])
         max = this[i];
  }
  return max;
}
Array.prototype.max = datenfeld_max;
var x = new Array(1, 2, 3, 4, 5, 6);
var y = x.max( );
Nach Durchführen dieses Codes enthält y den größten Wert im Datenfeld x oder 6.

Alle integrierten JScript-Objekte verfügen über die schreibgeschützte prototype-Eigenschaft. Wie in dem Beispiel kann dem Prototyp Funktionalität hinzugefügt werden. Dem Objekt darf aber kein anderer Prototyp zugewiesen werden. Jedoch darf einem benutzerdefinierten Objekt ein neuer Prototyp zugewiesen werden.

In den Methoden- und Eigenschaftenlisten für jedes integrierte Objekt in diesem Sprachverzeichnis wird angegeben, welche zum Teil des Objekt-Prototyps gehören und welche nicht.


prototype-Eigenschaft

prototype-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
Boolean-Objekt
Date-Objekt
Function-Objekt
Number-Objekt
Object-Objekt
String-Objekt


prototype-Eigenschaft

prototype-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

constructor-Eigenschaft


toString-Methode

toString-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolgendarstellung eines Objekts zurück.
Syntax
Objektname.toString([Radix])

Die Syntax der toString-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objektname | Erforderlich. Ein Objekt, für das eine Zeichenfolgendarstellung gesucht wird.
Radix | Optional. Gibt eine Radix zur Konvertierung von numerischen Werten in Zeichenfolgen an.

Anmerkungen
Die toString-Methode ist ein Element aller in JScript integrierten Objekte. Ihr Verhalten hängt vom Objekttyp ab:

Objekt | Verhalten
Array | Elemente eines Arrays werden in Zeichenfolgen konvertiert. Die sich ergebenden Zeichenfolgen werden durch Kommas getrennt aneinander gefügt.
Boolean | Ist der Boolesche Wert True, dann wird "true" zurückgegeben. Andernfalls wird "false" zurückgegeben.
Function Gibt eine Zeichenfolge im folgenden Format zurück, bei der Funktionsname der Name der Funktion ist, deren toString-Methode aufgerufen wurde:
Funkion Funktionsname( ) { [Code] }
Number | Gibt eine Textdarstellung der Zahl zurück.
String | Gibt den Wert des String-Objekts zurück.
Default | Gibt "[object objectname]" zurück, wobei objectname der Name des Objekttyps ist.

Das folgende Beispiel zeigt die Verwendung der toString-Methode mit einem Basis-Argument:

function ErstelleRadixTabelle ()
{
  var s1, s2, s3, x;
  document.write("Hex    Dec   Bin<BR>");
  for (x = 0; x < 16; x++)
  {
    switch(x)
    {
      case 0 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 1 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 2 :
        s3 = "   ";
        break;
      case 3 :
        s3 = "   ";
        break;
      case 4 :
        s3 = "   ";
        break;
      case 5 :
        s3 = "   ";
        break;
      case 6 :
        s3 = "   ";
        break;
      case 7 :
        s3 = "   ";
        break;
      case 8 :
        s3 = "";
        break;
      case 9 :
        s3 = "";
        break;
      default:
        s1 = "      ";
        s2 = "";
        s3 = "   ";
    }
    document.write(" ", x.toString(16), s1, x.toString(10), s2, s3, x.toString(2), "<BR>");
  }
}


toString-Methode

toString-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
Boolean-Objekt
Function-Objekt
Number-Objekt
Object-Objekt
String-Objekt


toString-Methode

toString-Methode
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung


valueOf-Methode

valueOf-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt den einfachen Wert des angegebenen Objekts zurück.
Syntax
Objektname.valueOf( )

Das Argument Objektname ist ein beliebiges JScript-Objekt.

Anmerkungen
Die valueOf-Methode wird für jedes systeminterne JScript-Objekt unterschiedlich definiert.

Objekt | Rückgabewert
Array | Die Elemente des Datenfelds werden in Zeichenfolgen konvertiert, und die Zeichenfolgen werden, getrennt durch Kommas, aneinander gefügt. Dies verhält sich gleichbedeutend wie die Methoden Array.toString und Array.join.
Boolean | In dem Objekt enthaltener Boolescher Wert.
Date | Die Zahl der Millisekunden seit dem 1. Januar 1970 UTC .
Function | Die Funktion selbst.
Number | In dem Objekt enthaltener numerischer Wert.
Object | Das Objekt selbst. (Voreinstellung).
String | In dem Objekt enthaltene Zeichenfolge.

Das Math-Objekt besitzt keine valueOf-Eigenschaft.


valueOf-Methode

valueOf-Methode
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
Boolean-Objekt
Date-Objekt
Function-Objekt
Number-Objekt
Object-Objekt
String-Objekt


valueOf-Methode

valueOf-Methode
Siehe auch 		JScript-Sprachverzeichnis

toString-Methode


Enumerator-Objekt

Enumerator-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Bietet die Möglichkeit, die Elemente einer Auflistung aufzuzählen.
Syntax
new Enumerator(Auflistung)

Das Argument Auflistung ist ein beliebiges Aufzählungsobjekt.

Anmerkungen
Auflistungen unterscheiden sich von Datenfeldern dadurch, dass auf die Elemente einer Auflistung nicht direkt zugegriffen werden kann. Anstatt wie bei Datenfeldern Indizes zu verwenden, können Sie nur den aktuellen Elementzeiger auf das erste oder nächste Element der Auflistung bewegen.

Das Enumerator-Objekt bietet einen Weg, auf ein beliebiges Element einer Auflistung zuzugreifen und verhält sich ähnlich wie die Anweisung For...Each in VBScript.

Der folgende Code zeigt die Verwendung des Enumerator-Objekts:

function ZeigeLaufwerkListe()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (;!e.atEnd();e.moveNext())
    {
      x = e.item();
      s = s + x.DriveLetter;
      s += " - ";
      if (x.DriveType == 3)
        n = d.ShareName;
      else if (x.IsReady)
        n = d.VolumeName;
      else
        n = "[Laufwerk ist nicht bereit]";
      s +=  n + "<br>";
    }
  return(s);
}


Enumerator-Objekt

Enumerator-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Drives-Auflistung
Files-Auflistung
Folders-Auflistung


Enumerator-Objektmethoden

Enumerator-Objekt
Methoden 		JScript-Sprachverzeichnis

atEnd-Methode
item-Methode
moveFirst-Methode
moveNext-Methode


Enumerator-Objekteigenschaften

Enumerator-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Das Enumerator-Objekt besitzt keine Eigenschaften.


Error-Objekt

Error-Objekt 		JScript-Sprachverzeichnis
Version 5

Siehe auch Eigenschaften

Beschreibung
Enthält Informationen zu Fehlern.
Syntax
var neuesErrorObj = new Error()
var neuesErrorObj = new Error(Nummer)
var neuesErrorObj = new Error(Nummer, Beschreibung)

Die Konstruktor-Syntax des Error-Objekts hat folgende Komponenten:

Komponente | Beschreibung
Nummer | Einem Fehler zugewiesener numerischer Wert. Null, wenn sie weggelassen wird.
Beschreibung | Kurze Zeichenfolge, die einen Fehler beschreibt. Leere Zeichenfolge, wenn sie weggelassen wird.

Anmerkungen
Bei jedem Auftreten eines Laufzeitfehlers wird eine Instanz des Error-Objekts erstellt, um den Fehler zu beschreiben. Diese Instanz hat zwei integrierte Eigenschaften, die die Beschreibung des Fehlers (description-Eigenschaft) und die Fehlernummer (number-Eigenschaft) enthalten.

Eine Fehlernummer ist ein 32-Bit-Wert. Das obere 16-Bit-Wort ist der Teildienstcode, wohingegen das untere Wort den eigentlichen Fehlercode darstellt.

Error-Objekte können auch explizit erstellt werden, indem die weiter oben dargestellte Syntax verwendet wird, oder mit Hilfe der throw-Anweisung erzeugt werden. In beiden Fällen können Sie zusätzliche gewünschte Eigenschaften hinzufügen, um den Funktionsumfang des Error-Objekts zu erweitern.

Für gewöhnlich verweist die lokale Variable, die in einer try...catch-Anweisung erstellt wird, auf das explizit erstellte Error-Objekt. Sie können die Fehlernummer und -beschreibung daher beliebig und Ihren Anforderungen entsprechend verwenden.

Das folgende Beispiel zeigt die Verwendung des explizit erstellten Error-Objekts:

try x = y                		     // Generiert einen Fehler.
catch(e){              		     // Erstellt die lokale Variable e.
  response.write(e)                  // Gibt "[object Error]" aus.
  response.write(e.number & 0xFFFF)  // Gibt 5009 aus.
  response.write(e.description)      // Gibt "'y' ist nicht definiert. Nicht definierter Bezeichner" aus.
}


Error-Objekt

Error-Objekt
Siehe auch 		JScript-Sprachverzeichnis

new-Operator
throw-Anweisung
try...catch-Anweisung
var-Anweisung


Error-Objekteigenschaften

Error-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

description-Eigenschaft
number-Eigenschaft


File-Objekt

File-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf alle Eigenschaften einer Datei.
Anmerkungen
Der folgende Code verdeutlicht das Abrufen eines File-Objekts und das Anzeigen seiner Eigenschaften.
Function ZeigeDateiInfo(dateispez)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(dateispez);
  s = f.DateCreated;
  return(s);
}


File-Objekt

File-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Auflistung
Files-Auflistung
Folder-Objekt
Folders-Auflistung


File-Objektmethoden

File-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
Delete-Methode
Move-Methode
OpenAsTextStream-Methode


File-Objekteigenschaften

File-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
Type-Eigenschaft


FileSystemObject-Objekt

FileSystemObject-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Ermöglicht den Zugriff auf das Dateisystem des Computers.
Syntax
y = new ActiveXObject("Scripting.FileSystemObject")
Anmerkungen
Der folgende Code zeigt die Verwendung des FileSystemObject-Objekts, um ein TextStream-Objekt zurückzugeben, das gelesen oder in das geschrieben werden kann:
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testdatei.txt", true);
a.WriteLine("Dies ist ein Test.");
a.Close();
Im Beispielcode ist das ActiveXObject-Objekt dem FileSystemObject (fso) zugewiesen. Die CreateTextFile-Methode erstellt anschließend die Datei als TextStream-Objekt (a), und die WriteLine-Methode schreibt eine Textzeile in die erstellte Textdatei. Die Close-Methode leert den Puffer und schließt die Datei.


FileSystemObject-Objekt

FileSystemObject-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt
Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
Folder-Objekt
Folders-Auflistung
TextStream-Objekt


FileSystemObject-Objektmethoden

FileSystemObject-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

BuildPath-Methode
CopyFile-Methode
CopyFolder-Methode
CreateFolder-Methode
CreateTextFile-Methode
DeleteFile-Methode
DeleteFolder-Methode
DriveExists-Methode
FileExists-Methode
FolderExists-Methode
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
MoveFile-Methode
MoveFolder-Methode
OpenTextFile-Methode


FileSystemObject-Objekteigenschaften

FileSystemObject-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Drives-Eigenschaft


Folder-Objekt

Folder-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf alle Eigenschaften eines Ordners.
Anmerkungen
Der folgende Code verdeutlicht das Abrufen eines Folder-Objekts und das Zurückgeben einer seiner Eigenschaften:
function ZeigeOrdnerInfo(ordnerspez)
{
  var fso, folder, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  folder = fso.GetFolder(ordnerspez);
  s = folder.DateCreated;
  return(s);
}


Folder-Objekt

Folder-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
Folders-Auflistung


Folder-Objektmethoden

Folder-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Copy-Methode
Delete-Methode
Move-Methode
OpenAsTextStream-Methode


Folder-Objekteigenschaften

Folder-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Function-Objekt

Function-Objekt 		JScript-Sprachverzeichnis
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Erstellt eine neue Funktion.
Syntax 1
function Funktionsname( [Argumentname1 [, ... ArgumentnameN]] )
{
Rumpf
}
Syntax 2
var Funktionsname = new Function( [Argumentname1,, [... ArgumentnameN,]] Rumpf );

Die Syntax des Function-Objekts hat folgende Komponenten:

Komponente | Beschreibung
Funktionsname | Der Name der neu erstellten Funktion.
Argumentname1...ArgumentnameN | Eine optionale Liste der Argumente, die die Funktion akzeptiert.
Rumpf | Eine Zeichenfolge mit dem JScript-Codeblock, der ausgeführt werden soll, wenn die Funktion aufgerufen wird.

Anmerkungen
Die Funktion ist ein Basisdatentyp in JScript. Syntax 1 erstellt einen Funktionswert, den JScript nach Bedarf in ein Function-Objekt konvertiert. JScript konvertiert Function-Objekte, die mit Syntax 2 erstellt wurden, zum Zeitpunkt des Aufrufs der Funktion in Funktionswerte.

Syntax 1 ist die Standardweise zum Erstellen neuer Funktionen in JScript. Syntax 2 bietet eine Alternative, mit der Funktionsobjekte explizit erstellt werden können.

Wenn Sie z. B. eine Funktion erstellen wollen, die die beiden Argumente addiert, die an sie übergeben wurden, haben Sie dazu die beiden folgenden Möglichkeiten:

Beispiel 1
function addiere(x, y)
{
   return(x + y);
}
Beispiel 2
var addiere = new Function("x", "y", "return(x+y)");
In beiden Fällen rufen Sie die Funktion mit einer Codezeile wie der folgenden auf:
addiere(2, 3);
Hinweis Stellen Sie beim Aufrufen einer Funktion stets sicher, dass Sie die Klammern sowie die notwendigen Argumente einschließen. Das Aufrufen einer Funktion ohne Klammern führt zum Zurückgeben des Textes der Funktion, nicht jedoch des eigentlichen Ergebnisses.


Function-Objekt

Function-Objekt
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung
new-Operator
var-Anweisung


Function-Objektmethoden

Function-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Function.prototype
toString-Methode
valueOf-Methode
Keine Elemente von Function.prototype
Das Function-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


Function-Objekteigenschaften

Function-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von Function.prototype
arguments-Eigenschaft
caller-Eigenschaft

constructor-Eigenschaft

Keine Elemente von Function.prototype
prototype-Eigenschaft


Global-Objekt

Global-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Ein integriertes Objekt, dessen Zweck das Zusammenfassen globaler Methoden in einem Objekt ist.
Syntax
Das Global-Objekt verfügt nicht über eine Syntax. Sie rufen seine Methoden direkt auf.
Anmerkungen
Das Global-Objekt wird nie direkt verwendet und kann nicht mit Hilfe des new-Operators erstellt werden. Es wird beim Initialisieren des Skriptmoduls erstellt, wodurch seine Methoden und Eigenschaften sofort verfügbar werden.


Global-Objekt

Global-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Object-Objekt


Global-Objektmethoden

Global-Objekt
Methoden 		JScript-Sprachverzeichnis

escape-Methode
eval-Methode
isFinite-Methode
isNaN-Methode
parseFloat-Methode
parseInt-Methode
unescape-Methode


Global-Objekteigenschaften

Global-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Infinity-Eigenschaft
NaN-Eigenschaft


Math-Objekt

Math-Objekt 		JScript-Sprachverzeichnis
Version 1

Siehe auch Methoden Eigenschaften

Beschreibung
Ein integriertes Objekt mit mathematischen Funktionen und Konstanten.
Syntax
Math[.{Eigenschaft | Methode}]
Anmerkungen
Das Math-Objekt kann nicht unter Verwendung des new-Operators erstellt werden und gibt bei einem solchen Versuch einen Fehler zurück. Es wird beim Laden des Skriptmoduls erstellt. Seine gesamten Methoden und Eigenschaften stehen Ihrem Skript jederzeit zur Verfügung.


Math-Objekt

Math-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Number-Objekt


Math-Objektmethoden

Math-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Math.prototype
Das Math-Objekt besitzt keine Methoden, die Teil des Prototyps sind.
Keine Elemente von Math.prototype
abs-Methode
acos-Methode
asin-Methode
atan-Methode
atan2-Methode
ceil-Methode
cos-Methode
exp-Methode
floor-Methode
log-Methode
max-Methode
min-Methode
pow-Methode
random-Methode
round-Methode
sin-Methode
sqrt-Methode
tan-Methode


Math-Objekteigenschaften

Math-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

E-Eigenschaft
LN10-Eigenschaft
LN2-Eigenschaft
LOG10E-Eigenschaft
LOG2E-Eigenschaft
PI-Eigenschaft
SQRT1_2-Eigenschaft
SQRT2-Eigenschaft


Number-Objekt

Number-Objekt 		JScript-Sprachverzeichnis
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Eine Objektdarstellung des numerischen Datentyps und Platzhalter für numerische Konstanten.
Syntax
new Number(Wert)

Das Argument Wert ist der gesuchte numerische Wert für das Objekt.

Anmerkungen
JScript erstellt Number-Objekte aus numerischen Werten, je nach Erfordernis. Es ist nur selten erforderlich, Number-Objekte explizit zu erstellen.

Der Hauptzweck des Number-Objekts besteht darin, seine Eigenschaften in einem Objekt zu vereinen und mit der toString-Methode das Konvertieren von Zahlen in Zeichenfolgen zu ermöglichen.


Number-Objekt

Number-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Math-Objekt
new-Operator


Number-Objektmethoden

Number-Objektmethoden
 JScript-Sprachverzeichnis

Elemente von Number.prototype
toString-Methode
valueOf-Methode
Keine Elemente von Number.prototype
Das Number-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


Number-Objekteigenschaften

Number-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von Number.prototype
MAX_VALUE-Eigenschaft
MIN_VALUE-Eigenschaft
NaN-Eigenschaft
NEGATIVE_INFINITY-Eigenschaft
POSITIVE_INFINITY-Eigenschaft

constructor-Eigenschaft

Keine Elemente von Number.prototype
prototype-Eigenschaft


Object-Objekt

Object-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Bietet allen JScript-Objekten eine gemeinsame Funktionalität.
Syntax
new Object([Wert])

Das optionale Argument Wert wird verwendet, wenn Sie einen elementaren Datentyp (Zahl, Boolescher Wert, Zeichenfolge oder Funktion) in ein Objekt konvertieren wollen. Falls weggelassen, wird ein Objekt ohne Inhalt erstellt.

Anmerkungen
Das Object-Objekt ist in allen weiteren JScript-Objekten enthalten. Alle seine Methoden und Eigenschaften sind in allen anderen Objekten verfügbar. Die Methoden können in von Ihnen definierten Objekten neu definiert werden und werden von JScript zum entsprechenden Zeitpunkt aufgerufen. Die toString-Methode ist ein Beispiel einer häufig neu definierten Object-Methode.

In diesem Sprachverzeichnis enthält die Beschreibung der einzelnen Object-Methoden sowohl standardisierte als auch objektspezifische Implementierungsinformationen für die integrierten JScript-Objekte.


Object-Objekt

Object-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Function-Objekt
Global-Objekt


Object-Objektmethoden

Object-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von Objekt.prototype
toString-Methode
valueOf-Methode

Keine Elemente von Objekt.prototype
Das Object-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


Object-Objekteigenschaften

Object-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von Objekt.prototype
constructor-Eigenschaft
prototype-Eigenschaft

Keine Elemente von Objekt.prototype
Das Object-Objekt besitzt keine Eigenschaften, die nicht Teil des Prototyps sind.


RegExp-Objekt

RegExp-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Speichert Informationen zu Mustersuchen regulärer Ausdrücke.
Syntax
RegExp.Eigenschaftsname

Das Argument Eigenschaftsname ist eine der Eigenschaften des RegExp-Objekts.

Anmerkungen
Das RegExp-Objekt kann nicht direkt erstellt werden, ist jedoch stets verwendbar. Der Wert seiner Eigenschaften ist solange undefined, bis eine erfolgreiche Suche nach regulären Ausdrücken abgeschlossen ist.

Das folgende Beispiel zeigt die Verwendung des RegExp-Objekts:

function trefferDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 enthält: " + RegExp.$1 + "<BR>";
  s += "$2 enthält: " + RegExp.$2 + "<BR>";
  s += "$3 enthält: " + RegExp.$3;
  return(s);
}


RegExp-Objekt

RegExp-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Regular Expression-Objekt
String-Objekt
Syntax regulärer Ausdrücke


RegExp-Objektmethoden

RegExp-Objekt
Methoden 		JScript-Sprachverzeichnis

Das RegExp-Objekt verfügt über keine Methoden.


RegExp-Objekteigenschaften

RegExp-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

$1...$9-Eigenschaften
index-Eigenschaft
input-Eigenschaft
lastIndex-Eigenschaft


Regular Expression-Objekt

Regular Expression-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Enthält das Muster eines regulären Ausdrucks.
Syntax 1
var regularexpression = /Muster/[Schalter]
Syntax 2
var regularexpression = new RegExp("Muster",["Schalter"])

Die Syntax des regular expression-Objekts hat folgende Komponenten:

Komponente | Beschreibung
Muster | Erforderlich. Das zu verwendende Muster eines regulären Ausdrucks. Beim Verwenden von Syntax 1 begrenzen Sie das Muster mit dem Zeichen "/". Beim Verwenden von Syntax 2 setzen Sie das Muster in Anführungszeichen.
Schalter Optional. Setzen Sie bei Verwenden von Syntax 2 den Schalter in Anführungszeichen. Folgende Schalter sind verfügbar:
  • i (Groß-/Kleinschreibung ignorieren)
  • g (globale Suche nach allen Treffern von Muster)
  • gi (globale Suche, Groß-/Kleinschreibung ignorieren)

    • Anmerkungen
    Regular Expression-Objekte speichern verwendete Muster, wenn Zeichenfolgen nach Buchstabenkombinationen durchsucht werden. Nach Erstellen des Regular Expression-Objekts wird dieses entweder an eine string-Methode übergeben, oder eine Zeichenfolge wird an eine der Regular Expression-Methoden übergeben. Informationen zu der zuletzt durchgeführten Suche werden im RegExp-Objekt gespeichert.

    Verwenden Sie Syntax 1, wenn Ihnen die zu suchende Zeichenfolge vorher bekannt ist. Verwenden Sie Syntax 2, wenn sich die Suchzeichenfolge häufig ändert oder unbekannt ist, wie z. B. Zeichenfolgen, die einer Benutzereingabe entnommen werden.

    Das Argument Muster wird vor dem Verwenden in ein internes Format kompiliert. Bei Syntax 1 wird Muster beim Laden des Skripts kompiliert. Bei Syntax 2 wird Muster kurz vor dem Verwenden bzw. nach Aufrufen der compile-Methode kompiliert.


Regular Expression-Objekt

Regular Expression-Objekt
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekt
String-Objekt
Syntax regulärer Ausdrücke


Regular Expression-Objektmethoden

Regular Expression-Objekt
Methoden 		JScript-Sprachverzeichnis

compile-Methode
exec-Methode
test-Methode


Regular Expression-Objekteigenschaften

Regular Expression-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

lastIndex-Eigenschaft
source-Eigenschaft


String-Objekt

String-Objekt 		JScript-Sprachverzeichnis
Version 1

Siehe auch Methoden Eigenschaften

Beschreibung
Ermöglicht das Verändern und Formatieren von Zeichenfolgen sowie das Festlegen und Suchen von Teilzeichenfolgen innerhalb von Zeichenfolgen.
Syntax
StringObj[.Methode]
"Zeichenfolgenliteral"[.Methode]
Anmerkungen
String-Objekte können implizit durch die Angabe von Zeichenfolgenliteralen erstellt werden. Auf diese Weise erstellte String-Objekte werden als Standardzeichenfolgen bezeichnet. Ihre Verarbeitung unterscheidet sich geringfügig von der anderer String-Objekte, die mit dem new-Operator erstellt worden sind. Standardzeichenfolgen verwenden ein gemeinsames, globales String-Objekt. Wenn eine Eigenschaft einer Standardzeichenfolge hinzugefügt wird, ist sie in allen Standard-Zeichenfolgenobjekten verfügbar:
var alpha, beta;
alpha = "Dies ist eine Zeichenfolge";
beta = "Dies ist ebenfalls eine Zeichenfolge";

alpha.test = 10;

In diesem Beispiel ist test nunmehr für beta und alle zukünftigen Zeichenfolgenliterale definiert. Im nächsten Beispiel werden hinzugefügte Eigenschaften anders behandelt:

var gamma, delta;
gamma = new String("Dies ist eine Zeichenfolge");
delta = new String("Dies ist ebenfalls eine Zeichenfolge");

gamma.test = 10;
In diesem Fall ist test für delta nicht definiert. Jedes String-Objekt, das als new String-Objekt definiert ist, hat seine eigene Gruppe von Elementen. Nur in diesem Fall werden String-Objekte und Zeichenfolgenliterale unterschiedlich behandelt.


String-Objekt

String-Objekt
Siehe auch 		JScript-Sprachverzeichnis

new-Operator


String-Objektmethoden

String-Objekt
Methoden 		JScript-Sprachverzeichnis

Elemente von String.prototype
anchor-Methode
big-Methode
blink-Methode
bold-Methode
charAt-Methode
charCodeAt-Methode
concat-Methode
fixed-Methode
fontcolor-Methode
fontsize-Methode
fromCharCode-Methode
indexOf-Methode
italics-Methode
lastIndexOf-Methode
link-Methode
match-Methode
replace-Methode
search-Methode
slice-Methode
small-Methode
split-Methode
strike-Methode
sub-Methode
substr-Methode
substring-Methode
sup-Methode
toLowerCase-Methode
toUpperCase-Methode

toString-Methode
valueOf-Methode

Keine Elemente von String.prototype
Das String-Objekt verfügt über keine Methoden, die nicht Teil des Prototyps sind.


String-Objekteigenschaften

String-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Elemente von String.prototype
constructor-Eigenschaft
Keine Elemente von String.prototype
length-Eigenschaft
prototype-Eigenschaft


TextStream-Objekt

TextStream-Objekt 		Referenz für die JScript-Laufzeitbibliothek
Version 2

Siehe auch Methoden Eigenschaften

Beschreibung
Vereinfacht den sequenziellen Zugriff auf eine Datei.
Syntax
TextStream.{Eigenschaft | Methode( )}

Bei den Argumenten Eigenschaft und Methode kann es sich um beliebige Eigenschaften und Methoden handeln, die mit dem TextStream-Objekt verknüpft sind.

Anmerkungen
Im folgenden Code handelt es sich bei a um das TextStream-Objekt, das von der CreateTextFile-Methode beim Ausführen auf dem FileSystemObject-Objekt zurückgegeben wird:
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testdatei.txt", true);
a.WriteLine("Dies ist ein Test.");
a.Close();
WriteLine und Close sind zwei Methoden des TextStream-Objekts.


TextStream-Objekt

TextStream-Objekt
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Dictionary-Objekt
FileSystemObject-Objekt


TextStream-Objektmethoden

TextStream-Objekt
Methoden 		Referenz für die JScript-Laufzeitbibliothek

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteBlankLines-Methode
WriteLine-Methode


TextStream-Objekteigenschaften

TextStream-Objekt
Eigenschaften 		Referenz für die JScript-Laufzeitbibliothek

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Column-Eigenschaft
Line-Eigenschaft


VBArray-Objekt

VBArray-Objekt 		JScript-Sprachverzeichnis
Version 3

Siehe auch Methoden Eigenschaften

Beschreibung
Bietet Zugriff auf sichere Visual Basic-Datenfelder.
Syntax
new VBArray(VBDatenfeld)

Das VBDatenfeld ist ein VBArray-Wert.

Anmerkungen
VBArrays sind schreibgeschützt und können nicht direkt erstellt werden. Das VBFeld-Argument muss einen VBArray-Wert haben, bevor es an den VBArray-Konstruktor übergeben werden kann. Dies ist nur möglich, indem der Wert von einem vorhandenen ActiveX-Objekt oder einem anderen Objekt abgerufen wird.

VBArrays können mehrere Dimensionen haben. Die Indizes der einzelnen Dimensionen können unterschiedlich sein. Die dimensions-Methode ruft die Zahl der Dimensionen in dem Datenfeld ab. Die Methoden lbound und ubound rufen den von jeder Methode verwendeten Indexbereich ab.

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der das Safe Array-Objekt in ein JScript Array-Objekt konvertiert. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="VBScript">
<!--
function VBArrayTest(vbdatenfeld)
{
  var a = new VBArray(vbdatenfeld);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.write("true");
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(ErstelleVBArray());
-->
</SCRIPT>
</BODY>


VBArray-Objekt

VBArray-Objekt
Siehe auch 		JScript-Sprachverzeichnis

Array-Objekt


VBArray-Objektmethoden

VBArray-Objekt
Methoden 		JScript-Sprachverzeichnis

dimensions-Methode
getItem-Methode
lbound-Methode
toArray-Methode
ubound-Methode


VBArray-Objekteigenschaften

VBArray-Objekt
Eigenschaften 		JScript-Sprachverzeichnis

Das VBArray-Objekt besitzt keine Eigenschaften.


Operatorvorrang

Operatorvorrang 		JScript-Sprachverzeichnis
Version 1

Operatoren werden in JScript in einer bestimmten Rangfolge ausgewertet. Diese wird Operatorvorrang genannt. Die folgende Tabelle listet die Operatoren in der Reihenfolge ihres Vorrangs von oben nach unten auf. Operatoren in derselben Zeile werden von links nach rechts ausgewertet.

Operator | Beschreibung
. [] () Feldzugriff, Datenfeldindizierung und Funktionsaufrufe
++ -- - ~ ! typeof new void | Unäre Operatoren, Rückgabedatentyp, Objekterstellung, nicht definierte Werte
* / % Multiplikation, Division, Modulo-Division
+ - + Addition, Subtraktion, Zeichenfolgenverknüpfung
<< >> >>> Bit-Verschiebung
< <= > >= instanceof | Kleiner als, Kleiner gleich, Größer als, Größer gleich, instanceof
== != === !== Gleichheit, Ungleichheit, Identität, Nicht-Identität
& Bitweises AND
^ Bitweises XOR
| Bitweises OR
&& Logisches AND
|| Logisches OR
?: Bedingt
= OP= | Zuweisungen, Zuweisungen mit Operation
, Mehrfache Auswertung

Sie verändern die Reihenfolge der Abarbeitung, indem Sie Klammern verwenden. Der Ausdruck in den Klammern wird abgearbeitet, bevor das Ergebnis für den verbleibenden Teil der Anweisung verwendet wird.

Ein Operator mit höherem Vorrang wird vor einem Operator mit niedrigerem Vorrang bearbeitet. Beispiele:

z = 78 * (96 + 3 + 45)

Dieser Ausdruck enthält fünf Operatoren: =, *, (), + und +. Gemäß dem Vorrang werden sie in der folgenden Reihenfolge ausgewertet: (), *, +, +, =.

  1. Die Auswertung des Ausdrucks in der Klammer erfolgt zuerst: Es gibt zwei Additionsoperatoren, die denselben Vorrang haben: 96 und 3 werden addiert, und 45 wird zu der Summe addiert. Das Ergebnis ist 144.
  2. Als Nächstes folgt die Multiplikation: 78 und 144 werden multipliziert. Das Ergebnis ist 10998.
  3. Zuletzt erfolgt die Zuweisung: 11232 wird z zugewiesen.


Additionsoperator (+)

Additionsoperator (+) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zum Addieren von Zahlen oder Verbinden von Zeichenfolgen verwendet.
Syntax
Ergebnis = Ausdruck1 + Ausdruck2

Die Syntax des Additionsoperators besteht aus folgenden Komponenten:

Komponenten | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der den Ausdrücken zugrunde liegende Untertyp bestimmt das Verhalten des Additionsoperators auf folgende Weise:

Fall | Ergebnis
Beide Ausdrücke sind numerisch oder Boolesch | Addition.
Beide Ausdrücke sind Zeichenfolgen | Verkettung.
Ein Ausdruck ist numerisch, der andere eine Zeichenfolge | Verkettung.

Weitere Informationen darüber, wann der Additionsoperator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Additionsoperator (+)

Additionsoperator (+)
Siehe auch 		JScript-Sprachverzeichnis

+= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


+= (Operator)

+= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zum Inkrementieren einer Variablen um einen angegebenen Wert verwendet.
Syntax
Ergebnis += Ausdruck

Die Syntax von += hat folgende Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung dieses Operators entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis + Ausdruck
Der den Ausdrücken zugrunde liegende Untertyp bestimmt das Verhalten von += auf folgende Weise:

Fall | Ergebnis
Beide Ausdrücke sind numerisch oder Boolesch | Addition.
Beide Ausdrücke sind Zeichenfolgen | Verkettung.
Ein Ausdruck ist numerisch, der andere eine Zeichenfolge | Verkettung.

Weitere Informationen darüber, wann += einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


+= (Operator)

+= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Additionsoperator (+)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Verbundzuweisungsoperatoren

Verbundzuweisungsoperatoren 		JScript-Sprachverzeichnis

Addition (+=)
Bitweises AND (&=)
Bitweises OR (|=)
Bitweises XOR (^=)
Division (/=)
Left Shift (<<=)
Modulo (%=)
Multiplikation (*=)
Right Shift (>>=)
Subtraktion (-=)
Vorzeichenloses Right Shift (>>>=)


Logischer AND-Operator (&&)

Logischer AND-Operator (&&) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Konjunktion zweier Ausdrücke durch.
Syntax
Ergebnis = Ausdruck1 && Ausdruck2

Die Syntax des logischen AND-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Das Argument Ergebnis ist nur dann True, wenn tatsächlich beide Ausdrücke True sind. Sobald einer der beiden Ausdrücke False ist, ist das Ergebnis ebenfalls False.

Weitere Informationen darüber, wann der logische AND-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.

JScript verwendet die folgenden Regeln bei der Konvertierung von nicht-Booleschen Werten in Boolesche Werte:

  • Alle Objekte werden als True angenommen.
  • Zeichenfolgen haben nur dann den Wert False, wenn sie leer sind.
  • Null und undefined werden als False angenommen.
  • Zahlen sind nur dann False, wenn sie Null (0) sind.


Logischer AND-Operator (&&)

Logischer AND-Operator (&&)
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Zuweisungsoperator (=)

Zuweisungsoperator (=) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Weist einer Variablen einen Wert zu.
Syntax
Ergebnis = Ausdruck

Die Syntax des Zuweisungsoperators besteht aus folgenden Komponenten:

Komponenten | Beschreibung
Ergebnis | Beliebige Variable.
Ausdruck | Beliebiger numerischer Ausdruck.

Anmerkungen
Da sich der Zuweisungsoperator wie andere Operatoren verhält, haben Ausdrücke, die den Operator verwenden, einen Wert und weisen diesen Wert darüber hinaus Variable zu. Das bedeutet, dass Sie Operatoren folgendermaßen verkettet zuweisen können:
j = k = l = 0;
j, k, und l sind gleich Null, nachdem die Beispielanweisung ausgeführt worden ist.


Zuweisungsoperator (=)

Zuweisungsoperator (=)
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verbundzuweisungsoperatoren
Verhalten der Operatoren


&= (Operator)

&= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zum Ausführen einer bitweisen AND-Operation auf einem Ausdruck verwendet.
Syntax
Ergebnis &= Ausdruck

Die Syntax von &= hat folgende Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung dieses Operators entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis & Ausdruck
&= liest die Binärdaten der Werte für Ergebnis und Ausdruck und führt eine bitweise AND-Operation durch. Das Ergebnis dieser Operation zeigt folgendes Verhalten:
0101    (Ergebnis)
1100    (Ausdruck)
----
0100    (Ausgabe)
Jedes Mal, wenn beide Ausdrücke eine 1 an einer Stelle aufweisen, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann &= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


&= (Operator)

&= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser AND-Operator (&)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


|= (Operator)

|= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zum Ausführen einer bitweisen OR-Operation auf einem Ausdruck verwendet.
Syntax
Ergebnis |= Ausdruck

Die Syntax von |= hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung dieses Operators entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis | Ausdruck
|= liest die Binärdaten der Werte für Ergebnis und Ausdruck und führt eine bitweise OR-Operation durch. Das Ergebnis dieser Operation zeigt folgendes Verhalten:
0101    (Ergebnis)
1100    (Ausdruck)
----
1101    (Ausgabe)
Jedes Mal, wenn einer der Ausdrücke eine 1 an einer Stelle aufweist, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann |= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


|= (Operator)

|= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser OR-Operator (|)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Bitweiser AND-Operator (&)

Bitweiser AND-Operator (&) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine bitweise AND-Verknüpfung auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 & Ausdruck2

Die Syntax des bitweisen AND-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der bitweise AND-Operator nimmt die Binärdaten zweier Ausdrücke und führt eine bitweise Konjunktion durch. Das Ergebnis dieser Operation sieht so aus:
0101    (Ausdruck1)
1100    (Ausdruck2)
----
0100    (Ergebnis)
Jedes Mal, wenn beide Ausdrücke eine 1 an einer Stelle aufweisen, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann der bitweise AND-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Bitweiser AND-Operator (&)

Bitweiser AND-Operator (&)
Siehe auch 		JScript-Sprachverzeichnis

&= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Bitweiser NOT-Operator (~)

Bitweiser NOT-Operator (~) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine bitweise Negation an einem Ausdruck durch.
Syntax
Ergebnis = ~ Ausdruck

Die Syntax des bitweisen NOT-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Alle unären Operatoren wie der bitweise NOT-Operator werten Ausdrücke wie folgt aus:
  • Beim Anwenden auf undefined-Ausdrücke oder Null-Ausdrücke wird ein Laufzeitfehler hervorgerufen.
  • Objekte werden in Zeichenfolgen umgewandelt.
  • Zeichenfolgen werden, wenn möglich, in Zahlen konvertiert. Andernfalls wird ein Laufzeitfehler erzeugt.
  • Boolesche Werte werden wie Zahlen behandelt (0=False, 1=True).
Der Operator wird auf die sich ergebende Zahl angewendet.

Der bitweise NOT-Operator nimmt die Binärdaten des Ausdrucks und führt eine bitweise Negation durch. Das Resultat dieses Vorgangs sieht so aus:

0101    (Ausdruck)
----
1010    (Ergebnis)
Jede Ziffer, die im Ausdruck eine 1 ist, wird im Ergebnis eine 0. Jede Ziffer, die im Ausdruck eine 0 ist, wird im Ergebnis eine 1.


Bitweiser NOT-Operator (~)

Bitweiser NOT-Operator (~)
Siehe auch 		JScript-Sprachverzeichnis

Logischer NOT-Operator (!)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Bitweiser OR-Operator (|)

Bitweiser OR-Operator (|) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine bitweise OR-Operation auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 | Ausdruck2

Die Syntax des bitweisen OR-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der bitweise OR-Operator nimmt die Binärdaten zweier Ausdrücke und führt eine bitweise Disjunktion durch. Das Ergebnis dieser Operation sieht so aus:
0101    (Ausdruck1)
1100    (Ausdruck2)
----
1101    (Ergebnis)
Jedes Mal, wenn einer der Ausdrücke eine 1 an einer Stelle aufweist, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann der bitweise OR-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Bitweiser OR-Operator (|)

Bitweiser OR-Operator (|)
Siehe auch 		JScript-Sprachverzeichnis

|= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Komma-Operator (,)

Komma-Operator (,) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Bewirkt das sequenzielle Ausführen zweier Ausdrücke.
Syntax
Ausdruck1, Ausdruck2

Die Syntax des Komma-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der Komma-Operator bewirkt, dass die Ausdrücke auf beiden Seiten von links nach rechts ausgeführt werden und den Wert des Ausdrucks rechts erhalten. Die gebräuchlichste Anwendung für den Komma-Operator ist im inkrementellen Ausdruck einer for-Schleife. Beispiel:
for (i = 0; i < 10; i++, j++)
{
  k = i + j;
}
Die for-Anweisung lässt nur die Ausführung eines einzigen Ausdrucks am Ende jedes Durchlaufens der Schleife zu. Der Komma-Operator wird eingesetzt, um zu ermöglichen, dass mehrere Ausdrücke als ein einziger behandelt werden und dadurch die Einschränkung umgangen werden kann.


Komma-Operator (,)

Komma-Operator (,)
Siehe auch 		JScript-Sprachverzeichnis

for-Anweisung
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Trinärer Bedingungsoperator (?:)

Trinärer Bedingungsoperator (?:) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt in Abhängigkeit einer Bedingung eine von zwei Anweisungen aus.
Syntax
Test ? Anweisung1 : Anweisung2

Die Syntax des trinären Bedingungsoperators hat die folgenden Komponenten:

Komponente | Beschreibung
Test | Beliebiger Boolescher Ausdruck.
Anweisung1 | Eine Anweisung, die ausgeführt wird, wenn Test True ist. Hierbei kann es sich auch um eine Verbundanweisung handeln.
Anweisung2 | Eine Anweisung, die ausgeführt wird, wenn Test False ist. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Der trinäre Bedingungsoperator ist eine kürzere Form der if...else-Anweisung. Üblicherweise ist er Teil eines größeren Ausdrucks, der durch eine if...else-Anweisung noch unhandlicher würde. Beispiel:
var jetzt = new Date();
var gruss = "Guten" + ((jetzt.getHours() > 17) ? " Abend." : " Tag.");
Das Beispiel erstellt die Zeichenfolge "Guten Abend.", wenn es später als 18.00 Uhr ist. Der gleiche Code mit einer if...else-Anweisung:
var jetzt = new Date();
var gruss = "Guten";
if (jetzt.getHours() > 17)
   gruss += " Abend.";
else
   gruss += " Tag.";


Trinärer Bedingungsoperator (?:)

Trinärer Bedingungsoperator (?:)
Siehe auch 		JScript-Sprachverzeichnis

if...else-Anweisung
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


delete-Operator

delete-Operator 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Löscht eine Eigenschaft aus einem Objekt oder entfernt ein Element aus einem Datenfeld.
Syntax
delete Ausdruck

Der Ausdruck ist ein gültiger Ausdruck in JScript, der gewöhnlich (aber nicht zwingend) einen Eigenschaftsnamen oder ein Datenfeldelement ergibt.

Anmerkungen
Wenn das Ergebnis von Ausdruck ein Objekt ist und die Eigenschaft, die im Ausdruck angegeben ist, existiert und wenn das Objekt nicht erlaubt, diese zu löschen, wird false zurückgegeben.

In allen anderen Fällen wird true zurückgegeben.


delete-Operator

delete-Operator
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


/= (Operator)

/= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zur Division einer Variablen durch einen Ausdruck verwendet.
Syntax
Ergebnis /= Ausdruck

Die Syntax von /= hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck | Beliebiger numerischer Ausdruck.

Anmerkungen
Die Verwendung von /= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis / Ausdruck
Weitere Informationen darüber, wann /= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


/= (Operator)

/= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Divisionsoperator (/)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Divisionsoperator (/)

Divisionsoperator (/) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zur Division zweier Zahlen und zur Rückgabe eines numerischen Ergebnisses verwendet.
Syntax
Ergebnis = Zahl1 / Zahl2

Die Syntax des Divisionsoperators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl1 | Beliebiger numerischer Ausdruck.
Zahl2 | Beliebiger numerischer Ausdruck.

Anmerkungen
Weitere Informationen darüber, wann der Divisionsoperator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Divisionsoperator (/)

Divisionsoperator (/)
Siehe auch 		JScript-Sprachverzeichnis

/= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Inkrementoperator (++) und Dekrementoperator (--)

Inkrementoperator (++)
und
Dekrementoperator (--) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
In- oder Dekrementieren einer Variablen um 1.
Syntax 1
Ergebnis = ++Variable
Ergebnis = --Variable
Ergebnis = Variable++
Ergebnis = Variable--
Syntax 2
++Variable
--Variable
Variable++
Variable--

Die Syntax der Inkrement- und Dekrementoperatoren hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige Variable.
Variable | Beliebige Variable.

Anmerkungen
Die Inkrement- und Dekrementoperatoren werden als Kurzform verwendet, um den Wert einer Variablen zu ändern. Der Wert eines Ausdrucks, der einen dieser Operatoren enthält, ist abhängig davon, ob der Operator vor oder nach der Variablen angegeben wird:
var j, k;
k = 2;
j = ++k;
j wird der Wert 3 zugewiesen, weil das Inkrementieren vor dem Verarbeiten des Ausdrucks vorgenommen wird.

Vergleichen Sie den Vorgang mit:

var j, k;
k = 2;
j = k++;
Hier wird j der Wert 2 zugewiesen, weil das Inkrementieren erst nach dem Verarbeiten des Ausdrucks stattfindet.


Inkrementoperator (++) und Dekrementoperator (--)

Inkrementoperator (++)
und
Dekrementoperator (--)
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


instanceof-Operator

instanceof-Operator 		JScript-Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Gibt einen Booleschen Wert zurück, der angibt, ob ein Objekt eine Instanz einer bestimmten Klasse ist.
Syntax
Ergebnis = Objekt instanceof Klasse

Die Syntax des instanceof-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Objekt | Jeder Objektausdruck.
Klasse | Jede definierte Objektklasse.

Anmerkungen
Der instanceof-Operator gibt true zurück, wenn Objekt eine Instanz von Klasse ist. Er gibt false zurück, wenn Objekt keine Instanz der angegebenen Klasse oder dieses null ist.

Das folgende Beispiel zeigt die Verwendung des instanceof-Operators:

function objTest(obj)
{
  var i, t, s = "";            // Erstellt Variablen.
  t = new Array();             // Erstellt ein Datenfeld.
  t["Date"] = Date;            // Schreibt in das Datenfeld.
  t["Object"] = Object;
  t["Array"] = Array;
  for (i in t)
    {
      if (obj instanceof t[i]) // Überprüft die Objektklasse.
      {
        s += "obj ist eine Instanz von " + i + "\n"; } else
      {
        s += "obj ist keine Instanz von " + i + "\n";
      }
    }
  return(s); 			// Gibt eine Zeichenfolge zurück.
}

var obj = new Date();
response.write(objTest(obj));


instanceof-Operator

instanceof-Operator
Siehe auch 		JScript-Sprachverzeichnis

Operatorvorrang
Zusammenfassung der Operatoren


Operatoren - Zusammenfassung

Operatoren: Zusammenfassung 		JScript-Sprachverzeichnis
Version 1

Arithmetisch
Addition (+)
Dekrement (--)
Division (/)
Inkrement (++)
Modulo (%)
Multiplikation (*)
Subtraktion (- )
Unäre Negation (-)
Logisch
Bedingung (?:, trinär)
Gleichheit (==)
Größer als (>)
Größer gleich (>=)
Identität (===)
Kleiner als (<)
Kleiner gleich (<=)
Komma (,)
Logisches AND (&&)
Logisches NOT (!)
Logisches OR (||)
Nicht-Identität (!==)
Ungleichheit (!=)
Bitweise
Bitweises AND (&)
Bitweises Left Shift (<<)
Bitweises NOT (~)
Bitweises OR (|)
Bitweises Right Shift (>>)
Bitweises XOR (^)
Vorzeichenloses Right Shift (>>>)
Zuweisung
Verbundzuweisung
Zuweisung (=)
Verschiedene
delete
instanceof
new
typeof
void


<<= (Operator)

<<= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschieben der Bits eines Ausdrucks nach links.
Syntax
Ergebnis <<= Ausdruck

Die Syntax von <<= besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung von <<= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis << Ausdruck
<<= schiebt die Bits von Ergebnis um die Anzahl der Bits, die in Ausdruck angegeben sind, nach links. Beispiel:
var temp
temp = 14
temp <<= 2
Die Variable temp hat einen Wert von 56, weil 14 (binär 00001110), um zwei Bits nach links verschoben, 56 ergibt (binär 00111000). Bits werden beim Verschieben durch Nullzeichen aufgefüllt.

Weitere Informationen darüber, wann <<= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


<<= (Operator)

<<= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser Left Shift-Operator (<<)
Bitweiser Right Shift-Operator (>>)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren
Vorzeichenloser Right Shift-Operator (>>>)


Bitweiser Left Shift-Operator (<<)

Bitweiser Left Shift-Operator (<<) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschiebt die Bits eines Ausdrucks nach links.
Syntax
Ergebnis = Ausdruck1 << Ausdruck2

Die Syntax des bitweisen Left Shift-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der bitweise Left Shift-Operator schiebt die Bits von Ausdruck1 um die Anzahl der Bits, die in Ausdruck2 angegeben sind, nach links. Beispiel:
var temp
temp = 14 << 2
Die Variable temp hat einen Wert von 56, weil 14 (binär 00001110), um zwei Bits nach links verschoben, 56 ergibt (binär 00111000).

Weitere Informationen darüber, wann der bitweise Left Shift-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Bitweiser Left Shift-Operator (<<)

Bitweiser Left Shift-Operator (<<)
Siehe auch 		JScript-Sprachverzeichnis

<<= (Operator)
Bitweiser Right Shift-Operator (>>)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren
Vorzeichenloser Right Shift-Operator (>>>)


Modulo-Operator (%)

Modulo-Operator (%) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Dividiert zwei Zahlen und gibt den Restwert zurück.
Syntax
Ergebnis = Zahl1 % Zahl2

Die Syntax des Modulo-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige Variable.
Zahl1 | Beliebiger numerischer Ausdruck.
Zahl2 | Beliebiger numerischer Ausdruck.

Anmerkungen
Der Modulo-Operator (oder Rest-Operator) dividiert Zahl1 durch Zahl2, rundet dabei Fließkommawerte in ganze Zahlen und gibt den Rest als Ergebnis zurück. Das Ergebnis des folgenden Ausdrucks (A) ist zum Beispiel 5.
A = 19 % 6,7
Weitere Informationen darüber, wann der Modulo-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Modulo-Operator (%)

Modulo-Operator (%)
Siehe auch 		JScript-Sprachverzeichnis

%= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


%= (Operator)

%= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wird zur Division von zwei Zahlen und der Rückgabe des Rests der Ganzzahldivision verwendet.
Syntax
Ergebnis %= Ausdruck

Die Syntax von %= hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger numerischer Ausdruck.

Anmerkungen
Die Verwendung von %= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis & Ausdruck
Weitere Informationen darüber, wann %= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


%= (Operator)

%= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Modulo-Operator (%)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


*= (Operator)

*= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Multiplizieren einer Zahl mit einer anderen Zahl.
Syntax
Ergebnis *= Ausdruck

Die Syntax von *= hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung von *= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis * Ausdruck
Weitere Informationen darüber, wann *= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


*= (Operator)

*= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Multiplikationsoperator (*)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Multiplikationsoperator (*)

Multiplikationsoperator (*) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Multipliziert zwei Zahlen miteinander.
Syntax
Ergebnis = Zahl1*Zahl2

Die Syntax des Multiplikationsoperators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Zahl1 | Beliebiger Ausdruck.
Zahl2 | Beliebiger Ausdruck.

Anmerkungen
Weitere Informationen darüber, wann der Multiplikationsoperator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Multiplikationsoperator (*)

Multiplikationsoperator (*)
Siehe auch 		JScript-Sprachverzeichnis

*= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


new-Operator

new-Operator
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Erstellt ein neues Objekt.
Syntax

new Konstruktor[(Argumente)]

Das Argument Konstruktor stellt einen Aufruf an den Konstruktor des Objekts dar. Die Klammern für den Funktionsaufruf können weggelassen werden, wenn der Konstruktor keine Argumente benötigt.

Anmerkungen
Die new-Anweisung führt folgende Schritte aus:
  1. Es wird ein Objekt ohne Elemente erstellt.
  2. Der Konstruktor für dieses Objekt wird aufgerufen, und ein Zeiger auf das neu angelegte Objekt wird als this-Zeiger übergeben.
Das Objekt wird entsprechend den an den Konstruktor übergebenen Argumenten initialisiert.

Hier folgen Beispiele gültiger Verwendungsweisen des new-Operators:

mein_objekt = new Object;
meinDatenfeld = new Array();
meinDatum = new Date("5. Jan 1996");


new-Operator

new-Operator
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung


Logischer NOT-Operator (!)

Logischer NOT-Operator (!) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Negation auf einen Ausdruck durch.
Syntax
Ergebnis = !Ausdruck

Die Syntax des logischen NOT-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die folgende Tabelle veranschaulicht, wie Ergebnis bestimmt wird.

Ist Ausdruck | Dann hat Ergebnis den Wert
True | False
False | True

Alle unären Operatoren wie der logische NOT-Operator werten Ausdrücke wie folgt aus:

  • Beim Anwenden auf undefined-Ausdrücke oder Null-Ausdrücke wird ein Laufzeitfehler hervorgerufen.
  • Objekte werden in Zeichenfolgen umgewandelt.
  • Zeichenfolgen werden, wenn möglich, in Zahlen konvertiert. Andernfalls wird ein Laufzeitfehler erzeugt.
  • Boolesche Werte werden wie Zahlen behandelt (0=False, 1=True).
Der Operator wird auf die sich ergebende Zahl angewendet.

Für den logischen NOT-Operator gilt: bei einem Ausdruck ungleich null (0) ist Ergebnis gleich null. Ist Ausdruck gleich null, dann ist Ergebnis 1.


Logischer NOT-Operator (!)

Logischer NOT-Operator (!)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser NOT-Operator (~)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Logischer OR-Operator (||)

Logischer OR-Operator (||) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Disjunktion auf zwei Ausdrücke durch.
Syntax
Ergebnis = Ausdruck1 || Ausdruck2

Die Syntax des logischen OR-Operators hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Ist einer der beiden Ausdrücke True, ist das Ergebnis ebenfalls True. Die folgende Tabelle zeigt, wie Ergebnis festgelegt wird:

Ist Ausdruck1 | Und ist Ausdruck2 | Dann ist Ergebnis
True | True | True
True | False | True
False | True | True
False | False | False

Weitere Informationen darüber, wann der logische OR-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.

JScript verwendet die folgenden Regeln bei der Konvertierung von nicht-Booleschen Werten in Boolesche Werte:

  • Alle Objekte werden als True angenommen.
  • Zeichenfolgen sind ausschließlich dann False, wenn sie leer sind.
  • Null und undefined werden als False angenommen.
  • Zahlen sind ausschließlich dann False, wenn sie 0 sind.


Logischer OR-Operator (||)

Logischer OR-Operator (||)
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


>>= (Operator)

>>= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschieben der Bits eines Ausdrucks nach rechts unter Beibehaltung des Vorzeichens.
Syntax
Ergebnis >>= Ausdruck

Die Syntax von >>= besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung von >>= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis >> Ausdruck
>>= schiebt die Bits von Ergebnis um die Anzahl der Bits, die in Ausdruck angegeben sind, nach rechts. Das Vorzeichenbit von Ergebnis wird verwendet, um die Bits von links aufzufüllen. Nach rechts hinausgeschobene Bits entfallen. So hat beispielsweise nach der Auswertung des folgenden Codes temp den Wert von -4: 14 (binär 11110010), um zwei Bits nach rechts verschoben, ergibt -4 (binär 11111100).
var temp
temp = -14
temp >>= 2
Weitere Informationen darüber, wann >>= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


>>= (Operator)

>>= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser Left Shift-Operator (<<)
Bitweiser Right Shift-Operator (>>)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren
Vorzeichenloser Right Shift-Operator (>>>)


Bitweiser Right Shift-Operator (>>)

Bitweiser Right Shift-Operator (>>) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschiebt die Bits eines Ausdrucks nach rechts unter Beibehaltung des Vorzeichens.
Syntax
Ergebnis = Ausdruck1 >> Ausdruck2

Die Syntax des bitweisen Right Shift-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der bitweise Right Shift-Operator schiebt die Bits von Ausdruck1 um die Anzahl der Bits, die in Ausdruck2 angegeben sind, nach rechts. Das Vorzeichenbit von Ergebnis wird verwendet, um die Bits von rechts aufzufüllen. Nach rechts hinausgeschobene Bits entfallen. So hat beispielsweise nach der Auswertung des folgenden Codes temp den Wert von -4: 14 (binär 11110010 ), um zwei Bits nach rechts verschoben, ergibt -4 (binär 11111100).
var temp
temp = -14 >> 2
Weitere Informationen darüber, wann der bitweise Right Shift-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Bitweiser Right Shift-Operator (>>)

Bitweiser Right Shift-Operator (>>)
Siehe auch 		JScript-Sprachverzeichnis

>>= (Operator)
Bitweiser Left Shift-Operator (<<)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren
Vorzeichenloser Right Shift-Operator (>>>)


-= (Operator)

-= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Subtrahieren des Wertes eines Ausdrucks von einer Variablen.
Syntax
Ergebnis -= Ausdruck

Die Syntax von -= besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck | Beliebiger numerischer Ausdruck.

Anmerkungen
Die Verwendung von -= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis - Ausdruck

Weitere Informationen darüber, wann -= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


-= (Operator)

-= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Subtraktionsoperator (-)
Verhalten der Operatoren


Subtraktionsoperator (-)

Subtraktionsoperator (-) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Zur Ermittlung der Differenz zweier Zahlen oder zur Anzeige des negativen Wertes eines numerischen Ausdrucks.

Syntax 1
Ergebnis = Zahl1-Zahl2
Syntax 2
-Zahl

Die Syntax des Subtraktionsoperators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl | Beliebiger numerischer Ausdruck.
Zahl1 | Beliebiger numerischer Ausdruck.
Zahl2 | Beliebiger numerischer Ausdruck.

Anmerkungen
Bei Syntax 1 ist der Subtraktionsoperator zur Bestimmung der Differenz zweier Zahlen durch arithmetische Subtraktion eingesetzt. Bei Syntax 2 wird der Subtraktionsoperator in einer unären Negation zur Anzeige des negativen Wertes eines Ausdrucks verwendet.

Weitere Informationen darüber, wann Syntax 1 einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.

In Syntax 2 und allen anderen unären Operatoren werden Ausdrücke wie folgt ausgewertet:

  • Auf undefined-Ausdrücke oder Null-Ausdrücke angewendet, wird ein Laufzeitfehler hervorgerufen.
  • Objekte werden in Zeichenfolgen umgewandelt.
  • Zeichenfolgen werden, wenn möglich, in Zahlen konvertiert. Andernfalls wird ein Laufzeitfehler erzeugt.
  • Boolesche Werte werden wie Zahlen behandelt (0=False, 1=True).
Der Operator wird auf die sich ergebende Zahl angewendet. Wenn in Syntax 2 die sich ergebende Zahl ungleich null (0) ist, dann ist Ergebnis gleich der sich ergebenden Zahl mit umgekehrtem Vorzeichen. Wenn die sich ergebende Zahl null (0) ist, ist Ergebnis gleich null (0).


Subtraktionsoperator (-)

Subtraktionsoperator (-)
Siehe auch 		JScript-Sprachverzeichnis

-= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


typeof-Operator

typeof-Operator 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge zurück, die den Datentyp eines Ausdrucks angibt.
Syntax
typeof [ ( ] Ausdruck [ ) ] ;

Das Argument Ausdruck ist ein beliebiger Ausdruck, zu dem Typeninformationen benötigt werden.

Anmerkungen
Der typeof-Operator gibt Typeninformationen als Zeichenfolge zurück. Es gibt sechs mögliche Werte, die typeof zurückgibt: "Number", "String", "Boolean", "Object", "Function" und "undefined".

In der typeof-Syntax sind die Klammern optional.


typeof-Operator

typeof-Operator
Siehe auch 		JScript-Sprachverzeichnis

Operatorvorrang
Operatoren - Zusammenfassung
Verhalten der Operatoren


>>>= (Operator)

>>>= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschieben der Bits einer Variablen nach rechts ohne Vorzeichen.
Syntax
Ergebnis >>>= Ausdruck

Die Syntax von >>>= besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung von >>>= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis >>> Ausdruck
>>>= schiebt die Bits von Ergebnis um die Anzahl der Bits, die in Ausdruck angegeben sind, nach rechts. Von links wird mit Nullen aufgefüllt. Nach rechts hinausgeschobene Bits entfallen. Beispiel:
var temp
temp = -14
temp >>>= 2
Die Variable temp hat einen Wert von 1073741820, da -14 (binär 11111111 11111111 11111111 11110010), um zwei Bits verschoben, 1073741820 (binär 00111111 11111111 11111111 11111100) ergibt.

Weitere Informationen darüber, wann >>>= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


>>>= (Operator)

>>>= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser Left Shift-Operator (<<)
Bitweiser Right Shift-Operator (>>)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren
Vorzeichenloser Right Shift-Operator (>>>)


Vorzeichenloser Right Shift-Operator (>>>)

Vorzeichenloser Right Shift-Operator (>>>) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verschiebt die Bits eines Ausdrucks nach rechts ohne Vorzeichen.
Syntax
Ergebnis = Ausdruck1 >>> Ausdruck2

Die Syntax des vorzeichenlosen Right Shift-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der vorzeichenlose Right Shift-Operator schiebt die Bits von Ausdruck1 um die Anzahl der Bits, die in Ausdruck2 angegeben sind, nach rechts. Von links wird mit Nullen aufgefüllt. Nach rechts hinausgeschobene Bits entfallen. Beispiel:
var temp
temp = -14 >>> 2
Die Variable temp hat einen Wert von 1073741820, da -14 (binär 11111111 11111111 11111111 11110010), um zwei Bits verschoben, 1073741820 (binär 00111111 11111111 11111111 11111100) ergibt.

Weitere Informationen darüber, wann der vorzeichenlose Right Shift-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Vorzeichenloser Right Shift-Operator (>>>)

Vorzeichenloser Right Shift-Operator (>>>)
Siehe auch 		JScript-Sprachverzeichnis

>>>= (Operator)
Bitweiser Left Shift-Operator (<<)
Bitweiser Right Shift-Operator (>>)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


void-Operator

void-Operator 		JScript-Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Verhindert bei einem Ausdruck die Zurückgabe eines Werts.
Syntax
void Ausdruck

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck in JScript.

Anmerkungen
Der void-Operator wertet seinen Ausdruck aus und gibt undefined zurück. Er wird meistens in Situationen verwendet, in denen ein Ausdruck ausgewertet werden, das Ergebnis aber für den Rest des Skipts nicht sichtbar sein soll.


void-Operator

void-Operator
Siehe auch 		JScript-Sprachverzeichnis

Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


Bitweiser XOR-Operator (^)

Bitweiser XOR-Operator (^) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine bitweise Exklusiv-OR-Operation auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 ^ Ausdruck2

Die Syntax des bitweisen XOR-Operators besteht aus folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Anmerkungen
Der bitweise XOR-Operator nimmt die Binärdaten zweier Ausdrücke und führt eine bitweise exklusive Disjunktion durch. Das Ergebnis dieser Operation sieht so aus:
0101    (Ausdruck1)
1100    (Ausdruck2)
----
1001    (Ergebnis)
Wenn nur einer der Ausdrücke eine 1 an einer Stelle aufweist, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann der bitweise XOR-Operator einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


Bitweiser XOR-Operator (^)

Bitweiser XOR-Operator (^)
Siehe auch 		JScript-Sprachverzeichnis

^= (Operator)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


^= (Operator)

^= (Operator) 		JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Ausführen einer bitweisen Exklusiv-OR-Operation auf einem Ausdruck.
Syntax
Ergebnis ^= Ausdruck

Die Syntax von ^= hat die folgenden Komponenten:

Komponente | Beschreibung
Ergebnis | Jede Variable.
Ausdruck | Beliebiger Ausdruck.

Anmerkungen
Die Verwendung von ^= entspricht genau der folgenden Eingabe:
Ergebnis = Ergebnis ^ Ausdruck
^= nimmt die Binärdaten zweier Ausdrücke und führt eine bitweise exklusive Disjunktion durch. Das Ergebnis dieser Operation sieht so aus:
0101    (Ergebnis)
1100    (Ausdruck)
----
1001    (Ergebnis)
Wenn nur einer der Ausdrücke eine 1 an einer Stelle aufweist, hat auch das Ergebnis an dieser Stelle eine 1. Andernfalls enthält das Ergebnis eine 0 an dieser Stelle.

Weitere Informationen darüber, wann ^= einen Laufzeitfehler verursacht, finden Sie in der Tabelle Verhalten der Operatoren.


^= (Operator)

^= (Operator)
Siehe auch 		JScript-Sprachverzeichnis

Bitweiser XOR-Operator (^)
Operatoren - Zusammenfassung
Operatorvorrang
Verhalten der Operatoren


description-Eigenschaft

description-Eigenschaft 		JScript-Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Setzt die einem bestimmten Fehler zugewiesene beschreibende Zeichenfolge oder gibt diese zurück.
Syntax
Objekt.description [= Zeichenfolgenausdruck]

Die Syntax der description-Eigenschaft hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Jede Instanz eines Error-Objekts.
Zeichenfolgenausdruck | Ein Zeichenfolgenausdruck, der eine zugehörige Fehlerbeschreibung enthält.

Anmerkungen
Die description-Eigenschaft enthält eine Zeichenfolge mit der Fehlermeldung, die einem bestimmten Fehler zugeordnet ist. Verwenden Sie den in dieser Eigenschaft enthaltenen Wert, um einen Benutzer auf einen Fehler hinzuweisen, den Sie nicht beheben können oder möchten.

Das folgende Beispiel zeigt die Verwendung der description-Eigenschaft:

try x = y			// Generiert einen Fehler.
catch(var e){			// Erstellt die lokale Variable e.
  document.write(e)                  // Gibt Error-Objekt aus.
  document.write((e.number & 0xFFFF))// Gibt 5009 aus.
  document.write(e.description)      // Gibt "'y' ist nicht definiert. Nicht definierter Bezeichner" aus.
}


description-Eigenschaft

description-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Error-Objekt


description-Eigenschaft

description-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

number-Eigenschaft


number-Eigenschaft

number-Eigenschaft 		JScript-Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Setzt den mit einem bestimmten Fehler zugewiesenen numerischen Wert oder gibt diesen zurück. Die Standardeigenschaft des Error-Objekts ist number.
Syntax
Objekt.number [= Fehlernummer]

Die Syntax der number-Eigenschaft hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Jede Instanz des Error-Objekts.
Fehlernummer | Eine Ganzzahl, die einen Fehler darstellt.

Anmerkungen
Eine Fehlernummer ist ein 32-Bit-Wert. Das obere 16-Bit-Wort ist der Teildienstcode, wohingegen das untere Wort den eigentlichen Fehlercode darstellt.

Das folgende Beispiel zeigt die Verwendung der number-Eigenschaft:

try x = y         		              // Generiert einen Fehler.
catch(var e){				// Erstellt die lokale Variable e.
  document.write(e)                  // Gibt Error-Objekt aus.
  document.write(e.number>>16 & 0x1FFF)// Gibt 10, den Teildienstcode, aus.
  document.write(e.number & 0xFFFF)    // Gibt 5009, den Fehlercode, aus.
  document.write(e.description)        // Gibt "'y' ist nicht definiert. Nicht definierter Bezeichner" aus.
}


number-Eigenschaft

number-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Error-Objekt


number-Eigenschaft

number-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

description-Eigenschaft


index-Eigenschaft

index-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Zeichenposition zurück, wo die erste erfolgreiche Entsprechung einer gesuchten Zeichenfolge beginnt.
Syntax
RegExp.index
Anmerkungen
Die index-Eigenschaft ist nullbasiert. Ihr Wert wird immer dann geändert, wenn eine erfolgreiche Entsprechung vorhanden ist.


index-Eigenschaft

index-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

RegExp-Objekt


index-Eigenschaft

index-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Eigenschaften des RegExp-Objekts
Syntax regulärer Ausdrücke


input-Eigenschaft

input-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Zeichenfolge zurück, die erfolgreich gesucht wurde. Schreibgeschützt.
Syntax
RegExp.input
Anmerkungen
Der Wert der input-Eigenschaft wird immer dann geändert, wenn sich die zu suchende Zeichenfolge ändert.

Das folgende Beispiel zeigt die Verwendung der input-Eigenschaft:

function inputDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "Die verwendete Suchzeichenfolge lautete" + RegExp.input;
  return(s);
}


input-Eigenschaft

input-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

RegExp-Objekt


input-Eigenschaft

input-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekteigenschaften
Syntax regulärer Ausdrücke


lastIndex-Eigenschaft (RegExp)

lastIndex-Eigenschaft (RegExp) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Zeichenposition zurück, wo die letzte erfolgreiche Entsprechung in einer gesuchten Zeichenfolge beginnt.
Syntax
RegExp.lastIndex
Anmerkungen
Die lastIndex-Eigenschaft ist nullbasiert. Ihr Wert wird immer dann geändert, wenn eine erfolgreiche Entsprechung vorhanden ist.

Die lastIndex-Eigenschaft wird von den Methoden exec und test des RegExp-Objekts und den Methoden match, replace und split des String-Objekts angepasst.

Die folgenden Regeln gelten für Werte für lastIndex:

  • Wenn es keine Übereinstimmung gibt, wird lastIndex auf -1 gesetzt.
  • Wenn lastIndex größer als die Zeichenfolge ist, schlagen test und exec fehl, und lastIndex wird auf -1 gesetzt.
  • Wenn lastIndex gleich der Länge der Zeichenfolge ist, gibt es eine Entsprechung für den regulären Ausdruck, wenn das Muster der leeren Zeichenfolge entspricht. Andernfalls schlägt die Entsprechung fehl, und lastIndex wird auf -1 zurückgesetzt.
  • Ansonsten wird lastIndex auf die nächste Stelle gesetzt, die der letzten Entsprechung folgt.


lastIndex-Eigenschaft (RegExp)

lastIndex-Eigenschaft (RegExp)
Betrifft 		JScript-Sprachverzeichnis

RegExp-Objekt


lastIndex-Eigenschaft (RegExp)

lastIndex-Eigenschaft (RegExp)
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekteigenschaften
Syntax regulärer Ausdrücke


$1...$9-Eigenschaften

$1...$9-Eigenschaften 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die neun zuletzt gespeicherten Teile zurück, die während des Mustervergleichs gefunden wurden. Schreibgeschützt.
Syntax
RegExp.$n

Das Argument n ist eine Zahl von 1 bis 9.

Anmerkungen
Der Wert der $1...$9-Eigenschaften wird immer dann geändert, wenn eine in Klammern gesetzte Entsprechung vorhanden ist. In einem regulären Ausdrucksmuster können beliebig viele in Klammern gesetzte untergeordnete Zeichenfolgen angegeben werden, jedoch nur die neun aktuellsten können gespeichert werden.

Das folgende Beispiel zeigt die Verwendung der $1...$9-Eigenschaften:

function trefferDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 enthält: " + RegExp.$1 + "<BR>";
  s += "$2 enthält: " + RegExp.$2 + "<BR>";
  s += "$3 enthält: " + RegExp.$3;
  return(s);
}


$1..$9-Eigenschaften

$1...$9-Eigenschaften
Betrifft 		JScript-Sprachverzeichnis

RegExp-Objekt


$1...$9-Eigenschaften

$1...$9-Eigenschaften
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekteigenschaften
Syntax regulärer Ausdrücke


compile-Methode

compile-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Kompiliert einen regulären Ausdruck in ein internes Format.
Syntax
RegExpress.compile(Muster)

Die Syntax der compile-Methode hat folgende Komponenten:

Komponente | Beschreibung
RegExpress | Erforderlich. Ein Regular Expression-Objekt. Es kann ein Variablenname oder ein Literal sein.
Muster | Erforderlich. Ein Zeichenfolgenausdruck, der ein zu kompilierendes reguläres Ausdrucksmuster enthält.

Anmerkungen
Die compile-Methode konvertiert das Muster zur schnelleren Ausführung in ein internes Format. Dadurch können Sie z. B. reguläre Ausdrücke in Schleifen effizienter verwenden.

Das folgende Beispiel zeigt die Verwendung der compile-Methode:

function compileDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
                  // Erstellen eines regulären Ausdrucks für Großbuchstaben.
  var r = new RegExp("[A-Z]", "g");
  var a = s.match(r)	// Suchen nach Übereinstimmungen.
  document.write(a);
                  // Kompilieren des regulären Ausdrucks nur für Kleinbuchstaben.
  r.compile("[a-z]", "g");
  var a = s.match(r)	// Suchen nach Übereinstimmungen.
  document.write(a);
}


compile-Methode

compile-Methode
Betrifft 		JScript-Sprachverzeichnis

Regular Expression-Objekt


compile-Methode

compile-Methode
Siehe auch 		JScript-Sprachverzeichnis

Regular Expression-Objektmethoden
Regular Expression-Objekteigenschaften
Syntax regulärer Ausdrücke


exec-Methode

exec-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Führt eine Suche nach einer Übereinstimmung in einer angegebenen Zeichenfolge aus.
Syntax
RgA.exec(ZF)

Die Syntax der exec-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
RgA | Erforderlich. Ein Regular Expression-Objekt. Kann der Name einer Variablen oder ein Literal sein.
ZF | Erforderlich. Die Zeichenfolge, auf welcher die Suche durchgeführt werden soll.

Anmerkungen
Die Suchergebnisse der exec-Methode werden in ein Datenfeld übertragen.

Findet die exec-Methode keine Übereinstimmung, wird null zurückgegeben. Werden eine oder mehrere Übereinstimmungen gefunden, gibt die exec-Methode ein Datenfeld zurück; das RegExp-Objekt wird aktualisiert, um die Suchergebnisse anzuzeigen.

Das folgende Beispiel zeigt die Verwendung der exec-Methode:

function ExecDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
  var r = new RegExp("g", "i");
  var a = r.exec(s);
  document.write(a);
  r.compile("g");
  var a = r.exec(s);
  document.write(a);
}


exec-Methode

exec-Methode
Betrifft 		JScript-Sprachverzeichnis

Regular Expression-Objekt


exec-Methode

exec-Methode
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekt
Regular Expression-Objekteigenschaften
Regular Expression-Objektmethoden
Syntax regulärer Ausdrücke


lastIndex-Eigenschaft (Regular Expression)

lastIndex-Eigenschaft (Regular Expression) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Index an, an dem die nächste Entsprechung beginnen soll.
Syntax
RegExpress.lastIndex [= Index]

Die Syntax der lastIndex-Eigenschaft hat folgende Komponenten:

Komponente | Beschreibung
RegExpress | Erforderlich. Ein Regular Expression-Objekt. Es kann ein Variablenname oder ein Literal sein.
Index | Der Index, an dem die nächste Suche beginnen soll.

Anmerkungen
Die lastIndex-Eigenschaft wird von der exec-Methode und den Methoden match, replace und split des String-Objekts geändert.

Die folgenden Regeln gelten für Werte für lastIndex:

  • Ist lastIndex größer als die Länge der Zeichenfolge, misslingen die Methoden test und exec , so dass lastIndex auf Null gesetzt wird.
  • Wenn lastIndex gleich der Länge der Zeichenfolge ist, gibt es eine Entsprechung für den regulären Ausdruck, wenn das Muster der leeren Zeichenfolge entspricht. Andernfalls schlägt die Entsprechung fehl, und lastIndex wird auf Null (0) zurückgesetzt.
  • Ansonsten wird lastIndex auf die nächste Stelle gesetzt, die der letzten Entsprechung folgt.


lastIndex-Eigenschaft (Regular Expression)

lastIndex-Eigenschaft (Regular Expression)
Betrifft 		JScript-Sprachverzeichnis

Regular Expression-Objekt


lastIndex-Eigenschaft (Regular Expression)

lastIndex-Eigenschaft (Regular Expression)
Siehe auch 		JScript-Sprachverzeichnis

match-Methode
Regular Expression-Objekteigenschaften
Regular Expression-Objektmethoden
replace-Methode
split-Methode
String-Objekt
Syntax regulärer Ausdrücke


source-Eigenschaft

source-Eigenschaft 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Kopie des Textes eines regulären Ausdrucksmusters zurück. Schreibgeschützt.
Syntax
RegExpress.source

Das Argument RegExpress ist ein Regular Expression-Objekt. Es kann ein Variablenname oder ein Literal sein.

Das folgende Beispiel zeigt die Verwendung der source-Eigenschaft:

function SourceDemo(re, s)
{
  var s1;
  // Testen der Zeichenfolge auf Vorkommen des regulären Ausdrucks.
  if (re.test(s))
    s1 = " enthält ";
  else
    s1 = " enthält nicht ";
  // Ausgeben des Textes des regulären Ausdrucks selbst.
  return(s + s1 + re.source);
}


source-Eigenschaft

source-Eigenschaft
Betrifft 		JScript-Sprachverzeichnis

Regular Expression-Objekt


source-Eigenschaft

source-Eigenschaft
Siehe auch 		JScript-Sprachverzeichnis

Regular Expression-Objekteigenschaften
Regular Expression-Objektmethoden
Syntax regulärer Ausdrücke


test-Methode

test-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Booleschen Wert zurück, der angibt, ob ein Muster in einer gesuchten Zeichenfolge vorhanden ist.
Syntax
RegExpress.test(Zf)

Die Syntax der test-Methode hat folgende Komponenten:

Komponente | Beschreibung
RegExpress | Erforderlich. Ein Regular Expression-Objekt. Es kann ein Variablenname oder ein Literal sein.
str | Erforderlich. Die für die Suche zu überprüfende Zeichenfolge.

Anmerkungen
Die test-Methode prüft, ob ein Muster in einer Zeichenfolge vorhanden ist, und gibt true zurück, wenn dem so ist. Ansonsten wird false zurückgegeben.

Das RegExp-Objekt wird von der test-Methode nicht geändert.

Das folgende Beispiel zeigt die Verwendung der test-Methode:

function TestDemo(re, s)
{
  var s1;
  // Testen der Zeichenfolge auf Vorkommen des regulären Ausdrucks.
  if (re.test(s))
    s1 = " enthält ";
  else
    s1 = " enthält nicht ";
  // Ausgeben des Textes des regulären Ausdrucks selbst.
  return(s + s1 + re.source);
}


test-Methode

test-Methode
Betrifft 		JScript-Sprachverzeichnis

Regular Expression-Objekt


test-Methode

test-Methode
Siehe auch 		JScript-Sprachverzeichnis

RegExp-Objekt
Regular Expression-Objekteigenschaften
Regular Expression-Objektmethoden
Syntax regulärer Ausdrücke


Syntax regulärer Ausdrücke

Syntax regulärer Ausdrücke 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Beim Schreiben von Mustern für reguläre Ausdrücke werden Sonderzeichen und Folgen verwendet. Die folgende Tabelle enthält Einzelheiten und zeigt kurze Beispiele zum Verwenden der Zeichen.

Zeichen | Beschreibung
\ Markiert das folgende Zeichen als Sonder- oder als wortgenaues Zeichen. Beispielsweise entspricht "n" dem Zeichen "n". "\n" entspricht einem Zeilenumbruchzeichen. Die Sequenz "\\" entspricht "\", und "\(" entspricht "(".
^ Entspricht dem Anfang der Eingabe.
$ Entspricht dem Ende der Eingabe.
* Entspricht dem vorhergehenden Zeichen kein oder mehrere Male. Beispielsweise entspricht "zo*" entweder "z" oder "zoo".
+ Entspricht dem vorhergehenden Zeichen ein oder mehrere Male. "zo+" entspricht beispielsweise "zoo", aber nicht "z".
? Entspricht dem vorhergehenden Zeichen kein- oder einmal. Beispielsweise entspricht "a?ve?" dem "ve" in "never".
. Entspricht allen Einzelzeichen außer einem Zeilenumbruchzeichen.
(Muster) | Entspricht Muster und speichert die Entsprechung. Die abgeglichene Teilzeichenfolge kann aus der sich ergebenden Matches-Auflistung unter Verwendung der Elemente [0]...[n] abgerufen werden. Verwenden Sie zum Abgleichen von in Klammern ( ) gesetzten Zeichen "\(" oder "\)".
x|y | Entspricht entweder x oder y. Beispielsweise entspricht "l|rot" entweder "l" oder "rot". "(l|r)ot" entspricht "lot" oder "rot".
{n} | n ist eine nicht negative Ganzzahl. Entspricht exakt n Male. Beispielsweise entspricht "o{2}" nicht dem "o" in "Robert", jedoch den ersten beiden "o" in "Booooot".
{n,} | n ist eine nicht negative Ganzzahl. Entspricht mindestens n Male. Zum Beispiel entspricht "o{2,}" nicht dem "o" in "Robert", aber allen "o" in "Booooot". "o{1,}" ist äquivalent zu "o+". "o{0,}" ist äquivalent zu "o*".
{n,m} | m und n sind nicht negative Ganzzahlen. Entspricht mindestens n und höchstens m Male. Beispielsweise entspricht "o{1,3}" den ersten drei "o" in "Boooooot". "o{0,1}" ist äquivalent zu "o?".
[xyz] | Eine Gruppe von Zeichen. Entspricht einem beliebigen der enthaltenen Zeichen. "[abc]" entspricht z. B. dem "a" in "fallen".
[^xyz] | Eine Gruppe ausgeschlossener Zeichen. Entspricht allen nicht enthaltenen Zeichen. "[^abc]" entspricht z. B. dem "f" in "fallen".
[a-z] | Ein Zeichenbereich. Entspricht allen Zeichen im angegebenen Bereich. Beispielsweise entspricht "[a-z]" allen alphabetischen Zeichen in Kleinschreibung des Bereichs "a" bis "z".
[^m-z] | Ein ausgeschlossener Bereich an Zeichen. Entspricht allen Zeichen, die im angegebenen Bereich nicht enthalten sind. Z. B. entspricht "[m-z]" allen Zeichen, die im Bereich "m" bis "z" nicht enthalten sind.
\b | Entspricht einer Wortgrenze, d. h. der Position zwischen einem Wort und einem Leerzeichen. "er\b" entspricht beispielsweise dem "er" in "never", nicht jedoch dem "er" in "verb".
\B | Entspricht einer Nicht-Wortgrenze. "ea*r\B" entspricht dem "ear" in "never early".
\d | Entspricht einer Ziffer. Äquivalent zu [0-9].
\D | Entspricht einer Nicht-Ziffer. Äquivalent zu [^0-9].
\f | Entspricht einem Formularvorschubzeichen.
\n | Entspricht einem Zeilenumbruchzeichen.
\r | Entspricht einem Wagenrücklaufzeichen.
\s | Entspricht beliebigen Leerzeichen wie Leerzeichen, Tabulator, Formularvorschub etc. Äquivalent zu "[ \f\n\r\t\v]".
\S | Entspricht beliebigen Nicht-Leerzeichen. Äquivalent zu "[^ \f\n\r\t\v]".
\t | Entspricht einem Tabulatorzeichen.
\v | Entspricht einem vertikalen Tabulatorzeichen.
\w | Entspricht allen Wortzeichen mit Unterstrich. Äquivalent zu "[A-Za-z0-9_]".
\W | Entspricht allen Nicht-Wortzeichen. Äquivalent zu "[^A-Za-z0-9_]".
\num | Entspricht num, wenn num eine positive Ganzzahl ist. Ein Rückverweis auf gespeicherte Entsprechungen. "(.)\1" entspricht z. B. zwei aufeinander folgenden identischen Zeichen.
\n | Entspricht n, wobei n ein oktaler Escape-Wert ist. Oktale Escape-Werte können 1, 2 oder 3 Stellen aufweisen. Beispielsweise entspricht sowohl "\11" als auch "\011" dem Tabulatorzeichen. "\0011" ist äquivalent zu "\001" & "1". Oktale Escape-Werte dürfen 256 nicht überschreiten, da andernfalls nur die ersten beiden Stellen den Ausdruck enthalten. Ermöglicht die Verwendung von ASCII-Codes in regulären Ausdrücken.
\x n | Entspricht n, wobei n ein hexadezimaler Escape-Wert ist. Hexadezimale Escape-Werte können nur genau zwei Stellen aufweisen. "\x41" entspricht beispielsweise "A". "\x041" ist äquivalent zu "\x04" & "1". Ermöglicht die Verwendung von ASCII-Codes in regulären Ausdrücken.


Syntax regulärer Ausdrücke

Syntax regulärer Ausdrücke
Betrifft 		JScript-Sprachverzeichnis

RegExp-Objekt
Regular Expression-Objekt


Syntax regulärer Ausdrücke

Syntax regulärer Ausdrücke
Siehe auch 		JScript-Sprachverzeichnis

String-Objekt


break-Anweisung

break-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Beendet die aktuelle Schleife oder in Verbindung mit einer Marke die zugehörige Anweisung.
Syntax
break [Marke];

Das optionale Argument Marke gibt die Marke der Anweisung an, die Sie unterbrechen möchten.

Anmerkungen
Die break-Anweisung wird gewöhnlich innerhalb von switch-Anweisungen oder while-, for-, for...in- oder do...while-Schleifen verwendet. Meistens verwenden Sie das Argument Marke in switch-Anweisungen; es kann jedoch in beliebigen Anweisungen verwendet werden, unabhängig davon, ob es sich um einfache oder Verbundanweisungen handelt.

Das Verlassen der Schleife mit Hilfe der break-Anweisung setzt die Skriptausführung mit der ersten Anweisung unmittelbar nach der Schleife fort.

Das folgende Beispiel zeigt die Verwendung der break-Anweisung:

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


break-Anweisung

break-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

continue-Anweisung
do...while-Anweisung
for...in-Anweisung
for-Anweisung
Labeled-Anweisung
while-Anweisung


@cc_on-Anweisung

@cc_on-Anweisung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Aktiviert die Unterstützung der bedingten Kompilierung.
Syntax
@cc_on
Anmerkungen
Die @cc_on-Anweisung aktiviert die Unterstützung der bedingten Kompilierung im Skriptmodul.

Es wird ausdrücklich empfohlen, die @cc_on-Anweisung in einem Kommentar anzugeben, damit Browser, die die bedingte Kompilierung nicht unterstützen, Ihr Skript als gültige Syntax akzeptieren:

/*@cc_on*/
...
(Rest des Skripts)
Alternativ können Sie mit den Anweisungen @if oder @set die bedingte Kompilierung ebenfalls aktivieren.


@cc_on-Anweisung

@cc_on-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

Bedingte Kompilierung
@if-Anweisung
@set-Anweisung
Variablen für die bedingte Kompilierung


Kommentaranweisungen

Kommentaranweisungen
 JScript-Sprachverzeichnis
Version 1

Beschreibung
Veranlasst den JScript-Parser, Kommentare zu ignorieren.
Syntax 1
Einzeiliger Kommentar:
// Kommentar
Syntax 2
Mehrzeiliger Kommentar:
/*
Kommentar
*/

Das Argument Kommentar ist jeder beliebige Kommentartext, den Sie einfügen möchten.

Syntax 3
//@BedAnweisung
Syntax 4
/*@
BedAnweisung
@*/

Bei dem Argument BedAnweisung handelt es sich um Code für die bedingte Kompilierung, der verwendet wird, wenn die bedingte Kompilierung aktiviert ist. Wenn Syntax 3 verwendet wird, dürfen sich keine Leerzeichen zwischen den Zeichen "//" und "@" befinden.

Anmerkungen
Verwenden Sie Kommentare, um Skriptteile vom Lesevorgang des JScript-Parsers auszuschließen. Sie können Kommentare verwenden, um Erläuterungen zu einem Programm hinzuzufügen.

Wird Syntax 1 verwendet, berücksichtigt der Parser den Text zwischen den Kommentarzeichen und dem Zeilenende nicht. Wenn Sie Syntax 2 verwenden, wird der gesamte Text zwischen den Zeichen für Start und Ende nicht berücksichtigt.

Syntax 3 und 4 werden für die Unterstützung der bedingten Kompilierung verwendet, während die Kompatibilität mit Browsern gewahrt bleibt, die dieses Leistungsmerkmal nicht unterstützen. Diese Browser behandeln diese Form der Kommentierung entsprechend der Syntax 1 oder 2.

Das folgende Beispiel zeigt die gebräuchlichsten Verwendungen der Kommentaranweisung:

function meinefunktion(arg1, arg2)
{
  /* Dies ist ein mehrzeiliger Kommentar,
     der über so viele Zeilen geht, wie nötig. */
  var r;
  // Dies ist ein einzeiliger Kommentar.
  r = arg1 + arg2; // Addieren zweier Argumente.
  return(i);
}


Kommentaranweisungen

Kommentaranweisungen
Siehe auch 		JScript-Sprachverzeichnis

Bedingte Kompilierung


@if-Anweisung

@if-Anweisung
 JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Wertet einen Ausdruck aus und führt in Abhängigkeit vom Ergebnis eine Reihe von Anweisungen aus.
Syntax
@if (Bedingung1)
Text1
[@elif (Bedingung2)
Text2]
[@else
Text3]
@end

Die Syntax der @if-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Bedingung1, Bedingung2 | Ein Ausdruck, der in einen Booleschen Ausdruck umgewandelt werden kann.
Text1 | Der zu analysierende Text, wenn Bedingung1 den Wert true hat.
Text2 | Der zu analysierende Text, wenn Bedingung1 den Wert false und Bedingung2 den Wert true hat.
Text3 | Der zu analysierende Text, wenn Bedingung1 und Bedingung2 den Wert false haben.

Anmerkungen
Beim Schreiben einer @if-Anweisung müssen Sie deren Klauseln nicht in getrennten Zeilen eingeben. Sie können mehrere @elif-Klauseln verwenden. Falls Sie so vorgehen, müssen diese alle vor einer @else-Klausel angegeben werden.

In der Regel verwenden Sie die @if-Anweisung, um zu bestimmen, welcher Text unter mehreren Optionen für die Textausgabe verwendet werden soll. Beispiel:

alert(@if (@_win32) "Für Windows NT oder Windows 95" @else "Für Windows 3.1" @end)


@if-Anweisung

@if-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

Bedingte Kompilierung
@cc_on-Anweisung
@set-Anweisung
Variablen für die bedingte Kompilierung


continue-Anweisung

continue-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Beendet die aktuelle Iteration einer Schleife und beginnt eine neue Iteration.
Syntax
continue [Marke];

Das optionale Argument Marke gibt die Anweisung an, auf die sich continue bezieht.

Anmerkungen
Sie können die continue-Anweisung nur innerhalb einer while-, do...while-, for- oder for...in-Schleife verwenden. Die Ausführung der continue-Anweisung beendet die laufende Iteration und fährt mit dem Programmablauf am Beginn der Schleife fort. Auf die verschiedenen Schleifenarten hat das folgende Auswirkungen:
  • while- und do...while-Schleifen überprüfen ihre Bedingung. Ist diese true, führen sie die Schleife wieder aus.
  • for-Schleifen erhöhen ihren Inkrementausdruck und führen die Schleife wieder aus, wenn die Abfrage true ergibt.
  • for...in-Schleifen springen zum nächsten Feld der angegebenen Variablen und führen die Schleife erneut aus.

Das folgende Beispiel zeigt die Verwendung der continue-Anweisung:

function skip5()
{
  var s = "", i=0;
  while (i < 10)
  {
    i++;
    // 5 überspringen
    if (i==5)
    {
      continue
    }
   s += i;
  }
  return(s);
}


continue-Anweisung

continue-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

break-Anweisung
do...while-Anweisung
for...in-Anweisung
for-Anweisung
Labeled-Anweisung
while-Anweisung


do...while-Anweisung

do...while-Anweisung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Führt einen Anweisungsblock einmal aus und wiederholt dann die Ausführung der Schleife, bis ein bedingter Ausdruck mit false ausgewertet wird.
Syntax
do
Anweisung
while (Ausdruck);

Die Syntax der do...while-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Anweisung | Die auszuführende Anweisung, wenn Ausdruck true ist. Hierbei kann es sich auch um eine Verbundanweisung handeln.
Ausdruck | Ein Ausdruck, der in die Booleschen Werte true oder false umgewandelt werden kann. Ist Ausdruck true, wird die Schleife erneut ausgeführt. Ist der Wert false, wird die Schleife beendet.

Anmerkungen
Der Wert von Ausdruck wird erst nach dem ersten Durchlaufen der Schleife überprüft, um sicherzustellen, dass die Schleife mindestens einmal ausgeführt wird. Danach wird er nach jedem folgenden Durchlaufen der Schleife überprüft.

Der folgende Code verwendet die do...while-Anweisung, um die Drives-Auflistung zu iterieren:

function HoleLaufwerkListe()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  do
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = d.ShareName;
    else if (x.IsReady)
      n = d.VolumeName
    else
      n = "[Drive not ready]";
    s +=  n + "<br>";
    e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


do...while-Anweisung

do...while-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

break-Anweisung
continue-Anweisung
for...in-Anweisung
for-Anweisung
while-Anweisung
Labeled-Anweisung


for-Anweisung

for-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt einen Anweisungsblock aus, solange eine Bedingung wahr ist.
Syntax
for (Initialisierung; Test; Inkrement)
Anweisung

Die Syntax der for-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Initialisierung | Ein Ausdruck. Dieser Ausdruck wird nur einmal vor der Schleife ausgeführt.
Test | Ein Boolescher Ausdruck. Ist Test true, dann wird die Anweisung ausgeführt. Ist test false, wird die Schleife beendet.
Inkrement | Ein Ausdruck. Nach jedem Schleifendurchlauf wird der Inkrementausdruck ausgeführt.
Anweisung | Die auszuführende Anweisung, wenn Test true ist. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
for-Schleifen werden in der Regel verwendet, um die Anzahl der Durchläufe in einer Schleife festzulegen. Das folgende Beispiel zeigt eine for-Schleife.
/* i wird zu Beginn auf 0 gesetzt
 und am Ende jeder Iteration erhöht. Die Schleife wird beendet, wenn i vor einem
 Schleifendurchlauf nicht mehr kleiner als 10 ist. */
var mein_datenfeld = new Array();
for (i = 0; i < 10; i++)
{
  mein_datenfeld[i] = i;
}


for-Anweisung

for-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

for...in-Anweisung
while-Anweisung


for...in-Anweisung

for...in-Anweisung
 JScript-Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Führt eine oder mehrere Anweisungen für jede Eigenschaft eines Objekts oder für jedes Element eines Datenfeldes aus.
Syntax
for (Variable in [Objekt | Datenfeld])
Anweisung

Die Syntax der for...in-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Variable | Eine Variable, die jede Eigenschaft von Objekt oder eines Elements von Datenfeld sein kann.
Objekt, Datenfeld | Ein Objekt oder Datenfeld, das durchlaufen werden soll.
Anweisung | Die für die einzelnen Eigenschaften von Objekt oder für die einzelnen Elemente von Datenfeld auszuführende Anweisung. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Vor jeder Iteration einer Schleife wird Variable die neue Eigenschaft von Objekt oder das neue Element von Datenfeld zugewiesen. Sie können sie anschließend für sämtliche Anweisungen innerhalb einer Schleife genauso verwenden wie die Eigenschaft von Objekt oder das Element von Datenfeld.

Bei der Iteration mit einem Objekt besteht keine Möglichkeit, die Reihenfolge festzustellen oder zu steuern, in der die Elemente des Objekts Variable zugeordnet werden. Die Iteration mit einem Datenfeld erfolgt in der Reihenfolge der Elemente, also 0, 1, 2, ...

Das folgende Beispiel zeigt die Verwendung der for ... in-Anweisung, wobei ein Objekt als assoziatives Datenfeld verwendet wird:

function ForInDemo()
{
  var a, key, s = ""; // Erstellt mehrere Variablen.
  a = {"a" : "Athen" , "b" : "Belgrad", "c" : "Chicago"}   // Initialisiert das Objekt.
  for (key in a)    // Durchläuft die Eigenschaften.
  {
     s += a[key] + "<BR>"; } return(s);
}
Hinweis Verwenden Sie das Enumerator-Objekt, um die Elemente einer Auflistung zu durchlaufen.


for...in-Anweisung

for...in-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

for-Anweisung
while-Anweisung


function-Anweisung

function-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert eine neue Funktion.
Syntax
function Funktionsname([Argument1 [, Argument2 [, ...Argumentn]]])
{
Anweisungen
}

Die Syntax der function-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Funktionsname | Der Name der Funktion.
Argument1...Argumentn | Eine optionale, durch Kommas getrennte Liste von Argumenten, welche die Funktion verarbeitet.
Anweisungen | Eine oder mehrere JScript-Anweisungen.

Anmerkungen
Verwenden Sie die function-Anweisung, um eine Funktion für den späteren Gebrauch zu deklarieren. Der Code, der in Anweisungen enthalten ist, wird nicht ausgeführt, bevor die Funktion nicht von anderer Stelle im Skript aus aufgerufen wird.

Das folgende Beispiel zeigt die Verwendung der function-Anweisung:

function meinefunktion(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(i);
}
Hinweis Stellen Sie beim Aufrufen einer Funktion stets sicher, dass Sie die Klammern sowie die notwendigen Argumente einschließen. Das Aufrufen einer Funktion ohne Klammern führt zum Zurückgeben des Textes der Funktion, nicht jedoch des eigentlichen Ergebnisses.


function-Anweisung

function-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

new-Operator


if...else-Anweisung

if...else-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wertet einen Ausdruck aus und führt in Abhängigkeit vom Ergebnis eine Reihe von Anweisungen aus.
Syntax
if (Bedingung)
Anweisung1
[else
Anweisung2]

Die Syntax der if...else-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Bedingung | Ein Boolescher Ausdruck. Hat Bedingung den Wert null oder undefined, wird Bedingung wie false behandelt.
Anweisung1 | Die auszuführende Anweisung, wenn Bedingung den Wert true hat. Hierbei kann es sich auch um eine Verbundanweisung handeln.
Anweisung2 | Die auszuführende Anweisung, wenn Bedingung den Wert false hat. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Im Allgemeinen ist es sinnvoll, Anweisung1 und Anweisung2 zur besseren Übersicht und Vermeidung von unbeabsichtigten Fehlern in geschweifte Klammern ({}) zu setzen. Im folgenden Beispiel sieht es so aus, als sei else mit der ersten if-Anweisung verwendet worden, tatsächlich bezieht es sich aber auf die zweite.
if (x == 5)
  if (y == 6)
     z = 17;
else
  z = 20;
Das Ändern des Codes wie folgt beseitigt alle Mehrdeutigkeiten:
if (x == 5)
  {
  if (y == 6)
     z = 17;
  }
else
  z = 20;
Wenn Sie später beabsichtigen, Anweisung1 eine Anweisung hinzuzufügen, und keine geschweiften Klammern verwendet werden, kann möglicherweise ein Fehler auftreten:
if (x == 5)
  z = 7;
  q = 42;
else
  z = 19;
In diesem Fall tritt ein Syntaxfehler auf, denn zwischen den Anweisungen if und else stehen mehrere Anweisungen. Die Anweisungen zwischen if und else müssen daher in geschweifte Klammern gesetzt werden.


if...else-Anweisung

if...else-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

Trinärer Bedingungsoperator (?:)


Labeled-Anweisung

Labeled-Anweisung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Stellt einen Bezeichner für eine Anweisung bereit.
Syntax
Bezeichner :
Anweisung

Die Syntax der Labeled-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Bezeichner | Eine eindeutige Kennzeichnung, die beim Verweisen auf die bezeichnete Anweisung verwendet wird.
Anweisung | Die mit dem Bezeichner verknüpfte Anweisung. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Die Bezeichner werden von den Anweisungen break und continue verwendet, um die Anweisungen anzugeben, für die break und continue gelten sollen.

In der folgenden Anweisung verwendet die continue-Anweisung eine labeled-Anweisung, um ein Datenfeld zu erstellen, in dem die dritte Spalte jeder Zeile einen undefinierten Wert enthält:

function labelDemo()
{
    var a = new Array();
    var i, j, s = "", s1 = "";
  Outer:
    for (i = 0; i < i++)
    {
      Inner:
        for (j = 0; j < 5; j++)
        {
          if (j == 2)
            continue Inner;
          else
            a[i,j] = j + 1;
        }
    }

    for (i = 0; i < i++)
    {
      s = "";
      for (j = 0; j < 5; j++)
      {
        s += a[i,j];
      }
      s1 += s + "\n";
    }
    return(s1)
}


Labeled-Anweisung

Labeled-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

break-Anweisung
continue-Anweisung


return-Anweisung

return-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verlässt die aktuelle Funktion und gibt einen Wert dieser Funktion zurück.
Syntax

return [Ausdruck];

Das Argument Ausdruck ist der Wert, der von der Funktion zurückgegeben werden soll. Ohne Angabe gibt die Funktion keinen Wert zurück.

Anmerkungen
Sie verwenden die return-Anweisung, um die Ausführung einer Funktion anzuhalten und den Wert von Ausdruck zurückzugeben. Wird Ausdruck weggelassen, oder wird keine return-Anweisung aus der Funktion heraus ausgeführt, dann wird dem Ausdruck, der die aktuelle Funktion aufgerufen hat, der Wert undefined zugewiesen.

Das folgende Beispiel zeigt die Verwendung der return-Anweisung:

function meinefunktion(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(r);
}


return-Anweisung

return-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung


@set-Anweisung

@set-Anweisung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Erstellt Variablen, die in bedingten Kompilierungsanweisungen verwendet werden.
Syntax
@set @VarName [= Term]

Die Syntax der @set-Anwendung hat die folgenden Komponenten:

Komponenten | Beschreibung
VarName | Gültiger JScript-Variablenname. Das Zeichen "@" muss stets vorangehen.
Term | Keine oder mehrere unäre Operatoren, auf die eine Konstante, bedingte Kompilierungsvariable oder ein in Klammern gesetzter Ausdruck folgt.

Anmerkungen
Numerische und Boolesche Variablen werden für die bedingte Kompilierung unterstützt. Zeichenfolgen werden nicht unterstützt. Variablen, die unter Verwendung von @set erstellt wurden, werden hauptsächlich in Anweisungen bei bedingten Kompilierungen verwendet. Sie können aber auch anderweitig in JScript-Code verwendet werden.

Beispiele für Variablendeklarationen sehen wie folgt aus:

@set @myvar1 = 12
@set @myvar2 = (@myvar1 * 20)
@set @myvar3 = @_jscript_version
Die folgenden Operatoren werden von in Klammern gesetzten Ausdrücken unterstützt:
  • ! ~
  • * / %
  • + -
  • << >> >>>
  • < <= > >=
  • == != === !==
  • & ^ |
  • && ||
Wird eine Variable vor ihrer Definition verwendet, ist ihr Wert NaN. Das Vorhandensein von NaN kann mit Hilfe der @if-Anweisung ermittelt werden:
@if (@newVar != @newVar)
  ...
Dies funktioniert, weil NaN der einzige Wert ist, der ungleich sich selbst ist.


@set-Anweisung

@set-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

Bedingte Kompilierung
@cc_on-Anweisung
@if-Anweisung
Variablen für die bedingte Kompilierung


switch-Anweisung

switch-Anweisung 		JScript-Sprachverzeichnis
Version 3

Siehe auch

Beschreibung
Aktiviert die Ausführung einer oder mehrerer Anweisungen, wenn der Wert eines angegebenen Ausdrucks einem Bezeichner entspricht.
Syntax
switch (Ausdruck) {
case Bezeichner :
Anweisungsliste
case Bezeichner :
Anweisungsliste
...
default :
Anweisungsliste
}

Die Syntax der switch-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Ausdruck | Der auszuwertende Ausdruck.
Bezeichner | Ein Bezeichner, der mit Ausdruck verglichen werden soll. Falls Bezeichner === Ausdruck, beginnt die Ausführung mit der Anweisungsliste unmittelbar nach dem Doppelpunkt und wird fortgesetzt, bis sie entweder auf die optionale Anweisung break oder auf das Ende der switch-Anweisung trifft.
Anweisungsliste | Eine oder mehrere auszuführende Anweisungen.

Anmerkungen
Verwenden Sie die default-Klausel, um eine Anweisung bereitzustellen, die ausgeführt werden soll, wenn keiner der Bezeichnerwerte mit Ausdruck übereinstimmt. Sie kann an einer beliebigen Stelle im switch-Codeblock erscheinen.

Es können keine oder mehrere Bezeichner-Blöcke angegeben werden. Falls kein Bezeichner dem Wert von Ausdruck entspricht und kein default-Fall angegeben ist, werden keine Anweisungen ausgeführt.

Die Ausführung einer switch-Anweisung verläuft wie folgt:

  1. Auswertung des Ausdrucks und Durchführung eines sequenziellen Vergleichs mit Bezeichner, bis eine Entsprechung gefunden wird.
  2. Wenn ein Bezeichner-Wert einem Ausdruck entspricht, wird die begleitende Anweisungsliste ausgeführt.
    Fortsetzung der Ausführung, bis eine break-Anweisung gefunden wird oder die switch-Anweisung endet. Dies bedeutet, dass mehrere Bezeichner-Blöcke ausgeführt werden, wenn keine break-Anweisung verwendet wird.
  3. Wenn kein Bezeichner dem Ausdruck entspricht, wird zum default-Fall gewechselt. Ist dieser nicht vorhanden, dann wird zum letzten Schritt übergegangen.
  4. Fortsetzung der Ausführung mit der Anweisung, die auf das Ende des switch-Codeblocks folgt.
Das folgende Beispiel versucht, den Typ eines Objekts zu ermitteln:
function MeinObjekt() {
...}
switch (object.constructor){
    case Date:
    ...
    case Number:
    ...
    case String:
    ...
    case MeinObjekt:
    ...
    default:
    ...
}


switch-Anweisung

switch-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

break-Anweisung
if...else-Anweisung


this-Anweisung

this-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Verweist auf das aktuelle Objekt.
Syntax
this.Eigenschaft
Anmerkungen
Das Schlüsselwort this wird normalerweise in Konstruktoren von Objekten verwendet, um auf das aktuelle Objekt zu verweisen. Im folgenden Beispiel bezieht sich this auf das neu erstellte Objekt "Auto" und weist drei Eigenschaften Werte zu:
function Auto(farbe, marke, modell)
{
  this.Farbe = farbe;
  this.Marke = marke;
  this.Modell = modell;
}
Bei Client-Versionen von JScript bezieht sich this auf das window-Objekt, wenn es außerhalb des Kontextes irgendeines anderen Objekts verwendet wird.


this-Anweisung

this-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

new-Operator


throw-Anweisung

throw-Anweisung
 JScript-Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Löst eine Fehlerbedingung aus, die von einer try...catch-Anweisung behandelt werden kann.
Syntax
throw Ausnahme

Das Argument Ausnahme kann dabei ein beliebiger Ausdruck sein.

Anmerkungen
Das folgende Beispiel erzeugt einen Fehler, der auf einem übergebenen Wert basiert, und zeigt, wie dieser Fehler in einer Hierarchie von try...catch-Anweisungen behandelt wird:
function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// Prüft das Argument.
      throw "x gleich null";			// Löst einen Fehler aus.
    throw "x ungleich null";			// Löst einen anderen Fehler aus.
    }
    catch(e) {					// Behandelt hier "x = 0"-Fehler.
      if (e == "x gleich null")			// Überprüft, ob ein Fehler hier behandelt wird.
        return(e + " wird hier behandelt.");	// Gibt die Fehlermeldung für das Objekt zurück.
      else					// Fehler kann hier nicht behandelt werden.
        throw e;					// Erzeugt einen weiteren Fehler für die nächste
    }							// Fehlerbehandlung.
  }
  catch(e) {                    	   	// Behandelt andere Fehler hier.
    return(e + " wird weiter oben behandelt.");		// Gibt eine Fehlermeldung zurück.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(0));


throw-Anweisung

throw-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

try...catch-Anweisung


try...catch-Anweisung

try...catch-Anweisung
 JScript-Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Implementiert die Fehlerbehandlung für JScript.
Syntax
try
tryAnweisung
catch(Fehler)
catchAnweisung

Die Syntax der try...catch-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
tryAnweisung | Anweisung, wo ein Fehler auftreten kann. Hierbei kann es sich auch um eine Verbundanweisung handeln.
Fehler | Jeder Variablenname. Der Anfangswert von Fehler ist der Wert des ausgelösten Fehlers.
catchAnweisung | Anweisung zur Behandlung von Fehlern, die im zugeordneten tryAnweisung auftreten. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Die try...catch-Anweisung bietet eine Möglichkeit, einige oder alle der möglichen Fehler zu behandeln, die in einem bestimmten Codeblock auftreten können, während dieser Code noch ausgeführt wird. Treten vom Programmierer nicht behandelte Fehler auf, übernimmt JScript die Anzeige der herkömmlichen Fehlermeldung an den Benutzer, als wäre keine Fehlerbehandlung vorhanden.

Das tryAnweisung-Argument enthält Code mit Informationen, wo ein Fehler auftreten kann, wohingegen catchAnweisung den Code zur entsprechenden Fehlerbehandlung enthält, wenn Fehler auftreten. Tritt ein Fehler in tryAnweisung auf, wird die Programmsteuerung an catchAnweisung zur Behandlung übergeben. Der Anfangswert von Fehler ist der Wert des in tryAnweisung ausgelösten Fehlers.

Kann der Fehler nicht im tryAnweisung zugewiesenen catchAnweisung behandelt werden, verwenden Sie die throw-Anweisung, um den Fehler an eine höhere Fehlerbehandlung weiterzuleiten.

Das folgende Beispiel erzeugt einen Fehler, der auf einem übergebenen Wert basiert. Anschließend wird verdeutlicht, wie dieser Fehler in einer Hierarchie von try...catch-Anweisungen behandelt wird:

function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// Prüft das Argument.
      throw "x gleich null";			// Löst einen Fehler aus.
    else throw "x ungleich null";		// Löst einen anderen Fehler aus.
    }
    catch(e) {					// Behandelt hier "x = 0"-Fehler.
      if (e == "x gleich null")			// Überprüft, ob ein Fehler hier behandelt wird.
        return(e + " wird hier behandelt.");	// Gibt die Fehlermeldung für das Objekt zurück.
      else					// Fehler kann hier nicht behandelt werden.
        throw e;					// Erzeugt einen weiteren Fehler für die nächste
    }							// Fehlerbehandlung.
  }
  catch(e) {						// Behandelt andere Fehler hier.
    return(e + " wird weiter oben behandelt.");		// Gibt eine Fehlermeldung zurück.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(0));


try...catch-Anweisung

try...catch-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

throw-Anweisung


var-Anweisung

var-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert eine Variable.
Syntax
var Variable [ = Wert ] [, Variable2 [ = Wert2], ...]

Die var-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Variable, Variable2 | Die Namen der Variablen, die deklariert werden sollen.
Wert, Wert2 | Der Startwert für die Variablen.

Anmerkungen
Verwenden Sie die var-Anweisung zum Deklarieren von Variablen. Diesen Variablen können sofort bei der Deklaration Werte zugewiesen werden oder erst später im Skript. Beispiele für Deklarationen:
var index;
var Name = "Guildo Horn";
var Antwort = 42, Zähler, AnzSeiten = 10;


var-Anweisung

var-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

function-Anweisung
new-Operator


while-Anweisung

while-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine Anweisung aus, bis eine angegebene Bedingung false ist.
Syntax
while (Ausdruck)
Anweisung

Die while-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Ausdruck Ein Boolescher Ausdruck, der vor jeder Schleifeniteration überprüft wird. Ist Ausdruck true, wird die Schleife ausgeführt. Ist Ausdruck false, wird die Schleife beendet.
Anweisung | Die auszuführende Anweisung, wenn Ausdruck true ist. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Die while-Anweisung überprüft Ausdruck vor der ersten Ausführung einer Schleife. Ist Ausdruck zu diesem Zeitpunkt false, dann wird die Schleife nie ausgeführt.

Das folgende Beispiel zeigt die Verwendung der while-Anweisung:

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


while-Anweisung

while-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

break-Anweisung
continue-Anweisung
do...while-Anweisung
for...in-Anweisung
for-Anweisung


with-Anweisung

with-Anweisung
 JScript-Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Legt das standardmäßig zu verwendende Objekt für eine Anweisung fest.
Syntax
with (Objekt)
Anweisung

Die with-Anweisung hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt

Das neue Standardobjekt.

Anweisung | Die Anweisung, für die Objekt das Standardobjekt sein soll. Hierbei kann es sich auch um eine Verbundanweisung handeln.

Anmerkungen
Die with-Anweisung wird vielfach verwendet, um den Programmcode, der in bestimmten Situationen zu schreiben ist, zu verkürzen. Beachten Sie in dem folgenden Beispiel die wiederholte Verwendung von Math:
x = Math.cos(3 * Math.PI) + Math.sin(Math.LN10)
y = Math.tan(14 * Math.E)
Wenn Sie die with-Anweisung verwenden, wird Ihr Code kürzer und leichter lesbar:
with (Math)
{
  x = cos(3 * PI) + sin (LN10)
  y = tan(14 * E)
}


with-Anweisung

with-Anweisung
Siehe auch 		JScript-Sprachverzeichnis

this-Anweisung


anchor-Methode

anchor-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung

Setzt ein HTML-Anchor-Tag mit einem NAME-Attribut um einen angegebenen Text im Objekt.
Syntax
strVariable.anchor(Anchor-Zeichenfolge)
"Zeichenfolgenliteral".anchor(Anchor-Zeichenfolge)

Das Argument Anchor-Zeichenfolge ist der Text, den Sie im NAME-Attribut eines HTML-Anchor-Tag angeben möchten.

Anmerkungen
Führen Sie die anchor-Methode aus, um ein benanntes Anchor-Tag aus einem String-Objekt zu generieren. Das folgende Beispiel zeigt, wie die anchor-Methode dies durchführt:
var strVariable =  "Das ist ein Anker" ;
strVariable = strVariable.anchor("Anker1");
Der Wert von strVariable nach der letzten Anweisung ist:
<A NAME="Anker1">Dies ist ein Anker</A>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


anchor-Methode

anchor-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


anchor-Methode

anchor-Methode
Siehe auch 		JScript-Sprachverzeichnis

link-Methode
String-Objekteigenschaften
String-Objektmethoden


big-Methode

big-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<BIG>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.big( )
"Zeichenfolgenliteral".big( )
Anmerkungen
Das folgende Beispiel zeigt, wie die big-Methode funktioniert:
var strVariable = "Dies ist ein String-Objekt";
strVariable = strVariable.big( );
Der Wert von strVariable nach der letzten Anweisung ist:
<BIG>Dies ist ein String-Objekt</BIG>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


big-Methode

big-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


big-Methode

big-Methode
Siehe auch 		JScript-Sprachverzeichnis

small-Methode
String-Objekteigenschaften
String-Objektmethoden


blink-Methode

blink-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<BLINK>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.blink( )
"Zeichenfolgenliteral".blink( )
Anmerkungen
Das folgende Beispiel zeigt, wie die blink-Methode funktioniert:
var strVariable = "Dies ist ein String-Objekt";
strVariable = strVariable.blink( );
Der Wert von strVariable nach der letzten Anweisung ist:
<BLINK>Dies ist ein String-Objekt</BLINK>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.

Das <BLINK>-Tag wird im Microsoft Internet Explorer nicht unterstützt.


blink-Methode

blink-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


blink-Methode

blink-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden


bold-Methode

bold-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<B>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.bold( )
"Zeichenfolgenliteral".bold( )
Anmerkungen
Das folgende Beispiel zeigt, wie die bold-Methode funktioniert:
var strVariable = "Dies ist ein String-Objekt";
strVariable = strVariable.bold( );
Der Wert von strVariable nach der letzten Anweisung ist:
<B>Dies ist ein String-Objekt</B>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


bold-Methode

bold-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


bold-Methode

bold-Methode
Siehe auch 		JScript-Sprachverzeichnis

italics-Methode
String-Objekteigenschaften
String-Objektmethoden


charAt-Methode

charAt-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt das durch den Index angegebene Zeichen zurück.
Syntax
strVariable.charAt(Index)
"Zeichenfolgenliteral".charAt(Index)

Das Argument Index ist der von Null ausgehende Index des gewünschten Zeichens. Gültige Werte liegen zwischen 0 und der Länge der Zeichenfolge minus 1.

Anmerkungen
Die charAt-Methode gibt das Zeichen mit dem angegebenen Index zurück. Das erste Zeichen einer Zeichenfolge hat den Index 0, das zweite den Index 1 usw. Werte außerhalb eines gültigen Bereiches geben undefined zurück.

Das folgende Beispiel zeigt die Verwendung der charAt-Methode:

function charAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charAt(n - 1);
  return(s);
}


charAt-Methode

charAt-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


charAt-Methode

charAt-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden


charCodeAt-Methode

charCodeAt-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Unicode-Codierung eines angegebenen Zeichens zurück.
Syntax
StringObj.charCodeAt(Index)

Die Syntax der charCodeAt-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Ein String-Objekt oder Literal.
Index | Erforderlich. Der nullbasierte Index des angegebenen Zeichens.

Anmerkungen
Wenn sich am angegebenen Index kein Zeichen befindet, wird NaN zurückgegeben.

Das folgende Beispiel zeigt die Verwendung der charCodeAt-Methode:

function charCodeAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charCodeAt(n - 1);
  //Gibt Unicode-Zeichencode zurück.
  return(s);
}


charCodeAt-Methode

charCodeAt-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


charCodeAt-Methode

charCodeAt-Methode
Siehe auch 		JScript-Sprachverzeichnis

fromCharCode-Methode
String-Objektmethoden


concat-Methode (String)

concat-Methode (String) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein String-Objekt zurück, das die Verkettung zweier angegebener Zeichenfolgen enthält.
Syntax
Zeichenfolge1.concat(Zeichenfolge2)

Die Syntax der concat-Methode hat folgende Komponenten:

Komponente | Beschreibung
Zeichenfolge1 | Erforderlich. Das String-Objekt oder Literal, das mit Zeichenfolge2 verkettet werden soll.
Zeichenfolge2 | Erforderlich. Das String-Objekt oder Literal, das mit dem Ende von Zeichenfolge1 verkettet werden soll.

Anmerkungen
Das Ergebnis der concat-Methode ist äquivalent zu: Ergebnis = Zeichenfolge1 + Zeichenfolge2.

Das folgende Beispiel zeigt die Verwendung der concat-Methode:

function concatDemo()
{
  var str1 = "ABCDEFGHIJKLM"
  var str2 = "NOPQRSTUVWXYZ";
  var s = str1.concat(str2);
  // Gibt verkettete Zeichenfolge zurück.
  return(s);
}


concat-Methode (String)

concat-Methode (String)
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
String-Objekt


concat-Methode (String)

concat-Methode (String)
Siehe auch 		JScript-Sprachverzeichnis

Additionsoperator (+)
concat-Methode (Array)
String-Objektmethoden


fixed-Methode

fixed-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<TT>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.fixed( )
"Zeichenfolgenliteral".fixed( )
Anmerkungen
Das folgende Beispiel zeigt, wie die fixed-Methode funktioniert:
var strVariable = "Dies ist ein String-Objekt";
strVariable = strVariable.fixed( );
Der Wert von strVariable nach der letzten Anweisung ist:
<TT>Dies ist ein String-Objekt</TT>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt wurde.


fixed-Methode

fixed-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


fixed-Methode

fixed-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden


fontcolor-Methode

fontcolor-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt ein HTML-<FONT>-Tag und das COLOR-Attribut um den Text in einem String-Objekt.
Syntax
strVariable.fontcolor(Farbwert)
"Zeichenfolgenliteral".fontcolor(Farbwert)

Das Argument Farbwert ist eine Zeichenfolge mit einer Farbangabe. Dies kann entweder der hexadezimale Wert oder der vordefinierte Name einer Farbe sein.

Anmerkungen
Das folgende Beispiel zeigt, wie die fontcolor-Methode funktioniert:
var strVariable = "Dies ist eine Zeichenfolge";
strVariable = strVariable.fontcolor("red");
Der Wert von strVariable nach der letzten Anweisung ist:
<FONT COLOR="RED">Dies ist eine Zeichenfolge</FONT>
Gültige vordefinierte Farbnamen hängen von Ihrem JScript-Host (Browser, Server usw.) ab. Sie variieren möglicherweise auch von Version zu Version des Hosts. Weitere Informationen hierzu finden Sie in der Dokumentation Ihres Hosts.

Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


fontcolor-Methode

fontcolor-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


fontcolor-Methode

fontcolor-Methode
Siehe auch 		JScript-Sprachverzeichnis

fontsize-Methode
String-Objekteigenschaften
String-Objektmethoden


fontsize-Methode

fontsize-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt ein HTML-<FONT>-Tag und das SIZE-Attribut um den Text in einem String-Objekt.
Syntax
strVariable.fontsize(intGröße)
"Zeichenfolgenliteral".fontsize(intGröße)

Das Argument intGröße ist ein ganzzahliger Wert zur Bestimmung der Textgröße.

Anmerkungen
Das folgende Beispiel zeigt, wie die fontsize-Methode funktioniert:
var strVariable = "Dies ist eine Zeichenfolge";
strVariable = strVariable.fontsize(-1);
Der Wert von strVariable nach der letzten Anweisung ist:
<FONT SIZE="-1">Dies ist eine Zeichenfolge</FONT>
Gültige ganzzahlige Werte hängen von Ihrem Microsoft JScript-Host ab. Weitere Informationen hierzu finden Sie in der Dokumentation Ihres Hosts.

Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


fontsize-Methode

fontsize-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


fontsize-Methode

fontsize-Methode
Siehe auch 		JScript-Sprachverzeichnis

fontcolor-Methode
String-Objekteigenschaften
String-Objektmethoden


fromCharCode-Methode

fromCharCode-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge aus mehreren Unicode-Zeichenwerten zurück.
Syntax
String.fromCharCode(Code1, Code2, ..., Coden)

Das Argument Code ist eine Folge von Unicode-Zeichen, die in eine Zeichenfolge umgewandelt werden.

Anmerkungen
Vor dem Aufrufen von fromCharCode muss kein String-Objekt erstellt werden.

Im folgenden Beispiel enthält Test die Zeichenfolge "plain":

var test = String.fromCharCode(112, 108, 97, 105, 110);


fromCharCode-Methode

fromCharCode-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


fromCharCode-Methode

fromCharCode-Methode
Siehe auch 		JScript-Sprachverzeichnis

charCodeAt-Methode
String-Objektmethoden


indexOf-Methode

indexOf-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Zeichenposition zurück, an der das erste Auftreten einer Teilzeichenfolge in einem String-Objekt vorkommt.
Syntax
strVariable.indexOf(Teilzeichenfolge, Startindex)
"Zeichenfolgenliteral".indexOf(Teilzeichenfolge, Startindex)

Die Syntax der indexOf-Methode hat folgenden Komponenten:

Komponente | Beschreibung
Teilzeichenfolge | Die im String-Objekt zu suchende Teilzeichenfolge.
Startindex | Ein optionaler ganzzahliger Wert, der die Startposition festlegt, bei der die Suche im String-Objekt begonnen werden soll. Ohne diese Angabe beginnt die Suche am Beginn der Zeichenfolge.

Anmerkungen
Die indexOf-Methode liefert einen ganzzahligen Wert, der die Startposition der zu suchenden Teilzeichenfolge innerhalb des String-Objekts angibt. Wird die Teilzeichenfolge nicht gefunden, ist der Rückgabewert -1.

Ist Startindex negativ, dann wird Startindex wie Null behandelt. Ist er höher als die höchste Index der Zeichenposition, dann wird er wie der höchstmögliche Index behandelt.

Die Suche wird von links nach rechts durchgeführt. Ansonsten ist diese Methode mit lastindexOf identisch.

Das folgende Beispiel zeigt die Verwendung der indexOf-Methode:

function IndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.indexOf(str2);
  return(s);
}


indexOf-Methode

indexOf-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


indexOf-Methode

indexOf-Methode
Siehe auch 		JScript-Sprachverzeichnis

lastIndexOf-Methode
String-Objekteigenschaften
String-Objektmethoden


italics-Methode

italics-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<I>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.italics( )
"Zeichenfolgenliteral".italics( )
Anmerkungen
Das folgende Beispiel zeigt, wie die italics-Methode funktioniert:
var strVariable = "Dies ist eine Zeichenfolge";
strVariable = strVariable.italics( );
Der Wert von strVariable nach der letzten Anweisung ist:
<I>Dies ist eine Zeichenfolge</I>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


italics-Methode

italics-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


italics-Methode

italics-Methode
Siehe auch 		JScript-Sprachverzeichnis

bold-Methode
String-Objekteigenschaften
String-Objektmethoden


lastIndexOf-Methode

lastIndexOf-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt das letzte Auftreten einer Teilzeichenfolge in einem String-Objekt zurück.
Syntax
strVariable.lastIndexOf(Teilzeichenfolge, Startindex)
"Zeichenfolgenliteral".lastIndexOf(Teilzeichenfolge, Startindex)

Die Syntax der lastindexOf-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Teilzeichenfolge | Die im String-Objekt zu suchende Teilzeichenfolge.
Startindex | Ein optionaler ganzzahliger Wert, der die Startposition festlegt, bei der die Suche im String-Objekt begonnen werden soll. Ohne diese Angabe beginnt die Suche am Beginn der Zeichenfolge.

Anmerkungen
Die lastIndexOf-Methode liefert einen ganzzahligen Wert, der die Startposition der zu suchenden Teilzeichenfolge innerhalb des String-Objekts angibt. Wird die Teilzeichenfolge nicht gefunden, ist der Rückgabewert -1.

Ist Startindex negativ, dann wird Startindex wie Null behandelt. Ist er höher als der höchste Index der Zeichenposition, dann wird er wie der höchstmögliche Index behandelt.

Die Suche wird von links nach rechts durchgeführt. Ansonsten ist diese Methode mit indexOf identisch.

Das folgende Beispiel zeigt die Verwendung der lastIndexOf-Methode:

function lastIndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.lastIndexOf(str2);
  return(s);
}


lastIndexOf-Methode

lastIndexOf-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


lastIndexOf-Methode

lastIndexOf-Methode
Siehe auch 		JScript-Sprachverzeichnis

indexOf-Methode
String-Objekteigenschaften
String-Objektmethoden


length-Eigenschaft (String)

length-Eigenschaft (String) 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Länge eines String-Objekts zurück.
Syntax
strVariable.length
"Zeichenfolgenliteral".length
Anmerkungen
Die length-Eigenschaft enthält eine Ganzzahl, die die Anzahl der Zeichen im String-Objekt angibt. Das letzte Zeichen im String-Objekt hat einen length-Index von -1.


length-Eigenschaft (String)

length-Eigenschaft (String)
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


length-Eigenschaft (String)

length-Eigenschaft (String)
Siehe auch 		JScript-Sprachverzeichnis

length-Eigenschaft (Array)
length-Eigenschaft (Function)
String-Objekteigenschaften
String-Objektmethoden


link-Methode

link-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt ein HTML-Anchor-Tag und ein HREF-Attribut um den Text in einem String-Objekt.
Syntax
strVariable.link(Verknüpfungszeichenfolge)
"Zeichenfolgeliteral".link(Verknüpfungszeichenfolge)

Das Argument Verknüpfungszeichenfolge enthält den Text, der im HREF-Attribut des HTML-Anchor-Tags eingesetzt werden soll.

Anmerkungen
Rufen Sie die link-Methode auf, um einen Hyperlink aus einem String-Objekt zu generieren. Das folgende Beispiel zeigt, wie die Methode dies durchführt:
var strVariable = "Dies ist ein Hyperlink";
strVariable = strVariable.link("http://www.microsoft.com");
Der Wert von strVariable nach der letzten Anweisung ist:
<A HREF="http://www.microsoft.com">Dies ist ein Hyperlink</A>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


link-Methode

link-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


link-Methode

link-Methode
Siehe auch 		JScript-Sprachverzeichnis

anchor-Methode
String-Objekteigenschaften
String-Objektmethoden


match-Methode

match-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Ergebnisse einer Suche in Zeichenfolgen unter Verwendung eines angegebenen Regular Expression-Objekts als Datenfeld zurück.
Syntax
StringObj.match(RegA)

Die Syntax der match-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Das String-Objekt oder Literal, in dem gesucht werden soll.
RegA | Erforderlich. Der für die Suche zu verwendende reguläre Ausdruck.

Anmerkungen
Die match-Methode, die sich wie die exec-Methode verhält, gibt ein Datenfeld von Werten zurück. Das Element Null des Datenfeldes enthält die zuletzt verglichenen Zeichen. Die Elemente 1...n enthalten Übereinstimmungen mit den in Klammern gesetzten Teilzeichenfolgen im regulären Ausdruck.

Die Methode aktualisiert den Inhalt des Regular Expression-Objekts.

Das folgende Beispiel zeigt die Verwendung der match-Methode:

function MatchDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.match(re);
  return(i);
}


match-Methode

match-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


match-Methode

match-Methode
Siehe auch 		JScript-Sprachverzeichnis

exec-Methode
RegExp-Objekt
replace-Methode
search-Methode
String-Objektmethoden
test-Methode


replace-Methode

replace-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt unter Verwendung regulärer Ausdrücke eine Kopie der Zeichenfolge mit ersetztem Text zurück.
Syntax
stringObj.replace(RegA, ErsetzenText)

Die Syntax der replace-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Das String-Objekt oder Literal, in dem gesucht werden soll. Dies Objekt wird durch die replace-Methode nicht verändert.
RegA | Erforderlich. Ein Regular Expression-Objekt, das das Gesuchte beschreibt.
ErsetzenText | Erforderlich. Ein String-Objekt oder Literal mit dem Text, der jede Entsprechung von RegA in StringObj ersetzen soll.

Anmerkungen
Das Ergebnis der replace- Methode ist eine Kopie von StringObj, nachdem alle Ersetzungen durchgeführt wurden.

Die Methode aktualisiert den Inhalt des Regular Expression-Objekts.

Das folgende Beispiel zeigt die Verwendung der replace-Methode:

function ReplaceDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.replace(re, "pig");
  return(i);
}
Darüber hinaus kann die replace-Methode Teilausdrücke in einem Muster ersetzen. Im folgenden Beispiel wird jedes Wortpaar in der Zeichenfolge ausgetauscht:
function ReplaceDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /(\S+)(\s+)(\S+)/g;
  r = s.replace(re, "$3$2$1");	// Tauscht die einzelnen Wortpaare.
  return(i);
}


replace-Methode

replace-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


replace-Methode

replace-Methode
Siehe auch 		JScript-Sprachverzeichnis

exec-Methode
match-Methode
RegExp-Objekt
search-Methode
String-Objektmethoden
test-Methode


search-Methode

search-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Position der ersten Entsprechung einer Teilzeichenfolge in einer Suche mit einem regulären Ausdruck zurück.
Syntax
StringObj.search(RegA)

Die Syntax der search-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Das String-Objekt oder Literal, das gesucht werden soll.
RegA | Erforderlich. Ein Regular Expression-Objekt, das das zu suchende Muster enthält.

Anmerkungen
Die search-Methode gibt an, ob eine Entsprechung vorhanden ist. Wenn eine Entsprechung gefunden wird, gibt die search-Methode einen Ganzzahlwert zurück, der den Versatz vom Anfang der Zeichenfolge anzeigt, an dem die Entsprechung auftrat. Wird keine Entsprchung gefunden, dann wird -1 zurückgegeben. Weitere Informationen erhalten Sie beim Verwenden der match-Methode.

Das folgende Beispiel zeigt die Verwendung der search-Methode:

function SearchDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.search(re);
  return(i);
}


search-Methode

search-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


search-Methode

search-Methode
Siehe auch 		JScript-Sprachverzeichnis

exec-Methode
match-Methode
replace-Methode
String-Objektmethoden
test-Methode


slice-Methode (String)

slice-Methode (String) 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Abschnitt einer Zeichenfolge zurück.
Syntax
StringObj.slice(Beginn, [Ende])

Die Syntax der slice-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Ein String-Objekt oder Literal.
Beginn | Erforderlich. Der nullbasierte Index des Beginns des angegebenen Abschnitts von StringObj.
Ende | Optional. Der nullbasierte Index des Endes des angegebenen Abschnitts von StringObj.

Anmerkungen
Die slice-Methode gibt ein String-Objekt zurück, das den angegebenen Abschnitt von StringObj enthält.

Falls negativ, gibt Ende einen Versatz vom Ende von stringObj an. Darüber hinaus ist es nicht nullbasiert. Falls weggelassen, wird die Extrahierung bis zum Ende von stringObj fortgesetzt.

Im folgenden Beispiel geben die beiden Verwendungen der slice-Methode dasselbe zurück. -1 im zweiten Beispiel verweist auf das letzte Zeichen in str1 als den Endpunkt:

str1.slice(0)
str2.slice(0,-1)


slice-Methode (String)

slice-Methode (String)
Betrifft 		JScript-Sprachverzeichnis

Array-Objekt
String-Objekt


slice-Methode (String)

slice-Methode (String)
Siehe auch 		JScript-Sprachverzeichnis

slice-Methode (Array)
String-Objektmethoden


small-Methode

small-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<SMALL>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.small( )
"Zeichenfolgenliteral".small( )
Anmerkungen
Das folgende Beispiel zeigt, wie die small-Methode funktioniert:
var strVariable = "Dies ist eine Zeichenfolge";
strVariable = strVariable.small( );
Der Wert von strVariable nach der letzten Anweisung ist:
<SMALL>Dies ist eine Zeichenfolge</SMALL>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


small-Methode

small-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


small-Methode

small-Methode
Siehe auch 		JScript-Sprachverzeichnis

big-Methode
String-Objekteigenschaften
String-Objektmethoden


split-Methode

split-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das Datenfeld der Zeichenfolgen zurück, wenn eine Zeichenfolge in Teilzeichenfolgen separiert wird.
Syntax
stringObj.split(str)

Die Syntax der split-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringObj | Erforderlich. Das String-Objekt oder Literal, das geteilt werden soll. Dieses Objekt wird von der split-Methode nicht verändert.
str | Erforderlich. Eine Zeichenfolge oder ein Regular Expression-Objekt, das das Zeichen beschreibt, an dem die Teilung stattfinden soll.

Anmerkungen
Das Ergebnis der split-Methode ist ein Datenfeld von Zeichenfolgen, die an jedem Punkt geteilt wurden, an dem str in StringObj auftaucht.

Das folgende Beispiel zeigt die Verwendung der split-Methode:

function SplitDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  // Teilen bei jedem Leerzeichen.
  ss = s.split(" ");
  return(s);
}


split-Methode

split-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


split-Methode

split-Methode
Siehe auch 		JScript-Sprachverzeichnis

concat-Methode
RegExp-Objekt
String-Objektmethoden
Syntax regulärer Ausdrücke


strike-Methode

strike-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<STRIKE>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.strike( )
"Zeichenfolgenliteral".strike( )
Anmerkungen
Das folgende Beispiel zeigt, wie die strike-Methode funktioniert:
var strVariable = "Dies ist ein String-Objekt";
strVariable = strVariable.strike( );
Der Wert von strVariable nach der letzten Anweisung ist:
<STRIKE>Dies ist ein String-Objekt</STRIKE>
Es wird nicht überprüft, ob das Tag bereits an die Zeichenfolge angefügt worden ist.


strike-Methode

strike-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


strike-Methode

strike-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden


sub-Methode

sub-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<SUB>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.sub( )
"Zeichenfolgenliteral".sub( )
Anmerkungen
Das folgende Beispiel zeigt, wie die sub-Methode funktioniert:
var strVariable = "Das ist ein String-Objekt"
strVariable = strVariable.sub( );
Nach dem letzten Befehl enthält strVariable:
<SUB>Das ist ein String-Objekt</SUB>
Es wird nicht überprüft, ob das Tag bereits existiert.


sub-Methode

sub-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


sub-Methode

sub-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
sup-Methode


substr-Methode

substr-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Teilzeichenfolge zurück, die an angegebener Stelle beginnt und eine angegebene Länge hat.
Syntax
StringVar.substr(Beginn [, Länge ])

Die Syntax der substr-Methode hat folgende Komponenten:

Komponente | Beschreibung
StringVar | Erforderlich. Ein Zeichenfolgenliteral oder String-Objekt, aus dem die Teilzeichenfolge extrahiert werden soll.
Beginn | Erforderlich. Die Anfangsposition der gewünschten Teilzeichenfolge. Der Index des ersten Zeichens der Zeichenfolge ist Null.
Länge | Optional. Die Zahl der Zeichen, die die zurückgegebene Teilzeichenfolge enthalten soll.

Anmerkungen
Falls Länge Null oder negativ ist, wird eine leere Zeichenfolge zurückgegeben. Falls nicht angegeben, wird die Teilzeichenfolge bis zum Ende von StringVar fortgesetzt.

Das folgende Beispiel zeigt die Verwendung der substr-Methode:

function SubstrDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  ss = s.substr(16, 3);
  // Gibt "fox" zurück.
  return(ss);
}


substr-Methode

substr-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


substr-Methode

substr-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
substring-Methode


substring-Methode

substring-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Ruft eine Teilzeichenfolge von der angegebenen Position in einem String-Objekt ab.
Syntax

strVariable.substring(Start, Ende)
"Zeichenfolgenliteral".substring(Start, Ende)

Die Syntax der substring-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Start | Der nullbasierte Index für den Beginn der gewünschten Teilzeichenfolge.
Ende | Der nullbasierte Index für das Ende der gewünschten Teilzeichenfolge.

Anmerkungen

Die substring-Methode gibt ein String-Objekt mit der aus dem ursprünglichen Zeichenfolgenobjekt entnommenen Teilzeichenfolge zurück.

Die substring-Methode verwendet den niedrigeren der beiden Werte von Start und Ende als Ausgangsposition für die Teilzeichenfolge. Beispiel: strvar.substring(0, 3) und strvar.substring(3, 0) liefern in beiden Fällen dieselbe Teilzeichenfolge.

Negative Parameter bilden die einzige Ausnahme. Ist der erste Parameter kleiner als Null, wird er wie Null behandelt. Ist der zweite Parameter negativ, erhält er den Wert des ersten Parameters.

Die Länge einer Teilzeichenfolge entspricht dem absoluten Wert der Differenz zwischen Start und Ende. Beispiel: Die Länge der Teilzeichenfolge in strvar.substring(0, 3) und strvar.substring(3, 0) ist drei.

Schließlich können Start und Ende selbst Zeichenfolgen sein und werden, wenn möglich, in ganzzahlige Werte umgewandelt. Ansonsten wird der Wert eines Parameters wie Null behandelt.

Das folgende Beispiel zeigt die Verwendung der substring-Methode:

function SubstringDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  ss = s.substring(16, 19);
  return(ss);
}


substring-Methode

substring-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


substring-Methode

substring-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
substr-Methode


sup-Methode

sup-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Setzt HTML-<SUP>-Tag um einen Text in einem String-Objekt.
Syntax
strVariable.sup( )
"Zeichenfolgenliteral".sup( )
Anmerkungen
Das folgende Beispiel zeigt, wie die sup-Methode funktioniert:
var strVariable = "Das ist ein String-Objekt"
strVariable = strVariable.sup( );

Nach dem letzten Befehl enthält strVariable:

<SUP>Das ist ein String-Objekt</SUP>

Es wird nicht überprüft, ob das Tag bereits existiert.


sup-Methode

sup-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


sup-Methode

sup-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
sub-Methode


toLowerCase-Methode

toLowerCase-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Wandelt den Text in einem String-Objekt in Kleinbuchstaben um.
Syntax

strVariable.toLowerCase( )
"Zeichenfolgenliteral".toLowerCase( )

Anmerkungen

Die toLowerCase-Methode hat keine Auswirkungen auf nicht-alphabetische Zeichen.

Das folgende Beispiel zeigt die Auswirkungen der toLowerCase-Methode:

var strVariable = "Das ist ein STRING-Objekt"
strVariable = strVariable.toLowerCase( );

Nach dem letzten Befehl enthält strVariable:

das ist ein string-objekt


toLowerCase-Methode

toLowerCase-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


toLowerCase-Methode

toLowerCase-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
toUpperCase-Methode


toUpperCase-Methode

toUpperCase-Methode 		JScript-Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Wandelt den Text in einem String-Objekt in Großbuchstaben um.
Syntax
strVariable.toUpperCase( )
"Zeichenfolgenliteral".toUpperCase( )
Anmerkungen

Die toUpperCase-Methode hat keine Auswirkungen auf nicht-alphabetische Zeichen.

Das folgende Beispiel zeigt die Auswirkungen der toUpperCase-Methode:

var strVariable = "Das ist ein STRING-Objekt";
strVariable = strVariable.toUpperCase( );
Nach dem letzten Befehl enthält strVariable:
DAS IST EIN STRING-OBJEKT


toUpperCase-Methode

toUpperCase-Methode
Betrifft 		JScript-Sprachverzeichnis

String-Objekt


toUpperCase-Methode

toUpperCase-Methode
Siehe auch 		JScript-Sprachverzeichnis

String-Objekteigenschaften
String-Objektmethoden
toLowerCase-Methode


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt true zurück, wenn der Dateizeiger sich unmittelbar vor der Zeilenendemarkierung einer TextStream-Datei befindet. Sie gibt false zurück, wenn dem nicht so ist.
Syntax
Objekt.AtEndOfLine

Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Die AtEndOfLine-Eigenschaft ist nur auf TextStream-Dateien anwendbar, die zum Lesen geöffnet sind. Andernfalls tritt ein Fehler auf.

Der folgende Code verdeutlicht die Verwendung der AtEndOfLine-Eigenschaft:

function HoleEineZeile(dateispez)
{
  var fso, a, s, ZumLesen;
  ZumLesen = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  a = fso.OpenTextFile(dateispez, ZumLesen, false);
  while (!a.AtEndOfLine)
  {
    s += a.Read(1);
  }
  a.Close( );
  return(s);
}


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AtEndOfStream-Eigenschaft


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt true zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet. Sie gibt false zurück, wenn dem nicht so ist.
Syntax
Objekt.AtEndOfStream

Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Die AtEndOfStream-Eigenschaft ist nur auf TextStream-Dateien anwendbar, die zum Lesen geöffnet sind. Andernfalls tritt ein Fehler auf.

Der folgende Code verdeutlicht die Verwendung der AtEndOfStream-Eigenschaft:

function HoleEineZeile(dateispez)
{
  var fso, f, s, ZumLesen;
  ZumLesen = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile(dateispez, ZumLesen, false);
  while (!f.AtEndOfStream)
    s += f.ReadLine( );
  f.Close( );
  return(s);
}


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

AtEndOfLine-Eigenschaft


Close-Methode

Close-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schließt eine geöffnete TextStream-Datei.

Syntax
Objekt.Close( );

Das Objekt ist immer der Name eines TextStream-Objekts.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der Close-Methode:

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("Dies ist ein Test.");
a.Close();


Close-Methode

Close-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


Close-Methode

Close-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Read-Methode
Write-Methode


Column-Eigenschaft

Column-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibgeschützte Eigenschaft, die die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurückgibt.

Syntax
Objekt.Column

Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Nach dem Schreiben eines Zeilenvorschubzeichens und vor dem Schreiben eines weiteren Zeichens entspricht Column 1.

Das folgende Beispiel zeigt die Verwendung der Column-Eigenschaft:

function HoleSpalte()
{
  var fso, f, m;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.Write("Hallo Welt");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  m = f.ReadLine();
  return(f.Column);
}


Column-Eigenschaft

Column-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


Column-Eigenschaft

Column-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Line-Eigenschaft


Line-Eigenschaft

Line-Eigenschaft 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibgeschützte Eigenschaft, die die aktuelle Zeilennummer in einer TextStream-Datei zurückgibt.

Syntax
Objekt.Line

Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Nach dem ersten Öffnen einer Datei und vor dem ersten Schreibvorgang entspricht Line 1.

Das folgende Beispiel zeigt die Verwendung der Line-Eigenschaft:

function HoleZeile()
{
  var fso, f, r
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\textfile.txt", ZumSchreiben, true)
  f.WriteLine("Hallo Welt");
  f.WriteLine("JScript ist klasse!");
  f.Close();
  f = fso.OpenTextFile("c:\\textfile.txt", ZumLesen);
  r =  f.ReadAll();
  return(f.Line);
}


Line-Eigenschaft

Line-Eigenschaft
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


Line-Eigenschaft

Line-Eigenschaft
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Column-Eigenschaft


Read-Methode

Read-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine angegebene Zahl von Zeichen aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.

Syntax
Objekt.Read(Zeichenzahl)

Die Syntax der Read-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenzahl | Erforderlich. Zahl der Zeichen, die aus der Datei gelesen werden sollen.

Das folgende Beispiel zeigt die Verwendung der Read-Methode, um einen sechs Buchstaben langen Dateikopf zu lesen und die Ergebniszeichenfolge zurückzugeben:

function HoleDateikopf()
{
  var fso, f;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  return(f.Read(6));
}


Read-Methode

Read-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


ReadAll-Methode

ReadAll-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine gesamte TextStream-Datei und gibt die resultierende Zeichenfolge zurück.

Syntax
Objekt.ReadAll( );

Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Bei großen Dateien verbraucht die ReadAll-Methode sehr viel Arbeitsspeicher. Andere Techniken sollten verwendet werden, um eine Datei einzulesen, etwa das Lesen der Datei Zeile für Zeile.

Das folgende Beispiel zeigt die Verwendung der ReadAll-Methode:

function HoleAlles()
{
  var fso, f;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  return(f.ReadAll());
}


ReadAll-Methode

ReadAll-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


ReadAll-Methode

ReadAll-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Read-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode


Read-Methode

Read-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode


ReadLine-Methode

ReadLine-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine gesamte Zeile einer TextStream-Datei (bis zum Zeilenumbruchzeichen) und gibt die resultierende Zeichenfolge zurück.

Syntax
Objekt.ReadLine( )

Das Argument Objekt ist stets der Name eines TextStream-Objekts.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der Line-Eigenschaft:

function HoleZeile()
{
  var fso, f, r;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.WriteLine("Hallo Welt");
  f.WriteLine("JScript ist klasse!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  r =  f.ReadLine();
  return(r);
}


ReadLine-Methode

ReadLine-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


ReadLine-Methode

ReadLine-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Read-Methode
ReadAll-Methode
Skip-Methode
SkipLine-Methode


Skip-Methode

Skip-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Überspringt beim Lesen einer TextStream-Datei die angegebene Zahl von Zeichen.

Syntax
Objekt.Skip(Zeichenzahl)

Die Syntax der Skip-Methode hat folgende Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenzahl | Erforderlich. Zahl der zu überspringenden Zeichen beim Lesen einer Datei.

Anmerkungen
Ausgelassene Zeichen werden verworfen.

Das folgende Beispiel zeigt die Verwendung der Skip-Methode:

function SkipDemo()
{
  var fso, f, r;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.WriteLine("Hallo Welt");
  f.WriteLine("JScript ist klasse!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  f.Skip(6);
  r = f.ReadLine();
  return(r);
}


Skip-Methode

Skip-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


Skip-Methode

Skip-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
SkipLine-Methode
Write-Methode
WriteBlankLines-Methode
WriteLine-Methode


SkipLine-Methode

SkipLine-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Übergeht die nächste Zeile beim Einlesen einer TextStream-Datei.

Syntax
Objekt.SkipLine( )

Das Objekt ist immer der Name eines TextStream-Objekts.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der SkipLine-Methode:

function SkipLineDemo()
{
  var fso, f, r
  var ZumLesen= 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true)
  f.WriteLine("Hallo Welt");
  f.WriteLine("JScript ist klasse!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  f.SkipLine();
  r = f.ReadLine();
  return(r);
}


SkipLine-Methode

SkipLine-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


SkipLine-Methode

SkipLine-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode


Write-Methode

Write-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.

Syntax
Objekt.Write(Zeichenfolge)

Die Syntax der Write-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenfolge | Erforderlich. Der Text, den Sie in die Datei schreiben wollen.

Anmerkungen
Die angegebenen Zeichenfolgen werden ohne dazwischenliegende Leerzeichen oder Zeichen zwischen den einzelnen Zeichenfolgen in die Datei geschrieben. Verwenden Sie die WriteLine-Methode, um ein Zeilenumbruchzeichen oder eine Zeichenfolge zu schreiben, die mit einem Zeilenumbruchzeichen endet.

Das folgende Beispiel zeigt die Verwendung der Write-Methode:

function WriteDemo()
{
  var fso, f, r
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true)
  f.Write("Hallo Welt");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  r = f.ReadLine();
  return(r);
}


Write-Methode

Write-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


WriteBlankLines-Methode

WriteBlankLines-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Zahl von Zeilenumbruchzeichen in eine TextStream-Datei.

Syntax
Objekt.WriteBlankLines(Zeilen)

Die Syntax der WriteBlankLines-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeilen | Erforderlich. Die Zahl der Zeilenumbruchzeichen, die Sie in die Datei schreiben wollen.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der WriteBlankLines-Methode:

function WriteBlanksDemo()
{
  var fso, f, r;
  var ZumLesen = 1, ZumSchreiben = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ZumSchreiben, true);
  f.Write("Hallo Welt");
  f.WriteBlankLines(2);
  f.Write("JScript ist klasse!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ZumLesen);
  r = f.ReadAll();
  return(r);
}


WriteBlankLines-Methode

WriteBlankLines-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


WriteBlankLines-Methode

WriteBlankLines-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Write-Methode
WriteLine-Methode


Write-Methode

Write-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

WriteBlankLines-Methode
WriteLine-Methode


WriteLine-Methode

WriteLine-Methode 		JScript-Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Zeichenfolge mit Zeilenumbruchzeichen in eine TextStream-Datei.

Syntax
Objekt.WriteLine([Zeichenfolge])

Die Syntax der WriteLine-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenfolge | Optional. Der Text, den Sie in die Datei schreiben wollen. Bei Weglassen wird ein Zeilenumbruchzeichen in die Datei geschrieben.

Anmerkungen
Das folgende Beispiel zeigt die Verwendung der WriteLine-Methode:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("Dies ist ein Test.");
f.Close();


WriteLine-Methode

WriteLine-Methode
Betrifft 		Referenz für die JScript-Laufzeitbibliothek

TextStream-Objekt


WriteLine-Methode

WriteLine-Methode
Siehe auch 		Referenz für die JScript-Laufzeitbibliothek

Write-Methode
WriteBlankLines-Methode


Referenz für die Microsoft® JScript-Laufzeitbibliothek

JScript-Sprachverzeichnis 		JScript-Tutorium
Versionsinformationen

Informationen über
Leistungsmerkmale
Alphabetische Liste
der Schlüsselwörter
Funktionen
Methoden
Objekte
Operatoren
Eigenschaften
Anweisungen
©1998 Microsoft Corporation. Alle Rechte vorbehalten. Rechtliche Hinweise.


JScript-Tutorium

JScript-Tutorium
 JScript-Sprachverzeichnis

Was ist JScript?
JScript-Grundlagen
Schreiben von JScript-Code
JScript-Variablen
JScript-Datentypen
JScript-Operatoren
Steuern des Programmablaufs
JScript-Funktionen
JScript-Objekte
Reservierte Schlüsselwörter von JScript
JScript für Fortgeschrittene
Rekursion
Gültigkeitsbereich von Variablen
Kopieren, Übergeben und Vergleichen von Daten
Verwenden von Datenfeldern
Erstellen erweiterter Objekte
Sonderzeichen
Beseitigen von Fehlern aus Skripten


Datentypkonvertierung

Datentypkonvertierung 		JScript-Sprachverzeichnis
Version 3

Beschreibung
Microsoft JScript bietet kontextabhängig eine automatische Datentypkonvertierung. Wenn also für den Kontext eine Zeichenfolge als Wert erwartet wird, versucht JScript, den Wert in eine Zeichenfolge umzuwandeln.

Die Sprache verfügt über sechs Datentypen. Alle Werte haben einen der folgenden Typen:

undefined
Der Typ "undefined" hat nur einen Wert, undefined.
Null
Der Typ "Null" hat nur einen Wert, null.
Boolean
Der Boolesche Typ stellt zwei logische Werte dar, true und false.
String
Zeichenfolgen, umgeben von einfachen oder doppelten Anführungszeichen, enthalten keine oder mehrere Unicode-Zeichen. Eine leere Zeichenfolge ("") hat keine Zeichen und keine Länge.
Number
Zahlen können Ganzzahl oder Fließkommazahlen gemäß der IEEE 754-Bestimmung sein. Es gibt darüber hinaus Sonderwerte:
  • NaN bzw. "Not a Number".
  • Plus-unendlich
  • Minus-unendlich
  • Positive Null
  • Negative Null
Object
Ein Objekttyp ist eine Objektdefinition samt Eigenschaften und Methoden.
Die folgende Tabelle definiert, was passiert, wenn der Kontext es erfordert, dass JScript einen Datentyp in einen anderen konvertiert:

Ausgabedatentyp | Eingabedatentyp
undefined | Null | Boolean | Number | String | Object
Boolean | false | false | Keine Konvertierung | false, wenn +0, -0 oder NaN; andernfalls true | false bei leerer Zeichenfolge (""); andernfalls true | true
Number NaN NaN +1, falls true
0, falls false 		Keine Konvertierung Falls nicht als Zahl interpretierbar, erfolgt Interpretation als NaN Number-Objekt
String "undefined" "null" "true" oder "false" Der absolute Wert der Zahl plus Vorzeichen mit folgenden Ausnahmen:
  • NaN gibt "NaN" zurück
  • +0 oder -0 geben "0" zurück
  • +-unendlich gibt "Infinity" zurück
  • --unendlich gibt "-Infinity" zurück
            • Keine Konvertierung String-Objekt
    Object | Laufzeitfehler | Laufzeitfehler | Neues Boolean-Objekt | Neues Number-Objekt | Neues String-Objekt | Keine Konvertierung


dimensions-Methode

dimensions-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Zahl der Dimensionen in einem VBArray zurück.
Syntax
Datenfeld.dimensions( )

Das Argument Datenfeld ist ein VBArray-Objekt.

Anmerkungen
Die dimensions-Methode bietet eine Möglichkeit, die Zahl der Dimensionen eines angegebenen VBArray abzurufen.

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der die Anzahl der Dimensionen in dem Safe Array-Objekt und die obere Grenze jeder Dimension feststellt. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Die obere Grenze der Dimension ";
    s += i + " ist ";
    s += a.ubound(i)+ ".<BR>";
  }
  return(s);

}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


dimensions-Methode

dimensions-Methode
Betrifft 		JScript-Sprachverzeichnis

VBArray-Objekt


dimensions-Methode

dimensions-Methode
Siehe auch 		JScript-Sprachverzeichnis

getItem-Methode
lbound-Methode
toArray-Methode
ubound-Methode


getItem-Methode

getItem-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Ruft das Element aus der angegebenen Position ab.
Syntax
VBFeld.getItem(Dimension1[, Dimension2, ...], Dimensionn)

Die Syntax der getItem-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
VBFeld | Erforderlich. Ein VBArray-Objekt.
Dimension1, ..., DimensionN | Gibt die exakte Position des gewünschten Elements im VBArray an. N entspricht der Zahl der Dimensionen in dem VBArray.

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der das Safe Array-Objekt durchläuft und den Inhalt jedes Elements ausgibt. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(i, j) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function GetItemTest(vbDatenfeld)
{
  var i, j;
  var a = new VBArray(vbDatenfeld);
  for (i = 0; i <= 2; i++)
  {
    for (j =0; j <= 2; j++)
    {
      document.writeln(a.getItem(i, j));
    }
  }
}-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  GetItemTest(ErstelleVBArray());
-->
</SCRIPT>
</BODY>


getItem-Methode

getItem-Methode
Betrifft 		JScript-Sprachverzeichnis

VBArray-Objekt


getItem-Methode

getItem-Methode
Siehe auch 		JScript-Sprachverzeichnis

dimensions-Methode
lbound-Methode
toArray-Methode
ubound-Methode


lbound-Methode

lbound-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den niedrigsten Indexwert zurück, der in der angegebenen Dimension eines VBArray verwendet wird.
Syntax
VBArray.lbound(Dimension)

Die Syntax der lbound-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
VBArray | Erforderlich. Ein VBArray-Objekt.
Dimension | Optional. Die Dimension des VBArray, dessen niedrigster Indexwert gewünscht wird. Falls weggelassen, verhält sich lbound, als würde eine 1 übergeben.

Anmerkungen
Ist das VBArray leer, gibt die lbound-Methode undefined zurück. Ist Dimension größer als die Zahl der Dimensionen in dem VBArray oder negativ, erzeugt die Methode den Fehler "Index außerhalb des gültigen Bereichs".

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der die Anzahl der Dimensionen in dem Safe Array-Objekt und die untere Grenze jeder Dimension feststellt. Da das Safe Array-Objekt in VBScript und nicht in Visual Basic erzeugt wird, ist die untere Grenze immer gleich null. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Die untere Grenze der Dimension ";
    s += i + " ist ";
    s += a.lbound(i)+ ".<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(ErstelleVBArray()));
</SCRIPT>
</BODY>


lbound-Methode

lbound-Methode
Betrifft 		JScript-Sprachverzeichnis

VBArray-Objekt


lbound-Methode

lbound-Methode
Siehe auch 		JScript-Sprachverzeichnis

dimensions-Methode
getItem-Methode
toArray-Methode
ubound-Methode


toArray-Methode

toArray-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Konvertiert ein VBArray in ein Standard-JScript-Datenfeld.
Syntax
VBArray.toArray( )

Das Argument VBArray ist ein VBArray-Objekt.

Anmerkungen
Bei der Umwandlung wird das mehrdimensionale VBArray in ein eindimensionales JScript-Datenfeld konvertiert. Jede folgende Dimension wird an das Ende der vorherigen angefügt. Ein VBArray mit z. B. drei Dimensionen und drei Elementen in jeder Dimension wird wie folgt in ein JScript-Datenfeld konvertiert:

Angenommen, das VBArray enthält: (1, 2, 3), (4, 5, 6), (7, 8, 9). Nach der Umwandlung enthält das JScript-Datenfeld: 1, 2, 3, 4, 5, 6, 7, 8, 9.

Momentan ist es nicht möglich, ein JScript-Datenfeld in ein VBArray umzuwandeln.

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der das Safe Array-Objekt in ein JScript Array-Objekt konvertiert. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vbdatenfeld)
{
  var a = new VBArray(vbdatenfeld);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.writeln(b[i]);
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(ErstelleVBArray());
-->
</SCRIPT>
</BODY>


toArray-Methode

toArray-Methode
Betrifft 		JScript-Sprachverzeichnis

VBArray-Objekt


toArray-Methode

toArray-Methode
Siehe auch 		JScript-Sprachverzeichnis

dimensions-Methode
getItem-Methode
lbound-Methode
ubound-Methode


ubound-Methode

ubound-Methode 		JScript-Sprachverzeichnis
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den höchsten Indexwert zurück, der in der angegebenen Dimension eines VBArray verwendet wird.
Syntax
VBArray.ubound(Dimension)

Die Syntax der ubound-Methode hat die folgenden Komponenten:

Komponente | Beschreibung
VBArray | Erforderlich. Ein VBArray-Objekt.
Dimension | Optional. Die Dimension des VBArray, dessen höchster Indexwert gewünscht wird. Falls weggelassen, verhält sich ubound, als würde eine 1 übergeben.

Anmerkungen
Ist das VBArray leer, gibt die ubound-Methode undefined zurück. Ist Dimension größer als die Zahl der Dimensionen in dem VBArray oder negativ, erzeugt die Methode den Fehler "Index außerhalb des gültigen Bereichs".

Das folgende Beispiel besteht aus drei Teilen. Der erste Teil ist VBScript-Code zum Erstellen eines Visual Basic Safe Array-Objekts. Der zweite Teil ist JScript-Code, der die Anzahl der Dimensionen in dem Safe Array-Objekt und die obere Grenze jeder Dimension feststellt. Beide Teile gehören in den <HEAD>-Abschnitt einer HTML-Seite. Der dritte Teil ist JScript-Code, der in den <BODY>-Abschnitt gehört, damit die anderen beiden Teile ausgeführt werden.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function ErstelleVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  ErstelleVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Die obere Grenze der Dimension ";
    s += i + " ist ";
    s += a.ubound(i)+ ".<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(ErstelleVBArray()));
</SCRIPT>
</BODY>


ubound-Methode

ubound-Methode
Betrifft 		JScript-Sprachverzeichnis

VBArray-Objekt


ubound-Methode

ubound-Methode
Siehe auch 		JScript-Sprachverzeichnis

dimensions-Methode
getItem-Methode
lbound-Methode
toArray-Methode


Versionsinformationen

Versionsinformationen 		JScript-Sprachverzeichnis

Die folgende Tabelle zeigt jeweils die Version von Microsoft JScript, die durch Host-Anwendungen implementiert wird.

Host | JScript-Version
1.0 | 2.0 | 3.0 | 4.0 | 5.0
Microsoft Internet Explorer 3.0 | x
Microsoft Internet Information Server 1.0 | x
Microsoft Internet Explorer 4.0 | x
Microsoft Internet Information Server 4.0 | x
Microsoft Windows Scripting Host 1.0 | x
Microsoft Visual Studio 6.0 | x
Microsoft Internet Explorer 5.0 | x
Microsoft Internet Information Server 5.0 | x